Google データスタジオを使用して BigQuery データを可視化する

BigQuery は、ペタバイト級のアナリティクス データ ウェアハウスであり、巨大容量のデータに対して SQL クエリをリアルタイムに近い速度で行うことができます。

データ可視化ツールは、BigQuery データを把握して、インタラクティブに分析するのに役立ちます。可視化ツールを使って、傾向を特定して対応し、データを利用して予測を行うことができます。このチュートリアルでは、Google データスタジオを使って BigQuery の natality サンプル テーブルのデータを可視化します。

目標

このチュートリアルの内容は、次のとおりです。

  • BigQuery データソースに接続する
  • レポートやグラフを作成し、BigQuery データを可視化する

料金

データスタジオの BigQuery コネクタを使用すると、データスタジオ内の BigQuery テーブルからデータにアクセスできます。BigQuery は有料プロダクトであり、データスタジオを使用して BigQuery にアクセスすると、BigQuery の利用料金が発生します。BigQuery クエリの料金については、毎月 1 TB まで無料です。詳細については、BigQuery の料金をご覧ください。

始める前に

このチュートリアルを始める前に、Google Cloud Platform Console を使用して、プロジェクトを作成または選択し、課金を有効にします。

  1. Google アカウントにログインします。

    Google アカウントをまだお持ちでない場合は、新しいアカウントを登録します。

  2. GCP プロジェクトを選択または作成します。

    [リソースの管理] ページに移動

  3. プロジェクトに対して課金が有効になっていることを確認します。

    課金を有効にする方法について

  4. 新しいプロジェクトでは、BigQuery が自動的に有効になります。既存のプロジェクトで BigQuery を有効にする手順は以下のとおりです。 BigQuery API を有効にする。

    Enable the API

Google データスタジオと BigQuery コネクタを使用してレポートやグラフを作成する

チュートリアルのこのセクションでは、Google データスタジオを使用し、BigQuery コネクタを使用して BigQuery のデータを可視化します。natality サンプル テーブルのデータを可視化するデータソース、レポート、グラフを作成します。

データソースを作成する

データスタジオでレポートを作成するための最初のステップは、レポートのデータソースを作成することです。レポートには 1 つ以上のデータソースを含めることができます。BigQuery データソースを作成する場合、データスタジオによって BigQuery コネクタが使われます。

BigQuery データソースをデータスタジオ レポートに追加するには、適切な権限を持っている必要があります。さらに、BigQuery データセットに適用される権限は、データスタジオで作成したレポート、グラフ、ダッシュボードにも適用されます。データスタジオ レポートが共有されている場合、レポートのコンポーネントを表示できるのは、適切な権限を持っているユーザーのみです。

データソースを作成するには:

  1. Google データスタジオを開きます。

  2. [Reports] ページの [Start a new report section] で [Blank] テンプレートをクリックします。これによって、新しい無題のレポートが作成されます。

    空のテンプレート

  3. プロンプトが表示されたら、[Marketing Preferences] と [Account and Privacy] に値を設定して、[Save] をクリックします。設定を保存した後、もう一度空白テンプレートのクリックが必要になる場合があります。

  4. [Add a data source] ウィンドウで [Create new data source] をクリックします。

    データソースを追加する

  5. [Google Connectors] セクションで BigQuery にカーソルを合わせて、[Select] をクリックします。

  6. [Authorization] で [Authorize] をクリックします。これによって、データスタジオから GCP プロジェクトにアクセスできるようになります。

  7. [Request for permission] ダイアログ ボックスで [Allow] をクリックしてデータスタジオで BigQuery のデータを表示できるようにします。以前にデータスタジオを使用した場合には、このプロンプトが表示されない可能性があります。

  8. [My Projects] で、[Public Datasets] をクリックします。

  9. [Billing Project] で、以前に作成した GCP プロジェクトの名前をクリックします。

  10. [Public Dataset] で [samples] をクリックします。

  11. [Table] で [natality] をクリックします。

    natality テーブル

  12. ウィンドウの右上隅で [Connect] をクリックします。データスタジオが BigQuery データソースに接続されると、テーブルのフィールドが表示されます。このページを使用して、フィールドのプロパティを調整したり、新しい計算フィールドを作成したりできます。

  13. natality テーブルで、year フィールドと source_year フィールドの値は整数型として保存されます。integers. データスタジオで、これらの列を文字列型として使用するには、これらの列の型をテキストに変更します。year フィールドと source_year フィールドの右側にある [Type] 列で [Number] をクリックして、プルダウン リストから [Text] を選択します。

    [Field] ダイアログ

  14. [Add to report] をクリックします。

    レポートに追加する

  15. プロンプトが表示されたら、[Add to report] をクリックします。

  16. [Request for permission] ダイアログ ボックスで [Allow] をクリックしてデータスタジオで Google Drive 内のファイルを表示したり管理したりできるようにします。以前にデータスタジオを使用した場合には、このプロンプトが表示されない可能性があります。

計算フィールドを使用して棒グラフを作成する

natality データソースをレポートに追加したら、次の手順は可視化することです。棒グラフを作成することから始めます。棒グラフには、毎年の合計出生数を表示します。年ごとの出生数を表示するには、計算フィールドを作成します。

年ごとの合計出生数を表示する棒グラフを作成するには:

  1. (オプション)ページの先頭にある [Untitled Report] をクリックして、レポート名を変更します。たとえば、「BigQuery tutorial」と入力します。

  2. レポート エディタが読み込まれたら、[Insert] > [Bar chart] をクリックします。

  3. ハンドルを使用して、レポートにグラフを表示するための四角形を描画します。

  4. [Data] タブで、データソース(natality)の値と、[Dimension] および [Metric] のデフォルト値を確認します。

  5. 年別に出生数をグラフ化しているため、[Dimension] を source_year に設定する必要があります。[Available Fields] リストで、source_year をクリックしてドラッグし、[Add dimension here] ボックスにドロップします。ソースの年は出生年(4 桁)です。

    デフォルトのグラフのプロパティ

  6. 分割項目を追加したら、デフォルトの分割項目にカーソルを合わせ、右側にある削除アイコンをクリックします。

    デフォルトのグラフのプロパティ

  7. [Metric] セクションで [Add metric here] をクリックします。

  8. [Metric picker] で [Create new metric] をクリックします。

  9. 年ごとに出生した子供の数を性別に表示するには、計算フィールドを作成します。このチュートリアルでは、[is_male] フィールドのエントリ数をカウントします。is_male の値は、子供が男の子の場合は true で、女の子の場合は false です。新しい指標ウィンドウで、[Name] に birth_count と入力します。

  10. フィールド ID は変更しないでください。

  11. [Formula] に「COUNT(is_male)」と入力します(または式アシスタントを使用します)。

  12. [Save] をクリックします。

    計算フィールドを作成する

  13. [Done] をクリックします。

  14. 戻る矢印をクリックして [Metric picker] を閉じます。

  15. [Available Fields] リストで、[birth_count] をクリックして [Add metric here] ボックスにドラッグします。

  16. 指標を追加したら、デフォルトの指標にカーソルを置き、右側にある削除アイコンをクリックします。[Dimension] を [source_year] に設定し、[Metric] を [birth_count] に設定する必要があります。

  17. デフォルトではグラフが降順で並べ替えられ、最も出生数が多い年が最初に表示されます。

    合計出生数のグラフ

  18. グラフを拡張するには、棒ラベルを変更します。[Bar chart properties] ウィンドウで [Style] タブをクリックします。

  19. [Bar chart] セクションで [Show data labels] チェックボックスをオンにします。

    ラベルを表示する

    出生数がグラフの各棒の上に表示されます。

  20. birth_count ではなく、source_year を基準としてデータを並べ替えます。[Bar chart properties] ウィンドウの [Data] タブにある [Sort] セクションで、次の操作を行います。

    • 既存のフィールド(birth_count)をクリックして、[ Sort picker] を開きます。
    • [Sort picker] で source_year を選択します。
    • 戻る矢印をクリックして [Sort picker] を閉じます。
    • [Descending] をクリックし、[Ascending] を選択します。年ごとの出生数を昇順に表示するように画面が変更されます。

    昇順の出生数

グラフにフィルタを追加する

現在、棒グラフに年ごとの出生した男の子と女の子の合計数が表示されています。年ごとに出生した女の子の数だけを表示するようにフィルタを追加します。

  1. [Bar chart properties] ウィンドウで [Data] タブをクリックします。

  2. [Filter] セクションで [Add a filter] をクリックします。

  3. [Create filter] ウィンドウで次の操作を行います。

    • [Name] に「Female birth count」と入力します。
    • [Include] をクリックして、[Exclude] に変更します。
    • [Select a field] をクリックして、[is_male] を選択します。
    • [Select a condition] をクリックして、[True] を選択します。
    • [Save] をクリックします。

    [Create filter] ウィンドウ

グラフが更新され、年ごとに出生した女の子の数だけが表示されます。また、凡例は変更されていないことにも注目してください。凡例名にはまだ metric - birth_count の名前が反映されています。

フィルタ後のグラフ

カスタムクエリを使用してグラフを作成する

データスタジオでは指標に集計を使用できないため、一部のレポート コンポーネントはカスタム SQL クエリを使用すると簡単に生成できます。Custom Query オプションでも BigQuery の完全なクエリ機能(追加、結合、解析機能など)を使用できます。

あるいは、ビューを作成することによって BigQuery の完全なクエリ機能を利用できます。ビューは SQL クエリによって定義される仮想テーブルです。データソースとしてそのビューを含むデータセットを追加すると、ビュー内のデータをクエリできます。詳細については、ビューの使用をご覧ください。

BigQuery データソースとして SQL クエリを指定した場合、クエリの結果はテーブル形式になり、データソースのフィールド定義(スキーマ)になります。データソースとしてカスタムクエリを使用する場合、データスタジオでは SQL を BigQuery に対して生成された各クエリの内部選択ステートメントとして使用します。データスタジオでのカスタムクエリの詳細については、オンライン ヘルプをご覧ください。

カスタムクエリを使用して棒グラフを追加する

カスタムクエリのデータソースを使用する棒グラフは、以下の手順でレポートに追加します。

  1. メニュー オプションから、[Page] > [New page] の順に選択します。

  2. [Insert] > [Bar chart] をクリックします。

  3. ハンドルを使用して、レポートにグラフを表示するための四角形を描画します。

  4. [Bar chart properties] ウィンドウの [Data] タブで、[Data Source] が natality に設定されています。natality をクリックして、[Select Data Source] ウィンドウを開きます。

  5. [Create new data source] をクリックします。

  6. [Google Connectors] セクションで BigQuery にカーソルを合わせて、[Select] をクリックします。

  7. [My Projects] で [Custom query] をクリックします。

  8. [Project] で GCP プロジェクトを選択します。

  9. [Enter custom query] ウィンドウに、次の標準 SQL クエリを入力します。

    SELECT
     source_year,
     sum(case when is_male then 1 else 0 end) as male_births,
     sum(case when is_male then 0 else 1 end) as female_births
    FROM
     `bigquery-public-data.samples.natality`
    GROUP BY
     source_year
    ORDER BY
     source_year
    DESC
    

    このクエリでは、CASE ステートメントを使用して is_male Boolean フィールドを評価し、特定の年の出生数のうちの女の子の数と男の子の数を特定します。

  10. [Query Options] で [Use Legacy SQL] をオフにします。これで、BigQuery 標準 SQL 構文を使用できます。

    カスタムクエリ

  11. ウィンドウの上部にある [Untitled data source] をクリックして、データソース名を Male female case query に変更します。

  12. ウィンドウの右上隅で [Connect] をクリックします。データスタジオが BigQuery データソースに接続されると、テーブル スキーマを特定するためにクエリの結果が使用されます。

  13. スキーマが表示されたら、各フィールドのタイプと集計を確認します。デフォルトでは、source_year が [Number] として書式設定され、Aggregation が [None] に設定されます。[source_year] フィールドの右側にある [Type] 列で [Number] をクリックし、[Text] を選択します。[Aggregation] が [None] に設定されていることを確認します。

    フィルタ後のグラフ

  14. [Add to report] をクリックします。

  15. プロンプトが表示されたら、[Add to report] をクリックします。

  16. 戻る矢印をクリックして [Select Data Source] ウィンドウを閉じます。

  17. データスタジオでは指標がグラフに適切であるかどうかを判断できません。年別に出生数をグラフ化しているため、[Metric] の値は female_births または male_births になります。[Bar chart properties] ウィンドウの [Data] タブで [Metric] セクションの [Record Count] をクリックします。

  18. [Metric picker] で [female_births] を選択します。

  19. 戻る矢印をクリックして [Metric picker] を閉じます。

  20. [Metric] セクションで [Add metric here] をクリックします。

  21. [Metric picker] で [male_births] を選択します。

  22. 戻る矢印をクリックして [Metric picker] を閉じます。年ごとの出生した男の子と女の子の数が別々の棒で表示されます。

    フィルタ後のグラフ

  23. グラフが female_births の降順でソートされます。前のグラフと同様に、これを source_year に変更します。[Sort] セクションで female_births をクリックします。

  24. [Sort picker] で source_year を選択します。

  25. 戻る矢印をクリックして [Sort picker] を閉じます。年ごとの出生した男の子と女の子の数が降順で表示されます。

  26. 読みやすくするために、グラフのスタイルを変更します。[Bar chart properties] で [Style] タブをクリックします。

  27. 各棒は、指標がグラフに追加された順序に基づくデフォルトの色であることを確認してください。カラーパレットの 2 番目の正方形をクリックすると、赤から青に変わります。

    フィルタ後のグラフ

  28. カラーパレットで最初の正方形をクリックすると、青から赤に変わります。

    グラフは次のようになります。

    色付きの棒グラフ

クエリの履歴を表示する

BigQuery のウェブ インターフェースでクエリの履歴を調べて、BigQuery コネクタ経由で送信されたクエリを表示できます。クエリの履歴を使用すると、クエリのコストを予測し、他のシナリオで使用するために保存することができます。

クエリの履歴を調べるには:

  1. BigQuery ウェブ UI に移動します。

    BigQuery ウェブ UI に移動

  2. [Query History] をクリックします。

  3. 最後に使用したクエリを先頭にして、クエリのリストが表示されます。[Open Query] をクリックして、[Job ID] や [Bytes Processed] などのクエリの詳細を表示します。

    色付きの棒グラフ

クリーンアップ

このチュートリアルで使用するリソースについて、Google Cloud Platform アカウントに課金されないようにする手順は次のとおりです。

  1. GCP Console で [プロジェクト] ページに移動します。

    プロジェクト ページに移動

  2. プロジェクト リストで、削除するプロジェクトを選択し、[プロジェクトの削除] をクリックします。 プロジェクト名の横にあるチェックボックスを選択し、[プロジェクトの削除] をクリックする
  3. ダイアログにプロジェクト ID を入力し、[シャットダウン] をクリックしてプロジェクトを削除します。

データソースがプロジェクトに関連付けられているため、プロジェクトを削除すると、データスタジオでデータのクエリを行えなくなります。Cloud Platform プロジェクトを削除したくない場合は、データスタジオ レポートとデータソースを削除できます。

データスタジオのリソースを削除するには:

  1. Google データスタジオを開きます。

  2. [Reports] ページで [BigQuery tutorial] レポートの右側にある [more] ボタン [more] ボタン をクリックし、[Remove] を選択します。

  3. [Data Sources] をクリックします。

  4. natality データソースの右側にある [more] ボタンをクリックし、[Remove] を選択します。

  5. Male female case query データソースの右側にある [more] ボタンをクリックし、[Remove] を選択します。

次のステップ

  • BigQuery 用のクエリの記述の詳細 - BigQuery ドキュメントのデータのクエリに、クエリを実行する方法やユーザー定義関数(UDF)を作成する方法などが説明されています。

  • BigQuery 構文の探索 - BigQuery の SQL クエリで推奨される言語は標準 SQL です。この言語については、SQL リファレンスをご覧ください。BigQuery のレガシー SQL に類似した構文については、クエリ リファレンス(レガシー SQL)をご覧ください。

このページは役立ちましたか?評価をお願いいたします。

フィードバックを送信...