Python 3.9 is now generally available.

google.appengine.api.datastore_errors.BadValueError

Raised by Entity.__setitem__(), Query.__setitem__(), Get(), and others.

Inherits From: Error, expected_type

Occurs when a property value or filter value is invalid.