Von Apigee Hybrid unterstützte Plattformen und Versionen

Unterstützte Plattformen

Apigee Hybrid unterstützt die folgenden Versionen dieser Plattformen:

Hybrid-Versionen von Apigee

Plattformen

1.5 1,6 1.7
Anthos(3) (Google Cloud) 1.18.x
1.19.x
1.19.x
1.20.x
1.21.x
1.20.x
1.21.x
Anthos(3) (AWS) 1.6.x
1.7.x
1.8.x(1)
1.7.x
1.8.x(1)
1.9.3+
1.10.x
1.9.x
1.10.x
Anthos(3) (Azure) 1.8.x 1.8.x
Anthos(3) (lokal – VMware) 1.6.x
1.7.x
1.8.x(1)
1.7.x
1.8.x(1)
1.9.3+
1.10.x
1.9.x
1.10.x
Anthos(3) (Bare Metal) 1.6.x
1.7.x
1.7.x
1.8.2+
1.9.3+
1.10.x
1.9.x
1.10.x
Anthos(3) (angehängte Cluster – Multi-Cloud)
Kubernetes-Version (EKS)
1.18.x
1.19.x
1.19.x
1.20.x
1.21.x
1.20.x
1.21.x
Anthos(3) (angehängte Cluster – Multi-Cloud)
Kubernetes-Version (AKS)
1.18.x
1.19.x
1.19.x
1.20.x
1.21.x
1.20.x
1.21.x
Anthos(3) (angehängte Cluster – Multi-Cloud)
OpenShift-Version
4.5
4.6
4.7
4.6
4.7
4.8
4.7
4.8
Anthos(3) (angehängte Cluster – Multi-Cloud)
Konvoy-Version
1.7.x 1.7.x

Komponenten

1.5 1,6 1,7
Anthos Service Mesh (ASM)(2) 1.7.x
1.8.x
1.9.x
1.12.x (für Apigee Hybrid 1.5 ab Version 1.5.9)
1.9.x
1.10.x
1.12.x (Apigee Hybrid-Version 1.6.6 und höher)
1.10.x
1.11.x
1.12.x
JDK JDK 11 JDK 11 JDK 11
cert-manager 1.2.0 1.5.4 1.7.x
Cassandra 3.11.6 3.11.6 3.11.9

(1) Folgen Sie ab Version 1.8.2 der Anleitung in diesem Dokument: Konflikt mit cert-manager beim Ausführen von Upgrades auf Version 1.8.2 oder höher.

(2) Nur unterstützte Versionen von ASM installieren.

(3) Nur unterstützte Versionen von Anthos installieren.

Unterstützte Versionen

Der Support für Apigee Hybrid folgt der Richtlinie für die Unterstützung der Version der Laufzeitebene. Die Richtlinie besagt, dass Nebenversionen von Apigee Hybrid ab der ursprünglichen Veröffentlichung höchstens neun Monate lang unterstützt werden.

In der folgenden Tabelle sind die unterstützten Versionen von Apigee Hybrid und das geplante Ende des Produktzyklus (End of Life, EOL) für eine Version aufgeführt.

Version Releasedatum Geplantes EOL-Datum
1,7 2022-04-18 2023-01-18
1,6 2021-09-13 2022-09-13*
1.5 2021-06-18 2022-06-18*
*Erweiterter Support

Wenn Sie eine nicht unterstützte Version von Apigee Hybrid verwenden, müssen Sie ein Upgrade auf eine unterstützte Version ausführen. Informationen zum Upgrade finden Sie unter Apigee Hybrid aktualisieren.

Die folgende Tabelle zeigt die nicht unterstützten Versionen von Apigee Hybrid und ihr Ende des Produktzyklus (EOL).

Version Releasedatum EOL-Datum
1.4 2020-12-17 2021-09-17
1.3 2020-07-30 2021-04-30
1.2 2020-04-30 2021-01-30
1.1 27.01.2020 2020-10-27