Looker Studio を使用したクイックスタート


BigQuery BI Engine では、BigQuery を基盤としたレポートとダッシュボードを使用して、高速で低レイテンシの分析サービスとインタラクティブな分析を実行できます。

この入門チュートリアルは、Looker Studio を使用してレポートとダッシュボードを作成するデータ アナリストとビジネス アナリストを対象としています。

目標

このチュートリアルの内容は次のとおりです。

  • Google Cloud コンソールで BigQuery を使用して BI Engine 容量の予約を作成します。
  • Looker Studio を使用して、BI Engine で管理されている BigQuery テーブルに接続します。
  • BI Engine 管理テーブルをクエリする Looker Studio ダッシュボードを作成します。

費用

このドキュメントでは、Google Cloud の次の課金対象のコンポーネントを使用します。

  • BI Engine: BI Engine で作成した予約の費用が発生します。BigQuery では、Looker Studio のクエリを促進するために、1 GB の予約容量が無料で用意されています。
  • BigQuery: BigQuery で作成したテーブルのストレージ費用が発生します。

料金計算ツールを使うと、予想使用量に基づいて費用の見積もりを生成できます。 新しい Google Cloud ユーザーは無料トライアルをご利用いただける場合があります。

BI Engine の料金の詳細については、料金設定のページをご覧ください。

BigQuery ストレージの料金について詳しくは、BigQuery のドキュメントのストレージの料金をご覧ください。

始める前に

作業を始める前に、使用するプロジェクトを所有し、そのプロジェクトで課金が有効になっていることと、BigQuery API が有効になっていることを確認してください。

  1. Google Cloud アカウントにログインします。Google Cloud を初めて使用する場合は、アカウントを作成して、実際のシナリオでの Google プロダクトのパフォーマンスを評価してください。新規のお客様には、ワークロードの実行、テスト、デプロイができる無料クレジット $300 分を差し上げます。
  2. Google Cloud Console の [プロジェクト セレクタ] ページで、Google Cloud プロジェクトを選択または作成します。

    プロジェクト セレクタに移動

  3. Google Cloud プロジェクトで課金が有効になっていることを確認します

  4. Google Cloud Console の [プロジェクト セレクタ] ページで、Google Cloud プロジェクトを選択または作成します。

    プロジェクト セレクタに移動

  5. Google Cloud プロジェクトで課金が有効になっていることを確認します

  6. 新しいプロジェクトでは、BigQuery API が自動的に有効になります。既存のプロジェクトで BigQuery API を有効にするには、

    BigQuery API を有効にします。

    API を有効にする

    に移動します。

BigQuery データセットを作成する

まず、BI Engine マネージド テーブルを格納する BigQuery データセットを作成します。データセットを作成する手順は次のとおりです。

  1. Google Cloud コンソールで [BigQuery] ページに移動します。

    [BigQuery] に移動

  2. ナビゲーション パネルの [エクスプローラ] パネルで、プロジェクト名をクリックします。

  3. 詳細パネルで、アクションを表示)をクリックし、[データセットを作成] をクリックします。

  4. [データセットの作成] ページで、次の操作を行います。

    • [データセット ID] に「biengine_tutorial」と入力します。
    • [データのロケーション] で、us(米国の複数のリージョン)と、一般公開データセットが保存されるマルチリージョンのロケーションを選択します。

    • このチュートリアルでは、[テーブルの有効期限を有効にする] を選択し、テーブルが期限切れになるまでの日数を指定できます。

      データセットの作成ページ

  5. その他のデフォルト設定はすべてそのままにし、[データセットを作成] をクリックします。

一般公開データセットからデータをコピーしてテーブルを作成する

このチュートリアルでは、Google Cloud 一般公開データセット プログラムを通じて提供されているデータセットを使用します。一般公開データセットは BigQuery でホストされ、ユーザーがアクセスして独自のアプリケーションに統合できます。

このセクションでは、San Francisco 311 サービス リクエストのデータセットからデータをコピーしてテーブルを作成します。データセットは、Google Cloud コンソールで探すことができます。

テーブルを作成する

テーブルを作成する手順は次のとおりです。

  1. Google Cloud コンソールで [BigQuery] ページに移動します。

    [BigQuery] に移動

  2. [エクスプローラ] パネルで「san_francisco_311」を検索します。

  3. [エクスプローラ] パネルで、[san_francisco_311] を開き、[311_service_requests] テーブルをクリックします。

  4. エクスプローラのツールバーで [コピー] をクリックします。

    ハイライト表示されたコピー オプション。

  5. [テーブルのコピー] ダイアログの [宛先] セクションで、次の操作を行います。

    • [プロジェクト名] で [参照] をクリックし、プロジェクトを選択します。
    • [データセット名] で [biengine_tutorial] を選択します。
    • テーブル名に「311_service_requests_copy」と入力します。

      宛先オプションが表示されている [テーブルのコピー] ウィンドウ

  6. [コピー] をクリックします。

  7. 省略可: コピージョブが完了したら、PROJECT_NAME > biengine_tutorial を開き、311_service_requests_copy > [プレビュー] をクリックして、テーブルの内容を確認します。PROJECT_NAME は、このチュートリアルで使用する Google Cloud プロジェクトの名前に置き換えます。

BI Engine 予約を作成する

  1. Google Cloud コンソールで、[管理] の下にある [BI Engine] ページに移動します。

    [BI Engine] ページに移動

  2. [予約を作成] をクリックします。

  3. [予約の作成] ページで、BI Engine の予約を構成します。

    • [プロジェクト] リストで、Google Cloud プロジェクトを確認します。
    • [ロケーション] リストで、ロケーションを選択します。ロケーションは、クエリするデータセットのロケーションと一致する必要があります。
    • [容量(GB)] スライダーを、予約するメモリ容量に合わせます。次の例では、容量を 2 GB に設定しています。上限は 250 GB です。

      BI Engine 容量のロケーション

  4. [次へ] をクリックします。

  5. [優先テーブル] セクションで、必要に応じて BI Engine で高速化するテーブルを指定します。テーブル名を調べる手順は次のとおりです。

    1. [テーブル ID] フィールドに、BI Engine で高速化するテーブルの名前の一部を入力します(例: 311)。
    2. 名前の候補リストから、テーブル名を選択します。

      指定したテーブルのみが高速化の対象となります。優先テーブルが指定されていない場合は、すべてのプロジェクト クエリが高速化の対象となります。

  6. [次へ] をクリックします。

  7. [確認して送信] セクションで、内容を確認します。

  8. 利用規約に同意する場合は、[作成] をクリックします。

予約を確認すると、[予約] ページに詳細が表示されます。

確認された予約

Looker Studio でデータソース接続を作成する

Looker Studio でレポートを作成する前に、レポートのデータソースを作成する必要があります。レポートには 1 つ以上のデータソースを含めることができます。Looker Studio は、BigQuery コネクタを使用して、BI Engine が管理する BigQuery テーブルに接続します。

Looker Studio でデータソース接続を定義すると、BI Engine は構成されたテーブルと列を使用して、キャッシュに保存するデータを決定します。BI Engine は、レポートに追加した列のみをキャッシュに保存します。

必要な権限

BigQuery データソースを Looker Studio レポートに追加するには、適切な権限が必要です。また、BigQuery データセットに適用される権限は、Looker Studio で作成したレポート、グラフ、ダッシュボードにも適用されます。Looker Studio レポートが共有されている場合は、適切な権限を持つユーザーにのみ、レポートの構成要素が表示されます。

レポートの入力に使用されるクエリジョブを実行するには、bigquery.jobs.create 権限が必要です。クエリジョブを正常に完了するには、クエリで参照されるテーブルを含むデータセットに対するアクセス権もユーザーまたはグループに付与されている必要があります。最低でも必要なアクセスレベルは閲覧者で、これは、そのデータセットの bigquery.dataViewer ロールにマッピングされています。

このチュートリアルで使用するデータセットは新しく作成しているので、データセットへのオーナー アクセス権が付与され、データセットを完全に制御できる状態になっています。また、このチュートリアルで使用したプロジェクトも作成しているので、プロジェクト レベルでオーナー アクセス権を取得しています。このオーナー アクセス権により、プロジェクトでジョブを実行できます。

権限の詳細

次の IAM 事前定義ロールを付与することで、プロジェクト レベルで bigquery.jobs.create 権限を設定できます。

  • bigquery.user
  • bigquery.jobUser
  • bigquery.admin

ユーザーまたはグループにプロジェク トレベルで bigquery.user ロールを付与すると、デフォルトでは、プロジェクト内のデータセット、テーブル、ビューへのアクセス権は付与されません。bigquery.user は、ユーザーが独自のデータセットを作成したり、アクセス権が付与されているデータセットに対してクエリジョブを実行できるようにするためのロールです。bigquery.user または bigquery.jobUser ユーザーロールを割り当てる際は、そのユーザーまたはグループがアクセスする必要のある、他のユーザーまたはグループによって作成されたデータセットに対するアクセス制御も割り当てる必要があります。

データセットに対するアクセス権を割り当てる際のオプションには、次の 3 つがあります。

  • 閲覧可能は、そのデータセットの bigquery.dataViewer ロールにマッピングされます。
  • 編集可能は、そのデータセットの bigquery.dataEditor ロールにマッピングされています。
  • オーナーは、そのデータセットの bigquery.dataOwner ロールにマッピングされています。

ユーザーがクエリを実行するために必要な最小のアクセス権限は、閲覧可能です。

BigQuery の IAM ロールの詳細は、BigQuery のドキュメントのアクセス制御をご覧ください。

BigQuery でのデータセットの保護については、BigQuery ドキュメントのデータセットへのアクセスの制御をご覧ください。

データソースの作成

データソースを作成するには、次の操作を行います。

  1. Looker Studio を開きます。

  2. [レポート] ページの [新しいレポートの開始] で、空のレポート テンプレートをクリックします。これによって、新しい無題のレポートが作成されます。

    空のテンプレート

  3. プロンプトが表示されたら、[マーケティング設定] と [アカウントとプライバシー] に値を設定して、[保存] をクリックします。設定を保存した後、もう一度 [空のレポート] テンプレートのクリックが必要になる場合があります。

  4. [データソースを追加] ウィンドウで [新しいデータソースを作成] をクリックします。

    データソースを追加する

  5. [Google コネクタ] セクションで BigQuery にカーソルを合わせて、[選択] をクリックします。

  6. [承認] セクションにある [承認] をクリックします。これにより、Looker Studio から Google Cloud プロジェクトにアクセスできるようになります。

  7. [Request for permission] ダイアログ ボックスで [許可] をクリックして、Looker Studio で BigQuery のデータを表示できるようにします。以前に Looker Studio を使用した場合には、このプロンプトが表示されない可能性があります。

  8. [プロジェクト] ペインで [マイ プロジェクト] が選択された状態のままにし、プロジェクトの名前をクリックします。

  9. [データセット] ペインで [biengine_tutorial] をクリックします。

  10. [テーブル] ペインで、[311_service_requests_copy] をクリックします。

  11. ウィンドウの右上にある [接続] をクリックします。Looker Studio が BigQuery データソースに接続されると、テーブルのフィールドが表示されます。このページは、フィールドのプロパティの調整や、新しい計算フィールドの作成に使用できます。

  12. 右上にある [レポートに追加] をクリックします。

  13. プロンプトが表示されたら、[レポートに追加] をクリックします。

  14. [Request for permission] ダイアログ ボックスで [許可] をクリックして、Looker Studio で Google Drive 内のファイルを表示および管理できるようにします。以前に Looker Studio を使用した場合には、このプロンプトが表示されない可能性があります。

グラフの作成

データソースをレポートに追加したら、次にデータを可視化します。ここでは棒グラフの作成から始めます。作成した棒グラフには、地域別の上位のクレームが表示されます。

近隣地域のクレームを表示する棒グラフを作成するには、次の操作を行います。

  1. (省略可)ページの先頭にある [無題のレポート] をクリックして、レポート名を変更します。たとえば、BI Engine tutorial と入力します。

  2. レポート エディタが読み込まれたら、[挿入] > [棒グラフ] をクリックします。

  3. ハンドルを使用して、グラフのサイズを拡大します。

  4. [データ] タブで、データソースの値が 311_service_requests_copy になっていることを確認します。

  5. 近隣地域別のリクエスト数をグラフ化するには、ディメンションを category に、内訳ディメンションを neighborhood に設定します。デフォルトのディメンション(status など)をクリックして、リストから [カテゴリ] を選択します。

    カテゴリ ディメンションの選択

  6. 使用可能なフィールドのリストで [近隣地域] をクリックして、[Breakdown dimension] の [Add dimension here] ボックスにドラッグします。

    近隣地域ディメンションの追加

フィルタを追加する

データには、neighborhood 列にNULL 値が含まれているため、グラフから NULL 値を削除するフィルタを追加します。

フィルタを追加するには、次の操作を行います。

  1. [データ] タブで [フィルタを追加] をクリックします。

    フィルタの追加オプション

  2. [Create filter] ダイアログで:

    • 名前として「Exclude nulls」と入力します。
    • データソース311_service_requests_copy に設定されていることを確認します。
    • [含む] をクリックし、[除外] を選択します。
    • [フィールドを選択] をクリックして、[近隣地域] を選択します。
    • [Select a condition] をクリックして [=null] を選択します。

      完成したフィルタ

    • [保存] をクリックします。

  3. フィルタを適用すると、グラフは次のようになります。

    完成した棒グラフ

クリーンアップ

このクイックスタートで使用したリソースについて、Google Cloud アカウントに課金されないようにするには、プロジェクトと BI Engine 予約のどちらか、または両方を削除してください。

プロジェクトの削除

課金をなくす最も簡単な方法は、チュートリアル用に作成したプロジェクトを削除することです。

プロジェクトを削除するには:

  1. Google Cloud コンソールで、[リソースの管理] ページに移動します。

    [リソースの管理] に移動

  2. プロジェクト リストで、削除するプロジェクトを選択し、[削除] をクリックします。
  3. ダイアログでプロジェクト ID を入力し、[シャットダウン] をクリックしてプロジェクトを削除します。

予約の削除

プロジェクトを残す場合は、容量の予約を削除することで、BI Engine の費用発生を回避できます。

予約を削除する手順は次のとおりです。

  1. Google Cloud コンソールで、[管理] の下にある [BI Engine] ページに移動します。

    [BI Engine] ページに移動

  2. [予約] セクションで、予約を探します。

  3. [操作] 列で、予約の右側にある アイコンをクリックし、[削除] を選択します。

  4. [予約を削除しますか?] ダイアログで「削除」を入力して、[削除] をクリックします。

次のステップ