Visualiser des données BigQuery à l'aide de Google Data Studio

BigQuery est un entrepôt de données analytiques, à l'échelle du pétaoctet, que vous pouvez utiliser pour exécuter des requêtes SQL sur de grandes quantités de données, en temps quasi réel.

Les outils de visualisation de données peuvent vous aider à comprendre les données BigQuery et à les analyser de manière interactive. Vous pouvez utiliser ces outils pour identifier des tendances, agir en conséquence et effectuer des prédictions à l'aide de vos données. Dans ce tutoriel, vous allez utiliser Google Data Studio pour visualiser les données de l'exemple de table BigQuery natality.

Objectifs

Dans ce tutoriel, vous allez :

  • Établir une connexion à une source de données BigQuery
  • Créer des rapports et des graphiques pour visualiser les données BigQuery

Coûts

Le connecteur Data Studio BigQuery vous permet d'accéder aux données de vos tables BigQuery dans Data Studio. BigQuery est un produit payant, dont les coûts d'utilisation vous sont facturés lorsque vous y accédez via Data Studio. Selon la tarification des requêtes BigQuery, le premier To par mois est gratuit. Pour en savoir plus, consultez l'article sur la tarification BigQuery.

Avant de commencer

Avant de commencer ce tutoriel, utilisez la console Google Cloud Platform pour créer ou sélectionner un projet et activer la facturation.

  1. Sign in to your Google Account.

    If you don't already have one, sign up for a new account.

  2. Select or create a GCP project.

    Go to the Manage resources page

  3. Assurez-vous que la facturation est activée pour votre projet.

    En savoir plus sur l'activation de la facturation

  4. BigQuery est automatiquement activé dans les nouveaux projets. Pour activer BigQuery dans un projet préexistant : Enable the BigQuery API.

    Enable the API

Créer des rapports et des graphiques à l'aide de Google Data Studio et du connecteur BigQuery

Dans cette section du tutoriel, vous allez utiliser Google Data Studio pour visualiser des données dans BigQuery à l'aide du connecteur BigQuery. Vous créez une source de données, un rapport et des graphiques qui visualisent les données dans l'exemple de table natality.

Créer une source de données

La première étape de la création d'un rapport dans Data Studio consiste à créer une source de données pour ce rapport. Un rapport peut contenir une ou plusieurs sources de données. Lorsque vous créez une source de données BigQuery, Data Studio utilise le connecteur BigQuery.

Vous devez disposer des autorisations appropriées pour ajouter une source de données BigQuery à un rapport Data Studio. En outre, les autorisations appliquées aux ensembles de données BigQuery s'appliqueront aux rapports, graphiques et tableaux de bord créés dans Data Studio. Lorsqu'un rapport Data Studio est partagé, ses composants sont visibles uniquement par les utilisateurs disposant des autorisations appropriées.

Pour créer une source de données :

  1. Ouvrez Google Data Studio.

  2. Dans la section Start a new report section (Commencer un nouveau rapport) de la page Reports (Reports), cliquez sur le modèle Blank (Vide). Cette action crée un nouveau rapport sans titre.

    Modèle vierge

  3. Si vous y êtes invité, renseignez les paramètres Marketing Preferences (Préférences Marketing), Account and Privacy (Compte et Confidentialité), puis cliquez sur Save (Enregistrer). Vous devrez peut-être cliquer de nouveau sur le modèle Blank (Vide) après l'enregistrement de vos paramètres.

  4. Dans la fenêtre Add a data source (Ajouter une source de données), cliquez sur Create new data source (Créer une source de données).

    Ajouter une source de données

  5. Dans la section Google Connectors (Connecteurs Google), passez la souris sur BigQuery, puis cliquez sur Select (Sélectionner).

  6. Pour Authorization (Autorisation), cliquez sur Authorize (Autoriser). Cela permet à Data Studio d'accéder à votre projet GCP.

  7. Dans la boîte de dialogue Request for permission (Demande d'autorisation), cliquez sur Allow (Autoriser) pour permettre à Data Studio d'afficher des données dans BigQuery. Si vous avez déjà utilisé Data Studio, il est possible que vous ne receviez pas cette invite.

  8. Pour My Projects (Mes projets), cliquez sur Public Datasets (Ensembles de données publics).

  9. Pour Billing Project (Projet de facturation), cliquez sur le nom du projet GCP que vous avez créé précédemment.

  10. Pour Public Dataset (Ensemble de données public), cliquez sur samples (exemples).

  11. Pour Table, cliquez sur natality.

    Table natality

  12. Dans l'angle supérieur droit de la fenêtre, cliquez sur Connect (Connecter). Une fois que Data Studio se connecte à la source de données BigQuery, les champs de la table s'affichent. Vous pouvez utiliser cette page pour ajuster les propriétés des champs ou pour créer des champs calculés.

  13. Dans la table natality, les champs year et source_year sont stockés sous forme d'entiers. Pour utiliser ces colonnes en tant que chaînes dans Data Studio, vous devez modifier le type de ces colonnes en texte. À droite des champs year et source_year, dans la colonne Type, cliquez sur Number (Nombre) et sélectionnez Text (Texte) dans la liste déroulante.

    Dialogue de champ

  14. Cliquez sur Add to report (Ajouter au rapport).

    Ajouter au rapport

  15. Lorsque vous y êtes invité, cliquez sur Add to report (Ajouter au rapport).

  16. Dans la boîte de dialogue Request for permission (Demande d'autorisation), cliquez sur Allow (Autoriser) pour permettre à Data Studio d'afficher et de gérer des fichiers dans Google Drive. Si vous avez déjà utilisé Data Studio, il est possible que vous ne receviez pas cette invite.

Créer un graphique à barres à partir d'un champ calculé

Une fois que vous avez ajouté la source de données natality au rapport, l'étape suivante consiste à créer une visualisation. Commencez par créer un graphique à barres. Celui-ci affiche le nombre total de naissances pour chaque année. Pour afficher les naissances par année, créez un champ calculé.

Pour créer un graphique à barres qui affiche le nombre total de naissances par année :

  1. (Facultatif) En haut de la page, cliquez sur Untitled Report (Rapport sans titre) pour modifier le nom du rapport. Par exemple, entrez BigQuery tutorial.

  2. Une fois l'éditeur de rapports chargé, cliquez sur Insert > Bar chart (Insérer > Graphique à barres).

  3. À l'aide de la poignée, dessinez un rectangle sur le rapport pour afficher le graphique.

  4. Sur l'onglet Data (Données), notez la valeur de la source de données (natality) et les valeurs par défaut de dimension et de métrique.

  5. Comme vous tracez le nombre de naissances par année, vous devez définir la dimension sur source_year. Dans la liste Available Fields (Champs disponibles), cliquez sur la valeur source_year et faites-la glisser sur la zone Add dimension here (Ajouter une dimension ici). L'année source est l'année à quatre chiffres de la naissance de l'enfant.

    Propriétés de graphique par défaut

  6. Une fois la dimension ajoutée, passez la souris sur la dimension par défaut et cliquez sur l’icône de suppression située à droite.

    Propriétés de graphique par défaut

  7. Dans la section Metric (Métrique), cliquez sur Add metric here (Ajouter une mesure ici).

  8. Dans l'outil de sélection de métriques, cliquez sur Create new metric (Créer une métrique).

  9. Pour afficher le nombre d'enfants nés chaque année (par sexe), créez un champ calculé. Pour ce tutoriel, vous comptez les entrées du champ is_male. La valeur dans is_male est true si l'enfant est un garçon, false s'il s'agit d'une fille. Dans la fenêtre de la nouvelle métrique, pour Name (Nom), entrez birth_count.

  10. Ne modifiez pas l'ID de champ.

  11. Pour Formula (Formule), entrez ce qui suit (ou utilisez l'assistant de formule) : COUNT(is_male).

  12. Cliquez sur Save (Enregistrer).

    Créer un champ calculé

  13. Cliquez sur Done (Terminé).

  14. Cliquez sur la flèche de retour pour fermer l'outil de sélection de métriques.

  15. Dans la liste Available Fields (Champs disponibles), cliquez sur la valeur birth_count et faites-la glisser sur la zone Add metric here (Ajouter une métrique ici).

  16. Une fois la métrique ajoutée, passez la souris sur la métrique par défaut, puis cliquez sur l'icône de suppression située à droite. La dimension doit désormais être définie sur source_year et la métrique sur birth_count.

  17. Notez que, par défaut, le graphique est trié par ordre décroissant. Les années avec le plus de naissances s'affichent en premier.

    Graphique du total des naissances

  18. Pour améliorer le graphique, modifiez les libellés des barres. Dans la fenêtre de propriétés du graphique à barres, cliquez sur l'onglet Style.

  19. Dans la section Bar chart (Graphique à barres), cochez Show data labels (Afficher les libellés des données).

    Afficher les libellés

    Le nombre total de naissances s'affiche en haut de chaque barre du graphique.

  20. Triez les données par source_year au lieu de birth_count. Dans la fenêtre de propriétés du graphique à barres, sur l'onglet Data (Données), dans la section Sort (Trier) :

    • Cliquez sur le champ existant (birth_count) pour ouvrir le sélecteur de tri.
    • Dans le sélecteur de tri, sélectionnez source_year.
    • Cliquez sur la flèche de retour pour fermer le sélecteur de tri.
    • Cliquez sur Descending (Décroissant) et sélectionnez Ascending (Croissant). Le nombre de naissances par année s'affiche dans l'ordre croissant.

    Naissances par ordre croissant

Filtrer le graphique

Le graphique à barres présente actuellement le nombre total de garçons et de filles nés chaque année. Ajoutez un filtre pour afficher uniquement les filles nées chaque année.

  1. Dans la fenêtre de propriétés du graphique à barres, cliquez sur l'onglet Data (Données).

  2. Dans la section Filter (Filtre), cliquez sur Add a filter (Ajouter un filtre).

  3. Dans la fenêtre Create filter (Créer un filtre) :

    • Pour Name (Nom), entrez Female birth count.
    • Cliquez sur Include (Inclure) et remplacez-le par Exclude (Exclure).
    • Cliquez sur Select a field (Sélectionner un champ) et sélectionnez is_male.
    • Cliquez sur Select a condition (Sélectionner une condition) et sélectionnez Vrai.
    • Cliquez sur Save (Enregistrer).

    Fenêtre Créer un filtre

Notez que le graphique a été mis à jour pour afficher uniquement les filles nées chaque année. Notez également que la légende ne change pas. Le nom de la légende reflète toujours le nom de la métrique (birth_count).

Graphique filtré

Créer un graphique à l'aide d'une requête personnalisée

Data Studio n'autorisant pas les agrégations sur les métriques, certains composants de rapport sont plus faciles à générer à l'aide d'une requête SQL personnalisée. L'option "Requête personnalisée" vous permet également de tirer parti des fonctionnalités de requêtes complètes de BigQuery, telles que les jointures, les liaisons et les fonctions d'analyse.

Vous pouvez également tirer parti des fonctionnalités de requêtes complètes de BigQuery en créant une vue. Il s'agit d'une table virtuelle définie par une requête SQL. Vous pouvez interroger les données d'une vue en ajoutant l'ensemble de données contenant la vue en tant que source de données. Pour plus d'informations sur les vues, voir la page sur l'utilisation des vues.

Lorsque vous spécifiez une requête SQL comme source de données BigQuery, les résultats de requête se présentent sous forme de table, et celle-ci devient la définition de champ (schéma) de votre source de données. Lorsque vous utilisez une requête personnalisée comme source de données, Data Studio l'utilise comme instruction de sélection interne pour chaque requête générée vers BigQuery. Pour plus d'informations sur les requêtes personnalisées dans Data Studio, consultez l'aide en ligne.

Ajouter un graphique à barres à l'aide d'une requête personnalisé

Pour ajouter à votre rapport un graphique à barres utilisant une requête personnalisée comme source de données :

  1. Dans les options du menu, sélectionnez Page > New page (Page > Nouvelle page).

  2. Cliquez sur Insert > Bar chart (Insérer > Graphique à barres).

  3. À l'aide de la poignée, dessinez un rectangle sur le rapport pour afficher le graphique.

  4. Dans la fenêtre Bar chart properties (Propriétés du graphique à barres), sous l'onglet Data (Données), notez que Data Source (Source de données) est définie sur natality. Cliquez sur natality pour ouvrir la fenêtre Select Data Source (Sélectionner la source de données).

  5. Cliquez sur Create new data source (Créer une source de données).

  6. Dans la section Google Connectors (Connecteurs Google), passez la souris sur BigQuery et cliquez sur Select (Sélectionner).

  7. Pour My Projects (Mes projets), cliquez sur Custom query (Requête personnalisée).

  8. Pour Project (Projet), sélectionnez votre projet GCP.

  9. Entrez la requête SQL standard suivante dans la fenêtre Enter custom query (Saisissez une requête personnalisée) :

    SELECT
     source_year,
     sum(case when is_male then 1 else 0 end) as male_births,
     sum(case when is_male then 0 else 1 end) as female_births
    FROM
     `bigquery-public-data.samples.natality`
    GROUP BY
     source_year
    ORDER BY
     source_year
    DESC
    

    Cette requête évalue le champ booléen is_male à l'aide d'une instruction CASE pour déterminer le nombre de naissances de filles et de garçons pour une année donnée.

  10. Sous Query Options (Options de requête), désélectionnez Use Legacy SQL (Utiliser l'ancien SQL). Cela vous permet d'utiliser la syntaxe SQL standard de BigQuery.

    Requête personnalisée

  11. En haut de la fenêtre, cliquez sur Untitled data source (Source de données sans titre), remplacez le nom de la source de données par Male female case query.

  12. Dans l'angle supérieur droit de la fenêtre, cliquez sur Connect (Connecter). Une fois que Data Studio est connecté à la source de données BigQuery, les résultats de requête permettent de déterminer le schéma de la table.

  13. Lorsque le schéma s'affiche, notez le type et l'agrégation de chaque champ. Par défaut, source_year est mis en forme sous la forme d'un nombre et l'agrégation est définie sur Aucun. À droite du champ source_year, dans la colonne Type, cliquez sur Number (Numéro) et sélectionnez Text (Texte). Vérifiez que l'agrégation est définie sur None (Aucun).

    Graphique filtré

  14. Cliquez sur Add to report (Ajouter au rapport).

  15. Lorsque vous y êtes invité, cliquez sur Add to report (Ajouter au rapport).

  16. Cliquez sur la flèche de retour pour fermer la fenêtre "Sélectionner une source de données".

  17. Il est possible que Data Studio ne puisse pas déterminer correctement la métrique appropriée pour le graphique. Étant donné que vous tracez le nombre de naissances de garçons et de filles par année, les valeurs de métrique doivent être female_births et male_births. Dans la fenêtre de propriétés du graphique à barres, sur l'onglet Data (Données), dans la section Metric (Métrique), cliquez sur Record Count (Nombre d'enregistrements).

  18. Dans l'outil de sélection de métriques, sélectionnez female_births.

  19. Cliquez sur la flèche de retour pour fermer l'outil de sélection de métriques.

  20. Dans la section Metric (Métrique), cliquez sur Add metric here (Ajouter une mesure ici).

  21. Dans l'outil de sélection de métriques, sélectionnez male_births.

  22. Cliquez sur la flèche de retour pour fermer l'outil de sélection de métriques. Le graphique affiche désormais sur des barres distinctes le nombre de garçons et de filles nés chaque année.

    Graphique filtré

  23. Le graphique doit être trié par female_births par ordre décroissant. Remplacez cette valeur par source_year comme vous l'avez fait dans le graphique précédent. Dans la section Sort (Trier), cliquez sur female_births.

  24. Dans le sélecteur de tri, sélectionnez source_year.

  25. Cliquez sur la flèche de retour pour fermer le sélecteur de tri. Le graphique affiche désormais par ordre décroissant le nombre de naissances de garçons et de filles par année.

  26. Pour plus de lisibilité, modifiez les styles du graphique. Dans la fenêtre Bar chart properties (Propriétés du graphique à barres), cliquez sur l'onglet Style.

  27. Notez que chaque barre dispose d'une couleur par défaut basée sur l'ordre dans lequel les métriques ont été ajoutées au graphique. Cliquez sur le deuxième carré de la palette de couleurs et passez du rouge au bleu.

    Graphique filtré

  28. Cliquez sur le premier carré de la palette de couleurs et passez du bleu au rouge.

    Le graphique doit se présenter comme illustré ci-dessous :

    Graphique à barres coloré

Afficher l'historique des requêtes

Pour afficher les requêtes soumises via le connecteur BigQuery, examinez l'historique de vos requêtes dans l'interface Web de BigQuery. Grâce à l'historique des requêtes, vous pouvez estimer leur coût et enregistrer celles qui pourront vous resservir dans d'autres scénarios.

Pour examiner l'historique de vos requêtes :

  1. Accédez à l'interface utilisateur Web de BigQuery.

    Accéder à l'interface utilisateur Web de BigQuery

  2. Cliquez sur Query History (Historique des requêtes).

  3. La liste des requêtes s'affiche, avec les plus récentes en tête. Cliquez sur Open Query (Ouvrir la requête) pour afficher les détails de la requête, tels que l'ID de la tâche et le nombre d'octets traités.

    Graphique à barres coloré

Effectuer un nettoyage

Afin d'éviter que des frais ne soient facturés sur votre compte Google Cloud Platform pour les ressources utilisées dans ce tutoriel, procédez comme suit :

  1. In the GCP Console, go to the Projects page.

    Go to the Projects page

  2. In the project list, select the project you want to delete and click Delete project. After selecting the checkbox next to the project name, click
      Delete project
  3. In the dialog, type the project ID, and then click Shut down to delete the project.

La suppression de votre projet empêche Data Studio d'interroger les données car la source de données est associée à votre projet. Si vous ne souhaitez pas supprimer votre projet Cloud Platform, vous pouvez supprimer le rapport et la source de données Data Studio.

Pour supprimer les ressources Data Studio :

  1. Ouvrez Google Data Studio.

  2. Sur la page Reports (Rapports), à droite du rapport du tutoriel BigQuery, cliquez sur le bouton "more" (plus) Bouton "plus" et sélectionnez Remove (Supprimer).

  3. Cliquez sur Data Sources (Sources de données).

  4. À droite de la source de données natality, cliquez sur le bouton "more" (plus) et sélectionnez Remove (Supprimer).

  5. À droite de la source de données Male female case query, cliquez sur le bouton "more" (plus) et sélectionnez Remove (Supprimer).

Étapes suivantes

Cette page vous a-t-elle été utile ? Évaluez-la :

Envoyer des commentaires concernant…