Como visualizar dados do BigQuery usando o Google Data Studio

O BigQuery é um serviço de armazenamento de dados para análise em escala de petabytes. Ele é usado para executar consultas SQL em um grande volume de dados, praticamente em tempo real.

As ferramentas de visualização de dados ajudam a compreender e a analisar os dados do BigQuery interativamente. Use essas ferramentas para identificar tendências, responder a elas e fazer previsões usando os seus dados. Neste tutorial, você usa o Google Data Studio para visualizar dados na tabela de amostras de natalidade do BigQuery.

Objetivos

Neste tutorial, você:

  • faz conexão com uma fonte de dados do BigQuery;
  • cria relatórios e gráficos para visualizar dados do BigQuery.

Custos

O conector do BigQuery para o Data Studio permite acessar dados das tabelas do BigQuery de dentro do Data Studio. O BigQuery é um produto pago e acarreta custos de uso se ele é acessado pelo Data Studio. No BigQuery, o primeiro 1 TB mensal de dados de consultas é fornecido gratuitamente. Para mais informações, consulte os preços do BigQuery.

Antes de começar

Antes de começar este tutorial, use o Google Cloud Platform Console para criar ou selecionar um projeto e ativar o faturamento.

  1. Faça login na conta do Google.

    Se você ainda não tiver uma, inscreva-se.

  2. Select or create a Cloud Platform project.

    Go to the Manage resources page

  3. Ative o faturamento do projeto.

    Ativar faturamento

  4. O BigQuery é ativado automaticamente em novos projetos. Para ativá-lo em um projeto já existente, Enable the BigQuery API.

    Enable the API

Criar relatórios e gráficos usando o Google Data Studio e o conector do BigQuery

Nesta seção do tutorial, use o Google Data Studio para visualizar dados do BigQuery usando o conector apropriado. Crie uma fonte de dados, um relatório e gráficos para visualizar o conteúdo da tabela de amostra de natalidade.

Criar uma fonte de dados

A primeira etapa na criação de um relatório no Data Studio é criar uma fonte de dados para ele. Esse relatório pode conter uma ou mais fontes de dados. Quando você cria uma fonte de dados do BigQuery, o conector dele é utilizado no Data Studio.

Para adicionar uma fonte de dados do BigQuery a um relatório do Data Studio, você precisa ter as permissões apropriadas. Além disso, as mesmas permissões são aplicáveis aos conjuntos de dados do BigQuery e aos relatórios, gráficos e painéis criados no Data Studio. Quando um relatório é compartilhado, os componentes dele são visíveis apenas a usuários com as permissões adequadas.

Para criar uma fonte de dados:

  1. Abra o Google Data Studio.

  2. Na página Relatórios, na seção Iniciar um novo relatório, clique no modelo Em branco. Isso cria um novo relatório sem título.

    Modelo em branco

  3. Se solicitado, clique em Eu aceito os termos e as condições e em Aceitar. Talvez seja necessário clicar no modelo em branco novamente depois de concordar com os termos e as condições.

  4. Na janela Adicionar uma fonte de dados, clique em Criar nova fonte de dados.

    Adicionar fonte de dados

  5. Em Conectores, clique em BigQuery.

  6. Em Autorização, clique em Autorizar. Isso permite o acesso do Data Studio ao seu projeto GCP.

  7. Na caixa de diálogo Solicitar permissão, clique em Permitir para que os dados possam ser vistos pelo Data Studio no BigQuery. Se você usou o Data Studio anteriormente, talvez não receba essa solicitação.

  8. Para Meus projetos, clique em Conjuntos de dados públicos.

  9. Em Conjuntos de dados, clique em amostras.

  10. Para Tabela, clique em natality.

    tabela natality

  11. Em Faturamento do projeto, selecione o projeto GCP.

  12. No canto superior direito da janela, clique em Conectar.

  13. Quando o Data Studio é conectado à fonte de dados do BigQuery, os campos da tabela são exibidos. Use esta página para ajustar as propriedades do campo ou criar novos campos calculados. Clique em Adicionar ao relatório.

    Adicionar ao relatório

  14. Quando solicitado, clique em Adicionar ao relatório.

  15. Na caixa de diálogo Solicitar permissão, clique em Permitir para que os arquivos do Google Drive possam ser vistos e gerenciados pelo Data Studio. Se você usou o Data Studio anteriormente, talvez não receba essa solicitação.

Criar um gráfico de barras usando um campo calculado

Depois de adicionar a fonte de dados de natalidade ao relatório, o próximo passo é criar uma visualização. Comece criando um gráfico de barras. Nesse gráfico é exibido o número total de nascimentos de cada ano. Para exibir os nascimentos por ano, crie um campo calculado.

Para criar um gráfico de barras que exiba o total de nascimentos por ano:

  1. (Opcional) No topo da página, clique em Relatório sem título para alterar o nome do relatório. Por exemplo, digite BigQuery tutorial.

  2. Quando o editor do relatório é carregado, clique em Inserir> Gráfico de barras.

  3. Usando a alça, desenhe um retângulo no relatório para exibir o gráfico.

  4. Na janela Propriedades do gráfico de barras, na guia Dados, observe o valor da fonte de dados (natality) e os valores padrão de "Dimensão" e "Métrica".

  5. Como os valores nulos são permitidos no campo year, altere a Dimensão para source_year. Na seção Dimensão, clique na dimensão existente.

    Propriedades do gráfico padrão

  6. No Seletor de dimensão, selecione source_year. O "source_year" é o ano com quatro dígitos do nascimento da criança.

  7. Clique na seta para trás Seta para trás para fechar o "Seletor de dimensão".

  8. Na seção Métrica, clique na métrica existente.

    Propriedades do gráfico padrão

  9. No Seletor de métrica, clique em Criar nova métrica.

  10. Clique em Criar um campo calculado (Criar um campo calculado). Para exibir uma contagem do número de crianças nascidas a cada ano, crie um campo calculado. Neste tutorial, você conta as entradas no campo is_male. O valor em is_male é true se a criança é do sexo masculino e false se ela é do sexo feminino.

  11. Em Nome, digite birth_count.

  12. Não altere o ID.

  13. Em Fórmula, use o assistente de fórmulas ou digite o seguinte: COUNT(is_male).

  14. Clique em Criar campo.

    Criar campo calculado

  15. Clique em Concluído.

  16. No Seletor de métrica, selecione birth_count.

  17. Clique na seta para trás para fechar o "Seletor de métrica". A Dimensão deve ser definida como source_year e a Métrica deve ser definida como birth_count. Observe que, por padrão, o gráfico é classificado em ordem decrescente. Os anos com mais nascimentos são exibidos em primeiro lugar.

    Gráfico do total de nascimentos

  18. Para aprimorar o gráfico, altere os marcadores das barras. Na janela Propriedades do gráfico de barras, clique na guia Estilo.

  19. Na seção Gráfico de barras, marque Mostrar marcadores de dados.

    Mostrar marcadores

    O número total de nascimentos é exibido acima de cada barra no gráfico.

  20. Classifique os dados por source_year em vez de birth_count . Na janela Propriedades do gráfico de barras, na guia Dados, na seção Classificar:

    • Clique em birth_count e selecione source_year.
    • Clique em Decrescente e depois em Crescente. A tela passa a mostrar o número de nascimentos por ano, em ordem crescente.

    Nascimentos em ordem crescente

Filtrar o gráfico

Atualmente, o número total de crianças do sexo masculino e feminino nascidas a cada ano é exibido no gráfico de barras. Adicione um filtro para exibir apenas as crianças do sexo feminino nascidas a cada ano.

  1. Na janela Propriedades do gráfico de barras, clique na guia Dados.

  2. Na seção Filtrar, clique em Adicionar um filtro.

  3. Na caixa de diálogo Criar filtro:

    • Em Nome, digite Female birth count.
    • Clique em Incluir e altere para Excluir.
    • Clique em Selecione um campo e escolha is_male.
    • Clique em Selecione uma condição e escolha Verdadeiro.
    • Clique em Salvar.

Observe que o gráfico é atualizado para exibir apenas crianças do sexo feminino nascidas a cada ano. Observe também que a legenda não muda. O nome da legenda ainda reflete o nome da métrica: birth_count.

Gráfico filtrado

Criar um gráfico usando uma consulta personalizada

Como as agregações nas métricas não são permitidas no Data Studio, é mais fácil gerar alguns componentes do relatório usando uma consulta SQL personalizada. A opção "Consulta personalizada" também permite tirar proveito de todos os recursos de consulta do BigQuery como junções, uniões e funções analíticas.

Alternativamente, use esses recursos para criar uma visualização, uma tabela virtual definida por uma consulta SQL. Consulte os dados dessa visualização, adicionando o conjunto de dados dela como fonte de dados. Para mais informações sobre visualizações, consulte Como usar visualizações.

Quando uma consulta SQL é especificada como fonte de dados do BigQuery, os resultados dela estão em formato de tabela. Esse resultado se transforma em definição de campo, ou esquema, da sua fonte de dados. Quando você usa uma consulta personalizada como fonte, esse SQL é usado como uma instrução SELECT interna no Data Studio para cada consulta gerada para o BigQuery. Para mais informações sobre consultas personalizadas no Data Studio, consulte a ajuda on-line.

Adicionar um gráfico de barras usando uma consulta personalizada

Para adicionar um gráfico de barras ao relatório que usa uma fonte de dados de consulta personalizada:

  1. Clique em Inserir > Gráfico de barras.

  2. Usando a alça, desenhe um retângulo no relatório para exibir o gráfico.

  3. Na janela Propriedades do gráfico de barras, na guia Dados, observe que o valor da fonte de dados (natality) e os valores padrão de Dimensão e Métrica são os mesmos do gráfico anterior. Na seção Fonte de dados, clique em Ícone "Selecionar fonte de dados" Selecionar fontes de dados.

    Gráfico filtrado

  4. Clique em Criar nova fonte de dados.

  5. Em Conectores, clique em BigQuery.

  6. Em Meus projetos, clique em Consulta personalizada.

  7. Em Projeto, selecione o projeto do GCP.

  8. Digite o seguinte código na janela Inserir consulta personalizada:

    SELECT
     source_year,
     sum(case when is_male then 1 else 0 end) as male_births,
     sum(case when is_male then 0 else 1 end) as female_births
    FROM
     `bigquery-public-data.samples.natality`
    GROUP BY
     source_year
    ORDER BY
     source_year
    DESC
    

    Esta consulta usa a declaração CASE para avaliar o campo booleano is_male e determinar o número de nascimentos de cada sexo que ocorreram em um determinado ano.

  9. Em Opções de consulta, desmarque Usar SQL legado. Isso permite usar a sintaxe SQL padrão do BigQuery.

  10. Na parte superior da janela, clique em Fonte de dados sem título e altere o nome da fonte de dados para Male female case query.

  11. No canto superior direito da janela, clique em Conectar. Quando o Data Studio é conectado à fonte de dados BigQuery, os resultados da consulta são usados para determinar o esquema da tabela.

  12. Quando o esquema é exibido, observe o tipo e agregação de cada campo. Por padrão, source_year é formatado como um número e a agregação é definida como soma. À direita do campo source_year, na coluna Agregação, clique em Soma e selecione Nenhum.

    Gráfico filtrado

  13. Clique em Adicionar ao relatório.

  14. Quando solicitado, clique em Adicionar ao relatório.

  15. Talvez não seja possível determinar a dimensão e as métricas apropriadas para o gráfico no Data Studio. Isso resulta no erro: Configuration incomplete - Invalid dimension or metric selected. Em Propriedades do gráfico de barras, na guia Dados, na seção Dimensão, clique em Dimensão inválida.

    Gráfico filtrado

  16. No Seletor de dimensão, selecione source_year.

  17. Clique na seta para trás para fechar o "Seletor de dimensão".

  18. Na janela Propriedades do gráfico de barras, na guia Dados, na seção Métrica, clique em Métrica inválida.

  19. No Seletor de métrica, selecione female_births.

  20. Clique na seta para trás para fechar o "Seletor de métrica".

  21. Na seção Métrica, clique em Adicionar uma métrica.

    Gráfico filtrado

  22. No Seletor de métrica, selecione male_births.

  23. Clique na seta para trás para fechar o "Seletor de métrica". O gráfico agora exibe o número de crianças do sexo masculino e feminino nascidas a cada ano.

    Gráfico filtrado

  24. Para facilitar a leitura, altere os estilos do gráfico. Em Propriedades do gráfico de barras, clique na guia Estilo.

  25. Na seção Gráfico de barras, desmarque Cor única.

  26. Observe que cada barra tem uma cor padrão com base na ordem em que as métricas foram adicionadas ao gráfico. Clique no segundo quadrado na paleta de cores e altere-o de vermelho para azul.

    Gráfico filtrado

  27. Clique no primeiro quadrado na paleta de cores e altere-o de azul para vermelho.

    O gráfico deve ficar assim:

    Gráfico de barras colorido

Ver o histórico da consulta

Para ver as consultas enviadas pelo conector do BigQuery, examine o histórico da consulta na interface da web do BigQuery. Usando o histórico de consultas, estime os custos das consultas e salve-as para uso em outros cenários.

Para examinar o histórico da consulta:

  1. Acesse a IU da Web do BigQuery.

    Acessar a IU da Web do BigQuery

  2. Clique em Histórico da consulta.

  3. A lista de consultas é exibida com as consultas mais recentes em primeiro lugar. Clique em Abrir consulta para ver os detalhes da consulta, como ID do job e Bytes processados.

    Gráfico de barras colorido

Limpar o ambiente

Para evitar cobranças dos recursos usados neste tutorial na conta do Google Cloud Platform:

  1. In the Cloud Platform Console, go to the Projects page.

    Go to the Projects page

  2. In the project list, select the project you want to delete and click Delete project. After selecting the checkbox next to the project name, click
      Delete project
  3. In the dialog, type the project ID, and then click Shut down to delete the project.

A exclusão do projeto impede a consulta de dados pelo Data Studio porque a fonte de dados está associada ao projeto. Se você não quer excluir o seu projeto Cloud Platform, exclua o relatório e a fonte de dados do Data Studio.

Para excluir os recursos do Data Studio:

  1. Abra o Google Data Studio.

  2. Na página Relatórios, à direita do relatório Tutorial do BigQuery, clique no botão Mais botão mais e escolha Remover.

  3. Clique em Fontes de dados.

  4. À direita da fonte de dados natality, clique no botão "mais" e escolha Remover.

  5. À direita da fonte de dados Consulta de caso feminino masculino,clique no botão "mais" e escolha Remover.

Próximas etapas

  • Saiba mais sobre como escrever consultas para o BigQuery - Como consultar dados na documentação do BigQuery explica como executar consultas, criar funções definidas pelo usuário (UDFs, na sigla em inglês) e muito mais.

  • Explorar a sintaxe do BigQuery — O dialeto preferencial para consultas SQL no BigQuery é o SQL padrão, descrito na Referência do SQL. A sintaxe semelhante a SQL legado do BigQuery é descrita na Referência de consulta (SQL legado).

Enviar comentários sobre…