Versiones de PHP compatibles

Organízate con las colecciones Guarda y clasifica el contenido según tus preferencias.

Las bibliotecas cliente de Cloud para PHP son compatibles con al menos las tres actualizaciones más recientes de PHP. Esto significa que las bibliotecas cliente de PHP son compatibles con todas las versiones de PHP admitidas de forma activa. En PHP, se lanza una versión principal nueva cada 12 meses. Las dos versiones activas y una solo reciben correcciones de seguridad.

Por ejemplo, si la versión actual de las bibliotecas cliente de Cloud para PHP es PHP 8.1, las bibliotecas cliente son compatibles con PHP 8.1, PHP 8.0 y PHP 7.4. Las bibliotecas siempre serán compatibles con al menos un entorno de ejecución de Google Analytics para App Engine y Cloud Functions. Para obtener más información, consulta Explicación de bibliotecas cliente.

Para un desarrollo nuevo

Cuando comiences un proyecto nuevo para un desarrollo nuevo, te recomendamos que uses la versión actual de PHP. Esto garantiza que el entorno de ejecución use una versión de PHP compatible y reciba parches de seguridad críticos.

Mantén los sistemas de producción actualizados

Mantener los sistemas de producción en versiones de PHP compatibles es la mejor manera de garantizar que recibas correcciones de errores y seguridad importantes. Cuando las bibliotecas cliente de Cloud para PHP aumentan una versión secundaria, pueden disminuir la compatibilidad con una versión de PHP anterior. Cuando haya una nueva versión de una biblioteca disponible que deje de ser compatible con una versión de PHP, considera actualizar tu entorno de ejecución a la versión más reciente de PHP. Para obtener más información sobre el uso de versiones principales y secundarias, consulta Control de versiones semántico.

Dónde encontrar la información de la versión

Para saber qué versiones de PHP se admiten actualmente, consulta la página Biblioteca cliente de Google Cloud para PHP.