Supported operating systems

Velostrata 4.0 by Google supports migrations of VMs running the following operating systems.

Before migrating Linux VMs to GCP, you need to install an additional package that performs reconfigurations. For more information, see preparing Linux VMs.

Offline migration, where disk volumes are copied directly to GCP and streaming data is not supported, has fewer operating system options. For more information, see Using offline migration.

Supported Windows versions

  • Windows Server 2008 (32 and 64 bit)
  • Windows Server 2008 R2 SP1 or higher
  • Windows Server 2012/Windows Server 2012 R2
  • Windows Server 2016
  • Windows server 1709

Supported Windows versions for offline migration

  • Windows Server 2003, Windows Server 2003 R2
  • Windows Server 2008 32 bit (contact support for assistance)

Supported Linux distributions and versions

  • RHEL 6.x, RHEL 7.x
  • CentOS 6.x, CentOS 7.x
  • SUSE Linux Enterprise Server 11 SP2 or higher
  • SUSE Linux Enterprise Server 12 SP2 or higher
  • Ubuntu 14.04.x, 16.04.x, 17.10.x, 18.04.x

Supported Linux versions for offline migration

  • Ubuntu 12.x
  • RHEL 5.1 or higher (64-bit)
  • RHEL 5.11 and higher (32-bit)
Was this page helpful? Let us know how we did:

Send feedback about...

Velostrata - Cloud Migration Software for GCP