Ops Agent overview

Contact us at google-cloud-ops-agent@google.com if you have any questions, need support, or would like to offer feedback.

The Ops Agent combines logging and metrics into a single agent and is targeted toward specialized logging workloads that require higher throughput and/or improved resource-efficiency compared to the standard Cloud Logging agent. You should choose the Ops Agent if you have such a workload and the agent's supported feature set meets your needs. If not, you should use the standard Logging and Monitoring agents.

Ops Agent features

Overall features include:

  • Single download and installation/upgrade process.
  • Simple, unified, YAML-based configuration.
  • Support for standard Linux distros.

Logging features include:

  • Standard system logs (/var/log/syslog and /var/log/messages) collected with no setup.
  • High throughput capability, taking full advantage of multi-core architecture.
  • Efficient resource (e.g. memory, CPU) management.
  • Support for syslog protocol (file-based and TCP-based).
  • Custom log files.
  • JSON logs.
  • Plain text logs.
  • Regex-based parsing.
  • JSON-based parsing.
  • Support for pre-defined log-file formats including standard third-party applications, such as nginx.

Monitoring features include:

Virtual machine instances

You can install the Ops Agent on Compute Engine instances.

To create a Compute Engine instance, see Compute Engine getting started guide.

Operating systems

The Ops Agent supports the following operating systems on compatible VM instances.

Linux operating systems

The agent supports the following Linux operating systems:

  • CentOS 7
  • CentOS 8
  • RHEL 7: rhel-7, rhel-7-4-sap, rhel-7-6-sap-ha, rhel-7-7-sap-ha
  • RHEL 8: rhel-8, rhel-8-1-sap
  • Debian 9 (Stretch)
  • Debian 10 (Buster)
  • SLES 12: sles-12, sles-12-sp2-sap, sles-12-sp3-sap, sles-12-sp4-sap, sles-12-sp5-sap
  • SLES 15: sles-15, sles-15-sap, sles-15-sp1-sap, sles-15-sp2-sap
  • Ubuntu LTS 16.04 (Xenial Xerus): ubuntu-1604-lts, ubuntu-minimal-1604-lts
  • Ubuntu LTS 18.04 (Bionic Beaver): ubuntu-1804-lts, ubuntu-minimal-1804-lts
  • Ubuntu LTS 20.04 (Focal Fossa): ubuntu-2004-lts, ubuntu-minimal-2004-lts

Agent access requirements

Installing the agent requires access to the following DNS name:

  • (Linux) Google Cloud package repository: packages.cloud.google.com

Running the agent requires access to the following DNS names:

  • OAuth2 token server: www.googleapis.com

  • Monitoring APIs: monitoring.googleapis.com

  • Logging APIs: logging.googleapis.com

Deprecation policy

The Ops Agent is subject to the Agents deprecation policy.

For deprecation information for legacy features and versions, refer to Google Cloud's operations suite deprecations.

What's next