オンプレミス ルーターの構成

このドキュメントでは、Dedicated Interconnect 用にオンプレミス ルーターを構成する方法について説明します。Partner Interconnect 接続を作成する場合は、Partner Interconnect 用のオンプレミス ルーターの構成をご覧ください。

VLAN アタッチメントを作成した後、オンプレミス ルーターを構成して、Cloud Router との BGP セッションを確立する必要があります。オンプレミス ルーターを構成するには、VLAN アタッチメントで指定された VLAN ID、インターフェース IP アドレス、ピアリング IP アドレスを使用します。 BGP セッションを構成して、MD5 認証を使用することもできます。Cloud Router の BGP セッションに MD5 認証を追加した場合、オンプレミス ルーターで BGP を構成するときにも同じ認証鍵を使用する必要があります。この機能はプレビュー中です。

このページで使用している用語の定義については、Cloud Interconnect の主な用語をご覧ください。

Dedicated Interconnect の使用時に発生する可能性のある一般的な問題を解決するには、トラブルシューティングをご覧ください。

サンプル トポロジを使用する

このドキュメントでは、オンプレミス ルーターを構成する際のガイドとして使用できる、次のサンプルのトポロジや構成について説明します。

  • レイヤ 3 のみのトポロジ(推奨): オンプレミス ルーターで終端する Dedicated Interconnect 接続。ルーターは、Cloud Router との BGP ピアリングを実行します。
  • レイヤ 2 / レイヤ 3 のトポロジ: オンプレミス ルーターに接続されたオンプレミス スイッチで終端する Dedicated Interconnect 接続。ルーターは、Cloud Router との BGP ピアリングを実行します。

オンプレミス ルーターに使用するサードパーティ プラットフォームの値については、ベンダー固有の注意事項をご覧ください。明確な値については、オンプレミス ルーターのドキュメントをご覧ください。

このドキュメントのサンプル トポロジでは、次の Google Cloud リソースを使用しています。

  • プロジェクト Sample Interconnect Project
  • ネットワーク my-network
  • リージョン us-east1

Dedicated Interconnect 接続には、my-interconnect1my-interconnect2 の 2 つがあります。これらの接続はすでにプロビジョニングされており、ステータスは ready to use になっています。

レイヤ 3 のみのトポロジ

このトポロジでは、Interconnect 接続はオンプレミス ルーターで終端します。オンプレミス ルーターは Cloud Router との BGP ピアリングを実行します。

以下の図は、レイヤ 3 のみの物理トポロジと論理トポロジの両方を示しています。

レイヤ 3 のみの物理トポロジのサンプル(クリックして拡大)
レイヤ 3 のみの物理トポロジのサンプル(クリックして拡大)



レイヤ 3 のみの論理トポロジのサンプル(クリックして拡大)
レイヤ 3 のみの論理トポロジのサンプル(クリックして拡大)

レイヤ 2 / レイヤ 3 のトポロジ

このトポロジでは、Interconnect 接続がオンプレミス スイッチで終端した後、オンプレミス スイッチがオンプレミス ルーターに接続しています。ルーターは、Cloud Router との BGP ピアリングを実行します。

以下の図は、レイヤ 2 / レイヤ 3 の物理トポロジと論理トポロジを示しています。

レイヤ 2 / レイヤ 3 の物理トポロジのサンプル(クリックして拡大)
レイヤ 2 / レイヤ 3 の物理トポロジのサンプル(クリックして拡大)



レイヤ 2 / レイヤ 3 の論理トポロジのサンプル(クリックして拡大)
レイヤ 2 / レイヤ 3 の論理トポロジのサンプル(クリックして拡大)

テスト用のオンプレミス デバイスの構成

次のセクションでは、Interconnect 接続をテストするためのオンプレミス デバイスの構成方法について説明します。レイヤ 2 / レイヤ 3 の構成の場合、この例では、Google Cloud に面しているスイッチに対してテスト インターフェースを構成するものの、ルーターでは構成しません。

Google が新しい Dedicated Interconnect 接続のテストを開始する前に、VLAN のタグ付けを行わずにインターフェースを構成します(アクセスモードと呼ばれることもあります)。

テスト用のサンプル構成

次の例は、テストの前に Juniper ルーターを構成する方法と、ポートチャネル ae0 用に構成する必須パラメータを示しています。この構成では、次の設定を使用します。

  • ポートチャネル ae0169.254.0.2 の BGP IP アドレスが構成されています。
  • ポートチャネル ae0 に LACP が構成されています。
  • ポートチャネル ae0 に VLAN のタグ付けは構成されていません。インターフェースは VLAN のタグ付けを使用しないで構成する必要があります(アクセスモード)。
  • 1,440 バイトの MTU。ただし、ルーター インターフェースの構成を適宜調整し、アタッチメントの MTU と接続された VPC ネットワークの MTU も 1,500 バイトの場合は、1,500 バイトの MTU を使用できます。

    set interfaces xe-0/0/0 description "my-interconnect2"
    set interfaces xe-0/0/0 gigether-options 802.3ad ae0
    set interfaces ae0 description "my-interconnect2"
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 aggregated-ether-options minimum-links 1
    set interfaces ae0 unit 0 family inet mtu 1440
    set interfaces ae0 unit 0 family inet address 169.254.0.2
    

Interconnect 接続が機能したら、次のセクションに進んで、各トポロジのサンプル本番環境構成を確認します。

本番環境用にオンプレミス ルーターを構成する

このセクションでは、本番環境用にレイヤ 3 のみのトポロジとレイヤ 2 / レイヤ 3 のトポロジを構成する方法について説明します。各構成例には、すべてのデバイス設定が示されています。

Interconnect 接続をテストするためのオンプレミス デバイスの構成方法については、テスト用のオンプレミス ルーターの構成をご覧ください。

両方のトポロジの本番環境オンプレミス ルーターの設定

次の表は、サンプルの Google Cloud プロジェクトの構成に基づいて、トポロジ例に使用するオンプレミス ルーターの設定をまとめたものです。

Google Cloud 側で使用される、サンプルのプロジェクト名、VPC ネットワーク、リージョンについては、トポロジのリファレンスをご覧ください。

ホールド タイマーとキープアライブ タイマーの値により、問題発生時にトラフィックを冗長接続に迅速に転送できます。テーブルに示すように値を設定します。

グレースフル リスタートを使用すると、Cloud Router のメンテナンス中に BGP セッションのパケットのドロップやルートの取り消しを防げます。オンプレミスのデバイスが BGP グレースフル リスタートをサポートしている場合は、それを有効にして、表に示すようにグレースフル リスタート タイマーと stalepath タイマーを設定します。

BGP タイマー設定の詳細については、Cloud Router のドキュメントの BGP タイマーの推奨値をご覧ください。

設定 my-interconnect1 my-interconnect2
VLAN 番号 1010 1020
VLAN インターフェースの IP アドレス 169.254.10.2/29 169.254.20.2/29
オンプレミスの ASN 64500 64500
Cloud Router の ASN 65200 65200
Cloud Router の BGP IP アドレス cr-us-east1 インターフェース 0 の場合:
169.254.10.1
cr-us-east1 インターフェース 1 の場合:
169.254.20.1
BGP タイマー キープアライブ: 20 秒 キープアライブ: 20 秒
ホールド タイマー: 60 秒 ホールド タイマー: 60 秒
グレースフル リスタート: グレースフル リスタート タイマーをニーズに適した値に設定します。詳細については、BGP タイマー設定をご覧ください。 グレースフル リスタート: グレースフル リスタート タイマーをニーズに適した値に設定します。
stalepath タイマー: 300 秒 stalepath タイマー: 300 秒
オンプレミスの LAN サブネット範囲 192.168.12.0/24 192.168.12.0/24

本番環境用にレイヤ 3 のみのトポロジを構成する

レイヤ 3 のみのトポロジを構成する場合は、次のガイドラインを参考にしてください。

  • オンプレミス ルーターのポート(図では 0/0)または Cloud Router に面しているポートは、ポートが 1 つのみである場合でも、ポートチャネルの一部であることが必要です。
  • ポートチャネルでは、アクティブ モードまたはパッシブモードで LACP を有効にする必要があります。トラフィックを中断することなく Interconnect 接続の容量を調整できるため、LACP は必須です。
  • ルーター インターフェース(図では 0/0)の Maximum Transmission Unit(MTU)は、アタッチメントの MTU と接続された VPC ネットワークの MTU に応じて 1,440 バイトまたは 1,500 バイトであることが必要です。
  • EBGP マルチホップ構成では、gcloud compute interconnects attachments describe コマンドを使用して VLAN アタッチメントの Dataplane バージョンを確認します。Dataplane のバージョンが 2 以降の場合、このコマンドは dataplaneVersion フィールドを返します。コマンド出力に dataplaneVersion フィールドが含まれていない場合、Dataplane バージョンは 1 です。
    • VLAN アタッチメントが Dataplane バージョン 1 を使用する場合は、EBGP ネイバーのマルチホップを構成する必要があります。この設定の推奨値は 4 です。
    • VLAN アタッチメントで Dataplane バージョン 2 以降が使用されている場合、EBGP ネイバーのマルチホップを構成する必要はありません。VLAN アタッチメントの BGP セッションで双方向転送検出(BFD)を使用する場合や、BFD マルチホップが BGP マルチホップから継承される場合は、EBGP マルチホップを構成しないでください。Google Cloud は、BFD のシングルホップ モードのみをサポートします。BFD の構成をご覧ください。

デバイス構成

VLAN 1010 ルーター(Cisco)

次に、VLAN 1010 上のオンプレミス Router1(Cisco)のレイヤ 3 のみのサンプル構成を示します。

        interface E0/0
          description connected_to_google_edge_device
          channel-group 2 mode active
          no shut

        interface Po2
          description my-interconnect1
          no shut

        interface Po2.1010
          description attachment_vlan1010
          encapsulation dot1Q 1010
          ip address 169.254.10.2 255.255.255.248
          ip mtu 1440

        ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

        route-map TO_GCP_OUTBOUND permit 10
          match ip address prefix-list TO_GCP

        router bgp 64500
          bgp graceful-restart restart-time 60
           neighbor 169.254.10.1 description peering_to_cloud_router
           neighbor 169.254.10.1 remote-as 65200
           neighbor 169.254.10.1 ebgp-multihop 4
           neighbor 169.254.10.1 timers 20 60
           neighbor 169.254.10.1 update-source Po2.1010
           neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
      

VLAN 1020 ルーター(Juniper)

次に、VLAN 1020 上のオンプレミス Router2(Juniper)のレイヤ 3 のみのサンプル構成を示します。

        set interfaces xe-0/0/0 ether-options 802.3ad ae1
        set interfaces xe-0/0/0 description "connected_to_google_edge_device"

        set interfaces ae1 description my-interconnect2
        set interfaces ae1 flexible-vlan-tagging
        set interfaces ae1 aggregated-ether-options minimum-links 1
        set interfaces ae1 aggregated-ether-options lacp active
        set interfaces ae1 unit 1020 family inet mtu 1440
        set interfaces ae1 unit 1020 vlan-id 1020
        set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

        set routing-options autonomous-system 64500

        set policy-options prefix-list TO_GCP 192.168.12.0/24

        set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
        set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
        set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
        set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

        set protocols bgp group config_vlan_1020 type external
        set protocols bgp group config_vlan_1020 multihop ttl 4
        set protocols bgp group config_vlan_1020 local-address 169.254.20.2
        set protocols bgp group config_vlan_1020 peer-as 65200
        set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
        set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 60
      

本番環境用にレイヤ 2 / レイヤ 3 のトポロジを構成する

レイヤ 2 / レイヤ 3 のトポロジを構成する場合は、オンプレミスのスイッチやルーターについて次のガイドラインを参考にしてください。

  • VLAN はスイッチで構成する必要があります。
  • Cloud Router に面しているスイッチポート(図に示す 1/1)または Cloud Router に面しているポートは、ポートチャネルの一部であることが必要です。
    • ポートチャネルでは、アクティブ モードまたはパッシブモードで LACP を有効にする必要があります。トラフィックを中断することなく Interconnect 接続の容量を調整できるため、LACP は必須です。
    • ポートチャネルは 802.1Q トランクモードで構成し、Interconnect 接続で使用されるすべての VLAN ID を許可する必要があります。
    • ポートチャネルでは、802.1Q VLAN タギングを有効にする必要があります。
  • オンプレミス ルーターに面しているスイッチポート(図に示す 1/2)は、トランクポートまたはアクセスポートにできます。これは、ルーターポートが単一の VLAN 専用である場合を対象としています。
  • スイッチ側でトランクモードを有効にする場合、オンプレミス ルーターは、必要なカプセル化(dot1q タグ)を持つサブインターフェースをサポートする必要があります。
  • この構成では、1,440 バイトの MTU を使用します。ただし、ルーター インターフェースの構成を適宜調整し、アタッチメントの MTU と接続された VPC ネットワークの MTU も 1,500 バイトの場合は、1,500 バイトの MTU を使用できます。
  • EBGP マルチホップ構成では、gcloud compute interconnects attachments describe コマンドを使用して VLAN アタッチメントの Dataplane バージョンを確認します。Dataplane のバージョンが 2 以降の場合、このコマンドは dataplaneVersion フィールドを返します。コマンド出力に dataplaneVersion フィールドが含まれていない場合、Dataplane バージョンは 1 です。
    • VLAN アタッチメントが Dataplane バージョン 1 を使用する場合は、EBGP ネイバーのマルチホップを構成する必要があります。この設定の推奨値は 4 です。
    • VLAN アタッチメントで Dataplane バージョン 2 以降が使用されている場合、EBGP ネイバーのマルチホップを構成する必要はありません。VLAN アタッチメントの BGP セッションで双方向転送検出(BFD)を使用する場合や、BFD マルチホップが BGP マルチホップから継承される場合は、EBGP マルチホップを構成しないでください。Google Cloud は、BFD のシングルホップ モードのみをサポートします。BFD の構成をご覧ください。

デバイス構成

VLAN 1010(Cisco)スイッチ

次の一覧に、VLAN 1010 上のオンプレミス Switch1(Cisco)のレイヤ 2 / レイヤ 3 のサンプル構成を示します。

          vlan 1010
          name cloud_vlan1010

          interface E1/1
            description connected_to_google_edge_device
            Channel-group 1 mode active

          interface port-channel1
            description connected_to_google_edge_device
            Switchport trunk encapsulation dot1q
            Switchport mode trunk
            Switchport trunk allowed vlan 1,1010

          interface E1/2
            description connected_to_onprem_router
            channel-group 2 mode active

          interface port-channel2
            description connected_to_onprem_router
            Switchport trunk encapsulation dot1q
            Switchport mode trunk
            Switchport trunk allowed vlan 1,1010
        

VLAN 1010(Cisco)ルーター

次の一覧に、VLAN 1010 上のオンプレミス Router1(Cisco)のレイヤ 2 / レイヤ 3 のサンプル構成を示します。

        interface E0/0
          description connected_to_onprem_switch
          channel-group 2 mode active
          no shut

        interface Po2
          description my-interconnect1
          no shut

        interface Po2.1010
          description attachment_vlan1010
          encapsulation dot1Q 1010
          ip address 169.254.10.2 255.255.255.248
          ip mtu 1440

        ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

        route-map TO_GCP_OUTBOUND permit 10
          match ip address prefix-list TO_GCP

        router bgp 64500
          bgp graceful-restart restart-time 1
          neighbor 169.254.10.1 description peering_to_cloud_router
          neighbor 169.254.10.1 remote-as 65200
          neighbor 169.254.10.1 ebgp-multihop 4
          neighbor 169.254.10.1 timers 20 60
          neighbor 169.254.10.1 update-source Po2.1010
          neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
      

VLAN 1020(Juniper)スイッチ

次の一覧に、VLAN 1020 上のオンプレミス Switch2(Juniper)のレイヤ 2 / レイヤ 3 のサンプル構成を示します。

        set vlans cloud_vlan1020 vlan-id 1020

        set interfaces xe-0/1/1 description "connected_to_google_edge_device"
        set interfaces xe-0/1/1 ether-options 802.3ad ae1

        set interfaces ae1 aggregated-ether-options lacp active
        set interfaces ae1 unit 0 description "connected_to_google_edge_device"
        set interfaces ae1 unit 0 family ethernet-switching port-mode trunk
        set interfaces ae1 unit 0 family ethernet-switching vlan member cloud_vlan1020

        set interfaces xe-0/1/2 description "connected_to_onprem_router"
        set interfaces xe-0/1/2 ether-options 802.3ad ae2

        set interfaces ae2 unit 0 description "connected_to_onprem_router"
        set interfaces ae2 unit 0 family ethernet-switching port-mode trunk
        set interfaces ae2 unit 0 family ethernet-switching vlan member cloud_vlan1020
      

VLAN 1020(Juniper)ルーター

次の一覧に、VLAN 1020 上のオンプレミス Router2(Juniper)のレイヤ 2 / レイヤ 3 のサンプル構成を示します。


      set interfaces xe-0/0/0 ether-options 802.3ad ae1
      set interfaces xe-0/0/0 description connected_to_onprem_switch

      set interfaces ae1 description my-interconnect2
      set interfaces ae1 flexible-vlan-tagging
      set interfaces ae1 aggregated-ether-options minimum-links 1
      set interfaces ae1 aggregated-ether-options lacp active
      set interfaces ae1 unit 1020 family inet mtu 1440
      set interfaces ae1 unit 1020 vlan-id 1020
      set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

      set routing-options autonomous-system 64500

      set policy-options prefix-list TO_GCP 192.168.12.0/24

      set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
      set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
      set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
      set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

      set protocols bgp group config_vlan_1020 type external
      set protocols bgp group config_vlan_1020 multihop ttl 4
      set protocols bgp group config_vlan_1020 local-address 169.254.20.2
      set protocols bgp group config_vlan_1020 peer-as 65200
      set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
      set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
      

ベスト プラクティス

Cloud Interconnect 99.9% と 99.99% トポロジの使用時に以下のおすすめの方法を実践することで、オンプレミスのデバイスから Google Cloud への効率的な接続を実現できます。

アクティブ / アクティブ転送用のデバイス構成

  • すべての BGP セッションで同じ MED 値が交換されるようにします。
  • BGP 構成で、等価コスト マルチパス(ECMP)ルーティングを有効にします。
  • BGP セッションでグレースフル リスタートを有効にして、Cloud Router タスクの再起動の影響を最小限に抑えます。推奨トポロジに記載されているように、異なるエッジ アベイラビリティ ドメインを使用して 2 つのアタッチメントを接続すると、Cloud Router はエッジ アベイラビリティ ドメインごとに 1 つのタスクを使用します。ダウンタイムを回避するため、ソフトウェア タスクは個別にスケジュールされます。
  • 2 つのオンプレミス デバイスを構成する場合は、任意のルーティング プロトコルを使用して両方のデバイスを相互に接続します。再配布用にデバイスを構成する場合は、IBGP や IGP を使用します。

アクティブ / パッシブ転送用のデバイス構成

  • 非対称ルーティングの発生を回避するには、Cloud Router 側とオンプレミス デバイス側により高い MED 値が適用されるていることを確認します。
  • BGP セッションでグレースフル リスタートを有効にして、Cloud Router タスクの再起動の影響を最小限に抑えます。推奨トポロジに記載されているように、異なるエッジ アベイラビリティ ドメインを使用して 2 つのアタッチメントを接続すると、Cloud Router はエッジ アベイラビリティ ドメインごとに 1 つのタスクを使用します。ダウンタイムを回避するため、ソフトウェア タスクは個別にスケジュールされます。
  • 2 つのオンプレミス デバイスを構成する場合は、両方のデバイスがそれぞれ、レイヤ 3 接続に対応していることを確認してください。再配布用にデバイスを構成する場合は、IBGP や IGP を使用します。

BGP セッションの確認

オンプレミス ネットワークと Google の Virtual Private Cloud(VPC)ネットワーク間で BGP セッションが機能していることを確認します。詳細については、Cloud Router のドキュメントの Cloud Router のステータスとルートの表示をご覧ください。