オンプレミス ルーターの構成

このドキュメントでは、Partner Interconnect 用にオンプレミス ルーターを構成する方法について説明します。Dedicated Interconnect 接続を作成する場合は、Dedicated Interconnect 用のオンプレミス ルーターの構成をご覧ください。

オンプレミス ルーターを構成するタイミング

この項におけるオンプレミス ルーターとは、Partner Interconnect を有効にするために構成するレイヤ 2(L2)またはレイヤ 3(L3)のデバイスを指します。

  • レイヤ 2(L2)接続の場合、Partner Interconnect の概要で説明しているように、サービス プロバイダが VLAN アタッチメントを構成した後にオンプレミス ルーターを構成します。
  • Partner Interconnect の概要で説明しているように、サービス プロバイダがエッジルーターに BGP を構成するため、レイヤ 3(L3)接続の場合はオンプレミス ルーターに BGP を構成する必要はありません。

このドキュメントで説明するレイヤ 2 接続のトポロジと構成の例は、オンプレミス ルーターを構成するときのガイドとして使用できます。

レイヤ 2 接続のトポロジ

このトポロジでは、Cloud Interconnect 接続がオンプレミス ルーターで終端しています。オンプレミス ルーターは Cloud Router との BGP ピアリングを実行します。

このサンプル トポロジは次の Google Cloud リソースを使用します。

  • プロジェクト Sample Interconnect Project
  • ネットワーク my-network
  • リージョン us-east1

ここには my-attachment1my-attachment2 という 2 つの Partner Interconnect アタッチメントがあります。これらのアタッチメントはすでにアクティブであり、BGP が構成されています。

物理

次の図は、レイヤ 2 接続の物理トポロジを示しています。Google Cloud とお客様のサービス プロバイダのネットワークとの物理的な接続は、Google とサービス プロバイダが設定し、管理します。

物理レイヤ 2 トポロジのサンプル(クリックして拡大)
レイヤ 2 接続の物理トポロジのサンプル(クリックして拡大)

論理

次の図は、レイヤ 2 接続の論理トポロジを示しています。

レイヤ 2 接続の論理トポロジのサンプル(クリックして拡大)
レイヤ 2 接続の論理トポロジのサンプル(クリックして拡大)

オンプレミス ルーターの構成

このセクションでは、本番環境用にレイヤ 2 トポロジを構成する方法について説明します。構成例には、すべてのデバイス設定が示されています。

オンプレミス ルーターの設定

次の表に、サンプルの Google Cloud プロジェクトの構成に基づいて、サンプル トポロジで使用されるオンプレミス ルーターの設定を示します。

Google Cloud 側で使用されるサンプル プロジェクトの名前、VPC ネットワーク、リージョンについては、トポロジのリファレンスを参照してください。

ホールド タイマーと keep-alive タイマーの値により、問題発生時にトラフィックを冗長接続に迅速に転送できます。テーブルに示すように値を設定します。

グレースフル リスタートを使用すると、Cloud Router のメンテナンス中に BGP セッションのパケットのドロップやルートの取り消しを防げます。オンプレミスのデバイスが BGP グレースフル リスタートをサポートしている場合は、それを有効にして、テーブルに示すようにグレースフル リスタート タイマーと stalepath タイマーを設定します。

BGP タイマー設定の詳細については、Cloud Router のドキュメントの BGP タイマーの推奨値を参照してください。

設定 my-attachment1 my-attachment2
VLAN 番号 1010 1020
VLAN インターフェースの IP アドレス 169.254.10.2/29 169.254.20.2/29
オンプレミスの ASN 64500 64500
Cloud Router の ASN 16550 16550
Cloud Router の BGP IP アドレス cr1-us-east1 の場合:
169.254.10.1
cr2-us-east1 の場合:
169.254.20.1
BGP タイマー keep-alive: 20 秒 キープアライブ: 20 秒
ホールド タイマー: 60 秒 ホールド タイマー: 60 秒
グレースフル リスタート: 1 秒 グレースフル リスタート: 1 秒
stalepath タイマー: 300 秒 stalepath タイマー: 300 秒
オンプレミスの LAN サブネット範囲 192.168.12.0/24 192.168.12.0/24

構成のガイドライン

オンプレミス スイッチやルーターで以下の情報を使用し、Cloud Router と BGP のセッションを確立します。

  • 有効化された Partner Interconnect VLAN アタッチメントによって提供されるインターフェース IP アドレスとピアリング IP アドレス
  • サービス プロバイダが提供する VLAN ID
  • サイズが 1,440 バイトの MTU
  • EBGP ネイバーにはマルチホップが構成されている必要があります。この設定の推奨値は 4 です。

デバイス構成

VLAN 1010(Cisco)ルーター

次に、VLAN 1010 で Router1(Cisco)を使用する、オンプレミスのレイヤ 2 のトポロジのサンプル構成を示します。

    interface E0/0
      description connected_to_service_provider_device
      no shut

    interface E0/0.1010
      description attachment_vlan1010
      encapsulation dot1Q 1010
      ip address 169.254.10.2 255.255.255.248
      ip mtu 1440

    ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

    route-map TO_GCP_OUTBOUND permit 10
      match ip address prefix-list TO_GCP

    router bgp 64500
      bgp graceful-restart restart-time 1
       neighbor 169.254.10.1 description peering_to_cloud_router
       neighbor 169.254.10.1 remote-as 16550
       neighbor 169.254.10.1 ebgp-multihop 4
       neighbor 169.254.10.1 timers 20 60
       neighbor 169.254.10.1 update-source E0/0.1010
       neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
  

VLAN 1020(Juniper)ルーター

次に、VLAN 1020 で Router2(Juniper)を使用する、オンプレミスのレイヤ 2 のトポロジのサンプル構成を示します。

    set interfaces xe-0/0/0 description "connected_to_service_provider_device"
    set interfaces xe-0/0/0 flexible-vlan-tagging
    set interfaces xe-0/0/0 unit 1020 family inet mtu 1440
    set interfaces xe-0/0/0 unit 1020 vlan-id 1020
    set interfaces xe-0/0/0 unit 1020 family inet address 169.254.20.2/29

    set routing-options autonomous-system 64500

    set policy-options prefix-list TO_GCP 192.168.12.0/24

    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
    set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

    set protocols bgp group config_vlan_1020 type external
    set protocols bgp group config_vlan_1020 multihop ttl 4
    set protocols bgp group config_vlan_1020 local-address 169.254.20.2
    set protocols bgp group config_vlan_1020 peer-as 16550
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1

ベスト プラクティス

Cloud Interconnect 99.9% と 99.99% トポロジの使用時に以下のおすすめの方法を実践することで、オンプレミスのデバイスから Google Cloud への効率的な接続を実現できます。

アクティブ / アクティブ転送用のデバイス構成

  • すべての BGP セッションで同じ MED 値が交換されるようにします。
  • BGP 構成で、等コスト マルチパス(ECMP)ルーティングを有効にします。
  • グレースフル リスタートを有効にするか、同一リージョン内にある複数の Cloud Router 間の相互接続のアタッチメントを配布します。この設定は、コードのアップグレードにあたり 2 つの Cloud Router が同時に再起動されることを防ぐものです。
  • 2 つのオンプレミス デバイスを構成する場合は、任意のルーティング プロトコルを使用して両方のデバイスを相互に接続します。再配布用にデバイスを構成する場合は、IBGP や IGP を使用します。

アクティブ転送とパッシブ転送に関するデバイス構成

  • 非対称ルーティングの発生を避けるため、Cloud Router 側とオンプレミス デバイス側により高い MED 値が適用されるようにします。
  • グレースフル リスタートを有効にするか、同一リージョン内にある複数の Cloud Router 間の相互接続のアタッチメントを配布します。この設定は、コードのアップグレードにあたり 2 つの Cloud Router が同時に再起動されることを防ぐものです。
  • 2 つのオンプレミス デバイスを構成する場合は、両方のデバイスがそれぞれ、レイヤ 3 接続に対応していることを確認してください。再配布用にデバイスを構成する場合は、IBGP や IGP を使用します。

次のステップ

オンプレミス ネットワークと Google の Virtual Private Cloud ネットワーク間で BGP セッションが機能していることを確認します。詳細については、Cloud Router のドキュメントにあるルーター ステータスとアドバタイズされたルートの表示をご覧ください。