Configura routers locales

Después de crear un adjunto de VLAN, debes configurar tu router local para establecer una sesión BGP con tu Cloud Router. Usa el ID de VLAN, la dirección IP de la interfaz y la dirección IP de intercambio de tráfico que proporcionó el adjunto de VLAN para configurar tu router local.

En este documento, se proporcionan las siguientes topologías y configuraciones de muestra que puedes usar como guía para configurar tu router local.

  • Topología de capa 3 únicamente (recomendado): una interconexión dedicada o conexiones que finalizan en un router local (topología de capa 3 únicamente). El router realiza el intercambio de tráfico de BGP con Cloud Router. Esta es la configuración recomendada.
  • Topología de capa 2 o capa 3: una o varias interconexiones dedicadas que terminan en un interruptor local conectado a un router local. El router realiza el intercambio de tráfico de BGP con Cloud Router.

También puedes consultar la sección Notas específicas del proveedor en la Guía de interoperabilidad de VPN a fin de obtener valores de algunas plataformas de terceros que podrías usar para tu router local o consultar la documentación de tu router local a fin de obtener valores definidos.

Referencia para topologías de muestra

Las topologías de muestra de este documento usan los siguientes recursos de Google Cloud:

  • El proyecto Sample Interconnect Project
  • La red my-network
  • La región us-east1

Existen dos tipos de interconexiones dedicadas: my-interconnect1 y my-interconnect2. Estas interconexiones ya están aprovisionadas y tienen un estado de ready to use.

Topología de capa 3 únicamente.

En esta topología, las conexiones de Cloud Interconnect terminan en un router local que realiza el intercambio de tráfico de BGP con Cloud Router.

Diagramas de topología

En los diagramas siguientes, se muestra la topología física y lógica de capa 3 únicamente.

Topología física de muestra de capa 3 únicamente (haz clic para ampliar)
Topología física y local de muestra de capa 3 únicamente (haz clic para ampliar)
Topología lógica de muestra de capa 3 únicamente (haz clic para ampliar)
Topología lógica y local de muestra de capa 3 únicamente (haz clic para ampliar)

Configuración de router local

En la siguiente tabla, se resume la configuración del router local que se usará para las topologías de ejemplo en función de la configuración del proyecto de Google Cloud de muestra.

Consulta la Referencia de topologías para obtener el nombre del proyecto de muestra, la red de VPC y la región que se usa en Google Cloud.

Los valores del temporizador de espera y el temporizador keepalive permiten que Google transfiera rápidamente el tráfico a conexiones redundantes en caso de que ocurra un problema. Establece sus valores como se muestra en la tabla.

El reinicio ordenado evita la pérdida de paquetes y el retiro de rutas de las sesiones BGP durante el mantenimiento de Cloud Router. Si tu dispositivo local admite el reinicio ordenado de BGP, habilítalo y configura el reinicio ordenado y los temporizadores de inactividad como se muestra en la tabla.

Para obtener más información sobre la configuración del temporizador de BGP, consulta los valores recomendados para los temporizadores de BGP en la documentación de Cloud Router.

Configuración my-interconnect1 my-interconnect2
Número de VLAN 1010 1020
Dirección IP de la interfaz de VLAN 169.254.10.2/29 169.254.20.2/29
ASN local 64500 64500
ASN de Cloud Router 65200 65200
Dirección IP de BGP de Cloud Router Para cr1-us-east1:
169.254.10.1
Para cr2-us-east1:
169.254.20.1
Temporizadores de BGP Keepalive: 20 s Keepalive: 20 s
Temporizador de suspensión: 60 s Temporizador de suspensión: 60 s
Reinicio ordenado: 1 s Reinicio ordenado: 1 s
Temporizador de inactividad: 300 s Temporizador de inactividad: 300 s
Rango de subred LAN local 192.168.12.0/24 192.168.12.0/24

Pautas de configuración

Usa las pautas siguientes para configurar la topología de solo capa 3:

  • El puerto del router local (0/0 en el diagrama) o los puertos orientados a Cloud Router deben ser parte de un canal de puerto, incluso si hay un solo puerto.
  • El canal del puerto debe tener LACP habilitado, en modo activo o pasivo.
  • La unidad de transmisión máxima (MTU) de la interfaz del router (0/0 en el diagrama) debe ser de 1440 bytes.
  • El vecino de EBGP debe tener configurado el salto múltiple. El valor recomendado es 4.

Configuración del dispositivo

Router de VLAN 1010 (Cisco)

En la siguiente lista, se muestra una configuración de muestra de capa 3 únicamente para el `Router1` local (Cisco) en VLAN 1010:

        interface E0/0
          description connected_to_google_edge_device
          channel-group 2 mode active
          no shut

        interface Po2
          description my-interconnect1
          no shut

        interface Po2.1010
          description attachment_vlan1010
          encapsulation dot1Q 1010
          ip address 169.254.10.2 255.255.255.248
          ip mtu 1440

        ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

        route-map TO_GCP_OUTBOUND permit 10
          match ip address prefix-list TO_GCP

        router bgp 64500
          bgp graceful-restart restart-time 1
           neighbor 169.254.10.1 description peering_to_cloud_router
           neighbor 169.254.10.1 remote-as 65200
           neighbor 169.254.10.1 ebgp-multihop 4
           neighbor 169.254.10.1 timers 20 60
           neighbor 169.254.10.1 update-source Po2.1010
           neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
      

Router de VLAN 1020 (Juniper)

En la siguiente lista, se muestra una configuración de muestra de capa 3 únicamente para el `Router2` local (Juniper) en VLAN 1020:

        set interfaces xe-0/0/0 ether-options 802.3ad ae1
        set interfaces xe-0/0/0 description "connected_to_google_edge_device"

        set interfaces ae1 description my-interconnect2
        set interfaces ae1 flexible-vlan-tagging
        set interfaces ae1 aggregated-ether-options minimum-links 1
        set interfaces ae1 aggregated-ether-options lacp active
        set interfaces ae1 unit 1020 family inet mtu 1440
        set interfaces ae1 unit 1020 vlan-id 1020
        set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

        set routing-options autonomous-system 64500

        set policy-options prefix-list TO_GCP 192.168.12.0/24

        set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
        set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
        set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
        set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

        set protocols bgp group config_vlan_1020 type external
        set protocols bgp group config_vlan_1020 multihop ttl 4
        set protocols bgp group config_vlan_1020 local-address 169.254.20.2
        set protocols bgp group config_vlan_1020 peer-as 65200
        set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
        set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
      

Topología de capa 2 o capa 3

En esta topología, la conexión o conexiones de Cloud Interconnect en Google Cloud finalizan en un interruptor local, que luego se conecta a un router local. El router realiza el intercambio de tráfico de BGP con Cloud Router.

Diagramas de topología

En los siguientes diagramas, se muestra la topología física y lógica de capa 2 o capa 3.

Topología física de muestra de capa 2 o capa 3 (haz clic para ampliar)
Topología física de muestra de capa 2 o capa 3 (haz clic para ampliar)
Topología lógica de capa 2 o capa 3 de muestra (haz clic para ampliar)
Topología lógica de muestra de capa 2 o capa 3 (haz clic para ampliar)

Configuración de router local

En la siguiente tabla, se resume la configuración del router local que se usará para las topologías de ejemplo en función de la configuración del proyecto de Google Cloud de muestra.

Consulta la Referencia de topologías para obtener el nombre del proyecto de muestra, la red de VPC y la región que se usa en Google Cloud.

Los valores del temporizador de espera y el temporizador keepalive permiten que Google transfiera rápidamente el tráfico a conexiones redundantes en caso de que ocurra un problema. Establece sus valores como se muestra en la tabla.

El reinicio ordenado evita la pérdida de paquetes y el retiro de rutas de las sesiones BGP durante el mantenimiento de Cloud Router. Si tu dispositivo local admite el reinicio ordenado de BGP, habilítalo y configura el reinicio ordenado y los temporizadores de inactividad como se muestra en la tabla.

Para obtener más información sobre la configuración del temporizador de BGP, consulta los valores recomendados para los temporizadores de BGP en la documentación de Cloud Router.

Configuración my-interconnect1 my-interconnect2
Número de VLAN 1010 1020
Dirección IP de la interfaz de VLAN 169.254.10.2/29 169.254.20.2/29
ASN local 64500 64500
ASN de Cloud Router 65200 65200
Dirección IP de BGP de Cloud Router Para cr1-us-east1:
169.254.10.1
Para cr2-us-east1:
169.254.20.1
Temporizadores de BGP Keepalive: 20 s Keepalive: 20 s
Temporizador de suspensión: 60 s Temporizador de suspensión: 60 s
Reinicio ordenado: 1 s Reinicio ordenado: 1 s
Temporizador de inactividad: 300 s Temporizador de inactividad: 300 s
Rango de subred LAN local 192.168.12.0/24 192.168.12.0/24

Pautas de configuración

Usa los siguientes lineamientos para configurar la topología de capa 2 o capa 3 en tu interruptor y en tus routers locales:

  • Las VLAN deben configurarse en el interruptor.
  • El puerto del interruptor (1/1 como se muestra en el diagrama) o los puertos orientados hacia Cloud Router deben ser parte de un canal de puerto.
    • El canal del puerto debe tener LACP habilitado, en modo activo o pasivo.
    • El canal del puerto se debe configurar en modo troncal 802.1Q y deben permitirse todas las VLAN.
    • El canal del puerto debe tener habilitado el etiquetado VLAN 802.1Q.
  • El puerto del interruptor (1/2 como se muestra en el diagrama) orientado hacia el router local puede ser un puerto troncal o un puerto de acceso. Incluye los casos en los que el puerto del router está dedicado a una sola VLAN.
  • Cuando se habilita el modo troncal en el lado del interruptor, el router local debe admitir subinterfaces con el encapsulamiento necesario (etiquetas dot1q).
  • La unidad de transmisión máxima (MTU) de la interfaz del router (0/0 en el diagrama) debe ser de 1440 bytes.
  • El vecino de EBGP debe tener configurado el salto múltiple. El valor recomendado para esta configuración es 4.

Configuración del dispositivo

Interruptor de VLAN 1010 (Cisco)

En la siguiente lista, se ofrece una configuración de muestra para una topología local de capa 2 o capa 3 mediante el interruptor `Switch1` (Cisco) en la VLAN 1010:

        vlan 1010
        name cloud_vlan1010

        interface E1/1
          description connected_to_google_edge_device
          Channel-group 1 mode active

        interface port-channel1
          description connected_to_google_edge_device
          Switchport trunk encapsulation dot1q
          Switchport mode trunk
          Switchport trunk allowed vlan 1,1010

        interface E1/2
          description connected_to_onprem_router
          channel-group 2 mode active

        interface port-channel2
          description connected_to_onprem_router
          Switchport trunk encapsulation dot1q
          Switchport mode trunk
          Switchport trunk allowed vlan 1,1010
      

Router de VLAN 1010 (Cisco)

En la siguiente lista, se ofrece una configuración de muestra para una topología local de capa 2 o capa 3 mediante el `Router1` (Cisco) en la VLAN 1010:

        interface E0/0
          description connected_to_onprem_switch
          channel-group 2 mode active
          no shut

        interface Po2
          description my-interconnect1
          no shut

        interface Po2.1010
          description attachment_vlan1010
          encapsulation dot1Q 1010
          ip address 169.254.10.2 255.255.255.248
          ip mtu 1440

        ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

        route-map TO_GCP_OUTBOUND permit 10
          match ip address prefix-list TO_GCP

        router bgp 64500
          bgp graceful-restart restart-time 1
          neighbor 169.254.10.1 description peering_to_cloud_router
          neighbor 169.254.10.1 remote-as 65200
          neighbor 169.254.10.1 ebgp-multihop 4
          neighbor 169.254.10.1 timers 20 60
          neighbor 169.254.10.1 update-source Po2.1010
          neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
      

Interruptor de VLAN 1020 (Juniper)

En la siguiente lista, se ofrece una configuración de muestra para una topología local de capa 2 o capa 3 mediante el interruptor `Switch2` (Juniper) en la VLAN 1020:

    set vlans cloud_vlan1020 vlan-id 1020

    set interfaces xe-0/1/1 description "connected_to_google_edge_device"
    set interfaces xe-0/1/1 ether-options 802.3ad ae1

    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 unit 0 description "connected_to_google_edge_device"
    set interfaces ae1 unit 0 family ethernet-switching port-mode trunk
    set interfaces ae1 unit 0 family ethernet-switching vlan member cloud_vlan1020

    set interfaces xe-0/1/2 description "connected_to_onprem_router"
    set interfaces xe-0/1/2 ether-options 802.3ad ae2

    set interfaces ae2 unit 0 description "connected_to_onprem_router"
    set interfaces ae2 unit 0 family ethernet-switching port-mode trunk
    set interfaces ae2 unit 0 family ethernet-switching vlan member cloud_vlan1020
    

Router de VLAN 1020 (Juniper)

En la siguiente lista, se ofrece una configuración de muestra para una topología local de capa 2 o capa 3 mediante el `Router2` (Juniper) en la VLAN 1020:


    set interfaces xe-0/0/0 ether-options 802.3ad ae1
    set interfaces xe-0/0/0 description connected_to_onprem_switch

    set interfaces ae1 description my-interconnect2
    set interfaces ae1 flexible-vlan-tagging
    set interfaces ae1 aggregated-ether-options minimum-links 1
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 unit 1020 family inet mtu 1440
    set interfaces ae1 unit 1020 vlan-id 1020
    set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

    set routing-options autonomous-system 64500

    set policy-options prefix-list TO_GCP 192.168.12.0/24

    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
    set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

    set protocols bgp group config_vlan_1020 type external
    set protocols bgp group config_vlan_1020 multihop ttl 4
    set protocols bgp group config_vlan_1020 local-address 169.254.20.2
    set protocols bgp group config_vlan_1020 peer-as 65200
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
    

Prácticas recomendadas

Sigue estas prácticas recomendadas para garantizar una conectividad eficaz con Google Cloud desde tus dispositivos locales cuando uses las topologías de Cloud Interconnect 99.9% y 99.99%.

Configura dispositivos para reenvío activo/activo

  • Asegúrate de que se intercambien los mismos valores MED en todas las sesiones BGP.
  • Habilita el enrutamiento de trayectoria múltiple de igual costo (ECMP) en tu configuración de BGP.
  • Habilita el reinicio ordenado o distribuye los adjuntos de interconexión entre varios Cloud Routers en la misma región. Es decir, asegúrate de que no se reinicien dos Cloud Routers al mismo tiempo para las actualizaciones de código.
  • Si quieres conectar dos dispositivos locales, conecta ambos dispositivos entre sí mediante cualquier protocolo de enrutamiento. Si configuras tu dispositivo para emplear la redistribución, usa IBGP o IGP.

Configura dispositivos para reenvío activo/pasivo

  • Asegúrate de que se apliquen valores MED más altos en el lado del Cloud Router y en el lado del dispositivo local para evitar el enrutamiento asimétrico.
  • Habilita el reinicio ordenado o distribuye los adjuntos de interconexión entre varios Cloud Routers en la misma región. Es decir, asegúrate de que no se reinicien dos Cloud Routers al mismo tiempo para las actualizaciones de código.
  • Si quieres configurar dos dispositivos locales, asegúrate de que ambos dispositivos tengan conectividad de capa 3 entre sí. Si configuras tu dispositivo para emplear la redistribución, usa IBGP o IGP.

Qué sigue

Verifica que tus sesiones de BGP funcionen entre tu red local y tu red de nube privada virtual de Google. Para obtener más información, consulta la página sobre cómo ver el estado de un router y las rutas anunciadas en la documentación de Cloud Router.