Configura routers locales

En este documento, se describe cómo configurar routers locales para la Interconexión de socio. Si quieres crear una conexión de Interconexión dedicada, consulta cómo configurar routers locales para este servicio.

Para obtener las definiciones de los términos que se usan en esta página, consulta los términos clave de Cloud Interconnect.

Para ayudarte a resolver problemas comunes que podrías encontrar cuando uses la interconexión de socio, consulta Solución de problemas.

Cuándo configurar tu router local

En este contexto, un router local hace referencia a un dispositivo de capa 2 o capa 3 que configuras para habilitar la interconexión de socio.

  • Para conexiones de la capa 2, configura tu router local después de que tu proveedor de servicios haya configurado tus adjuntos de VLAN.
  • Para las conexiones de capa 3, no es necesario configurar el BGP en tu router local, ya que el proveedor de servicios lo configura en sus routers perimetrales.

En este documento, se proporciona una topología de muestra y una configuración para las conexiones de capa 2 que puedes usar como guía cuando configures tu router local.

Topología para conexiones de capa 2

En esta topología, las conexiones de interconexión de socio terminan en un router local, que realiza el intercambio de tráfico del BGP con Cloud Router.

En esta topología de muestra, se usan los siguientes recursos de Google Cloud:

  • El proyecto Sample Interconnect Project
  • La red my-network
  • La región us-east1

Hay dos adjuntos de VLAN, my-attachment1 y my-attachment2, que ya están activos y tienen BGP configurado.

Topología física

En el siguiente diagrama, se muestra la topología física para las conexiones de capa 2. Google y tu proveedor de servicios configuran y administran las conexiones físicas entre Google Cloud y la red de tu proveedor de servicios.

Topología física de muestra de capa 2 (haz clic para ampliar).
Topología física de muestra para conexiones de capa 2 (haz clic para ampliar)

Topología lógica

En el siguiente diagrama, se muestra la topología lógica para las conexiones de capa 2.

Topología lógica de muestra de capa 2 (haz clic para ampliar).
Topología lógica de muestra para conexiones de capa 2 (haz clic para ampliar)

Configura tu router local

En esta sección, se describe cómo configurar las topologías de capa 2 para el uso en producción. En cada configuración de muestra, se describen todos los ajustes del dispositivo.

Configuración de router local

La siguiente tabla se basa en la configuración del proyecto de Google Cloud de muestra. En ella, se resume la configuración del router local que se debe usar para la topología de ejemplo.

Para obtener el nombre del proyecto de muestra, la red de nube privada virtual (VPC) y la región que se usan en Google Cloud, consulta la referencia de topología.

Los valores de temporizador de suspensión y temporizador keepalive permiten a Google transferir con rapidez el tráfico a conexiones redundantes en caso de que ocurra un problema. Establece sus valores como se muestra en la tabla.

El reinicio ordenado evita la pérdida de paquetes y el retiro de rutas en las sesiones BGP durante el mantenimiento de Cloud Router. Si tu dispositivo local admite el reinicio ordenado de BGP, habilítalo y configura el reinicio ordenado y los temporizadores de inactividad como se muestra en la tabla.

Para obtener más información sobre la configuración del temporizador de BGP, consulta los valores recomendados para los temporizadores de BGP en la documentación de Cloud Router.

Configuración my-attachment1 my-attachment2
Número de VLAN 1010 1020
Dirección IP de la interfaz de VLAN 169.254.10.2/29 169.254.20.2/29
ASN local 64500 64500
ASN de Cloud Router 16550 16550
Dirección IP del BGP de Cloud Router Para cr1-us-east1:
169.254.10.1
Para cr2-us-east1:
169.254.20.1
Temporizadores de BGP Keepalive: 20 s Keepalive: 20 s
Temporizador de suspensión: 60 s Temporizador de suspensión: 60 s
Reinicio ordenado: 1 s Reinicio ordenado: 1 s
Temporizador de inactividad: 300 s Temporizador de inactividad: 300 s
Rango de subred LAN local 192.168.12.0/24 192.168.12.0/24

Lineamientos de configuración

Usa la siguiente información en tu switch o router local para establecer una sesión BGP con el Cloud Router:

  • La dirección IP de la interfaz y la dirección IP de intercambio de tráfico que proporcionó el adjunto de VLAN activado
  • El ID de VLAN que proporciona tu proveedor de servicios
  • Una unidad de transmisión máxima (MTU) de 1,440 o 1,500 bytes, según la MTU de tu adjunto y la red de VPC.
  • El vecino de EBGP debe tener configurado el salto múltiple. El valor recomendado para esta configuración es 4

Configuración del dispositivo

Router de VLAN 1010 (Cisco)

En la siguiente lista, se muestra una configuración de muestra de capa 2 para el Router1 local (Cisco) en VLAN 1010:

        interface E0/0
          description connected_to_service_provider_device
          no shut

        interface E0/0.1010
          description attachment_vlan1010
          encapsulation dot1Q 1010
          ip address 169.254.10.2 255.255.255.248
          ip mtu 1440

        ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

        route-map TO_GCP_OUTBOUND permit 10
          match ip address prefix-list TO_GCP

        router bgp 64500
          bgp graceful-restart restart-time 1
           neighbor 169.254.10.1 description peering_to_cloud_router
           neighbor 169.254.10.1 remote-as 16550
           neighbor 169.254.10.1 ebgp-multihop 4
           neighbor 169.254.10.1 timers 20 60
           neighbor 169.254.10.1 update-source E0/0.1010
           neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
      

Router de VLAN 1020 (Juniper)

En la siguiente lista, se muestra una configuración de muestra de capa 2 para el Router2 local (Juniper) en VLAN 1020:

          set interfaces xe-0/0/0 description "connected_to_service_provider_device"
          set interfaces xe-0/0/0 flexible-vlan-tagging
          set interfaces xe-0/0/0 unit 1020 family inet mtu 1440
          set interfaces xe-0/0/0 unit 1020 vlan-id 1020
          set interfaces xe-0/0/0 unit 1020 family inet address 169.254.20.2/29

          set routing-options autonomous-system 64500

          set policy-options prefix-list TO_GCP 192.168.12.0/24

          set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
          set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
          set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
          set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

          set protocols bgp group config_vlan_1020 type external
          set protocols bgp group config_vlan_1020 multihop ttl 4
          set protocols bgp group config_vlan_1020 local-address 169.254.20.2
          set protocols bgp group config_vlan_1020 peer-as 16550
          set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
          set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
      

Prácticas recomendadas

Sigue estas prácticas recomendadas para garantizar una conectividad efectiva a Google Cloud desde tus dispositivos locales cuando uses las topologías de Cloud Interconnect para la disponibilidad del 99.9% y el 99.99%.

Configura dispositivos para reenvío activo/activo

  • Asegúrate de que se intercambien los mismos valores MED en todas las sesiones BGP.
  • Habilita el enrutamiento de ruta múltiple de igual costo (ECMP) en tu configuración de BGP.
  • Habilita el reinicio ordenado o distribuye los adjuntos de VLAN entre varios Cloud Routers en la misma región. Es decir, asegúrate de que no se reinicien dos Cloud Routers al mismo tiempo para las actualizaciones de código.
  • Si configuras dos dispositivos locales, usa cualquier protocolo de enrutamiento para conectar ambos dispositivos entre sí. Si configuras tu dispositivo para emplear la redistribución, usa IBGP o IGP.

Configura dispositivos para reenvío activo/pasivo

  • Para evitar el enrutamiento asimétrico, asegúrate de que se apliquen valores MED más altos en el lado del Cloud Router y en el lado del dispositivo local.
  • Habilita el reinicio ordenado o distribuye los adjuntos de VLAN entre varios Cloud Routers en la misma región. Es decir, asegúrate de que no se reinicien dos Cloud Routers al mismo tiempo para las actualizaciones de código.
  • Si estás configurando dos dispositivos locales, asegúrate de que ambos dispositivos tengan conectividad de capa 3 entre sí. Si configuras tu dispositivo para emplear la redistribución, usa IBGP o IGP.

Verifica que tus sesiones de BGP estén en funcionamiento entre tu red local y tu red de nube privada virtual de Google (VPC). Para obtener más información, consulta Visualiza el estado y las rutas de Cloud Router en la documentación de Cloud Router.