Versões compatíveis do Go

Mantenha tudo organizado com as coleções Salve e categorize o conteúdo com base nas suas preferências.

As bibliotecas de cliente do Cloud para Go são compatíveis com pelo menos as três versões principais mais recentes do Go e com pelo menos um ambiente de execução do GA para o App Engine e o Cloud Functions. Isso significa que as bibliotecas de cliente do Cloud para Go são compatíveis com todas as versões compatíveis do Go atualmente e com pelo menos uma versão adicional. Por exemplo, se a versão atual do Go for Go 1.19, as bibliotecas de cliente do Cloud serão compatíveis com pelo menos o Go 1.19, Go 1.18 e Go 1.17. Para mais informações sobre as bibliotecas de cliente do Cloud, consulte Explicação sobre bibliotecas de clientes.

Para um desenvolvimento novo

Ao iniciar um novo projeto, recomendamos escolher a versão atual do Go, se possível. Isso garante que o ambiente de execução esteja nas versões compatíveis do Go e receba patches de segurança essenciais.

Como manter os sistemas de produção atualizados

Manter seus sistemas de produção em ambientes de execução Go compatíveis é a melhor maneira de garantir a segurança crítica e as correções de bugs. Nossas bibliotecas de cliente do Cloud para Go incrementam uma versão secundária ao eliminar a compatibilidade com uma versão anterior do ambiente de execução do Go. Para mais informações sobre o uso de versões principais e secundárias, consulte Controle de versão semântico.

Onde encontrar informações sobre a versão

Para saber quais versões do Go são compatíveis no momento, consulte o README do google-cloud-go.