Cloud Dataproc 映像檔版本清單

Google Cloud Dataproc 會使用映像檔版本,將作業系統、大數據元件和 Google Cloud Platform 連接器整合成一個可於叢集部署的套件。詳情請參閱 Cloud Dataproc 版本管理一文。

支援的 Cloud Dataproc 版本

Debian 映像檔

Cloud Dataproc 叢集支援下列 Debian9 映像檔版本。請注意,如果版本在發布後有任何副次要修補程式,系統會建立新叢集以涵蓋這些修補程式。

版本 上次更新日期 發行日期 附註
1.4-debian9 2019 年 3 月 22 日 2019 年 3 月 22 日 正式發行版。
1.3-debian9 2019 年 3 月 22 日 2018 年 6 月 29 日 正式發行版。
這是從 2019 年 1 月 22 日起的新叢集預設版本。
1.2-debian9 2019 年 3 月 22 日 2017 年 7 月 21 日 正式發行版。
這是 2017 年 8 月 8 日至 2019 年 1 月 22 日的新叢集預設版本。
1.1-debian9 2019 年 3 月 22 日 2016 年 8 月 8 日 正式發行版。
2019 年 9 月 30 日之後將不再支援這個版本。

Ubuntu 映像檔 (預覽版)

Cloud Dataproc 叢集支援下列 Ubuntu 18.04 LTS 映像檔版本。請注意,如果版本在發布後有任何副次要修補程式,系統會建立新叢集以涵蓋這些修補程式。

版本 上次更新日期 發行日期 附註
1.4-ubuntu18 2019 年 3 月 22 日 2019 年 3 月 22 日 這個版本僅供測試或預覽,下一個穩定版本的元件可能有所不同。
1.3-ubuntu18 2019 年 3 月 22 日 2019 年 3 月 22 日 這個版本僅供測試或預覽,下一個穩定版本的元件可能有所不同。

不支援的 Cloud Dataproc 版本

下列為不支援的 Cloud Dataproc 版本。Cloud Dataproc 對使用這些版本建立的叢集並不提供更新和支援。雖然您可以繼續執行使用不支援版本建立的叢集,但我們仍建議您改用使用支援版本建立的新叢集。

版本 包含 發行日期 上次更新日期 附註
1.0-debian9 Apache Spark 1.6.2
Apache Hadoop 2.7.4
Apache Pig 0.15.0
Apache Hive 1.2.1
Cloud Storage 連接器 1.6.10-hadoop2
BigQuery 連接器 0.10.11-hadoop2
2016 年 2 月 22 日 2019 年 3 月 22 日 映像檔的第一個正式發行版,
自 2019 年 4 月 1 日起已不再支援。
0.2 Apache Spark 1.5.2
Apache Hadoop 2.7.1
Apache Pig 0.15.0
Apache Hive 1.2.1
Cloud Storage connector 1.5.1-hadoop2
BigQuery connector 0.7.7-hadoop2
2015/11/18 2016/08/02 第二次發行的測試版映像檔。
0.1 Apache Spark 1.5.0
Apache Hadoop 2.7.1
Apache Pig 0.14.10
Apache Hive 1.0
Cloud Storage connector 1.5.1-hadoop2
BigQuery connector 0.7.7-hadoop2
2015/09/23 2016/08/02 Cloud Dataproc 測試版。
Spark 1.5 已針對 Hive 1.2 進行編譯。
本頁內容對您是否有任何幫助?請提供意見:

傳送您對下列選項的寶貴意見...

這個網頁
Cloud Dataproc 說明文件
需要協助嗎?請前往我們的支援網頁