Diese Seite wurde von der Cloud Translation API übersetzt.
Switch to English

Kurzanleitung: Kubernetes-Anwendung mit Cloud Code ausführen

Auf dieser Seite werden die ersten Schritte mit Cloud Code beschrieben.

In dieser Kurzanleitung richten Sie eine neue Kubernetes-Anwendung mithilfe der "Hello World"-Vorlage ein. Anschließend erstellen Sie einen Cluster und führen Ihre App auf diesem Cluster aus. Damit können Sie Ihre App kontinuierlich neu erstellen, um iterativ zu entwickeln und Fehler darin zu beheben. {101 }Code ausführen und Logs über Ihre Live-Anwendung streamen.

Neue "Hello World"-Anwendung mit Cloud Code erstellen

Hinweis

Wenn Sie Google Cloud verwenden möchten, müssen Sie ein Google Cloud-Projekt erstellen und die Abrechnung aktivieren.

Alternativ können Sie einen Cluster verwenden, der auf einer anderen Cloudplattform oder einem lokalen Kubernetes-Cluster mit Tools wie minikube und Docker Desktop gehostet wird.

Plug-in installieren

So installieren Sie das Cloud Code-Plug-in:

  1. Installieren Sie JetBrains IDE Version 2020.1+ (z. B. IntelliJ Ultimate/Community, PyCharm Professional/Community, WebStorm, GoLand), sofern nicht bereits geschehen.
  2. Für alle Cloud-Plattformen muss der Docker-Client (authentifiziert mit Ihrer Docker-Registry) auf dem PATH Ihres Computers installiert sein. Der entsprechende Ordner sollte in einem Verzeichnis in PATH sichtbar sein. Wenn Sie prüfen möchten, ob Docker bereits installiert ist, führen Sie docker -v aus.

    Cloud Code installiert und verwaltet automatisch die folgenden Abhängigkeiten in Ihrer IDE: kubectl, Skaffold und Cloud SDK.

  3. Öffnen Sie IntelliJ IDEA oder eine der unterstützten JetBrains-IDEs.

  4. Suchen Sie im Plugins Marketplace nach dem Plug-in Cloud Code und installieren Sie es.

    Der Plug-in-Marktplatz kann über die folgenden Menüs aufgerufen werden:

    • Windows oder Linux: Datei > Einstellungen > Plug-ins
    • macOS: IntelliJ IDEA > Preferences (Einstellungen) > Plugins.

    Falls erforderlich, werden Sie aufgefordert, die IDE neu zu starten, um das Plug-in zu aktivieren.

Anwendung erstellen

So erstellen Sie eine neue Anwendung mit einem vorhandenen Beispiel:

  1. Öffnen Sie in Ihrer IDE Datei > Neues Projekt und wählen Sie Cloud Code: Kubernetes aus.
  2. Wählen Sie eine Hello World-Vorlage aus der Liste der Startanwendungen aus. Liste der verfügbaren Vorlagen: "Hello World"- und Gästebuchanwendungen in Python, Go, Node.js und Java
  3. Wenn Sie IntelliJ IDEA verwenden, werden Sie aufgefordert, anzugeben, wo Ihr Container-Image gespeichert wird.

    Geben Sie im Feld Ihr Standard-Image-Repository im Format gcr.io/{gcp-project-name} oder docker.io/{account} an.

    Wählen Sie je nach Container Registry ein geeignetes Format aus:

    • Wenn Sie GKE verwenden, können Sie Ihre Images im Google Container Repository speichern.

      Darüber hinaus ist das Feld mit der automatischen Vervollständigung ausgestattet, sodass Sie das mit Ihrem bevorzugten Google Cloud-Projekt (und aktuell im Cluster aktive Cluster) ganz einfach finden können. Wenn Sie keinen Cluster haben oder einen neuen Cluster für diese Kurzanleitung haben möchten, erstellen Sie im folgenden Abschnitt dieses Schnellstarts einen.

      Verwenden Sie das folgende Format:

      gcr.io/{project-name}, wobei {project-name} der Name Ihres Google Cloud-Projekts ist, das den Cluster enthält oder wo Sie ihn erstellen möchten.

    • Verwenden Sie das folgende Format, wenn Sie Ihre Images in Docker Hub speichern (achten Sie bei Verwendung eines privaten Docker Hub-Repositorys auf eine ordnungsgemäße Authentifizierung):

      docker.io/{account}, wobei {account} der Name Ihres Docker Hub-Kontos ist.

    • Wenn Sie die Ausführung auf einem lokalen Cluster wie Minikube oder Docker Desktop ausführen, können Sie diesen Schritt überspringen und auf Weiter klicken.

  4. Wählen Sie einen Namen für Ihr Projekt aus.

    Sobald Sie auf Fertigstellen klicken, klont Cloud Code die ausgewählte Vorlage und öffnet das neu erstellte Projekt.

    • Bei Java-Vorlagen werden Sie aufgefordert, Maven-Projekte zu importieren, um Ihre pom.xml-Datei zu synchronisieren. Klicken Sie auf Als Maven-Projekt hinzufügen.

      Grafik: Benachrichtigung über nicht verwaltete pom.xml-Datei

      Außerdem können Sie durch Klicken auf Änderungen importieren die erforderlichen Maven-Projekte importieren.

      Benachrichtigung zum Import von Maven-Änderungen

Cluster erstellen

Wenn Sie bereits einen Cluster für die Arbeit mit Kubernetes-Tools wie kubectl konfiguriert haben, den Sie für diese Kurzanleitung verwenden können, können Sie mit der Entwicklung Ihrer Anwendung fortfahren.

Zum Entwickeln Ihrer Anwendung benötigen Sie einen zugehörigen Kubernetes-Cluster, der entweder lokal mit Minikube gehostet oder eine Cloud-Plattform wie ein Google Kubernetes Engine-Cluster verwendet wird. auf. Wenn Sie noch keinen Cluster für diese Kurzanleitung haben, erstellen Sie mithilfe Ihrer Cloud Platform-spezifischen Anleitung einen Cluster.

Wenn Sie sich für die Verwendung von Google Cloud entscheiden, können Sie einen GKE-Cluster mit dem Cloud Code-Terminal oder der Cloud Console erstellen:

Cloud Code-Terminal verwenden

  1. Wenn das Projektfenster in Ihrer IDE geöffnet ist, können Sie auf das Cloud Code-Terminal zugreifen. Verwenden Sie dazu entweder die Seitenleiste unten in Ihrer IDE oder das Menü Tools (Extras) > Cloud Code > Tools > Cloud Code Terminal (Cloud Code-Terminal)

  2. Legen Sie, falls noch nicht geschehen, Ihr Standardprojekt fest:

    gcloud config set project PROJECT_ID
    
  3. Erstellen Sie einen Cluster.

    gcloud container clusters create CLUSTER_NAME --zone=COMPUTE_ZONE
    

    Wenn Sie beispielsweise einen Cluster namens "test-cluster" in der Zone "us-central1-a" erstellen möchten, führen Sie gcloud container clusters create test-cluster --zone=us-central1-a aus.

    Weitere Informationen zur Anpassung des Clusters finden Sie in der Referenzdokumentation des Befehls.

  4. Nachdem Sie einen Cluster erstellt haben, fügen Sie ihn Ihrer lokalen Datei "kubeconfig" hinzu. Führen Sie dazu folgenden Befehl aus:

    gcloud container clusters get-credentials CLUSTER_NAME --zone=COMPUTE_ZONE
    

    Dadurch wird auch der angegebene Cluster auf den aktiven Kontext gesetzt.

Cloud Console verwenden

  1. .ffnen Sie das Google Kubernetes Engine-Menü.

    Google Kubernetes Engine-Menü öffnen

  2. Klicken Sie auf Erstellen.

  3. Wählen Sie Ihren bevorzugten Clustertyp aus (Standard oder Autopilot) und klicken Sie auf Konfigurieren.

  4. Wählen Sie den gewünschten Clusternamen und den gewünschten Standort aus.

  5. Klicken Sie auf Erstellen, um die Erstellung des Clusters abzuschließen.

    Weitere Informationen zur Feldanpassung finden Sie in der GKE-Anleitung.

  6. Nachdem Sie einen Cluster erstellt haben, fügen Sie ihn Ihrer lokalen Datei "kubeconfig" hinzu. Führen Sie dazu folgenden Befehl aus:

    gcloud container clusters get-credentials CLUSTER_NAME --zone=COMPUTE_ZONE
    

    Dadurch wird auch der angegebene Cluster auf den aktiven Kontext gesetzt.

Anwendung entwickeln

So starten Sie die Entwicklung Ihrer Anwendung in Kubernetes:

  1. Achten Sie darauf, dass Sie für Develop on Kubernetes definiert haben, wo Ihre Container-Images gespeichert werden.
  2. Wählen Sie das Ausführungsziel Entwickeln auf Kubernetes in der Konfigurationsauswahl für die Ausführung/Fehlerbehebung in der Navigationsleiste aus.

    Dadurch wird sichergestellt, dass Codeänderungen automatisch erstellt, per Push übertragen und in einer neuen Version Ihrer Anwendung bereitgestellt werden.

    Kubernetes-Deployment-Ausführungskonfigurationen

    Klicken Sie auf die Ausführungsaktion für Entwickeln auf Kubernetes Symbol für Ausführungsaktion, um den Entwicklungszyklus für Ihren Kubernetes-Cluster zu starten.

  3. Sehen Sie sich im Ausgabefenster die eingehenden Anwendungslogs an.

    Nach dem Start des Deployments wird die Liste der weitergeleiteten Ports für die bereitgestellte Anwendung angezeigt.

    Gestreamte Logs über die Kubernetes-Anwendung aufrufen

  4. Nach erfolgreicher Bereitstellung werden Sie in einer Benachrichtigung darüber informiert, dass Ihr Dienst jetzt über lokale URLs aufgerufen werden kann. Klicken Sie auf View (Ansicht), um das Ereignisprotokoll zu öffnen.

    Benachrichtigung zur Angabe der URL, um auf deine Live-App zuzugreifen, ist jetzt im Ereignisprotokoll verfügbar

    Klicken Sie im Event Log auf den Link, um den Browser mit Ihrer ausgeführten Anwendung zu öffnen.

    Portweiterleitungsdienste mithilfe von "Event Log" suchen

Anwendung debuggen

So beheben Sie Fehler in der Anwendung:

  1. Achten Sie darauf, dass Sie für Develop on Kubernetes definiert haben, wo Ihre Container-Images gespeichert werden.
  2. Klicken Sie auf die Debug-Aktion Symbol für Ausführungsaktion für Develop on Kubernetes, um den Entwicklungszyklus im Debug-Modus auf Ihrem Kubernetes-Cluster zu starten.

    Kubernetes-Cluster-Entwicklungszyklus im Debug-Modus starten

  3. Cloud Code hängt dann eine Debug-Sitzung an. Nach Abschluss des Vorgangs wird das Fenster mit dem Debugging-Tool geöffnet und die Verbindung bestätigt (auf dem Tab "Console").

    Sie können jetzt Fehler in Ihrem Live-Kubernetes-Cluster beheben.

  4. Klicken Sie auf den Bundsteg bei der ausführbaren Zeile des Codes, bei der Sie einen Haltepunkt hinzufügen möchten.

    Rot ausgefüllte Kreise kennzeichnen aktive Haltepunkte, während rot umrandete Kreise deaktivierte Haltepunkte angeben.

  5. Wenn Sie eine neue Anfrage an Ihre Anwendung senden, wird sie in der gewünschten Zeile pausiert.

    Kubernetes Debugger-Sitzung

  6. Klicken Sie zum Beenden der Debugging-Sitzung auf das Stopp-Symbol in der Ausführungskonfiguration für Develop on Kubernetes.

Anwendung ausführen

So führen Sie eine Anwendung in Kubernetes aus:

  1. Achten Sie darauf, dass Sie für Run on Kubernetes definiert haben, wo Ihre Container-Images gespeichert werden.
  2. Achten Sie darauf, dass Sie die Anwendung in Ihrem bevorzugten Kubernetes-Kontext bereitstellen.

    Wählen Sie in der Navigationsleiste in der Konfigurationsleiste "Ausführung/Fehlerbehebung" die Option Konfigurationen bearbeiten... aus. Auf dem Tab "Run" (Ausführen) der Ausführung in Kubernetes können Sie das gewünschte Deployment festlegen.

  3. Die Anwendung ist nun für die Bereitstellung bereit. Wählen Sie in der Navigationsleiste in der Navigationsleiste Auf Kubernetes ausführen aus, um die Anwendung bereitzustellen.

    Kubernetes-Deployment-Ausführungskonfigurationen

  4. Klicken Sie auf In Kubernetes ausführen Symbol für Ausführungsaktion.

  5. Wie bei der Entwicklung in Kubernetes können Sie eingehende Anwendungslogs im Ausgabefenster anzeigen.

  6. Nach erfolgreicher Bereitstellung werden Sie in einer Benachrichtigung darüber informiert, dass Ihr Dienst jetzt über lokale URLs zugänglich ist. Klicken Sie auf View (Ansicht), um das Ereignisprotokoll zu öffnen.

    Suchen Sie im Event Log nach dem Port, an dem Ihre Anwendung bereitgestellt wird. Klicken Sie auf den Link, um den Browser mit Ihrer ausgeführten Anwendung zu öffnen.

  7. Rufen Sie http://localhost:{port-number} auf, um auf Ihre neu bereitgestellte Anwendung zuzugreifen.

    Anwendung unter http://localhost:{port-number}, bei der "Hello World!" angezeigt wird

Logs ansehen

Sie können bei der Entwicklung und Ausführung Ihrer Anwendung einen Livestream der Logs aus ausgeführten Pods in der Terminalausgabe sehen. Außerdem haben Sie die Möglichkeit, Logs von einem bestimmten Pod anzusehen. Rufen Sie dazu den Kubernetes Explorer auf.

So rufen Sie Logs eines bestimmten Pods auf:

  1. Rufen Sie den Kubernetes Explorer auf. Sie können entweder über die rechte Seitenleiste oder über Tools > Cloud Code > Kubernetes > View Cluster Explorer darauf zugreifen.

    Das Kubernetes Explorer-Steuerfeld wird über den Tab in der rechten Taskleiste geöffnet

  2. Wählen Sie den Pod aus, für den Sie Logs aufrufen möchten.

  3. Klicken Sie mit der rechten Maustaste auf den Pod und wählen Sie Logs streamen aus. Alternativ können Sie Logs für einzelne Container streamen, die in Pods ausgeführt werden.

    Dadurch werden Logs in der Kubernetes Explorer Console ausgegeben.

    Streamen von Logs eines Pods über das Kontextmenü, um die Logs in der Kubernetes Explorer-Konsole auszugeben

Bereinigen

Damit Ihr Konto nicht für die in dieser Kurzanleitung verwendeten Ressourcen belastet wird, müssen Sie den von Ihnen erstellten Cluster und das Projekt löschen.

Wenn Sie Google Cloud verwenden und Ihr Projekt und die zugehörigen Ressourcen, einschließlich GKE-Cluster, löschen möchten:

  • Rufen Sie in der Cloud Console die Seite "Projekte" auf:

    Zur Seite "Projekte"

  • Wählen Sie das Projekt aus, das Sie für diesen Schnellstart erstellt haben, und klicken Sie auf das Papierkorbsymbol, um es zu löschen.

    Das Projekt wird beendet und der Löschvorgang geplant.

Nächste Schritte

Support

Wenn Sie uns Feedback geben möchten, können Sie ein Problem auf GitHub melden oder eine Frage auf Stack Overflow stellen.