注意:此产品的某些方面处于 Beta 版阶段。Hybrid 安装选项是 GA。要加入 Beta 版计划,请与您的 Apigee 代表联系。

Method: organizations.environments.getIamPolicy

Gets the IAM policy on an environment. For more information, see Manage users, roles, and permissions using the API.

You must have the apigee.environments.getIamPolicy permission to call this API.

HTTP request

GET https://apigee.googleapis.com/v1/{resource=organizations/*/environments/*}:getIamPolicy

The URL uses gRPC Transcoding syntax.

Path parameters

Parameters
resource

string

REQUIRED: The resource for which the policy is being requested. See the operation documentation for the appropriate value for this field.

Query parameters

Parameters
options

object (GetPolicyOptions)

OPTIONAL: A GetPolicyOptions object for specifying options to GetIamPolicy.

Request body

The request body must be empty.

Response body

If successful, the response body contains an instance of Policy.

Authorization Scopes

Requires the following OAuth scope:

  • https://www.googleapis.com/auth/cloud-platform

GetPolicyOptions

Encapsulates settings provided to GetIamPolicy.

JSON representation
{
  "requestedPolicyVersion": integer
}
Fields
requestedPolicyVersion

integer

Optional. The policy format version to be returned.

Valid values are 0, 1, and 3. Requests specifying an invalid value will be rejected.

Requests for policies with any conditional bindings must specify version 3. Policies without any conditional bindings may specify any valid value or leave the field unset.

To learn which resources support conditions in their IAM policies, see the IAM documentation.