Configura router on-premise

Mantieni tutto organizzato con le raccolte Salva e classifica i contenuti in base alle tue preferenze.

Questo documento descrive come configurare i router on-premise per Partner Interconnect. Se crei una connessione Dedicated Interconnect, consulta la sezione Configurare i router on-premise per Dedicated Interconnect.

Per le definizioni dei termini utilizzati in questa pagina, consulta i termini chiave di Cloud Interconnect.

Per la risoluzione dei problemi comuni che potresti riscontrare quando utilizzi Partner Interconnect, consulta la sezione Risoluzione dei problemi.

Quando configurare il router on-premise

Un router on-premise in questo contesto significa che un dispositivo è configurato per abilitare Partner Interconnect.

  • Per le connessioni di livello 2, configura il router on-premise dopo che il provider di servizi ha configurato i collegamenti VLAN.
  • Per le connessioni di livello 3, non è necessario configurare BGP sul tuo router locale perché il provider di servizi configura BGP sui propri router on-premise.

Questo documento fornisce una topologia di esempio e una configurazione per le connessioni di livello 2 che puoi utilizzare come guida durante la configurazione del router on-premise.

Topologia per connessioni di livello 2

In questa topologia, la connessione o le connessioni Partner Interconnect vengono terminate su un router on-premise, che esegue il peering BGP con il router Cloud.

Questa topologia di esempio utilizza le seguenti risorse Google Cloud:

  • Il progetto Sample Interconnect Project
  • La rete my-network
  • L'area geografica us-east1

Esistono due collegamenti VLAN, my-attachment1 e my-attachment2, già attivi e con BGP configurato.

Topologia fisica

Il seguente diagramma mostra la topologia fisica per le connessioni di livello 2. Google e il tuo fornitore di servizi configurano e gestiscono le connessioni fisiche tra Google Cloud e la rete del tuo fornitore di servizi.

Esempio di topologia fisica di livello 2 (fai clic per ingrandire).
Esempio di topologia fisica per le connessioni di livello 2 (fai clic per ingrandire)

Topologia logica

Il seguente diagramma mostra la topologia logica per le connessioni di livello 2.

Esempio di topologia logica di livello 2 (fai clic per ingrandire).
Esempio di topologia logica per le connessioni di livello 2 (fai clic per ingrandire)

Configura il router on-premise

Questa sezione descrive come configurare le topologie di livello 2 per l'uso in produzione. La configurazione di esempio descrive tutte le impostazioni del dispositivo.

Impostazioni del router on-premise

In base alla configurazione nel progetto Google Cloud di esempio, la seguente tabella riassume le impostazioni del router on-premise da utilizzare per la topologia di esempio.

Per il nome del progetto di esempio, la rete Virtual Private Cloud (VPC) e l'area geografica utilizzata sul lato Google Cloud, consulta la documentazione di riferimento sulla topologia.

I valori del timer di attesa e del timer keepalive consentono a Google di trasferire rapidamente il traffico verso le connessioni ridondanti in caso di problemi. Imposta i valori come mostrato nella tabella.

Il riavvio graceful impedisce le sessioni BGP dai cadute di pacchetti e dal ritiro delle route durante la manutenzione del router Cloud. Se il tuo dispositivo on-premise supporta il riavvio controllato GGP, abilitalo e imposta i tempi di riavvio graceful e stalepath come mostrato nella tabella.

Per ulteriori informazioni sulle impostazioni dei timer BGP, consulta i valori consigliati per i timer BGP nella documentazione del router Cloud.

Impostazioni my-attachment1 my-attachment2
Numero VLAN 1010 1020
Indirizzo IP dell'interfaccia VLAN 169.254.10.2/29 169.254.20.2/29
ASN on-premise 64500 64500
ASN router Cloud 16550 16550
Indirizzo IP BGP router Cloud Per cr1-us-east1:
169.254.10.1
Per cr2-us-east1:
169.254.20.1
Timer BGP Keepalive: 20 sec Keepalive: 20 sec
Durata timer: 60 sec Durata timer: 60 sec
Riavvio normale: imposta il timer di riavvio su un valore appropriato in base alle tue esigenze. Per ulteriori informazioni, consulta la sezione Impostazioni del timer BGP. Riavvio normale: imposta il timer di riavvio su un valore appropriato in base alle tue esigenze.
Timer inattività: 300 sec Timer inattività: 300 sec
Intervallo di subnet LAN on-premise 192.168.12.0/24 192.168.12.0/24

Linee guida per la configurazione

Utilizza le seguenti informazioni sullo switch o sul router on-premise per stabilire una sessione BGP con il tuo router Cloud:

  • L'indirizzo IP dell'interfaccia e dell'indirizzo IP di peering forniti dal collegamento VLAN attivato.
  • L'ID VLAN fornito dal fornitore di servizi.
  • Un'unità di trasmissione massima (MTU) di 1440 o 1500 byte, in base al MTU del tuo collegamento e alla rete VPC.
  • (Facoltativo) Puoi configurare le sessioni BGP per utilizzare l'autenticazione MD5. Se hai aggiunto l'autenticazione MD5 alla sessione BGP sul router Cloud, devi utilizzare la stessa chiave di autenticazione quando configuri BGP sul tuo router on-premise. Questa funzionalità è in anteprima.
  • Per la configurazione multi-hop EBGP, controlla la versione del Dataplane del tuo collegamento VLAN utilizzando il comando gcloud compute interconnects attachments describe. Il comando restituisce un campo dataplaneVersion se la versione di Dataplane è 2 o superiore. Se l'output dei comandi non contiene un campo dataplaneVersion, la versione del piano dati è 1.

    • Se il collegamento VLAN utilizza Dataplane versione 1, devi configurare più hop per il vicino EBGP. Il valore consigliato per questa impostazione è 4.
    • Se il collegamento VLAN utilizza Dataplane versione 2 o successiva, non è necessario configurare l'hop multiplo per il vicino EBGP. Non configurare l'hop multiplo EBGP se prevedi di utilizzare il BFD (Bidirectional Forwarding Detection) nelle sessioni BGP dell'allegato VLAN e se il multi-hop BFD viene ereditato dalla configurazione multi-hop BGP. Google Cloud supporta solo la modalità hop singolo BFD. Consulta la sezione Configurare il protocollo BFD.

Configurazione dispositivi

Router VLAN 1010 (Cisco)

L'elenco seguente mostra una configurazione di esempio di livello 2 per Router1 (Cisco) on-premise su VLAN 1010:

        interface E0/0
          description connected_to_service_provider_device
          no shut

        interface E0/0.1010
          description attachment_vlan1010
          encapsulation dot1Q 1010
          ip address 169.254.10.2 255.255.255.248
          ip mtu 1440

        ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

        route-map TO_GCP_OUTBOUND permit 10
          match ip address prefix-list TO_GCP

        router bgp 64500
          bgp graceful-restart restart-time 1
           neighbor 169.254.10.1 description peering_to_cloud_router
           neighbor 169.254.10.1 remote-as 16550
           neighbor 169.254.10.1 ebgp-multihop 4
           neighbor 169.254.10.1 timers 20 60
           neighbor 169.254.10.1 update-source E0/0.1010
           neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
      

Router VLAN 1020 (Juniper)

L'elenco seguente mostra una configurazione di esempio di livello 2 per on-premise Router2 (Juniper) su VLAN 1020:

          set interfaces xe-0/0/0 description "connected_to_service_provider_device"
          set interfaces xe-0/0/0 flexible-vlan-tagging
          set interfaces xe-0/0/0 unit 1020 family inet mtu 1440
          set interfaces xe-0/0/0 unit 1020 vlan-id 1020
          set interfaces xe-0/0/0 unit 1020 family inet address 169.254.20.2/29

          set routing-options autonomous-system 64500

          set policy-options prefix-list TO_GCP 192.168.12.0/24

          set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
          set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
          set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
          set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

          set protocols bgp group config_vlan_1020 type external
          set protocols bgp group config_vlan_1020 multihop ttl 4
          set protocols bgp group config_vlan_1020 local-address 169.254.20.2
          set protocols bgp group config_vlan_1020 peer-as 16550
          set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
          set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
      

Best practice

Segui queste best practice per garantire una connettività efficace a Google Cloud dai dispositivi on-premise quando utilizzi le topologie Cloud Interconnect 99,9% e 99,99%.

Configurare i dispositivi per l'inoltro attivo/attivo

  • Assicurati che gli stessi valori MED vengano scambiati in tutte le sessioni BGP.
  • Abilita il routing Equal-cost multipath (ECMP) nella configurazione BGP.
  • Abilita il riavvio graceful nelle sessioni BGP per ridurre al minimo l'impatto dei riavvii delle attività del router Cloud. Quando connetti due collegamenti tramite domini di disponibilità perimetrale diversi, come descritto nelle topologie consigliate, il router Cloud utilizza un'attività per ogni dominio di disponibilità perimetrale. Per evitare tempi di inattività, le attività software vengono pianificate in modo indipendente.
  • Se configuri due dispositivi on-premise, utilizza un protocollo di routing per connettere entrambi i dispositivi. Se stai configurando il dispositivo in modo da utilizzare la ridistribuzione, utilizza IBGP o IGP.

Configurare i dispositivi per l'inoltro attivo/passivo

  • Per evitare il routing asimmetrico, assicurati che vengano applicati valori MED più elevati sul lato router Cloud e sul dispositivo on-premise.
  • Abilita il riavvio graceful nelle sessioni BGP per ridurre al minimo l'impatto dei riavvii delle attività del router Cloud. Quando connetti due collegamenti tramite domini di disponibilità perimetrale diversi, come descritto nelle topologie consigliate, il router Cloud utilizza un'attività per ogni dominio di disponibilità perimetrale. Per evitare tempi di inattività, le attività software vengono pianificate in modo indipendente.
  • Se configuri due dispositivi on-premise, assicurati che entrambi abbiano la connettività di livello 3 tra di loro. Se stai configurando il dispositivo in modo da utilizzare la ridistribuzione, utilizza IBGP o IGP.

Verifica delle sessioni BGP

Verifica che le tue sessioni BGP funzionino tra la tua rete on-premise e la rete Virtual Virtual Cloud (VPC) di Google. Per ulteriori informazioni, consulta la sezione relativa alla visualizzazione dello stato e delle route dei router Cloud nella documentazione di Cloud Router.