Kurzanleitung: Cloud Run-Dienst mit Cloud Code bereitstellen

Auf dieser Seite werden die ersten Schritte mit Cloud Code beschrieben.

Sie richten einen Hello World-Dienst ein, der in Cloud Run mit einer Beispielanwendung ausgeführt wird, stellen Ihren Dienst in Cloud Run bereit und sehen den Status der Ressourcen Ihres Livedienstes.

Neuen Cloud Run-Dienst mit Cloud Code erstellen

Wenn Sie diese Kurzanleitung für Apple M-Series Silicon ausführen, wird Ihre Anwendung mithilfe von Cloud Build erstellt, für das Gebühren anfallen können. Weitere Informationen finden Sie unter Cloud Code-Unterstützung für Apple M-Serie Silicon.

Hinweis

  1. Melden Sie sich bei Ihrem Google Cloud-Konto an. Wenn Sie mit Google Cloud noch nicht vertraut sind, erstellen Sie ein Konto, um die Leistungsfähigkeit unserer Produkte in der Praxis sehen und bewerten zu können. Neukunden erhalten außerdem ein Guthaben von 300 $, um Arbeitslasten auszuführen, zu testen und bereitzustellen.
  2. Wählen Sie in der Google Cloud Console auf der Seite der Projektauswahl ein Google Cloud-Projekt aus oder erstellen Sie eines.

    Zur Projektauswahl

  3. Die Abrechnung für das Cloud-Projekt muss aktiviert sein. So prüfen Sie, ob die Abrechnung für Ihr Projekt aktiviert ist.

  4. Aktivieren Sie die Cloud Run API.

    Aktivieren Sie die API

Cloud Code installieren

So installieren Sie das Cloud Code for IntelliJ-Plug-in:

  1. JetBrains-IDE Version 2020.3 installieren (z. B. IntelliJ Ultimate/Community, PyCharm Professional/Community, WebStorm oder GoLand).

  2. Wenn Sie Cloud Code auf dem Silicon von Apple M-Serie ausführen, installieren Sie Rosetta 2. Dadurch kann Cloud Code kubectl als verwaltete Abhängigkeit installieren.

    Wenn Sie Rosetta 2 nicht installieren möchten, deaktivieren Sie verwaltete Abhängigkeiten (IntelliJ, IDEA >.Einstellungen >.Werkzeuge >Cloud Code >.Abhängigkeiten ) und installieren Sie Ihre eigene ARM-Version von kubectl, wie inBenutzerdefinierte Versionen von Abhängigkeiten aus.

  3. Installieren Sie die Abhängigkeiten:

    • Für alle Cloud-Plattformen muss der Docker-Client (authentifiziert mit Ihrer Docker-Registry) auf dem PATH Ihres Computers installiert sein. (Der Ordner sollte in einem Verzeichnis in PATH angezeigt werden.) Um zu prüfen, ob Docker bereits installiert ist, führen Sie docker -v aus.
    • Cloud Code installiert automatisch andere erforderliche Abhängigkeiten.
  4. Öffnen Sie IntelliJ IDEA oder eine der unterstützten JetBrains-IDEs.

  5. Aktualisieren Sie diese Seite, nachdem die IDE geöffnet ist.

    Sie können das Cloud Code-Plug-in jetzt direkt installieren, indem Sie auf die Schaltfläche unten klicken:

    Mit der Schaltfläche wird ein Installationsdialogfeld in Ihrer geöffneten IDE geöffnet. Klicken Sie auf OK, um Cloud Code einzurichten.

Dienst erstellen

So erstellen Sie einen neuen Dienst mit einem vorhandenen Beispiel:

  1. Öffnen Sie in Ihrer IDE Datei > Neues Projekt und wählen Sie dann Cloud Code: Cloud Run aus.
  2. Wählen Sie die Programmiersprache für Ihre Beispielanwendung aus und klicken Sie auf Weiter. Dienst aus einer Liste der vorhandenen Beispielanwendungen erstellen
  3. Benennen Sie Ihr Projekt und klicken Sie dann auf Fertigstellen.

    Cloud Code klont die Beispielanwendung, öffnet das neu erstellte Projekt und erstellt die erforderlichen Cloud Run-Ausführungskonfigurationen.

  4. Wenn Sie eine Java-Beispielanwendung ausgewählt haben, klicken Sie bei Aufforderung auf Maven-Projekt laden.

    Benachrichtigung zu Maven-Build-Skripts gefunden – Wählen Sie MavenMaven-Projekt laden“, SkipÜberspringen“ oder HelpHilfe“

Sie können den Hello-World-Dienst jetzt ausführen. Cloud Code überwacht Ihr Dateisystem auf Änderungen, sodass Sie den Dienst nahezu in Echtzeit bearbeiten und noch einmal ausführen können.

Dienst in Cloud Run bereitstellen

So stellen Sie Ihren Dienst bereit:

  1. Wählen Sie in der Navigationsleiste der Auswahl für /Run/Debug-Konfigurationen“ die automatisch erstellte Ausführungskonfiguration Cloud Run: Deploy aus.

    Wenn Sie diese Kurzanleitung mit Apple M-Series Silicon ausführen, wird Ihre Anwendung mit Cloud Build erstellt. Informationen zu den Preisen für Cloud Build finden Sie unter Preise.

  2. Klicken Sie auf Ausführen Symbol für Ausführungsaktion. Das Fenster "Konfiguration bearbeiten" wird geöffnet.

  3. Legen Sie die Google Cloud-Projekt-ID fest.

  4. Wählen Sie eine Region für Ihre Deployment-Plattform aus.

    In dieser Kurzanleitung wird die Standardplattformoption Cloud Run (vollständig verwaltet) als Deployment Platform verwendet.

  5. Klicken Sie auf Ausführen.

  6. Rufen Sie den ausgeführten Dienst auf. Folgen Sie dazu der im Ausgabefenster angezeigten URL.

  7. Sie können den Status Ihres Dienstes (Messwerte, Überarbeitungsdetails und mehr) auch mithilfe der Log-URL aufrufen, die im Ausgabefenster angezeigt wird.

    Status Ihres Dienstes in der Cloud Console ansehen

Ressourcenstatus ansehen

So zeigen Sie den Status der Ressourcen Ihres ausgeführten Dienstes an:

  1. Rufen Sie den Cloud Run Explorer auf. Er kann über das Steuerfeld auf der rechten Seite aufgerufen werden.

    Cloud Run-Explorer-Tab auf der rechten Seitenleiste hervorgehoben

  2. Klicken Sie im Explorer auf den Dienst oder die Überarbeitung, um die Eigenschaften eines Dienstes oder einer Überarbeitung anzeigen zu lassen.

    Cloud Run Explorer wird mit einem ausgewählten Dienst und den unten angezeigten Eigenschaften geöffnet

  3. Klicken Sie mit der rechten Maustaste auf die Überarbeitung und klicken Sie dann auf Cloud Logs ansehen, um die Logs einer Überarbeitung anzuzeigen.

    Klicken Sie mit der rechten Maustaste auf eine Überarbeitung, um ihre Logs aufzurufen

Bereinigen

Wenn Sie für diese Kurzanleitung ein Projekt erstellt haben, löschen Sie es, um unnötige Kosten zu vermeiden:

  1. Rufen Sie in der Google Cloud Console die Seite "Projekte" auf.

    Zur Seite "Projekte"

  2. Wählen Sie das für diese Kurzanleitung erstellte Projekt aus und klicken Sie auf Löschen.

    Das Projekt wird beendet und der Löschvorgang geplant.

Wenn Sie ein bereits vorhandenes Projekt verwenden und nur die Ressourcen löschen möchten, die Sie für diese Kurzanleitung erstellt haben:

Nächste Schritte

Support

Rufen Sie Tools > Cloud Code > Hilfe / Über > auf, um Feedback zu senden oder ein Problem in der IntelliJ-IDE zu melden. Senden Sie uns Feedback oder melden Sie ein Problem , um ein Problem auf GitHub zu melden, oder stellen Sie eine Frage in Stack Overflow.

Sie können auch dem Kanal #cloud-code beitreten, der Teil der Google Cloud-Slack-Community ist.