Elenco delle versioni di runtime

Mantieni tutto organizzato con le raccolte Salva e classifica i contenuti in base alle tue preferenze.

AI Platform Training utilizza le immagini container, basate sulla designazione della versione di runtime, per configurare le risorse cloud al fine di gestire le richieste di addestramento e previsione. Questa pagina elenca le versioni di runtime e i relativi pacchetti. Per ulteriori informazioni, consulta la sezione Gestire le versioni di runtime.

Versioni di runtime AI Platform Training supportate

Le versioni seguenti sono supportate in AI Platform Training:

Versione Pacchetto Data di uscita Ultimo aggiornamento Fine disponibilità
2,11 TensorFlow 2.11.x (ultima patch)
scikit-learn 1.0.2
XGBoost 1.6.1

Le GPU sono supportate per la previsione online in questa versione di runtime. Questa versione di runtime supporta anche le TPU per l'addestramento.

La versione 2.11 di runtime non supporta la previsione batch.

Python 3.7 è l'unica versione di Python disponibile per la previsione online con la versione di runtime 2.11. Non puoi utilizzare Python 2 con la versione di runtime 2.11.

23 gennaio 2023 23 gennaio 2023

A partire dal 23 gennaio 2024, non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 23 gennaio 2025, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

2,9 TensorFlow 2.9.x (ultima patch)
scikit-learn 1.0.2
XGBoost 1.6.1

Le GPU sono supportate per la previsione online in questa versione di runtime. Questa versione di runtime supporta anche le TPU per l'addestramento.

La versione 2.9 di runtime non supporta la previsione batch.

Python 3.7 è l'unica versione di Python disponibile per la previsione online con la versione di runtime 2.9. Non puoi utilizzare Python 2 con la versione 2.9 del runtime.

26 ottobre 2022 26 ottobre 2022

A partire dal 26 ottobre 2023, non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 26 ottobre 2024, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

2,8 TensorFlow 2.8.x (ultima patch)
scikit-learn 1.0.2
XGBoost 1.5.2

Le GPU sono supportate per la previsione online in questa versione di runtime. Questa versione di runtime supporta anche le TPU per l'addestramento.

La versione 2.8 di Runtime non supporta la previsione batch.

Python 3.7 è l'unica versione di Python disponibile per la previsione online con la versione 2.8 di runtime. Non puoi utilizzare Python 2 con la versione 2.8 del runtime.

15 febbraio 2022 15 febbraio 2022

A partire dal 16 marzo 2023, non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 16 marzo 2024, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

2,7 TensorFlow 2.7.x (ultima patch)
scikit-learn 1.0.1
XGBoost 1.5.0

Le GPU sono supportate per la previsione online in questa versione di runtime. Questa versione di runtime supporta anche le TPU per l'addestramento.

La versione 2.7 di runtime non supporta la previsione batch.

Python 3.7 è l'unica versione di Python disponibile per la previsione online con la versione di runtime 2.7. Non puoi utilizzare Python 2 con la versione 2.7 del runtime.

8 dicembre 2021 8 dicembre 2021

A partire dall'8 dicembre 2022, non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

L'8 dicembre 2023 AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

2,6 TensorFlow 2.6.x (ultima patch)
scikit-learn 0.24.2
XGBoost 1.4.2

Le GPU sono supportate per la previsione online in questa versione di runtime. Questa versione di runtime supporta anche le TPU per l'addestramento.

La versione 2.6 di runtime non supporta la previsione batch.

Python 3.7 è l'unica versione di Python disponibile per la previsione online con la versione di runtime 2.6. Non puoi utilizzare Python 2 con la versione 2.6 del runtime.

6 ottobre 2021 6 ottobre 2021

A partire dal 6 ottobre 2022, non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 6 ottobre 2023, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

2,5 TensorFlow 2.5.x (ultima patch)
scikit-learn 0.24.2
XGBoost 1.4.0

Le GPU sono supportate per l'addestramento e la previsione online in questa versione di runtime. Questa versione di runtime supporta anche le TPU per l'addestramento.

La versione 2.5 di Runtime non supporta la previsione batch.

Python 3.7 è l'unica versione di Python disponibile per la previsione online con runtime 2.5. Non puoi utilizzare Python 2 con runtime versione 2.5.

13 agosto 2021 13 agosto 2021

A partire dal 13 agosto 2022, non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 13 agosto 2023, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

2,4 TensorFlow 2.4.x (ultima patch)
scikit-learn 0.24.0
XGBoost 1.3.1

Le GPU sono supportate per l'addestramento e la previsione online in questa versione di runtime. Questa versione di runtime supporta anche le TPU per l'addestramento.

La versione 2.4 di runtime non supporta la previsione batch.

Python 3.7 è l'unica versione di Python disponibile per l'addestramento e la previsione online con la versione 2.4 di runtime. Non puoi utilizzare Python 2 con la versione di runtime 2.4.

10 febbraio 2021 10 febbraio 2021

A partire dal 16 aprile 2022, non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 16 aprile 2023, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

2,3 TensorFlow 2.3.x (patch più recente)
scikit-learn 0.23.2
XGBoost 1.2.1

Le GPU sono supportate per l'addestramento e la previsione online in questa versione di runtime. Questa versione di runtime supporta anche le TPU per l'addestramento.

La versione 2.3 di runtime non supporta la previsione batch.

Python 3.7 è l'unica versione di Python disponibile per l'addestramento e la previsione online con la versione 2.3 di runtime. Non puoi utilizzare Python 2 con il runtime di versione 2.3.

9 dicembre 2020 9 dicembre 2020

A partire dal 9 dicembre 2021, non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 9 dicembre 2022, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

2,2 TensorFlow 2.2.x (ultima patch)
scikit-learn 0.23.1
XGBoost 1.1.1

Le GPU sono supportate per l'addestramento e la previsione online in questa versione di runtime. Questa versione di runtime supporta anche le TPU per l'addestramento.

La versione 2.2 di runtime non supporta la previsione batch.

Python 3.7 è l'unica versione di Python disponibile per l'addestramento e la previsione online con la versione 2.2 del runtime. Non puoi utilizzare Python 2 con la versione di runtime 2.2.

28 agosto 2020 28 agosto 2020

A partire dal 28 agosto 2021, non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 28 agosto 2022, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

2,1 TensorFlow 2.1.0
scikit-learn 0.22.1
XGBoost 0.90

La versione 2.1 di runtime supporta TensorFlow 2.1.0 per CPU e GPU. Le GPU sono supportate per l'addestramento e la previsione online in questa versione di runtime. Questa versione di runtime supporta anche le TPU per l'addestramento.

Python 3.7 è l'unica versione di Python disponibile per l'addestramento e la previsione online con la versione 2.1 di runtime. Non puoi utilizzare Python 2 con la versione di runtime 2.1.

9 marzo 2020 9 marzo 2020

A partire dal 9 marzo 2021, non puoi più creare job di addestramento che utilizzano questa versione di runtime o versioni di modello che utilizzano questa versione di runtime. La previsione batch continuerà a essere supportata.

Il 31 gennaio 2023, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

1,15 TensorFlow 1.15.0
scikit-learn 0.20.4
XGBoost 0.82

La versione di runtime 1.15 supporta TensorFlow 1.15.0 per CPU e GPU. Le GPU sono supportate per l'addestramento e la previsione online in questa versione di runtime. Questa versione di runtime supporta anche le TPU per l'addestramento.

Python 3.7 è disponibile per l'addestramento e la previsione online con la versione 1.15 del runtime. I pacchetti Ubuntu per Python 3 (indicati in grassetto) vengono installati durante l'esecuzione di Python 3.

19 dicembre 2019 19 dicembre 2019

A partire dal 30 settembre 2022, non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 30 settembre 2023, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

1,14 TensorFlow 1.14.0
scikit-learn 0.20.2
XGBoost 0.81

La versione 1.14 di runtime supporta TensorFlow 1.14.0 per CPU e GPU. Le GPU sono supportate per l'addestramento e la previsione online in questa versione di runtime. Questa versione di runtime supporta anche le TPU per l'addestramento.

Python 3.5 è disponibile per l'addestramento e la previsione online con la versione 1.14 del runtime. I pacchetti Ubuntu per Python 3 (indicati in grassetto) vengono installati durante l'esecuzione di Python 3.

19 luglio 2019 16 agosto 2019

A partire dal 19 luglio 2020, non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 19 luglio 2021 AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

1,13 TensorFlow 1.13.1
scikit-learn 0.20.2
XGBoost 0.81

La versione di runtime 1.13 supporta TensorFlow 1.13.1 per CPU e GPU. Le GPU sono supportate per l'addestramento e la previsione online in questa versione di runtime. Questa versione di runtime supporta anche le TPU per l'addestramento.

Python 3.5 è disponibile per l'addestramento e la previsione online con la versione 1.13 del runtime. I pacchetti Ubuntu per Python 3 (indicati in grassetto) vengono installati durante l'esecuzione di Python 3.

6 marzo 2019 16 agosto 2019

A partire dal 19 luglio 2020, non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 6 marzo 2021, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

1,12 TensorFlow 1.12.3
scikit-learn 0.20.0
XGBoost 0.81

La versione di runtime 1.12 supporta TensorFlow 1.12.3 per CPU e GPU. Le GPU sono supportate per l'addestramento e la previsione online in questa versione di runtime.

Python 3.5 è disponibile per l'addestramento e la previsione online con la versione 1.12 di runtime. I pacchetti Ubuntu per Python 3 (indicati in grassetto) vengono installati durante l'esecuzione di Python 3.

19 dicembre 2018 19 luglio 2019

A partire dal 19 luglio 2020, non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 19 dicembre 2020, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

1,11 TensorFlow 1.11
scikit-learn 0.19.2
XGBoost 0.80

La versione 1.11 di runtime supporta TensorFlow 1.11.0 per CPU e GPU. Le GPU sono supportate per l'addestramento e la previsione online in questa versione di runtime.

Python 3.5 è disponibile per l'addestramento e la previsione online con la versione 1.11 di runtime. I pacchetti Ubuntu per Python 3 (indicati in grassetto) vengono installati durante l'esecuzione di Python 3.

19 dicembre 2018

A partire dal 19 luglio 2020, non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 19 dicembre 2020, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

1,10 TensorFlow 1.10
scikit-learn 0.19.2
XGBoost 0.72.1

La versione 1.10 del runtime supporta TensorFlow 1.10.0 per CPU e GPU (le GPU non sono supportate per la previsione online).

Python 3.5 è disponibile per l'addestramento e la previsione online con la versione 1.10 di runtime. I pacchetti Ubuntu per Python 3 (indicati in grassetto) vengono installati durante l'esecuzione di Python 3.

31 agosto 2018 19 dicembre 2018

A partire dal giorno (data non impostata), non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 31 agosto 2020, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

1,9 TensorFlow 1.9
scikit-learn 0.19.1
XGBoost 0.72.1

La versione 1.9 del supporto supporta TensorFlow 1.9.0 per CPU e GPU (le GPU non sono supportate per la previsione online).

Python 3.5 è disponibile per l'addestramento e la previsione online con la versione 1.9 del runtime. I pacchetti Ubuntu per Python 3 (indicati in grassetto) vengono installati durante l'esecuzione di Python 3.

27 giugno 2018 19 dicembre 2018

A partire dal 16 marzo 2020, non puoi più creare job di addestramento che utilizzano questa versione di runtime.

A partire dal giorno (data non impostata), non puoi più creare job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 27 giugno 2020, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

1,8 TensorFlow 1.8
scikit-learn 0.19.1
XGBoost 0.71

La versione 1.8 del runtime supporta TensorFlow 1.8.0 per CPU e GPU (le GPU non sono supportate per la previsione online).

Python 3.5 è disponibile per l'addestramento e la previsione online con la versione 1.8 del runtime. I pacchetti Ubuntu per Python 3 (indicati in grassetto) vengono installati durante l'esecuzione di Python 3.

I pacchetti gcloud e google-cloud-logging sono stati sostituiti con il pacchetto google-cloud, che contiene entrambi i pacchetti rimossi.

8 maggio 2018 19 dicembre 2018

A partire dal 16 marzo 2020, non puoi più creare job di addestramento che utilizzano questa versione di runtime.

A partire dal giorno (data non impostata), non puoi più creare job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

L'8 maggio 2020, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

1,7 TensorFlow 1.7
scikit-learn 0.19.1
XGBoost 0.7.post3

La versione 1.7 di runtime supporta TensorFlow 1.7.0 per CPU e GPU.

Python 3.5 è disponibile per l'addestramento e la previsione online con la versione 1.7 del runtime. I pacchetti Ubuntu per Python 3 (indicati in grassetto) vengono installati durante l'esecuzione di Python 3.

26 aprile 2018 19 dicembre 2018

A partire dal 16 marzo 2020, non puoi più creare job di addestramento che utilizzano questa versione di runtime.

A partire dal giorno (data non impostata), non puoi più creare job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 26 aprile 2020, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

1,6 TensorFlow 1.6
scikit-learn 0.19.1
XGBoost 0.7.post3

La versione 1.6 di runtime supporta TensorFlow 1.6.0 per CPU e GPU.

Python 3.5 è disponibile per l'addestramento e la previsione online con la versione 1.6 del runtime. I pacchetti Ubuntu per Python 3 (indicati in grassetto) vengono installati durante l'esecuzione di Python 3.

20 marzo 2018 19 dicembre 2018

A partire dal 16 marzo 2020, non puoi più creare job di addestramento che utilizzano questa versione di runtime.

A partire dal giorno (data non impostata), non puoi più creare job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 13 aprile 2020, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

1,5 TensorFlow 1.5
scikit-learn 0.19.1
XGBoost 0.7.post3

La versione 1.5 di runtime supporta TensorFlow 1.5.0 per CPU e GPU.

Python 3.5 è disponibile per l'addestramento e la previsione online con la versione 1.5 del runtime. I pacchetti Ubuntu per Python 3 (indicati in grassetto) vengono installati durante l'esecuzione di Python 3.

13 marzo 2018 19 dicembre 2018

A partire dal 16 marzo 2020, non puoi più creare job di addestramento che utilizzano questa versione di runtime.

A partire dal giorno (data non impostata), non puoi più creare job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 13 aprile 2020, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

1,4 TensorFlow 1.4.0 e 1.4.1
scikit-learn 0.18.1
XGBoost 0.6a2

La versione 1.4 di runtime utilizza TensorFlow 1.4.0 per la previsione online e 1.4.1 per la previsione e l'addestramento in batch.

Python 3.5 è disponibile per l'addestramento e la previsione online con la versione 1.4 del runtime. I pacchetti Ubuntu per Python 3 (indicati in grassetto) vengono installati durante l'esecuzione di Python 3.

La prima versione di runtime di AI Platform Training che fornisce supporto per scikit-learn e XGBoost è la versione 1.4.

11 dicembre 2017 19 dicembre 2018

A partire dal 16 marzo 2020, non puoi più creare job di addestramento che utilizzano questa versione di runtime.

A partire dal giorno (data non impostata), non puoi più creare job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 13 aprile 2020, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

1,2 TensorFlow 1.2.0

La versione di runtime 1.2 utilizza un'immagine di base del sistema operativo Ubuntu 16.04 invece della versione di Debian Jessie utilizzata da 1.0.

27 giugno 2017

A partire dal 16 marzo 2020, non puoi più creare job di addestramento che utilizzano questa versione di runtime.

A partire dal giorno (data non impostata), non puoi più creare job di previsione batch o versioni del modello che utilizzano questa versione di runtime.

Il 13 aprile 2020, AI Platform Prediction elimina tutte le versioni del modello che utilizzano questa versione di runtime.

Criterio per supportare le versioni di runtime precedenti

AI Platform Training e AI Platform Prediction supportano ciascuna versione di runtime per un anno dopo la data di rilascio.

Il supporto di ogni versione del runtime cambia in base alla seguente pianificazione:

  • A partire dalla data di rilascio: puoi creare job di addestramento, job di previsione batch e versioni del modello che utilizzano la versione di runtime.

  • A partire da 12 mesi dopo la data di rilascio: non puoi più creare job di addestramento, job di previsione batch o versioni del modello che utilizzano la versione di runtime.

    Le versioni esistenti dei modelli di cui è stato eseguito il deployment in AI Platform Prediction continuano a funzionare.

  • A partire da 24 mesi dopo la data di rilascio: AI Platform Prediction elimina automaticamente tutte le versioni di modello che utilizzano la versione di runtime.

Una versione modificata di questo criterio viene applicata in modo retroattivo, in più fasi, alle versioni di runtime 1.13 e precedenti. Per la disponibilità attuale di ogni versione di runtime, consulta questo documento.

Supporto per le GPU

Le macchine abilitate per GPU sono preinstallate con tensorflow-gpu, il pacchetto TensorFlow Python con supporto GPU.

Altre macchine sono preinstallate con il normale pacchetto tensorflow.

Supporto per Cloud TPU

Per l'addestramento dei modelli su Cloud TPU sono disponibili le versioni di runtime di AI Platform Training 1.15, 2.1, 2.2, 2.3, 2.4, 2.5, 2.6, 2.7, 2.8, 2.9 e 2.11. Scopri come richiedere una quota di Cloud TPU e come utilizzare le TPU per addestrare il tuo modello.

Container PyTorch predefiniti

Oltre alle versioni di runtime, AI Platform Training offre diversi container PyTorch predefiniti che puoi utilizzare per addestrare un modello PyTorch. Scopri di più sui container PyTorch disponibili e su come utilizzarli.

Passaggi successivi