App Engine スタンダード環境へのデプロイ

このドキュメントでは、IntelliJ IDEA 内から App Engine アプリケーションを App Engine スタンダード環境にデプロイする方法について説明します。

始める前に

  • IntelliJ IDEA のインストールとセットアップをまだ行っていない場合は、クイックスタートに沿ってインストールしてから、このドキュメントに戻ってください。

  • アプリの作成ガイドに従って、スタンダード環境用の App Engine アプリを作成します。App Engine スタンダード フレームワーク サポートを必ず追加してください。

  • Gradle ベースのプロジェクトがあり、IntelliJ IDEA Community Edition を使用している場合は、App Engine Gradle プラグインを使用してプロジェクトを構成します。必ずプロジェクトを Gradle と同期してください。

    アプリケーションをお持ちでない場合は、サンプルアプリをダウンロードして、これらのデプロイ手順を試すことができます。

    1. Hello World サンプルアプリのクローンをローカルマシンに作成します。

        git clone https://github.com/GoogleCloudPlatform/java-docs-samples
      
    2. IntelliJ IDEA で、[File] > [Open] を選択してファイル選択画面を開きます。

    3. /java-docs-samples/appengine/ に移動します。

    4. /helloworld/ ディレクトリを選択します。

    5. [OK] をクリックします。

デプロイ構成の作成

  1. [Tools] > [Google Cloud Tools] > [Deploy to App Engine] を選択します。

    [Create Deployment Configuration] ダイアログのフィールドが表示されたスクリーンショット

  2. サーバーの構成を確認します。

    1. [Server] フィールドの横にある省略記号(...)をクリックします。

    2. ダイアログで、[Name] フィールドに [Google App Engine] が表示されていることを確認します。

    3. [OK] をクリックします。

  3. [Deployment] でソースを選択します。

    Community Edition を使用している場合、Cloud Tools for IntelliJ では、Maven または Gradle アーティファクトからのデプロイのみがサポートされます。

  4. [Project] フィールドでプロジェクトを選択します。

    初めてデプロイを構成する場合、デプロイする GCP Console プロジェクトに関連付けられているアカウントにログインするように求められます。

    [Server] フィールドを指定するまで非表示であったプロジェクト選択フィールドが表示された状態のスクリーンショット

  5. 必要に応じて、他のフィールドに入力してデプロイを構成します。

  6. [Run] をクリックしてアプリをビルドし、デプロイします。

  7. [Application Servers] ウィンドウで、デプロイの進行状況をモニタリングするプロジェクトの名前をクリックします。このウィンドウが表示されていない場合は、[View] > [Tool Windows] > [Application Servers] をクリックします。

    デプロイが完了すると、コンソール出力でアプリの URL を確認できます。

App Engine スタンダード構成を更新する

最初のデプロイ構成を作成した後、アプリケーションの要件に応じてこの構成を変更できます。

  1. [File] > [Project Structure] を選択します。

    [Project Structure] ダイアログが表示されます。

  2. [Project Settings] で [Facets] を選択します。

  3. App Engine スタンダード ファセットを選択します。

    左側のナビゲーションにプロジェクト設定(プロジェクト、モジュール、ライブラリ、ファセット、アーティファクト)が表示されているダイアログ。プラットフォーム設定も表示されています。[Facets] オプションが選択され、プロジェクトに関連するファセットが中央の列に表示されています。右側の列には、プロジェクトで使用できるライブラリが表示され、どのライブラリが選択されているかが示されます。

  4. プロジェクトに追加するライブラリを選択します。

  5. [OK] をクリックします。

サーバーの削除

プロジェクト用に構成したサーバーを削除する手順は次のとおりです。

  1. [File] > [Settings] > [Build, Execution, Deployment] > [Clouds] を選択します。

    Mac OS の場合は、[IntelliJ IDEA] > [Preferences] > [Build, Execution, Deployment] > [Clouds] となります。

  2. サーバー(App Engine)を選択し、ウィンドウの上部にあるマイナス記号(-)をクリックして削除します。

  3. [OK] をクリックします。

次のステップ

このページは役立ちましたか?評価をお願いいたします。