Configurer des routeurs sur site

Ce document explique comment configurer des routeurs sur site pour l'interconnexion partenaire. Si vous créez une connexion par interconnexion dédiée, consultez la section Configurer des routeurs sur site pour une interconnexion dédiée.

À quel moment configurer votre routeur sur site

Dans ce contexte, un routeur sur site désigne un appareil de couche 2 (L2) ou 3 (L3) que vous configurez pour activer l'interconnexion partenaire.

  • Pour les connexions de couche 2 (L2), configurez votre routeur sur site après que votre fournisseur de services a configuré vos rattachements de VLAN, comme décrit dans la section Présentation de l'interconnexion partenaire.
  • Pour les connexions de couche 3 (L3), il n'est pas nécessaire de configurer BGP sur votre routeur sur site, car le fournisseur de services configure BGP sur ses routeurs périphériques, comme décrit dans la section Présentation de l'interconnexion partenaire.

Ce document fournit un exemple de topologie et de configuration pour les connexions de couche 2, que vous pouvez utiliser comme guide lors de la configuration de votre routeur sur site.

Topologie des connexions de couche 2

Dans cette topologie, la ou les connexions Cloud Interconnect aboutissent à un routeur sur site, qui effectue un appairage BGP avec Cloud Router.

Cet exemple de topologie utilise les ressources Google Cloud suivantes :

  • Le projet Sample Interconnect Project
  • Le réseau my-network
  • La région us-east1

Il existe deux rattachements d'interconnexion partenaires, my-attachment1 et my-attachment2, qui sont déjà actifs et qui ont configuré BGP.

Physique

Le schéma suivant illustre la topologie physique pour les connexions de couche 2. Google et votre fournisseur de services configurent et gèrent les connexions physiques entre Google Cloud et le réseau de votre fournisseur de services.

Exemple de topologie physique de couche 2 (cliquez pour agrandir)
Exemple de topologie physique pour les connexions de couche 2 (cliquez pour agrandir)

Logique

Le schéma suivant illustre la topologie logique pour les connexions de couche 2.

Exemple de topologie logique de couche 2 (cliquez pour agrandir)
Exemple de topologie logique pour les connexions de couche 2 (cliquez pour agrandir)

Configurer votre routeur sur site

Cette section explique comment configurer les topologies de couche 2 pour une utilisation en production. Chaque exemple de configuration décrit tous les paramètres de l'appareil.

Paramètres du routeur sur site

Sur la base de la configuration de l'exemple de projet Google Cloud, le tableau suivant récapitule les paramètres du routeur sur site à utiliser pour l'exemple de topologie.

Consultez la documentation de référence de la topologie pour déterminer le nom de projet, le réseau VPC et la région utilisés côté Google Cloud.

Les valeurs de compteur de préservation et d'intervalle keepalive permettent à Google de transférer rapidement le trafic vers des connexions redondantes en cas de problème. Définissez leurs valeurs comme indiqué dans le tableau.

Le redémarrage progressif protège les sessions BGP contre les suppressions de paquets et les retraits de routes lors de la maintenance du routeur cloud. Si cette option est compatible avec votre appareil sur site, activez le redémarrage progressif des services BGP, en définissant le compteur de redémarrage progressif et l'intervalle "stalepath" comme indiqué dans le tableau.

Pour plus d'informations sur les paramètres de compteur BGP, consultez les valeurs recommandées pour les compteurs de BGP dans la documentation de Cloud Router.

Paramètres my-attachment1 my-attachment2
Numéro de VLAN 1010 1020
Adresse IP de l'interface VLAN 169.254.10.2/29 169.254.20.2/29
Numéro ASN du routeur sur site 64500 64500
Numéro ASN du routeur cloud 16550 16550
Adresse IP BGP du routeur cloud Pour cr1-us-east1 :
169.254.10.1
Pour cr2-us-east1 :
169.254.20.1
Timers BGP Keepalive : 20 secondes Keepalive : 20 secondes
Compteur de préservation : 60 secondes Compteur de préservation : 60 secondes
Redémarrage progressif : 1 seconde Redémarrage progressif : 1 seconde
Intervalle "stalepath" : 300 secondes Intervalle "stalepath" : 300 secondes
Plage de sous-réseaux LAN sur site 192.168.12.0/24 192.168.12.0/24

Instructions de configuration

Appliquez les informations suivantes sur votre commutateur ou routeur sur site pour établir une session BGP avec le routeur cloud :

Configuration de l'appareil

Routeur du VLAN 1010 (Cisco)

Voici un exemple de configuration pour une topologie de couche 2 sur site utilisant le routeur Router1 (Cisco) sur le VLAN 1010 :

    interface E0/0
      description connected_to_service_provider_device
      no shut

    interface E0/0.1010
      description attachment_vlan1010
      encapsulation dot1Q 1010
      ip address 169.254.10.2 255.255.255.248
      ip mtu 1440

    ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

    route-map TO_GCP_OUTBOUND permit 10
      match ip address prefix-list TO_GCP

    router bgp 64500
      bgp graceful-restart restart-time 1
       neighbor 169.254.10.1 description peering_to_cloud_router
       neighbor 169.254.10.1 remote-as 16550
       neighbor 169.254.10.1 ebgp-multihop 4
       neighbor 169.254.10.1 timers 20 60
       neighbor 169.254.10.1 update-source E0/0.1010
       neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
  

Routeur du VLAN 1020 (Juniper)

Voici un exemple de configuration pour une topologie de couche 2 sur site utilisant le routeur Router2 (Juniper) sur le VLAN 1020 :

    set interfaces xe-0/0/0 description "connected_to_service_provider_device"
    set interfaces xe-0/0/0 flexible-vlan-tagging
    set interfaces xe-0/0/0 unit 1020 family inet mtu 1440
    set interfaces xe-0/0/0 unit 1020 vlan-id 1020
    set interfaces xe-0/0/0 unit 1020 family inet address 169.254.20.2/29

    set routing-options autonomous-system 64500

    set policy-options prefix-list TO_GCP 192.168.12.0/24

    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
    set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

    set protocols bgp group config_vlan_1020 type external
    set protocols bgp group config_vlan_1020 multihop ttl 4
    set protocols bgp group config_vlan_1020 local-address 169.254.20.2
    set protocols bgp group config_vlan_1020 peer-as 16550
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1

Bonnes pratiques

Suivez ces bonnes pratiques pour garantir une connectivité efficace à Google Cloud depuis vos appareils sur site dans le cadre des topologies Cloud Interconnect à 99,9 % ou à 99,99 % de disponibilité.

Configurer des appareils pour le transfert actif/actif

  • Assurez-vous que les mêmes valeurs MED sont échangées à l'échelle de toutes les sessions BGP.
  • Activez le routage ECMP (Equal-Cost Multi-Path) dans votre configuration BGP.
  • Activez le redémarrage progressif ou distribuez les rattachements d'interconnexion entre plusieurs routeurs cloud d'une même région. En d'autres termes, assurez-vous que deux routeurs cloud ne seront pas redémarrés en même temps pour les mises à niveau de code.
  • Si vous configurez deux appareils sur site, interconnectez-les via le protocole de routage de votre choix. Si vous configurez votre appareil pour exploiter la redistribution, utilisez IBGP ou IGP.

Configurer des appareils pour le transfert actif/passif

  • Veillez à appliquer des valeurs MED plus élevées du côté du routeur cloud et de l'appareil sur site, afin d'éviter un routage asymétrique.
  • Activez le redémarrage progressif ou répartissez les rattachements entre plusieurs routeurs cloud d'une même région. En d'autres termes, assurez-vous que deux routeurs de cloud ne seront pas redémarrés en même temps pour les mises à niveau de code.
  • Si vous configurez deux appareils sur site, assurez-vous qu'ils disposent d'une connectivité de couche 3 l'un par rapport à l'autre. Si vous configurez votre appareil pour exploiter la redistribution, utilisez IBGP ou IGP.

Étape suivante

Vérifiez le bon fonctionnement de vos sessions BGP entre le réseau sur site et le réseau Google Virtual Private Cloud. Pour en savoir plus, consultez la section Afficher l'état des routeurs et les routes annoncées dans la documentation de Cloud Router.