Configurer des routeurs sur site

Après avoir créé un rattachement de VLAN, vous devez configurer le routeur sur site pour établir une session BGP avec le routeur cloud. Servez-vous de l'ID de VLAN, de l'adresse IP d'interface et de l'adresse IP d'appairage fournis par le rattachement de VLAN pour configurer le routeur sur site.

Ce document fournit les exemples de topologies et de configurations suivants, que vous pouvez utiliser comme guide lors de la configuration de votre routeur sur site.

  • Topologie de couche 3 uniquement (recommandée) : une ou plusieurs connexions d'interconnexion dédiées aboutissant à un routeur sur site (topologie de couche 3 uniquement). Le routeur effectue un appairage BGP avec Cloud Router. Il s'agit de la configuration recommandée.
  • Topologie de couche 2/couche 3 : une ou plusieurs connexions d'interconnexion dédiées aboutissant à un commutateur sur site connecté à un routeur sur site. Le routeur effectue un appairage BGP avec Cloud Router.

Reportez-vous à la section Remarques propres aux fournisseurs du guide d'interopérabilité VPN pour connaître les valeurs correspondant à certaines plates-formes tierces utilisables avec votre routeur sur site, ou consultez la documentation de celui-ci pour obtenir des valeurs précises.

Les topologies fournies en exemple dans ce document utilisent les ressources Google Cloud suivantes :

  • Le projet Sample Interconnect Project
  • Le réseau my-network
  • La région us-east1

Il existe deux interconnexions dédiées, my-interconnect1 et my-interconnect2. Ces interconnexions sont déjà configurées et se trouvent à l'état ready to use.

Topologie de couche 3 uniquement

Dans cette topologie, la ou les connexions Cloud Interconnect aboutissent à un routeur sur site, qui effectue un appairage BGP avec Cloud Router.

Les diagrammes suivants illustrent les composants physiques et logiques de la topologie de couche 3 uniquement.

Exemple de topologie physique de couche 3 uniquement (cliquez pour agrandir)
Exemple de topologie physique sur site de couche 3 uniquement (cliquez pour agrandir)
Exemple de topologie logique de couche 3 uniquement (cliquez pour agrandir)
Exemple de topologie logique sur site de couche 3 uniquement (cliquez pour agrandir)

Topologie de couche 2/couche 3

Dans cette topologie, la ou les connexions Cloud Interconnect de Google Cloud aboutissent à un commutateur sur site, qui se connecte ensuite à un routeur sur site. Le routeur effectue un appairage BGP avec Cloud Router.

Les diagrammes suivants illustrent les composants physiques et logiques de la topologie de couche 2/couche 3.

Exemple de topologie physique de couche 2/couche 3 (cliquez pour agrandir)
Exemple de topologie physique de couche 2/couche 3 (cliquez pour agrandir)
Exemple de topologie logique de couche 2/couche 3 (cliquez pour agrandir)
Exemple de topologie logique de couche 2/couche 3 (cliquez pour agrandir)

Configurer des appareils sur site pour les tests

La section suivante explique comment configurer des appareils sur site pour tester votre interconnexion Cloud Interconnect. Pour une configuration L2/L3, cet exemple décrit la configuration de l'interface de test sur un ou plusieurs commutateurs Google Cloud, mais pas sur les routeurs.

Instructions de configuration

Avant que Google ne commence à tester votre nouvelle connexion d'interconnexion dédiée, vous devez configurer vos interfaces sans marquage VLAN, autrement dit, en mode d'accès.

Exemple de configuration pour les tests

L'exemple suivant montre comment configurer un routeur Juniper avant de procéder au test et présente les paramètres requis pour configurer le canal de port ae0. Cette configuration utilise les paramètres suivants :

  • Une adresse IP BGP de 169.254.0.2 est configurée sur le canal de port ae0.
  • LACP est configuré sur le canal de port ae0.
  • Le marquage VLAN n'est pas configuré sur le canal de port ae0. Vous devez configurer vos interfaces sans marquage VLAN (en mode d'accès).
  set interfaces xe-0/0/0 description "my-interconnect2"
  set interfaces xe-0/0/0 gigether-options 802.3ad ae0
  set interfaces ae0 description "my-interconnect2"
  set interfaces ae0 aggregated-ether-options lacp active
  set interfaces ae0 aggregated-ether-options minimum-links 1
  set interfaces ae0 unit 0 family inet mtu 1440
  set interfaces ae0 unit 0 family inet address 169.254.0.2

Une fois que votre connexion Cloud Interconnect fonctionne, passez à la section suivante pour voir un exemple de configuration de production pour chaque topologie.

Configurer des routeurs sur site pour la production

Cette section explique comment configurer les topologies de couche 3 uniquement et de couche 2/couche 3 pour une utilisation en production. Chaque exemple de configuration décrit tous les paramètres de l'appareil.

Pour en savoir plus sur la configuration des appareils sur site pour le test de votre interconnexion Cloud Interconnect, consultez la page Configurer des routeurs sur site pour les tests.

Paramètres du routeur de production sur site pour la couche 3 uniquement

Sur la base de la configuration de l'exemple de projet Google Cloud, le tableau suivant récapitule les paramètres de routeur sur site à utiliser pour les exemples de topologies.

Consultez la documentation de référence de la topologie pour déterminer le nom de projet, le réseau VPC et la région utilisés côté Google Cloud.

Les valeurs de compteur de préservation et d'intervalle keepalive permettent à Google de transférer rapidement le trafic vers des connexions redondantes en cas de problème. Définissez leurs valeurs comme indiqué dans le tableau.

Le redémarrage progressif protège les sessions BGP contre les suppressions de paquets et les retraits de routes lors de la maintenance du routeur cloud. Si cette option est compatible avec votre appareil sur site, activez le redémarrage progressif des services BGP, en définissant le compteur de redémarrage progressif et l'intervalle "stalepath" comme indiqué dans le tableau.

Pour plus d'informations sur les paramètres de compteur BGP, consultez les valeurs recommandées pour les compteurs de BGP dans la documentation de Cloud Router.

Paramètres my-interconnect1 my-interconnect2
Numéro de VLAN 1010 1020
Adresse IP de l'interface VLAN 169.254.10.2/29 169.254.20.2/29
Numéro ASN du routeur sur site 64500 64500
Numéro ASN du routeur cloud 65200 65200
Adresse IP BGP du routeur cloud Pour cr1-us-east1 :
169.254.10.1
Pour cr2-us-east1 :
169.254.20.1
Timers BGP Keepalive : 20 secondes Keepalive : 20 secondes
Compteur de préservation : 60 secondes Compteur de préservation : 60 secondes
Redémarrage progressif : 1 seconde Redémarrage progressif : 1 seconde
Intervalle "stalepath" : 300 secondes Intervalle "stalepath" : 300 secondes
Plage de sous-réseaux LAN sur site 192.168.12.0/24 192.168.12.0/24

Consignes de configuration pour la production

Conformez-vous aux instructions suivantes pour configurer la topologie de couche 3 uniquement :

  • Le port du routeur sur site (0/0 sur le diagramme) ou les ports faisant face à Cloud Router doivent faire partie d'un canal de port, y compris lorsqu'un seul port est utilisé.
  • Le protocole LACP doit être activé pour le canal de port, en mode actif ou passif.
  • L'unité de transmission maximale (MTU) de l'interface du routeur (0/0 sur le diagramme) doit être de 1 440 octets.
  • La fonction de sauts multiples doit être configurée sur le voisin EBGP. La valeur recommandée est 4.

Configuration de l'appareil

Routeur du VLAN 1010 (Cisco)

Voici un exemple de configuration de couche 3 uniquement pour le routeur sur site "Router1" (Cisco) installé sur le VLAN 1010 :

    interface E0/0
      description connected_to_google_edge_device
      channel-group 2 mode active
      no shut

    interface Po2
      description my-interconnect1
      no shut

    interface Po2.1010
      description attachment_vlan1010
      encapsulation dot1Q 1010
      ip address 169.254.10.2 255.255.255.248
      ip mtu 1440

    ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

    route-map TO_GCP_OUTBOUND permit 10
      match ip address prefix-list TO_GCP

    router bgp 64500
      bgp graceful-restart restart-time 1
       neighbor 169.254.10.1 description peering_to_cloud_router
       neighbor 169.254.10.1 remote-as 65200
       neighbor 169.254.10.1 ebgp-multihop 4
       neighbor 169.254.10.1 timers 20 60
       neighbor 169.254.10.1 update-source Po2.1010
       neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
  

Routeur du VLAN 1020 (Juniper)

Voici un exemple de configuration de couche 3 uniquement pour le routeur sur site "Router2" (Juniper) installé sur le VLAN 1020 :

    set interfaces xe-0/0/0 ether-options 802.3ad ae1
    set interfaces xe-0/0/0 description "connected_to_google_edge_device"

    set interfaces ae1 description my-interconnect2
    set interfaces ae1 flexible-vlan-tagging
    set interfaces ae1 aggregated-ether-options minimum-links 1
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 unit 1020 family inet mtu 1440
    set interfaces ae1 unit 1020 vlan-id 1020
    set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

    set routing-options autonomous-system 64500

    set policy-options prefix-list TO_GCP 192.168.12.0/24

    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
    set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

    set protocols bgp group config_vlan_1020 type external
    set protocols bgp group config_vlan_1020 multihop ttl 4
    set protocols bgp group config_vlan_1020 local-address 169.254.20.2
    set protocols bgp group config_vlan_1020 peer-as 65200
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
  

Paramètres du routeur de production sur site pour la couche 2/couche 3

Sur la base de la configuration de l'exemple de projet Google Cloud, le tableau suivant récapitule les paramètres de routeur sur site à utiliser pour les exemples de topologies.

Consultez la documentation de référence de la topologie pour déterminer le nom de projet, le réseau VPC et la région utilisés côté Google Cloud.

Les valeurs de compteur de préservation et d'intervalle keepalive permettent à Google de transférer rapidement le trafic vers des connexions redondantes en cas de problème. Définissez leurs valeurs comme indiqué dans le tableau.

Le redémarrage progressif protège les sessions BGP contre les suppressions de paquets et les retraits de routes lors de la maintenance du routeur cloud. Si cette option est compatible avec votre appareil sur site, activez le redémarrage progressif des services BGP, en définissant le compteur de redémarrage progressif et l'intervalle "stalepath" comme indiqué dans le tableau.

Pour plus d'informations sur les paramètres de compteur BGP, consultez les valeurs recommandées pour les compteurs de BGP dans la documentation de Cloud Router.

Paramètres my-interconnect1 my-interconnect2
Numéro de VLAN 1010 1020
Adresse IP de l'interface VLAN 169.254.10.2/29 169.254.20.2/29
Numéro ASN du routeur sur site 64500 64500
Numéro ASN du routeur cloud 65200 65200
Adresse IP BGP du routeur cloud Pour cr1-us-east1 :
169.254.10.1
Pour cr2-us-east1 :
169.254.20.1
Timers BGP Keepalive : 20 secondes Keepalive : 20 secondes
Compteur de préservation : 60 secondes Compteur de préservation : 60 secondes
Redémarrage progressif : 1 seconde Redémarrage progressif : 1 seconde
Intervalle "stalepath" : 300 secondes Intervalle "stalepath" : 300 secondes
Plage de sous-réseaux LAN sur site 192.168.12.0/24 192.168.12.0/24

Consignes de configuration pour la production

Conformez-vous aux instructions suivantes pour configurer le commutateur et les routeurs sur site dans le cadre de la topologie de couche 2/couche 3 :

  • Les VLAN doivent être configurés sur le commutateur.
  • Le port du commutateur (1/1 sur le diagramme) ou les ports faisant face à Cloud Router doivent faire partie d'un canal de port.
    • Le protocole LACP doit être activé pour le canal de port, en mode actif ou passif.
    • Le canal de port doit être configuré en mode trunk 802.1Q et tous les ID de VLAN utilisés par la connexion d'interconnexion doivent être autorisés.
    • Le marquage de VLAN 802.1Q doit être activé sur le canal de port.
  • Le port du commutateur (1/2 sur le diagramme) faisant face au routeur sur site peut être un port en mode trunk ou un port d'accès. Cela couvre le cas d'utilisation dans lequel un port de routeur est dédié à un seul VLAN.
  • Lors de l'activation du mode trunk sur le commutateur, le routeur sur site doit accepter les sous-interfaces présentant l'encapsulation requise (balises dot1q).
  • L'unité de transmission maximale (MTU) de l'interface du routeur (0/0 sur le diagramme) doit être de 1 440 octets.
  • La fonction de sauts multiples doit être configurée sur le voisin EBGP. La valeur recommandée pour ce paramètre est 4.

Configuration de l'appareil

Commutateur du VLAN 1010 (Cisco)

Voici un exemple de configuration pour une topologie de couche 2/couche 3 sur site utilisant le commutateur "Switch1" (Cisco) sur le VLAN 1010 :

    vlan 1010
    name cloud_vlan1010

    interface E1/1
      description connected_to_google_edge_device
      Channel-group 1 mode active

    interface port-channel1
      description connected_to_google_edge_device
      Switchport trunk encapsulation dot1q
      Switchport mode trunk
      Switchport trunk allowed vlan 1,1010

    interface E1/2
      description connected_to_onprem_router
      channel-group 2 mode active

    interface port-channel2
      description connected_to_onprem_router
      Switchport trunk encapsulation dot1q
      Switchport mode trunk
      Switchport trunk allowed vlan 1,1010
  

Routeur du VLAN 1010 (Cisco)

Voici un exemple de configuration pour une topologie de couche 2/couche 3 sur site utilisant le routeur "Router1" (Cisco) sur le VLAN 1010 :

    interface E0/0
      description connected_to_onprem_switch
      channel-group 2 mode active
      no shut

    interface Po2
      description my-interconnect1
      no shut

    interface Po2.1010
      description attachment_vlan1010
      encapsulation dot1Q 1010
      ip address 169.254.10.2 255.255.255.248
      ip mtu 1440

    ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

    route-map TO_GCP_OUTBOUND permit 10
      match ip address prefix-list TO_GCP

    router bgp 64500
      bgp graceful-restart restart-time 1
      neighbor 169.254.10.1 description peering_to_cloud_router
      neighbor 169.254.10.1 remote-as 65200
      neighbor 169.254.10.1 ebgp-multihop 4
      neighbor 169.254.10.1 timers 20 60
      neighbor 169.254.10.1 update-source Po2.1010
      neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
  

Commutateur du VLAN 1020 (Juniper)

Voici un exemple de configuration pour une topologie de couche 2/couche 3 sur site utilisant le commutateur "Switch2" (Juniper) sur le VLAN 1020 :

set vlans cloud_vlan1020 vlan-id 1020

set interfaces xe-0/1/1 description "connected_to_google_edge_device"
set interfaces xe-0/1/1 ether-options 802.3ad ae1

set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 unit 0 description "connected_to_google_edge_device"
set interfaces ae1 unit 0 family ethernet-switching port-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan member cloud_vlan1020

set interfaces xe-0/1/2 description "connected_to_onprem_router"
set interfaces xe-0/1/2 ether-options 802.3ad ae2

set interfaces ae2 unit 0 description "connected_to_onprem_router"
set interfaces ae2 unit 0 family ethernet-switching port-mode trunk
set interfaces ae2 unit 0 family ethernet-switching vlan member cloud_vlan1020

Routeur du VLAN 1020 (Juniper)

Voici un exemple de configuration pour une topologie de couche 2/couche 3 sur site utilisant le routeur "Router2" (Juniper) sur le VLAN 1020 :


set interfaces xe-0/0/0 ether-options 802.3ad ae1
set interfaces xe-0/0/0 description connected_to_onprem_switch

set interfaces ae1 description my-interconnect2
set interfaces ae1 flexible-vlan-tagging
set interfaces ae1 aggregated-ether-options minimum-links 1
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 unit 1020 family inet mtu 1440
set interfaces ae1 unit 1020 vlan-id 1020
set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

set routing-options autonomous-system 64500

set policy-options prefix-list TO_GCP 192.168.12.0/24

set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

set protocols bgp group config_vlan_1020 type external
set protocols bgp group config_vlan_1020 multihop ttl 4
set protocols bgp group config_vlan_1020 local-address 169.254.20.2
set protocols bgp group config_vlan_1020 peer-as 65200
set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1

Bonnes pratiques

Suivez ces bonnes pratiques pour garantir une connectivité efficace à Google Cloud depuis vos appareils sur site dans le cadre des topologies Cloud Interconnect à 99,9 % ou à 99,99 % de disponibilité.

Configurer des appareils pour le transfert actif/actif

  • Assurez-vous que les mêmes valeurs MED sont échangées à l'échelle de toutes les sessions BGP.
  • Activez le routage ECMP (Equal-Cost Multi-Path) dans votre configuration BGP.
  • Activez le redémarrage progressif ou distribuez les rattachements d'interconnexion entre plusieurs routeurs cloud d'une même région. En d'autres termes, assurez-vous que deux routeurs cloud ne seront pas redémarrés en même temps pour les mises à niveau de code.
  • Si vous configurez deux appareils sur site, interconnectez-les via le protocole de routage de votre choix. Si vous configurez votre appareil pour exploiter la redistribution, utilisez IBGP ou IGP.

Configurer des appareils pour le transfert actif/passif

  • Veillez à appliquer des valeurs MED plus élevées du côté du routeur cloud et de l'appareil sur site, afin d'éviter un routage asymétrique.
  • Activez le redémarrage progressif ou répartissez les rattachements entre plusieurs routeurs cloud d'une même région. En d'autres termes, assurez-vous que deux routeurs de cloud ne seront pas redémarrés en même temps pour les mises à niveau de code.
  • Si vous configurez deux appareils sur site, assurez-vous qu'ils disposent d'une connectivité de couche 3 l'un par rapport à l'autre. Si vous configurez votre appareil pour exploiter la redistribution, utilisez IBGP ou IGP.

Étape suivante

Vérifiez le bon fonctionnement de vos sessions BGP entre le réseau sur site et le réseau Google Virtual Private Cloud. Pour en savoir plus, consultez la page Afficher l'état des routeurs et les routes annoncées dans la documentation de Cloud Router.