配置本地路由器

创建 VLAN 连接以后,您需要配置本地路由器以与您的 Cloud Router 路由器建立 BGP 会话。请使用 VLAN 连接提供的 VLAN ID、接口 IP 地址和对等互连 IP 地址来配置本地路由器。

本文档提供了以下示例拓扑和配置,供您在配置本地路由器时参考。

  • 仅限第 3 层拓扑(推荐):终止于本地路由器的专用互连连接(仅限第 3 层拓扑)。该路由器会执行与 Cloud Router 路由器的 BGP 对等互连。这是推荐的配置。
  • 第 2 层/第 3 层拓扑:专用互连连接或终止于连接到本地路由器的本地交换机的连接。该路由器会执行与 Cloud Router 路由器的 BGP 对等互连。

您还可以参阅 VPN 互操作指南中的特定供应商说明部分,查找您可能用于本地路由器的某些第三方平台的值,或者参阅本地路由器文档以查找确切值。

本文档中的示例拓扑使用以下 Google Cloud 资源:

  • 项目 Sample Interconnect Project
  • 网络 my-network
  • 地区 us-east1

示例拓扑中有两个专用互连:my-interconnect1my-interconnect2。这些互连已经过预配,处于 ready to use 状态。

仅限第 3 层拓扑

在此拓扑中,Cloud Interconnect 连接终止于本地路由器,该路由器会执行与 Cloud Router 路由器的 BGP 对等互连。

以下几张图片显示了仅限第 3 层的物理拓扑和逻辑拓扑。

仅限第 3 层的物理拓扑示例(点击可放大)
仅限第 3 层的本地物理拓扑示例(点击可放大)
仅限第 3 层的逻辑拓扑示例(点击可放大)
仅限第 3 层的本地逻辑拓扑示例(点击可放大)

第 2 层/第 3 层拓扑

在此拓扑中,Google Cloud Cloud Interconnect 连接终止于本地交换机,该交换机随后连接到本地路由器。该路由器会执行与 Cloud Router 路由器的 BGP 对等互连。

以下几张图片显示了第 2 层/第 3 层的物理拓扑和逻辑拓扑。

第 2 层/第 3 层物理拓扑示例(点击可放大)
第 2 层/第 3 层物理拓扑示例(点击可放大)
第 2 层/第 3 层逻辑拓扑示例(点击可放大)
第 2 层/第 3 层逻辑拓扑示例(点击可放大)

配置本地设备以进行测试

以下部分介绍如何配置本地设备以测试 Cloud Interconnect。对于第 2 层/第 3 层配置,此示例介绍如何在一个或多个面向 Google Cloud 的开关(而不是路由器)上配置测试接口。

配置准则

在 Google 开始测试新的专用互连连接之前,您必须在没有 VLAN 标记(有时称为访问模式)的情况下配置接口。

用于测试的示例配置

以下示例显示了如何在测试之前配置 Juniper 路由器,并显示了为端口通道 ae0 配置所需的参数。此配置采用以下设置:

  • 在端口通道 ae0 上配置 169.254.0.2 的 BGP IP 地址。
  • 在端口通道 ae0 上配置 LACP。
  • 未在端口通道 ae0 上配置 VLAN 标记。您必须配置没有 VLAN 标记的接口(访问模式)。
  set interfaces xe-0/0/0 description "my-interconnect2"
  set interfaces xe-0/0/0 gigether-options 802.3ad ae0
  set interfaces ae0 description "my-interconnect2"
  set interfaces ae0 aggregated-ether-options lacp active
  set interfaces ae0 aggregated-ether-options minimum-links 1
  set interfaces ae0 unit 0 family inet mtu 1440
  set interfaces ae0 unit 0 family inet address 169.254.0.2

一旦您的 Cloud Interconnect 连接正常,请继续阅读下一部分,了解每个拓扑的示例生产环境配置。

为生产环境配置本地路由器

本部分介绍如何仅配置第 3 层以及第 2 层/第 3 层拓扑以用于生产环境。每个示例配置都介绍了所有设备设置。

如需了解如何配置本地设备以测试 Cloud Interconnect,请参阅用于测试的本地路由器配置

仅适用于第 3 层的生产环境本地路由器设置

根据示例 Google Cloud 项目中的配置,下表总结了用于示例拓扑的本地路由器设置。

如需了解 Google Cloud 端使用的示例项目名称、VPC 网络、区域,请参阅拓扑参考

Hold 计时器和 keepalive 计时器值让 Google 在出现问题时快速将流量传输到冗余连接。请按照下表所示设置计时器值。

在 Cloud Router 路由器维护期间,安全重启可以防止 BGP 会话丢失数据包及撤消路由。如果本地设备支持 BGP 安全重启,请加以启用并设置安全重启计时器和 stalepath 计时器,如下表所示。

如需详细了解 BGP 计时器设置,请参阅 Cloud Router 路由器文档中的 BGP 计时器建议值

设置 my-interconnect1 my-interconnect2
VLAN 编号 1010 1020
VLAN 接口 IP 地址 169.254.10.2/29 169.254.20.2/29
本地 ASN 64500 64500
Cloud Router 路由器 ASN 65200 65200
Cloud Router 路由器 BGP IP 地址 对于 cr1-us-east1:
169.254.10.1
对于 cr2-us-east1:
169.254.20.1
BGP 计时器 Keepalive:20 秒 Keepalive:20 秒
Hold 计时器:60 秒 Hold 计时器:60 秒
安全重启:1 秒 安全重启:1 秒
Stalepath 计时器:300 秒 Stalepath 计时器:300 秒
本地 LAN 子网范围 192.168.12.0/24 192.168.12.0/24

生产环境的配置指南

配置“仅限第 3 层”拓扑时,请遵循以下准则:

  • 即使只有一个端口,面向 Cloud Router 路由器的本地路由器端口(图中的 0/0)也必须是某个端口通道的一部分。
  • 端口通道必须启用 LACP,并且处于主动或被动模式。
  • 路由器接口(图中的 0/0)的最大传输单元 (MTU) 应为 1440 字节。
  • EBGP 邻居必须配置多跃点。建议值为 4

设备配置

VLAN 1010 路由器 (Cisco)

以下清单显示了 VLAN 1010 上本地 Router1 (Cisco) 的“仅限第 3 层”示例配置:

    interface E0/0
      description connected_to_google_edge_device
      channel-group 2 mode active
      no shut

    interface Po2
      description my-interconnect1
      no shut

    interface Po2.1010
      description attachment_vlan1010
      encapsulation dot1Q 1010
      ip address 169.254.10.2 255.255.255.248
      ip mtu 1440

    ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

    route-map TO_GCP_OUTBOUND permit 10
      match ip address prefix-list TO_GCP

    router bgp 64500
      bgp graceful-restart restart-time 1
       neighbor 169.254.10.1 description peering_to_cloud_router
       neighbor 169.254.10.1 remote-as 65200
       neighbor 169.254.10.1 ebgp-multihop 4
       neighbor 169.254.10.1 timers 20 60
       neighbor 169.254.10.1 update-source Po2.1010
       neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
  

VLAN 1020 路由器 (Juniper)

以下清单显示了 VLAN 1020 上本地 Router2 (Juniper) 的“仅限第 3 层”示例配置:

    set interfaces xe-0/0/0 ether-options 802.3ad ae1
    set interfaces xe-0/0/0 description "connected_to_google_edge_device"

    set interfaces ae1 description my-interconnect2
    set interfaces ae1 flexible-vlan-tagging
    set interfaces ae1 aggregated-ether-options minimum-links 1
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 unit 1020 family inet mtu 1440
    set interfaces ae1 unit 1020 vlan-id 1020
    set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

    set routing-options autonomous-system 64500

    set policy-options prefix-list TO_GCP 192.168.12.0/24

    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
    set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

    set protocols bgp group config_vlan_1020 type external
    set protocols bgp group config_vlan_1020 multihop ttl 4
    set protocols bgp group config_vlan_1020 local-address 169.254.20.2
    set protocols bgp group config_vlan_1020 peer-as 65200
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
  

第 2 层/第 3 层的生产环境本地路由器设置

根据示例 Google Cloud 项目中的配置,下表总结了用于示例拓扑的本地路由器设置。

如需了解 Google Cloud 端使用的示例项目名称、VPC 网络、区域,请参阅拓扑参考

Hold 计时器和 keepalive 计时器值让 Google 在出现问题时快速将流量传输到冗余连接。请按照下表所示设置计时器值。

在 Cloud Router 路由器维护期间,安全重启可以防止 BGP 会话丢失数据包及撤消路由。如果本地设备支持 BGP 安全重启,请加以启用并设置安全重启计时器和 stalepath 计时器,如下表所示。

如需详细了解 BGP 计时器设置,请参阅 Cloud Router 路由器文档中的 BGP 计时器建议值

设置 my-interconnect1 my-interconnect2
VLAN 编号 1010 1020
VLAN 接口 IP 地址 169.254.10.2/29 169.254.20.2/29
本地 ASN 64500 64500
Cloud Router 路由器 ASN 65200 65200
Cloud Router 路由器 BGP IP 地址 对于 cr1-us-east1:
169.254.10.1
对于 cr2-us-east1:
169.254.20.1
BGP 计时器 Keepalive:20 秒 Keepalive:20 秒
Hold 计时器:60 秒 Hold 计时器:60 秒
安全重启:1 秒 安全重启:1 秒
Stalepath 计时器:300 秒 Stalepath 计时器:300 秒
本地 LAN 子网范围 192.168.12.0/24 192.168.12.0/24

生产环境的配置指南

在配置第 2 层/第 3 层拓扑时,请确保本地交换机和路由器遵循以下准则:

  • 必须在交换机上配置 VLAN。
  • 面向 Cloud Router 路由器的交换机端口(图中所示的 1/1)必须是某个端口通道的一部分。
    • 端口通道必须启用 LACP,并且处于主动或被动模式。
    • 必须在 802.1Q 中继模式下配置端口通道,并且必须允许互连连接使用的所有 VLAN ID。
    • 端口通道必须启用 802.1Q VLAN 标记。
  • 面向本地路由器的交换机端口(图中所示的 1/2)可以是某个中继端口或访问端口。这包括某个路由器端口专用于单个 VLAN 的情况。
  • 在交换机端启用中继模式时,本地路由器必须支持具有所需封装的子接口(dot1q 标记)。
  • 路由器接口(图中的 0/0)的最大传输单元 (MTU) 应为 1440 字节。
  • EBGP 邻居必须配置多跃点。此设置的建议值为 4

设备配置

VLAN 1010 (Cisco) 交换机

以下清单显示了在 VLAN 1010 上使用 Switch1 (Cisco) 的本地第 2 层/第 3 层拓扑的示例配置:

    vlan 1010
    name cloud_vlan1010

    interface E1/1
      description connected_to_google_edge_device
      Channel-group 1 mode active

    interface port-channel1
      description connected_to_google_edge_device
      Switchport trunk encapsulation dot1q
      Switchport mode trunk
      Switchport trunk allowed vlan 1,1010

    interface E1/2
      description connected_to_onprem_router
      channel-group 2 mode active

    interface port-channel2
      description connected_to_onprem_router
      Switchport trunk encapsulation dot1q
      Switchport mode trunk
      Switchport trunk allowed vlan 1,1010
  

VLAN 1010 (Cisco) 路由器

以下清单显示了在 VLAN 1010 上使用 Router1 (Cisco) 的本地第 2 层/第 3 层拓扑的示例配置:

    interface E0/0
      description connected_to_onprem_switch
      channel-group 2 mode active
      no shut

    interface Po2
      description my-interconnect1
      no shut

    interface Po2.1010
      description attachment_vlan1010
      encapsulation dot1Q 1010
      ip address 169.254.10.2 255.255.255.248
      ip mtu 1440

    ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

    route-map TO_GCP_OUTBOUND permit 10
      match ip address prefix-list TO_GCP

    router bgp 64500
      bgp graceful-restart restart-time 1
      neighbor 169.254.10.1 description peering_to_cloud_router
      neighbor 169.254.10.1 remote-as 65200
      neighbor 169.254.10.1 ebgp-multihop 4
      neighbor 169.254.10.1 timers 20 60
      neighbor 169.254.10.1 update-source Po2.1010
      neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
  

VLAN 1020 (Juniper) 交换机

以下清单显示了在 VLAN 1020 上使用 Switch2 (Juniper) 的本地第 2 层/第 3 层拓扑的示例配置:

set vlans cloud_vlan1020 vlan-id 1020

set interfaces xe-0/1/1 description "connected_to_google_edge_device"
set interfaces xe-0/1/1 ether-options 802.3ad ae1

set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 unit 0 description "connected_to_google_edge_device"
set interfaces ae1 unit 0 family ethernet-switching port-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan member cloud_vlan1020

set interfaces xe-0/1/2 description "connected_to_onprem_router"
set interfaces xe-0/1/2 ether-options 802.3ad ae2

set interfaces ae2 unit 0 description "connected_to_onprem_router"
set interfaces ae2 unit 0 family ethernet-switching port-mode trunk
set interfaces ae2 unit 0 family ethernet-switching vlan member cloud_vlan1020

VLAN 1020 (Juniper) 路由器

以下清单显示了在 VLAN 1020 上使用 Router2 (Juniper) 的本地第 2 层/第 3 层拓扑的示例配置:


set interfaces xe-0/0/0 ether-options 802.3ad ae1
set interfaces xe-0/0/0 description connected_to_onprem_switch

set interfaces ae1 description my-interconnect2
set interfaces ae1 flexible-vlan-tagging
set interfaces ae1 aggregated-ether-options minimum-links 1
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 unit 1020 family inet mtu 1440
set interfaces ae1 unit 1020 vlan-id 1020
set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

set routing-options autonomous-system 64500

set policy-options prefix-list TO_GCP 192.168.12.0/24

set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

set protocols bgp group config_vlan_1020 type external
set protocols bgp group config_vlan_1020 multihop ttl 4
set protocols bgp group config_vlan_1020 local-address 169.254.20.2
set protocols bgp group config_vlan_1020 peer-as 65200
set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1

最佳做法

在使用 Cloud Interconnect 99.9% 和 99.99% 拓扑时,请遵循以下最佳做法以确保从本地设备有效连接到 Google Cloud。

配置“主动/主动”转发设备

  • 确保在所有 BGP 会话之间交换相同的 MED 值。
  • 在 BGP 配置中启用等价多路径 (ECMP) 路由
  • 在同一区域内的多个 Cloud Router 路由器之间启用安全重启或分配互连连接。也就是说,在进行代码升级时,确保两个 Cloud Router 路由器不会同时重启。
  • 如果要配置两个本地设备,请使用任何路由协议将这两个设备互相连接起来。如果要将设备配置为使用重新分配功能,请使用 IBGP 或 IGP。

配置“主动/被动”转发设备

  • 确保在 Cloud Router 路由器端和本地设备端应用较高的 MED 值,以避免出现非对称路由。
  • 在同一区域内的多个 Cloud Router 路由器之间启用安全重启或分配互连连接。也就是说,在进行代码升级时,确保两个 Cloud Router 路由器不会同时重启。
  • 如果要配置两个本地设备,请确保这两个设备之间具有第 3 层连接。如果要将设备配置为使用重新分配功能,请使用 IBGP 或 IGP。

后续步骤

检查您的 BGP 会话是否在本地网络与 Google 虚拟私有云网络之间正常工作。如需了解详情,请参阅 Cloud Router 文档中的查看路由器状态和通告的路由