Afficher les journaux

Ce guide explique comment rechercher des journaux et afficher les entrées de journal en utilisant la visionneuse de journaux.

  • Pour lire des entrées de journal via l'API Stackdriver Logging, consultez la page concernant la méthode entries.list.
  • Pour lire des entrées de journal à l'aide du SDK Google Cloud, consultez la section Lire des entrées de journal.

Avant de commencer

Vous n'avez pas besoin d'un espace de travail pour utiliser la journalisation Stackdriver Logging, sauf si vous envoyez des journaux d'Amazon Web Services (AWS) à Logging.

La visionneuse de journaux affiche les journaux d'un seul projet Google Cloud Platform. Si vous utilisez un espace de travail, Logging ne combine pas les journaux des projets surveillés. Vous devez sélectionner un projet spécifique pour afficher ses journaux.

Si vous utilisez un espace de travail et AWS, sélectionnez le projet de connecteur AWS pour afficher les journaux AWS.

Premiers pas

  1. Accédez à la page Stackdriver Logging > Journaux (Visionneuse de journaux) dans la console GCP :

    Accéder à la page de la visionneuse de journaux

  2. Sélectionnez un projet GCP existant en haut de la page, ou créez un projet.

  3. À l'aide des menus déroulants, sélectionnez la ressource pour laquelle vous souhaitez afficher les journaux.

Si vous ne voyez aucun journal, consultez la section Dépannage ci-dessous.

Interfaces des filtres de la visionneuse de journaux

La visionneuse de journaux comporte deux interfaces de filtrage :

  • L'interface des filtres de journaux de base par défaut permet de sélectionner les journaux à partir des menus et d'effectuer des recherches simples.
  • L'interface des filtres avancés permet d'afficher les entrées de journal à partir de plusieurs journaux et offre une fonctionnalité de recherche plus élaborée.

Pour basculer entre ces interfaces, utilisez la flèche du menu déroulant (▾) située à l'extrême droite de la zone de recherche de filtre dans l'une ou l'autre des interfaces.

La capture d'écran suivante montre la disposition de la visionneuse de journaux avec l'interface de filtre de base. La capture d'écran affiche les entrées de journal d'une application App Engine :

Visionneuse de journaux

L'interface des filtres de journaux de base contient les principaux composants suivants (indiqués par des chiffres rouges dans la capture d'écran ci-dessus), qui se retrouvent pour certains dans l'interface des filtres de journaux avancés :

  1. Les onglets de la fenêtre vous permettent de rester dans les journaux (visionneuse de journaux) ou de choisir d'autres fonctions Stackdriver Logging : Métriques (voir Métriques basées sur les journaux), Exportations (voir Exporter des entrées de journal avec la visionneuse de journaux) et Ingestion de journaux (voir Exclusions de journaux).
  2. La zone de recherche de filtre de l'interface des filtres de journaux de base vous permet de filtrer les entrées de journal par libellé ou texte recherché. Le filtre de base est affiché, et la flèche du menu déroulant (▾) tout à droite vous permet de basculer vers l'interface des filtres avancés ou d'obtenir un lien vers votre filtre.
  3. Le menu de sélection de base permet de choisir les ressources, les journaux et les niveaux de gravité à afficher.
  4. Les menus déroulants du sélecteur de période permettent de filtrer selon des dates et heures spécifiques au sein des journaux.
  5. Le sélecteur de flux, situé en haut de la page, permet de contrôler si les nouvelles entrées de journal s'affichent au fur et à mesure qu'elles arrivent.
  6. La table d'entrées de journal contient les entrées de journal disponibles en fonction des filtres actuellement choisis et des champs personnalisés.
  7. La flèche de développement (▸) située devant chaque entrée de journal permet d'afficher l'ensemble du contenu d'une entrée. Pour plus d'informations, consultez la section Développer les entrées de journal.
  8. Le menu View Options (Options d'affichage), situé tout à droite, comporte d'autres options d'affichage.
  9. Le menu Download logs (Télécharger les journaux), à l'extrême droite, vous permet de télécharger un ensemble d'entrées de journal. Pour plus de détails, voir Télécharger les entrées de journal.
  10. L'option Plus (⋮), affichée avec chaque entrée de journal, vous permet de placer une épingle sur l'entrée de journal, d'afficher l'entrée de journal dans son contexte de ressource et de copier une URL pour l'entrée de journal dans le presse-papiers.

Enfin, la visionneuse de journaux utilise la position du curseur pour mettre en évidence l'entrée de journal associée et pour afficher un symbole de punaise (📌) à côté de l'icône Plus (⋮).

Faire défiler les journaux et les diffuser

Lorsque vous ouvrez la visionneuse de journaux pour la première fois, les entrées de journal récentes sont suffisamment nombreuses pour remplir l'écran. Lorsque vous faites défiler les entrées de journal, la visionneuse de journaux tente d'extraire des entrées supplémentaires. La barre jaune située au-dessus et en dessous des journaux permet de savoir si d'autres entrées de journal sont disponibles.

Les icônes en haut de l'écran permettent de contrôler le moment où les journaux sont actualisés :

  • Cliquez sur l'icône "Actualiser" (refresh) pour récupérer les derniers journaux et ajuster le défilement de l'affichage.
  • Cliquez sur l'icône "Lecture" (play_arrow) pour diffuser les derniers journaux. La diffusion s'arrête lorsqu'une action est effectuée : sélection d'une entrée de journal ou défilement de l'affichage des journaux.
  • Cliquez sur l'icône Pause (pause) pour arrêter la diffusion.

Faire défiler les journaux jusqu'à un moment spécifique

Vous pouvez filtrer les entrées de journal par heure et par date en utilisant les menus du sélecteur de période, sous la zone de recherche de filtre.

Sélecteur de période

La sélection par défaut est Last hour (Dernière heure). Vous pouvez utiliser le menu déroulant pour sélectionner d'autres périodes ou définir une période :

  • Sélectionnez Jump to time (Choisir une heure) pour filtrer les journaux à une date et une heure particulières.
  • Sélectionnez Custom (Personnaliser) pour spécifier une période personnalisée ou un fuseau horaire.

Pour afficher les entrées actuelles du journal, cliquez sur Jump to now (Heure actuelle).

Dans tous les cas, une sélection entraîne l'actualisation de l'affichage de la visionneuse de journaux. Vous pouvez ensuite faire défiler et inspecter les entrées de journal affichées.

Pour réinitialiser la date et l'heure afin qu'elles correspondent à la dernière entrée de journal reçue, cliquez sur l'icône Actualiser ou Lecture.

Modifier le fuseau horaire

Vous pouvez sélectionner un fuseau horaire pour vos entrées de journal :

  1. Dans le menu déroulant Last Hour (Dernière heure), sélectionnez Custom (Personnaliser).
  2. Cliquez sur la flèche de développement (▾) dans l'un des nouveaux menus pour ouvrir un calendrier déroulant.
  3. Dans le volet Time Zone (Fuseau horaire), sélectionnez votre pays et votre fuseau horaire préférés.

Votre sélection entraîne l'affichage de la visionneuse de journaux et la mise à jour du fuseau horaire pour chaque entrée de journal :

Personnaliser le fuseau horaire

Développer les entrées de journal

La table des entrées de journal affiche par défaut une ligne de résumé pour chaque entrée de journal.

Ligne de résumé de l'entrée de journal

La ligne récapitulative d'entrée de journal peut contenir des champs en surbrillance. Par exemple, les champs personnalisés sont mis en évidence.

Les champs inclus dans la ligne de résumé sont sélectionnés en tant que sous-ensembles des champs d'entrée de journal. Certains champs sont affichés par défaut s'ils répondent à un ou plusieurs de ces critères :

  • Le type de l'entrée de journal est connu, par exemple un journal de requêtes App Engine.
  • L'entrée de journal contient le champ httpRequest.
  • L'entrée de journal a une charge utile contenant un champ nommé message.

Pour afficher tous les détails d'une entrée de journal, cliquez sur la flèche de développement (▸) située devant la ligne de résumé. Pour afficher dans une vue structurée tous les détails de toutes les entrées de journal disponibles pour le filtre actuel, cliquez sur le menu View Options (Options d'affichage) situé tout à droite, puis sélectionnez Expand all (Tout développer) :

Menu Options d'affichage

Vous pouvez sélectionner Tout réduire pour réduire les détails des entrées de journal développées.

Lorsque vous développez une ligne de résumé pour une entrée de journal, la visionneuse de journaux affiche une représentation structurée (JSON) :

Entrée de journal de requête structurée

Pour une description des champs d'une entrée de journal, consultez la page relative au type LogEntry.

Ajouter des champs personnalisés

Les champs personnalisés sont des champs dans les entrées de journal dont vous pouvez spécifier qu'ils soient inclus dans la ligne de résumé. Ces champs sont renseignés et mis en surbrillance en bleu chaque fois qu'ils sont disponibles dans vos entrées de journal.

Champs personnalisés dans la ligne de résumé

Il existe deux manières d'ajouter des champs personnalisés aux lignes de résumé de la table d'entrées de journal :

  • Dans une entrée de journal développée, cliquez sur un champ dans la représentation JSON. Dans le panneau affiché, sélectionnez Add field to summary line (Ajouter un champ à la ligne de résumé) :

Ajouter un champ à la ligne de résumé

  • Dans le menu Options d'affichage situé dans l'angle supérieur droit de la visionneuse de journaux, sélectionnez Ajouter des champs personnalisés. Si vous avez des champs personnalisés existants dans ce projet, cette option est Modifier les champs personnalisés. Dans le panneau qui s'affiche, ajoutez la clé JSON souhaitée et cliquez sur Save (Enregistrer). Vous pouvez ajouter plusieurs clés en les séparant par une virgule. Pour réorganiser l'apparence des champs personnalisés dans les lignes de résumé, réorganisez le texte à l'intérieur de ce panneau et cliquez sur Save (Enregistrer).

Ajouter un champ JSON à la ligne de résumé

Il existe deux façons de supprimer des champs personnalisés des lignes de résumé de la table d'entrées de journal :

  • À partir de n'importe quelle ligne de résumé contenant le champ personnalisé que vous souhaitez supprimer, cliquez sur le champ et sélectionnez Supprimer le champ de la ligne de résumé.
  • Dans le menu Options d'affichage situé dans l'angle supérieur droit de la visionneuse de journaux, sélectionnez Modifier les champs personnalisés. Dans le panneau qui s'affiche, effacez les clés JSON que vous souhaitez supprimer et cliquez sur Enregistrer.

Les champs personnalisés sont ajoutés à l'URL actuelle et y resteront tant que vous utiliserez cette URL ou que vous resterez dans la même session de navigateur. Vous ne pouvez pas les définir globalement et ils ne peuvent pas être enregistrés par utilisateur ou par projet GCP.

Les champs par défaut ne peuvent pas être supprimés de la table d'entrées de journal.

Épingler une entrée de journal

Si vous avez identifié une entrée de journal intéressante et souhaitez rechercher des entrées à proximité, vous pouvez placer une épingle sur l'entrée de journal. Une fois l'entrée du journal épinglée, vous pouvez modifier le filtre, et la visionneuse de journaux centre automatiquement la recherche autour de l'entrée épinglée. Épingler une entrée de journal vous permet de l'examiner dans le contexte spécifié par un filtre que vous définissez. Lorsqu'une entrée de journal est épinglée, son arrière-plan est modifié et une épingle est affichée :

Entrée de journal épinglée

Pour épingler une entrée de journal, cliquez sur son épingle ou sur Plus (⋮), puis sélectionnez Épingler cette entrée de journal.

Lorsque vous placez une épingle sur une entrée de journal, cette épingle n'est visible que par vous. Aucun autre utilisateur consultant les mêmes entrées de journal ne verra votre épingle et ne pourra en aucun cas modifier leur affichage.

Épingler une entrée de journal ne modifie ni l'interface, ni les paramètres des filtres et n'actualise pas le contenu affiché. C'est vous qui déterminez les paramètres de filtre et à quel moment actualiser l'affichage de la visionneuse de journaux. Vous pouvez modifier les paramètres de filtre et actualiser l'affichage autant de fois que vous le souhaitez sans affecter les épingles.

Épingler une entrée de journal arrête la diffusion si elle est actuellement activée.

Si une entrée de journal est épinglée, vous pouvez déplacer ou supprimer l'épingle :

  • Pour déplacer l'épingle vers une autre entrée du journal, cliquez sur son icône ou sur Plus (⋮) et sélectionnez Déplacer l'épingle vers cette entrée du journal.

  • Pour supprimer l'épingle d'une entrée du journal, cliquez sur son symbole ou sur Plus (⋮) et sélectionnez Supprimer l'épingle de cette entrée du journal.

Si vous activez la diffusion alors qu'une entrée de journal est épinglée, la visionneuse de journaux supprime l'épingle.

Afficher des journaux similaires

Vous pouvez cliquer sur la valeur d'un champ individuel dans la vue développée des entrées de journal, puis afficher ou masquer toutes les entrées de journal ayant la même valeur :

Afficher les entrées correspondantes

La visionneuse de journaux bascule alors vers l'interface des filtres avancés. Pour modifier la recherche, modifiez le filtre et cliquez sur Envoyer le filtre. Pour en savoir plus, consultez la page relative à l'interface des filtres avancés.

Vous pouvez aussi corréler les entrées de journal des requêtes App Engine, puis les afficher dans une structure imbriquée. Pour plus de détails, consultez la page relative à l'affichage d'entrées de journal de requêtes associées et sélectionnez un langage d'environnement d'exécution.

Afficher les informations de latence

Nouveau : pour les journaux de requêtes App Engine, la visionneuse de journaux fournit un lien vers Stackdriver Trace pour une visualisation aisée des informations de latence de l'entrée de journal.

Pour afficher le menu des options liées à la latence d'une entrée de journal, identifiez le champ protoPayload.latency :

Afficher protoPayload.latency

Cliquez sur la valeur de latence :

Afficher les options de latence

Les deux premières options du menu limitent les entrées de journal affichées à celles avec des latences plus élevées ou plus basses. La dernière option du menu limite les entrées du journal à celles qui contiennent des informations de trace visibles par Stackdriver Trace. Plus précisément, la dernière option limite les entrées du journal à celles pour lesquelles View trace details (Afficher les détails des traces) est activé.

Affichage des informations de latence dans Stackdriver Trace

Pour certains journaux de requêtes App Engine, l'option Afficher les détails des traces est activée. Lorsque cette option est activée, cliquez dessus pour ouvrir Stackdriver Trace et afficher les informations de latence de l'entrée de journal :

Afficher la chronologie de la trace

Afficher dans le contexte de la ressource

Si vous avez identifié une entrée de journal intéressante et souhaitez identifier d'autres entrées de journal associées au même type de ressource, cliquez sur Plus (⋮) à l'extrême droite de la ligne et sélectionnez l'option Show in resource context (Afficher dans le contexte de la ressource) :

Afficher le contexte

En réponse à votre action, la visionneuse de journaux :

  1. épingle l'entrée du journal ;
  2. bascule vers l'interface de filtre avancée et remplace le contenu du filtre par un filtre sur le type de ressource ;
  3. actualise l'affichage. L'entrée du journal épinglée est affichée vers le bas de l'écran.

Affiché dans le contexte

Partager une entrée de journal

Pour partager une entrée de journal, cliquez sur Plus (⋮) et sélectionnez Copier le lien de l'entrée de journal dans le presse-papiers. Ensuite, la visionneuse de journaux génère une URL unique pour l'entrée de journal et la copie dans le presse-papiers.

Sélectionner des journaux

Utilisez les menus et la zone de recherche de filtre pour trouver les journaux à afficher :

  • Sélectionnez un type de ressource et une instance pour lesquels vous souhaitez afficher les journaux. Vous pouvez consulter toutes les instances de ce type de ressource ou sélectionner une instance particulière. Dans la capture d'écran ci-dessus, l'instance de VM G​C​E (c'est-à-dire toutes les instances) est sélectionnée. Pour obtenir la liste des types de ressources, consultez la liste des ressources surveillées.

  • Sélectionnez dans le deuxième menu les journaux nommés que vous souhaitez afficher, ou sélectionnez Tous les journaux. Le menu affiche les journaux utilisés par les instances de ressources sélectionnées.

  • Sélectionnez dans le troisième menu le niveau de gravité le plus bas que vous souhaitez afficher. La sélection de Tous niveaux de journalisation affiche également les entrées de journal dont le niveau de gravité n'est pas indiqué.

  • Sélectionnez dans le quatrième menu la période que vous souhaitez afficher, ou sélectionnez Heure actuelle dans le cinquième menu.

Lorsque vous modifiez les sélections dans les menus, les entrées de journal correspondantes s'affichent.

Remarques sur les menus :

  • Seuls les types de ressources, les instances et les noms de journaux présents dans le projet sont affichés dans les menus. La mise à jour des menus peut prendre un certain temps après l'ajout d'un nouveau type de ressource ou d'une nouvelle instance, ou après une opération d'écriture dans un nouveau journal.

  • Dans l'interface des filtres de journaux de base, vous ne pouvez consulter que les entrées de journal d'un type de ressource à la fois. L'interface des filtres avancés autorise, quant à elle, la consultation de plusieurs types de ressources.

  • Vous ne verrez aucun journal si vous tentez d'accéder à une heure antérieure à la durée de conservation actuelle. Pour plus d'informations, consultez la section Durée de conservation des journaux.

Télécharger les entrées du journal

En quelques clics, vous pouvez télécharger, au format JSON ou CSV, toutes les entrées de journal stockées dans la mémoire de travail de la visionneuse de journaux. Pour des raisons de performances, la visionneuse de journaux tente de charger 100 entrées de journal à la fois et ne conserve pas plus de 300 entrées de journal dans sa mémoire de travail. Ces valeurs ne peuvent pas être configurées.

Pour télécharger des entrées de journal, cliquez sur le menu Download logs (Télécharger les journaux), situé en haut à droite de la visionneuse de journaux. Dans la boîte de dialogue de téléchargement, sélectionnez JSON ou CSV pour le champ Log entry format (Format d'entrée de journal), puis cliquez sur Download (Télécharger) :

Afficher les détails du téléchargement

Pour afficher les entrées de journal au format JSON ou CSV dans une page Web, suivez les mêmes étapes que pour un téléchargement, mais sélectionnez Afficher dans un nouvel onglet.

Effectuer une recherche avec la visionneuse de journaux

Vous pouvez affiner vos recherches en utilisant des filtres dans les interfaces des filtres de base et avancés. L'interface des filtres avancés contient la plupart des fonctionnalités de l'interface des filtres de journaux de base, mais offre des fonctionnalités de recherche plus sophistiquées.

Différences entre les filtres de base et les filtres avancés

La syntaxe de l'interface des filtres de journaux de base est différente de celle de l'interface des filtres avancés. L'interface des filtres de journaux de base est construite avec des hypothèses. Par exemple, toutes les recherches sont non sensibles à la casse et non valides pour l'interface des filtres avancés.

Les sections suivantes mettent en évidence les principales différences de syntaxe entre ces deux interfaces.

Mot clé "texte :"

La visionneuse de journaux affiche les recherches de texte du filtre de base en préfixant le texte avec le libellé text:. N'utilisez pas l'étiquette text: avec des filtres avancés.

Le tableau suivant indique des recherches de texte équivalentes :

Filtre de base de la visionneuse de journaux Filtres de journaux avancés ayant la même fonction
text:"one two" "one two"
text:three three
text:n=5 "n=5" (guillemets obligatoires)

Si vous utilisez accidentellement du texte text: dans le filtre avancé, vous recherchez une correspondance dans un champ appelé text, qui n'existe pas.

Noms des champs

L'interface des filtres de journaux de base comporte des noms de champs intégrés pour certains journaux, y compris le journal de requêtes App Engine. Ces noms de champs n'existent pas dans les filtres avancés.

Le tableau suivant montre une zone de recherche équivalente pour un journal de requêtes App Engine :

Filtre de base Filtre avancé
querystring:var=3 protoPayload.resource:"var=3"
status:400..405 protoPayload.status >= 400 AND protoPayload.status <= 405

Si vous utilisez la variable querystring:var=3 dans le filtre avancé, vous recherchez un champ nommé querystring, qui n'existe pas. Par conséquent, la visionneuse de journaux ne trouve aucune entrée de journal correspondante.

Correspondances de sous-chaînes

Dans l'interface des filtres de journaux de base, toutes les recherches renvoient des correspondances de sous-chaînes non sensibles à la casse, c'est-à-dire que les recherches text:abc ou somefieldname:abc correspondent aux entrées de journal contenant abc, xyabcyx et ABc. Dans les filtres de journaux avancés, vous devez utiliser l'opérateur de recherche de présence (:) pour reproduire le même comportement.

Pour rechercher une correspondance exacte, utilisez l'opérateur de correspondance parfaite (=). La comparaison field=abc exige que field contienne exactement abc, quelle que soit la casse. Cette recherche ne peut pas être effectuée dans l'interface des filtres de journaux de base.

Opérateurs d'intersection et d'union

Dans l'interface des filtres de journaux de base, deux comparaisons utilisant le même nom de champ (ou text:) sont implicitement liées par l'opérateur OR. À l'inverse, les comparaisons utilisant des libellés différents sont liées par l'opérateur AND. Dans les filtres de journaux avancés, toutes les comparaisons sont liées par l'opérateur AND, sauf si l'opérateur OR est spécifié explicitement. Vous pouvez également utiliser des parenthèses pour regrouper les comparaisons. Le tableau suivant présente des recherches équivalentes dans les deux interfaces de filtrage :

Recherche avec filtre de base Recherche avec filtre avancé
text:abc querystring:def text:xyz protoPayload.resource:"def" AND ("abc" OR "xyz")

Performances des recherches

Voici quelques astuces pour améliorer les performances des recherches :

  • Recherchez des valeurs spécifiques de champs indexés, telles que le nom de l'entrée de journal, le type de ressource et les libellés de ressource. Dans l'interface des filtres de journaux de base, vous effectuez cette opération à l'aide des sélections de menus. Dans l'interface des filtres avancés, utilisez les critères suivants :

    resource.type = "gce_instance"
    logName = "projects/[PROJECT_ID]/logs/cloudaudit.googleapis.com%2Factivity"
    resource.labels.module_id="default"
    resource.labels.instance_id="1234567890"
    
  • Préférez les recherches de correspondances exactes aux recherches de sous-chaînes. Les correspondances partielles sont plus lentes, surtout sur les champs d'index. Dans l'interface des filtres de journaux de base, toutes les recherches de texte renvoient des correspondances partielles. Dans l'interface des filtres de journaux avancés, privilégiez les tests utilisant l'opérateur d'égalité (=) plutôt que "has" (contient) (:).

  • Réduisez la période sur laquelle portent vos recherches. Vous ne pouvez pas le faire dans l'interface des filtres de base, contrairement à l'interface des filtres avancés qui vous permet de spécifier une période :

    timestamp >= "2016-11-29T23:00:00Z" AND timestamp <= "2016-11-29T23:30:00Z"
    

Pour plus d'informations sur les performances des recherches, consultez la section Rechercher des entrées de journal rapidement.

Dépannage

Cette section fournit des instructions permettant de résoudre des problèmes courants rencontrés lors d'une interaction ou d'une recherche avec la visionneuse de journaux.

Sélection de projet GCP

Pour sélectionner un projet GCP depuis n'importe quel emplacement dans la console Google Cloud Platform, y compris depuis la visionneuse de journaux, utilisez le sélecteur de projet situé en haut de la page :

Sélecteur de projet de la console GCP

ID du projet GCP

Pour récupérer l'ID du projet GCP depuis n'importe quel emplacement dans la console Google Cloud Platform, y compris depuis la visionneuse de journaux, développez la liste des projets en haut de la page et examinez la colonne ID :

Informations relatives à l'ID du projet de la console GCP

Aucun journal ne s'affiche

Si aucun journal ne s'affiche, vérifiez les éléments suivants :

  • Le bon projet est-il sélectionné en haut de la page ? Si ce n'est pas le cas, sélectionnez un projet à l'aide du menu déroulant en haut de la page. Vous devez sélectionner le projet dont vous voulez voir les journaux.

  • Des activités ont-elles été enregistrées pour votre projet ? Même si le projet est nouveau, des journaux d'activité ou d'audit devraient être présents et confirmer la création du projet. Pour obtenir davantage de journaux, consultez le Démarrage rapide.

  • La période définie est-elle trop restrictive ? Vous pouvez utiliser les menus déroulants sous le champ de filtre de recherche pour sélectionner d'autres périodes ou pour définir une Période personnalisée. Sélectionnez Avancer dans le temps pour filtrer les journaux selon une date et une heure spécifiques, ou utilisez le menu Heure actuelle pour afficher les entrées de journal en cours.

  • La période sélectionnée est-elle incorrecte ? Si vous rédigez un filtre qui inclut un horodatage, vous devez sélectionner l'option Aucune limite dans le sélecteur de période situé sous la zone de recherche de filtre.

Ma recherche ne fonctionne pas

Si vous ne savez pas pourquoi votre recherche ne fonctionne pas dans l'interface des filtres de base, passez brièvement à l'interface des filtres avancés. Pour ce faire, procédez comme suit :

  1. Sélectionnez Convertir en filtre avancé dans le menu "▾" situé à l'extrémité de la zone de recherche de filtre.
  2. Examinez le filtre avancé et vérifiez s'il s'agit de celui que vous souhaitiez utiliser.
  3. Retournez à l'interface des filtres de journaux de base à l'aide du bouton Précédent du navigateur.

D'autres raisons peuvent justifier un affichage incomplet des entrées de journal attendues :

  • Les entrées de journal ayant dépassé la durée de conservation de Stackdriver Logging ne s'affichent pas. Reportez-vous à la section Durée de conservation des journaux pour la période de conservation des journaux en vigueur.

  • Pendant les périodes de charges importantes, on peut observer des retards lors de l'envoi de journaux à Stackdriver Logging, ou lors de leur réception et de leur affichage.

  • La visionneuse de journaux n'affiche pas les entrées de journal présentant des horodatages futurs tant que cette date n'est pas passée. Cette situation inhabituelle est probablement causée par un décalage au niveau de l'application envoyant les journaux.

Étapes suivantes

Cette page vous a-t-elle été utile ? Évaluez-la :

Envoyer des commentaires concernant…

Stackdriver Logging
Besoin d'aide ? Consultez notre page d'assistance.