将您的模板迁移到 Python 3

使用集合让一切井井有条 根据您的偏好保存内容并对其进行分类。

从 2020 年 1 月 1 日起,Python 社区将不再为 Python 2.7 提供更新服务、修复错误或修补安全问题。我们建议您尽快确保您的 Deployment Manager 模板与 Python 3 兼容。

有关受此变化影响的产品的概述,包括有关使用 Google Cloud Python 客户端库的信息,请参阅 Google Cloud 的 Python 支持

迁移 Deployment Manager 模板

Deployment Manager 的语法不使用任何特定于 Python 3 的功能。在大多数情况下,您的模板应该可以在 Python 3 中使用,而无需更改代码。

如果使用帮助程序脚本等模板模块,则必须确保脚本与 Python 3 兼容。

有关将 Python 2 代码移植到 Python 3 的信息,请参阅 Python.org 移植指南。 如果要测试模板是否与 Python 3 兼容,请尝试使用该模板进行测试部署。如果部署成功且没有任何警告,则模板是兼容的,不需要更改。

如果模板包含与 Python 3 不兼容的功能,则在 2020 年 6 月之前,您的部署可以继续正常运行。您可能会看到以下警告之一:

  • 模板与 Python 3 不兼容:模板使用 Python 2 运行,但在 Python 3 中运行失败。该警告会显示 Python 3 错误消息,以便您调试代码。

  • 模板在 Python 3 和 Python 2 中产生了不同的结果:这可能是因为您的部署具有不确定性(例如,它依赖于当前时间或随机数),或者模板可能使用了与 Python 3 不兼容的功能。如果您的模板设计具有不确定性,则无需进行更改。

    如果您的模板使用了与 Python 3 不兼容的功能,请按照 Python 3 移植指南中的准则更新模板。