La compatibilité de Python 2 n'est plus assurée par la communauté. Nous vous recommandons de migrer les applications Python 2 vers Python 3.

Configurer votre environnement de développement

Pour configurer votre environnement de développement sur Python 2, procédez comme suit :

  1. Installez la dernière version de Python 2.

    Pour obtenir la liste des versions compatibles, consultez la page Environnement d'exécution Python 2.

  2. Installez et initialisez le SDK Cloud. Si le SDK Cloud est déjà installé et initialisé, exécutez la commande gcloud components update pour le mettre à jour vers la dernière version.

    Le SDK Cloud vous fournit les outils de ligne de commande gcloud permettant de déployer et de gérer vos applications.

    En le téléchargeant, vous acceptez de respecter les Conditions d'utilisation du SDK Cloud pour App Engine.

    Installer et initialiser le SDK Cloud

  3. Installez le composant gcloud qui inclut l'extension App Engine pour Python 2 :

    Si vous avez utilisé les gestionnaires de packages apt ou yum pour installer le SDK Cloud, utilisez-les également pour installer le composant gcloud.

    Sinon, utilisez la commande suivante :

     gcloud components install app-engine-python
    

Installer les outils facultatifs

  • Installez Git pour accéder au code, aux exemples, aux bibliothèques et aux outils de GitHub.

    Installer Git

  • Installez votre framework ou vos outils préférés. Par exemple, vous pouvez utiliser l'un des frameworks suivants pour développer votre application Python 2 :

  • Exécutez la commande suivante pour installer le composant Extra Libraries pour Python 2, qui comprend les bibliothèques graphy et Django :

      gcloud components install app-engine-python-extras
    

Installer la compatibilité pour appcfg

Si vous avez déjà utilisé le SDK App Engine d'origine et que vous devez continuer à utiliser la commande appcfg obsolète, vous pouvez télécharger et installer le SDK App Engine d'origine en suivant les instructions ci-dessous. Le SDK Cloud n'inclut pas la commande appcfg.