Cette page a été traduite par l'API Cloud Translation.
Switch to English

Migrer entre les versions de Dialogflow

V2beta1 à V2

L'API V2beta1 permet de partager des fonctionnalités bêta avec les utilisateurs de Dialogflow. Cette section contient des conseils pour passer à la version stable de l'API V2.

  • Si vous utilisez REST ou RPC, mettez à jour le point de terminaison de dialogflow.googleapis.com/v2beta1/... vers dialogflow.googleapis.com/v2/....
  • Si vous utilisez une bibliothèque cliente, mettez-la à jour :
    • Langages dynamiques (Python, Node.js, Ruby) : mettez à niveau le package, et votre code utilisera automatiquement la dernière version stable.
    • Langages statiques (Java, C #, PHP, Go) : installez le nouveau package, puis mettez à jour toutes les instructions d'importation de façon qu'elles fassent référence à "v2" au lieu de "v2beta1".
  • Le champ chargé de contrôler si le machine learning (ML) est activé pour un Intent a été modifié. Le champ mlEnabled a été supprimé et remplacé par le champ mlDisabled, et le ML est activé par défaut.
    Version REST RPC Valeur par défaut Comportement par défaut
    V2beta1 mlEnabled ml_enabled true Le ML est activé
    V2 mlDisabled ml_disabled faux Le ML est activé