アプリケーションの移行

このページでは、Cloud Shell エディタで開発しているアプリケーションを VS Code などのローカル IDE に移行する方法について説明します。

インタラクティブなチュートリアル

このクイックスタートをインタラクティブに取り組むには、下のボタンで Cloud Shell チュートリアルを開始してください。

インタラクティブなチュートリアルを開始する

Cloud Shell からローカル IDE へのアプリの移行

アプリケーションを移行するには、次の手順に従います。

  1. IDE の Cloud Code 拡張機能を設定します。

    Cloud Code は VS CodeJetBrains IDE(IntelliJ Ultimate / Community、PyCharm Professional / Community、WebStorm、GoLand)にインストール可能です。

  2. 次に、[File] > [Download] をクリックし、必要なソースコードをダウンロードします。

    ファイル メニューから [ダウンロード] オプションを使用してワークスペースをダウンロードする

    または、アクティビティ バー ソース コントロール アイコン から [Source Control: Git] ビュー経由で、または Cloud Shell ターミナル Cloud Shell のトップメニューバーから利用できる「ターミナルを開く」アイコン を使用して Git コマンド経由で、Git リポジトリにソースコードを commit できます。

  3. Cloud Code ワークスペースをダウンロードした場合は、[File] > [Open Workspace](VS Code)/ [Open](IntelliJ)を使用して、またはソースコードを Git リポジトリに commit した場合は、ローカルの [Source Control: Git] ビューを使用して、ローカル IDE からワークスペースにアクセスできるようになりました。