追加の kubeconfig ファイルの操作

デフォルトでは、Cloud Code プラグインはデフォルトの kubeconfig ファイル(「$HOME/.kube」ディレクトリ内)を使用して Kubernetes リソースを取得し、コマンドを実行します。ただし、追加の kubeconfig ファイルが構成される場合があります。

kubeconfig の管理

kubeconfig を追加または削除するには、IDE 内の Cloud Code 設定に移動します([File] > [Settings] > [Tools] > [Cloud Code] > [Kubernetes]、または Mac OS X の場合は [IntelliJ IDEA]) > [Preferences] > [Tools] > [Cloud Code] > [Kubernetes])。

Cloud Code 設定の [Kubernetes] の [Kubeconfig] セクションを使用して kubeconfig ファイルを追加する。kubeconfig のリストの下には、さらに kubeconfig を追加したり、選択した kubeconfig を削除したりするためのボタンがあります。

Kubernetes リソース ブラウザを使用する

[kubeconfigs] プルダウン メニューをクリックして、使用する kubeconfig を選択すると、リソース ブラウザの現在の kubeconfig が簡単に切り替わります。kubeconfig を選択すると、選択した kubeconfig を使用するようにツール ウィンドウが更新されます。

ヒント: 新しい kubeconfig は [kubeconfig] プルダウン メニューを使用して直接追加できます。

Kubernetes リソース ブラウザの [kubeconfig] プルダウン メニューを展開して、使用可能な kubeconfig を表示します。追加済みの kubeconfig を選択するか、新しい kubeconfig を追加するかを選択できます。

Cloud Code 実行構成の使用

Cloud Code 実行構成は、別の kubeconfig ファイルを使用するように変更できます。kubeconfig を変更するには、変更する実行構成を開き、[Run] > [Advanced settings] で、kubeconfig プルダウン メニューから使用する kubeconfig を選択します。kubeconfig を選択すると、使用可能なコンテキストが選択した kubeconfig にあるコンテキストを反映するように更新されます。

ヒント: プルダウンの右側にある「+」ボタンをクリックすると、実行構成から新しい kubeconfig を直接追加できます。

実行構成で kubeconfig 設定を編集する。追加済みの kubeconfig を選択するためのプルダウンと、新しい kubeconfig を追加するためのボタンが表示されます。

サポートの利用

IntelliJ IDE でフィードバックを送信するか、問題を報告するには、[Tools] > [Cloud Code] > [Help / About] > [Submit feedback or report an issue] を選択します。ここから、GitHub で問題を報告したり、Stack Overflow で質問したりできます。

また、Google Cloud Slack コミュニティの 1 つである、#cloud-code チャンネルにも参加できます。