Anwendung für die flexible App Engine-Umgebung erstellen

App Engine ist eine vollständig verwaltete, serverlose Plattform für die Entwicklung und das Hosting von Webanwendungen in großem Umfang.

In diesem Dokument wird beschrieben, wie Sie mit Cloud Code eine Anwendung für die flexible App Engine-Umgebung erstellen oder ein vorhandenes Projekt importieren können.

Hinweis

  • Installieren und richten Sie JetBrains IDE Version 2019.3+ (IntelliJ Ultimate oder Community) auf dem PATH Ihres Computers ein.
  • Installieren Sie das Cloud Code-Plug-in:

    • Öffnen Sie IntelliJ IDEA oder eine der unterstützten JetBrains-IDEs.
    • Über den Plug-in-Marktplatz (Datei > Einstellungen > Plug-ins oder für Mac OS X, IntelliJ IDEA) > Einstellungen > Plug-ins), suchen Sie nach dem Plug-in "Cloud Code" und installieren Sie es.

    Eventuell werden Sie aufgefordert, die IDE neu zu starten, um das Plug-in zu aktivieren.

Neue Anwendung erstellen

Eine neue Anwendung erstellen Sie mithilfe des Projektassistenten oder indem Sie ein vorhandenes Projekt nach Cloud Source Repositories importieren.

Neuen Projektassistenten verwenden

Um ein neues Projekt zu erstellen, können Sie den IntelliJ New Project-Assistenten verwenden. Hier generieren Sie dann eine Vorlagenanwendung als Ausgangspunkt für Ihre eigene Anwendung.

Erstellen Sie mit folgenden Schritten ein neues Projekt:

  1. Wählen Sie Datei > Neu > Projekt aus, um das Dialogfeld Neues Projekt aufzurufen.

  2. Wählen Sie im linken Bereich Java aus.

  3. Klicken Sie im Bereich Zusätzliche Bibliotheken und Frameworks für Ihre Umgebung auf das Kästchen Google App Engine.

    Grafik: Neues Java-Projekt mit der Option "Google App Engine Flexible" unter "Additional Libraries and Frameworks"

  4. Klicken Sie gegebenenfalls auf das Kästchen Create app.yaml.

  5. Klicken Sie auf Weiter.

  6. Geben Sie einen Projektnamen ein.

  7. Geben Sie einen Projektspeicherort ein, wenn Sie die Standardeinstellung nicht übernehmen möchten.

  8. Aktualisieren Sie die Felder im Bereich More Settings, wenn Sie die Standardeinstellungen nicht übernehmen möchten.

  9. Klicken Sie auf Beenden.

Vorhandenes Projekt auschecken

Sie können in Cloud Source Repositories Ihr vorhandenes Projekt auschecken:

  1. Wählen Sie VCS > Get from Version Control… aus.

  2. Wählen Sie Google Cloud im Drop-down Versionsverwaltung aus und klicken Sie auf Klonen.
  3. Wählen Sie im Dialogfeld Aus Google Cloud klonen das mit Ihrem Projekt verknüpfte Cloud-Projekt aus.
  4. Wählen Sie Ihr Cloud Repository aus.
  5. Wählen Sie das übergeordnete Verzeichnis aus.
  6. Geben Sie den Verzeichnisnamen ein.
  7. Klicken Sie auf Klonen.

Framework-Support hinzufügen

Wenn Sie Ihrer Anwendung noch keinen Framework-Support hinzugefügt haben, werden Sie in IntelliJ IDEA aufgefordert, das Framework zu konfigurieren, nachdem erkannt wurde, dass Sie eine App Engine-Anwendung geöffnet haben.

  1. Klicken Sie mit der rechten Maustaste auf das Projekt.

  2. Wählen Sie Add Framework Support aus.

  3. Klicken Sie das Kästchen App Engine flexible an.

    Alternativ können Sie den App Engine-Framework-Support über das Cloud Code-Menü hinzufügen:

    1. Wählen Sie Tools > Cloud Code > App Engine-Unterstützung hinzufügen > Flexible Google App Engine aus.

    2. Wählen Sie das Modul aus, dem Sie den Framework-Support hinzufügen möchten.

    3. Klicken Sie auf OK.

  4. Klicken Sie gegebenenfalls auf das Kästchen Create app.yaml.

  5. Klicken Sie auf OK.

Nächste Schritte

Nachdem Sie nun eine Anwendung erstellt haben, können Sie sie in der flexiblen App Engine-Umgebung bereitstellen.

Support

Wenn Sie Feedback geben oder ein Problem in Ihrer IntelliJ-IDE melden möchten, gehen Sie zu Tools > Cloud Code > Help / About > . Senden Sie Feedback oder melden Sie ein Problem, um ein Problem auf GitHub zu melden, oder stellen Sie eine Frage in Stack Overflow.

Sie können auch dem Kanal #cloud-code beitreten, der Teil der Google Cloud-Slack-Community ist.