Como configurar roteadores locais

Depois de criar um anexo de VLAN, você precisa configurar seu roteador local para estabelecer uma sessão de BGP com o Cloud Router. Use o código da VLAN, o endereço IP da interface e o endereço IP do peering fornecidos pelo anexo da VLAN para configurar o roteador local.

Este documento fornece as seguintes topologias de exemplo e configurações que você pode usar como um guia ao configurar seu roteador local.

  • Topologia somente da camada 3 (recomendada): uma conexão ou conexões de Interconexão dedicada que terminam em um roteador local (somente topologia da camada 3). O roteador realiza o peering do BGP com o Cloud Router. Essa é a configuração recomendada.
  • Topologia Layer2/Layer3: uma conexão ou conexões de Interconexão dedicada que terminam em um switch local conectado a um roteador local. O roteador realiza o peering do BGP com o Cloud Router.

Confira também a seção Observações específicas do fornecedor no Guia de interoperabilidade da VPN para ver os valores de algumas plataformas de terceiros que podem ser usadas no roteador local. Se preferir, consulte a documentação do roteador local para acessar os valores definitivos.

Nas topologias de amostra deste documento, são usados os recursos do Google Cloud a seguir:

  • O projeto Sample Interconnect Project
  • A rede my-network
  • A região us-east1

Há duas Interconexões dedicadas, my-interconnect1 e my-interconnect2. Essas interconexões já estão provisionadas e têm o status ready to use.

Topologia somente de camada 3

Nessa topologia, a conexão ou as conexões do Cloud Interconnect são encerradas em um roteador local, que realiza o peering do BGP com o Cloud Router.

Veja nos diagramas a seguir a topologia física e lógica somente de camada 3.

Topologia física de amostra, somente da Camada 3 (clique para ampliar)
Amostra de topologia física local somente de camada 3 (clique para ampliar)
Amostra de topologia lógica somente de camada 3 (clique para ampliar)
Amostra de topologia lógica local somente de camada 3 (clique para ampliar)

Topologia de camada 2/camada 3

Nessa topologia, as conexões do Cloud Interconnect do Google Cloud terminam em um switch local, que se conecta a um roteador local. O roteador executa o peering de BGP com o Cloud Router.

Os diagramas a seguir mostram a topologia física e lógica da camada 2/camada 3.

Topologia física de amostra da Camada 2/Camada 3 (clique para ampliar)
Amostra de topologia física de camada 2/camada 3 (clique para ampliar)
Amostra de topologia lógica de camada 2/camada 3 (clique para ampliar)
Amostra de topologia física de camada 2/camada 3 (clique para ampliar)

Como configurar dispositivos locais para testes

A seção a seguir descreve como configurar dispositivos locais para testar o Cloud Interconnect. Para uma configuração L2/L3, este exemplo descreve a configuração da interface de teste em um ou mais interruptores voltados para o Google Cloud, mas não nos roteadores.

Diretrizes de configuração

Antes de o Google começar a testar sua nova Interconexão dedicada, você precisa configurar suas interfaces sem tags da VLAN, que às vezes são chamadas de modo de acesso.

Um exemplo de configuração para teste

No exemplo a seguir, mostramos como configurar um roteador Juniper antes dos testes, mostrando os parâmetros necessários para configurar o canal de porta ae0. Essa configuração usa os seguintes ajustes:

  • Um endereço IP do BGP de 169.254.0.2 configurado no canal de porta ae0.
  • O LACP configurado no canal de porta ae0.
  • A codificação da VLAN não configurada no canal da porta ae0. Configure suas interfaces sem a inclusão de tag VLAN (modo de acesso).
  set interfaces xe-0/0/0 description "my-interconnect2"
  set interfaces xe-0/0/0 gigether-options 802.3ad ae0
  set interfaces ae0 description "my-interconnect2"
  set interfaces ae0 aggregated-ether-options lacp active
  set interfaces ae0 aggregated-ether-options minimum-links 1
  set interfaces ae0 unit 0 family inet mtu 1440
  set interfaces ae0 unit 0 family inet address 169.254.0.2

Quando a conexão do Cloud Interconnect estiver funcionando, vá para a próxima seção e veja um exemplo de configuração de produção para cada topologia.

Como configurar roteadores locais para produção

Esta seção descreve como configurar somente as topologias da camada 3 e da camada 2/camada 3 para uso em produção. Cada configuração de amostra descreve todas as configurações do dispositivo.

Para informações sobre como configurar dispositivos locais para testar o Cloud Interconnect, consulte Como configurar roteadores locais para testes.

Configurações do roteador local de produção somente para a camada 3

Com base na configuração da amostra do projeto do Google Cloud, veja na tabela a seguir um resumo das definições do roteador local a serem usadas nas topologias de exemplo.

Consulte a Referência de topologia para acessar a região, rede VPC e nome de projeto de amostra usados no lado do Google Cloud.

Os valores de tempo de espera e sinal de atividade permitem que o Google transfira rapidamente o tráfego para conexões redundantes no caso de um problema. Defina seus valores conforme mostrado na tabela.

O Graceful Restart impede que as sessões do BGP caiam e que as rotas sejam abandonadas durante a manutenção do Cloud Router. Se seu dispositivo local oferecer suporte ao Graceful Restart do BGP, ative-o e defina os tempos de Graceful Restart e Stalepath conforme mostrado na tabela.

Para mais informações sobre as configurações de tempo do BGP, consulte os valores recomendados para tempos do BGP na documentação do Cloud Router.

Configurações my-interconnect1 my-interconnect2
Número de VLAN 1010 1020
Endereço IP da interface de VLAN 169.254.10.2/29 169.254.20.2/29
ASN local 64500 64500
ASN do Cloud Router 65200 65200
Endereço IP do BGP do Cloud Router Para cr1-us-east1:
169.254.10.1
Para cr2-us-east1:
169.254.20.1
Temporizadores do BGP Sinal de atividade: 20 seg Sinal de atividade: 20 seg
Tempo de espera: 60 seg Tempo de espera: 60 seg
Graceful Restart: 1 seg Graceful Restart: 1 seg
Tempo de Stalepath: 300 seg Tempo de Stalepath: 300 seg
Intervalo de sub-rede LAN local 192.168.12.0/24 192.168.12.0/24

Diretrizes de configuração para produção

Siga as diretrizes a seguir ao configurar a topologia somente de camada 3:

  • A porta do roteador local (0/0 no diagrama) ou as portas voltadas para o Cloud Router precisam fazer parte de um canal da porta, mesmo que haja apenas uma porta.
  • O canal da porta precisa ter o LACP ativado, no modo ativo ou passivo.
  • A Maximum Transmission Unit (MTU) da interface do roteador (0/0 no diagrama) precisa ter 1.440 bytes.
  • O vizinho EBGP precisa ter o multihop configurado. O valor recomendado é 4.

Configuração do dispositivo

Roteador VLAN 1010 (Cisco)

A listagem a seguir mostra uma configuração de amostra somente da Camada 3 para o `Router1` local (Cisco) na VLAN 1010:

    interface E0/0
      description connected_to_google_edge_device
      channel-group 2 mode active
      no shut

    interface Po2
      description my-interconnect1
      no shut

    interface Po2.1010
      description attachment_vlan1010
      encapsulation dot1Q 1010
      ip address 169.254.10.2 255.255.255.248
      ip mtu 1440

    ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

    route-map TO_GCP_OUTBOUND permit 10
      match ip address prefix-list TO_GCP

    router bgp 64500
      bgp graceful-restart restart-time 1
       neighbor 169.254.10.1 description peering_to_cloud_router
       neighbor 169.254.10.1 remote-as 65200
       neighbor 169.254.10.1 ebgp-multihop 4
       neighbor 169.254.10.1 timers 20 60
       neighbor 169.254.10.1 update-source Po2.1010
       neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
  

Roteador VLAN 1020 (Juniper)

A listagem a seguir mostra uma configuração de amostra somente da Camada 3 para o `Router2` (Juniper) local na VLAN 1020:

    set interfaces xe-0/0/0 ether-options 802.3ad ae1
    set interfaces xe-0/0/0 description "connected_to_google_edge_device"

    set interfaces ae1 description my-interconnect2
    set interfaces ae1 flexible-vlan-tagging
    set interfaces ae1 aggregated-ether-options minimum-links 1
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 unit 1020 family inet mtu 1440
    set interfaces ae1 unit 1020 vlan-id 1020
    set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

    set routing-options autonomous-system 64500

    set policy-options prefix-list TO_GCP 192.168.12.0/24

    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
    set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

    set protocols bgp group config_vlan_1020 type external
    set protocols bgp group config_vlan_1020 multihop ttl 4
    set protocols bgp group config_vlan_1020 local-address 169.254.20.2
    set protocols bgp group config_vlan_1020 peer-as 65200
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
  

Configurações do roteador local de produção para a camada 2/camada 3

Com base na configuração da amostra do projeto do Google Cloud, veja na tabela a seguir um resumo das definições do roteador local a serem usadas nas topologias de exemplo.

Consulte a Referência de topologia para acessar a região, rede VPC e nome de projeto de amostra usados no lado do Google Cloud.

Os valores de tempo de espera e sinal de atividade permitem que o Google transfira rapidamente o tráfego para conexões redundantes no caso de um problema. Defina seus valores conforme mostrado na tabela.

O Graceful Restart impede que as sessões do BGP caiam e que as rotas sejam abandonadas durante a manutenção do Cloud Router. Se seu dispositivo local oferecer suporte ao Graceful Restart do BGP, ative-o e defina os tempos de Graceful Restart e Stalepath conforme mostrado na tabela.

Para mais informações sobre as configurações de tempo do BGP, consulte os valores recomendados para tempos do BGP na documentação do Cloud Router.

Configurações my-interconnect1 my-interconnect2
Número de VLAN 1010 1020
Endereço IP da interface de VLAN 169.254.10.2/29 169.254.20.2/29
ASN local 64500 64500
ASN do Cloud Router 65200 65200
Endereço IP do BGP do Cloud Router Para cr1-us-east1:
169.254.10.1
Para cr2-us-east1:
169.254.20.1
Temporizadores do BGP Sinal de atividade: 20 seg Sinal de atividade: 20 seg
Tempo de espera: 60 seg Tempo de espera: 60 seg
Graceful Restart: 1 seg Graceful Restart: 1 seg
Tempo de Stalepath: 300 seg Tempo de Stalepath: 300 seg
Intervalo de sub-rede LAN local 192.168.12.0/24 192.168.12.0/24

Diretrizes de configuração para produção

Use as seguintes diretrizes para sua chave local e roteadores ao configurar a topologia da Camada 2/Camada 3:

  • As VLANs precisam ser configuradas na chave.
  • A porta da chave (1/1, como mostrado no diagrama) ou as portas voltadas para o Cloud Router precisam fazer parte de um canal da porta.
  • O canal de portas precisa ter o LACP ativado no modo ativo ou passivo.
  • O canal de porta precisa ser configurado no modo tronco 802.1Q, e todos os códigos da VLAN usados pela conexão do Interconnect precisam ser permitidos.
  • O canal da porta precisa ter a inclusão de tag de VLAN 802.1Q ativada.
  • A porta da chave (1/2, como mostrado no diagrama) voltada para o roteador local pode ser uma porta de tronco ou de acesso. Isso abrange o caso em que uma porta do roteador é dedicada a uma única VLAN.
  • Ao ativar o modo de tronco no lado da chave, o roteador local precisa oferecer suporte a subinterfaces com o encapsulamento necessário (tags dot1q).
  • A Maximum Transmission Unit (MTU) da interface do roteador (0/0 no diagrama) precisa ter 1.440 bytes.
  • O vizinho EBGP precisa ter o multihop configurado. O valor recomendado para essa configuração é 4.
  • Configuração do dispositivo

    Switch VLAN 1010 (Cisco)

    A listagem a seguir mostra uma configuração de amostra para uma topologia de camada 2/camada 3 local usando `Switch1` (Cisco) na VLAN 1010:

        vlan 1010
        name cloud_vlan1010
    
        interface E1/1
          description connected_to_google_edge_device
          Channel-group 1 mode active
    
        interface port-channel1
          description connected_to_google_edge_device
          Switchport trunk encapsulation dot1q
          Switchport mode trunk
          Switchport trunk allowed vlan 1,1010
    
        interface E1/2
          description connected_to_onprem_router
          channel-group 2 mode active
    
        interface port-channel2
          description connected_to_onprem_router
          Switchport trunk encapsulation dot1q
          Switchport mode trunk
          Switchport trunk allowed vlan 1,1010
      

    Roteador VLAN 1010 (Cisco)

    A listagem a seguir mostra uma configuração de amostra para uma topologia de camada 2/camada 3 local usando `Router1` (Cisco) na VLAN 1010:

        interface E0/0
          description connected_to_onprem_switch
          channel-group 2 mode active
          no shut
    
        interface Po2
          description my-interconnect1
          no shut
    
        interface Po2.1010
          description attachment_vlan1010
          encapsulation dot1Q 1010
          ip address 169.254.10.2 255.255.255.248
          ip mtu 1440
    
        ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24
    
        route-map TO_GCP_OUTBOUND permit 10
          match ip address prefix-list TO_GCP
    
        router bgp 64500
          bgp graceful-restart restart-time 1
          neighbor 169.254.10.1 description peering_to_cloud_router
          neighbor 169.254.10.1 remote-as 65200
          neighbor 169.254.10.1 ebgp-multihop 4
          neighbor 169.254.10.1 timers 20 60
          neighbor 169.254.10.1 update-source Po2.1010
          neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
      

    Switch VLAN 1020 (Juniper)

    A listagem a seguir mostra uma configuração de amostra para uma topologia de camada 2/camada 3 local usando `Switch2` (Juniper) na VLAN 1020:

    set vlans cloud_vlan1020 vlan-id 1020
    
    set interfaces xe-0/1/1 description "connected_to_google_edge_device"
    set interfaces xe-0/1/1 ether-options 802.3ad ae1
    
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 unit 0 description "connected_to_google_edge_device"
    set interfaces ae1 unit 0 family ethernet-switching port-mode trunk
    set interfaces ae1 unit 0 family ethernet-switching vlan member cloud_vlan1020
    
    set interfaces xe-0/1/2 description "connected_to_onprem_router"
    set interfaces xe-0/1/2 ether-options 802.3ad ae2
    
    set interfaces ae2 unit 0 description "connected_to_onprem_router"
    set interfaces ae2 unit 0 family ethernet-switching port-mode trunk
    set interfaces ae2 unit 0 family ethernet-switching vlan member cloud_vlan1020
    

    Roteador VLAN 1020 (Juniper)

    A listagem a seguir mostra uma configuração de amostra para uma topologia de camada 2/camada 3 local usando `Router2` (Juniper) na VLAN 1020:

    
    set interfaces xe-0/0/0 ether-options 802.3ad ae1
    set interfaces xe-0/0/0 description connected_to_onprem_switch
    
    set interfaces ae1 description my-interconnect2
    set interfaces ae1 flexible-vlan-tagging
    set interfaces ae1 aggregated-ether-options minimum-links 1
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 unit 1020 family inet mtu 1440
    set interfaces ae1 unit 1020 vlan-id 1020
    set interfaces ae1 unit 1020 family inet address 169.254.20.2/29
    
    set routing-options autonomous-system 64500
    
    set policy-options prefix-list TO_GCP 192.168.12.0/24
    
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
    set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
    set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject
    
    set protocols bgp group config_vlan_1020 type external
    set protocols bgp group config_vlan_1020 multihop ttl 4
    set protocols bgp group config_vlan_1020 local-address 169.254.20.2
    set protocols bgp group config_vlan_1020 peer-as 65200
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
    set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
    

    Práticas recomendadas

    Siga estas práticas recomendadas para garantir uma conectividade eficaz com o Google Cloud em dispositivos locais ao usar topologias de 99,9% e 99,99% do Cloud Interconnect.

    Como configurar dispositivos para encaminhamento ativo/ativo

    • Certifique-se de que os mesmos valores MED sejam trocados entre todas as sessões do BGP.
    • Ative o roteamento por caminhos múltiplos e custo igual (ECMP, na sigla em inglês) na configuração do BGP.
    • Ative o Graceful Restart ou distribua anexos de interconexão entre vários Cloud Routers na mesma região. Ou seja, verifique se não há dois Cloud Routers reiniciados ao mesmo tempo para upgrades de código.
    • Se você estiver configurando dois dispositivos locais, conecte os dois dispositivos usando qualquer protocolo de roteamento. Se estiver configurando o dispositivo para usar a redistribuição, use o IBGP ou o IGP.

    Como configurar dispositivos para encaminhamento ativo/passivo

    • Certifique-se de que valores MED mais altos sejam aplicados no lado do Cloud Router e no lado do dispositivo local para evitar roteamento assimétrico.
    • Ative o Graceful Restart ou distribua anexos de interconexão entre vários Cloud Routers na mesma região. Ou seja, verifique se não há dois Cloud Routers reiniciados ao mesmo tempo para upgrades de código.
    • Se você estiver configurando dois dispositivos locais, certifique-se de que ambos tenham a conectividade de Camada 3 entre si. Se estiver configurando o dispositivo para usar a redistribuição, use o IBGP ou o IGP.

    A seguir

    Verifique se as sessões do BGP estão funcionando entre sua rede local e sua rede da Nuvem Privada Virtual do Google. Para mais informações, consulte Como ver o status do roteador e as rotas anunciadas na documentação do Cloud Router.