Configura routers locales

En este documento, se describe cómo configurar routers locales para la interconexión dedicada. Si quieres crear una conexión de interconexión de socio, consulta Configura routers locales para la interconexión de socio.

Después de crear un adjunto de VLAN, debes configurar tu router local para establecer una sesión de BGP con tu Cloud Router. Para configurar tu router local, usa el ID de VLAN, la dirección IP de la interfaz y la dirección IP de intercambio de tráfico que proporcionó el adjunto de VLAN.

Para obtener las definiciones de los términos que se usan en esta página, consulta los términos clave de Cloud Interconnect.

Para ayudarte a resolver problemas comunes que podrías encontrar cuando uses interconexiones dedicadas, consulta Solución de problemas.

Usa topologías de muestra

En este documento, se proporcionan las topologías y configuraciones de muestra siguientes, que puedes usar como guía para configurar tu router local:

  • Topología de capa 3 únicamente (recomendado): una o varias conexiones de interconexión dedicada que terminan en un router local. El router realiza el intercambio de tráfico de BGP con Cloud Router.
  • Topología de capa 2 o capa 3: una o varias interconexiones dedicadas que terminan en un interruptor local conectado a un router local. El router realiza el intercambio de tráfico de BGP con Cloud Router.

Para conocer los valores de las plataformas de terceros que podrías usar para tu router local, consulta las notas específicas del proveedor. Para obtener valores definidos, consulta la documentación de tu router local.

Las topologías de muestra de este documento usan los siguientes recursos de Google Cloud:

  • El proyecto Sample Interconnect Project
  • La red my-network
  • La región us-east1

Hay dos conexiones de interconexión dedicada, my-interconnect1 y my-interconnect2. Estas conexiones ya están aprovisionadas y tienen un estado de ready to use.

Topología de capa 3 únicamente.

En esta topología, las conexiones de Interconnect finalizan en un router local, que realiza el intercambio de tráfico de BGP con Cloud Router.

En los diagramas siguientes, se muestra la topología física y lógica de capa 3 únicamente.

Topología física de muestra de capa 3 únicamente (haz clic para ampliar).
Topología física local de muestra de capa 3 únicamente (haz clic para ampliar)



Topología lógica de muestra de capa 3 únicamente (haz clic para ampliar).
Topología lógica local de muestra de capa 3 únicamente (haz clic para ampliar)

Topología de capa 2 o capa 3

En esta topología, las conexiones de Interconnect terminan en un interruptor local, que luego se conecta a un router local. El router realiza el intercambio de tráfico de BGP con Cloud Router.

En los diagramas siguientes, se muestra la topología física y lógica de capa 2 o capa 3.

Topología física de muestra de capa 2 o capa 3 (haz clic para ampliar).
Topología física de muestra de capa 2 o capa 3 (haz clic para ampliar)



Topología lógica de muestra de capa 2 o capa 3 (haz clic para ampliar).
Topología lógica de muestra de capa 2 o capa 3 (haz clic para ampliar)

Configura dispositivos locales para realizar pruebas

En la siguiente sección, se describe cómo configurar dispositivos locales para probar tu conexión de Interconnect. En este ejemplo, para una configuración de capa 2 o 3, se describe cómo configurar la interfaz de prueba en uno o más interruptores orientados a Google Cloud, pero no en los routers.

Antes de que Google comience a probar tu nueva conexión de interconexión dedicada, configura tus interfaces sin el etiquetado de VLAN, que a veces se denomina modo de acceso.

Configuración de muestra para pruebas

En el siguiente ejemplo, se muestra cómo configurar un router Juniper antes de realizar la prueba y se muestran los parámetros necesarios para configurar el canal del puerto ae0. En este ejemplo se usa la siguiente configuración:

  • Se configura una dirección IP de BGP de 169.254.0.2 en el canal del puerto ae0.
  • Se configura LACP en el canal del puerto ae0.
  • El etiquetado de VLAN no se configura en el canal del puerto ae0. Debes configurar tus interfaces sin el etiquetado de VLAN (modo de acceso).
  • Una MTU de 1440 bytes. Sin embargo, puedes usar una MTU de 1,500 bytes si ajustas la configuración de la interfaz del router según corresponda, y si la MTU del adjunto y la MTU de la red de VPC conectada también son de 1,500 bytes.

    set interfaces xe-0/0/0 description "my-interconnect2"
    set interfaces xe-0/0/0 gigether-options 802.3ad ae0
    set interfaces ae0 description "my-interconnect2"
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 aggregated-ether-options minimum-links 1
    set interfaces ae0 unit 0 family inet mtu 1440
    set interfaces ae0 unit 0 family inet address 169.254.0.2
    

Cuando tu conexión de Interconnect esté en funcionamiento, continúa con la siguiente sección a fin de ver una configuración de producción de muestra para cada topología.

Configura routers locales para la producción

En esta sección, se describe cómo configurar la topología de capa 3 únicamente y la topología de capa 2 o capa 3 para el uso de producción. En cada configuración de muestra, se describen todos los ajustes del dispositivo.

Si deseas obtener información sobre cómo configurar dispositivos locales para probar tu conexión de Interconnect, consulta Configura routers locales para pruebas.

Configuración del router local en producción para ambas topologías

En función de la configuración del proyecto de Google Cloud de muestra, en la siguiente tabla, se resume la configuración del router local que se usará para las topologías de ejemplo.

Para obtener el nombre del proyecto de muestra, la red de VPC y la región que se usan en Google Cloud, consulta la referencia de topología.

Los valores de temporizador de suspensión y temporizador keepalive permiten a Google transferir con rapidez el tráfico a conexiones redundantes en caso de que ocurra un problema. Establece sus valores como se muestra en la tabla.

El reinicio ordenado evita la pérdida de paquetes y el retiro de rutas en las sesiones BGP durante el mantenimiento de Cloud Router. Si tu dispositivo local admite el reinicio ordenado de BGP, habilítalo y configura el reinicio ordenado y los temporizadores de inactividad como se muestra en la tabla.

Para obtener más información sobre la configuración del temporizador de BGP, consulta los valores recomendados para los temporizadores de BGP en la documentación de Cloud Router.

Configuración my-interconnect1 my-interconnect2
Número de VLAN 1010 1020
Dirección IP de la interfaz de VLAN 169.254.10.2/29 169.254.20.2/29
ASN local 64500 64500
ASN de Cloud Router 65200 65200
Dirección IP de BGP de Cloud Router Para la interfaz cr-us-east1 0:
169.254.10.1
Para la interfaz cr-us-east1 1:
169.254.20.1
Temporizadores de BGP Keepalive: 20 s Keepalive: 20 s
Temporizador de suspensión: 60 s Temporizador de suspensión: 60 s
Reinicio ordenado: configura el temporizador de reinicio ordenado en un valor adecuado para tus necesidades. Para obtener más información, consulta Configuración del temporizador de BGP. Reinicio ordenado: configura el temporizador de reinicio ordenado en un valor adecuado para tus necesidades.
Temporizador de inactividad: 300 s Temporizador de inactividad: 300 s
Rango de subred LAN local 192.168.12.0/24 192.168.12.0/24

Configura la topología de capa 3 únicamente para producción

Usa las pautas siguientes para configurar la topología de solo capa 3:

  • El puerto del router local (0/0 en el diagrama) o los puertos orientados hacia Cloud Router deben ser parte de un canal de puerto, incluso si solo hay un puerto.
  • El canal de puerto debe tener LACP habilitado, en modo activo o pasivo.
  • La unidad de transmisión máxima (MTU) de la interfaz del router (0/0 en el diagrama) debe ser de 1,440 o 1,500 bytes, según la MTU del adjunto y la MTU de la red de VPC conectada.
  • El vecino de EBGP debe tener configurado el salto múltiple. El valor recomendado para esta configuración es 4.

Configuración del dispositivo

Router de VLAN 1010 (Cisco)

En la siguiente lista, se muestra una configuración de muestra de capa 3 únicamente para el Router1 local (Cisco) en VLAN 1010:

        interface E0/0
          description connected_to_google_edge_device
          channel-group 2 mode active
          no shut

        interface Po2
          description my-interconnect1
          no shut

        interface Po2.1010
          description attachment_vlan1010
          encapsulation dot1Q 1010
          ip address 169.254.10.2 255.255.255.248
          ip mtu 1440

        ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

        route-map TO_GCP_OUTBOUND permit 10
          match ip address prefix-list TO_GCP

        router bgp 64500
          bgp graceful-restart restart-time 1
           neighbor 169.254.10.1 description peering_to_cloud_router
           neighbor 169.254.10.1 remote-as 65200
           neighbor 169.254.10.1 ebgp-multihop 4
           neighbor 169.254.10.1 timers 20 60
           neighbor 169.254.10.1 update-source Po2.1010
           neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
      

Router de VLAN 1020 (Juniper)

En la siguiente lista, se muestra una configuración de muestra de capa 3 únicamente para el Router2 local (Juniper) en VLAN 1020:

        set interfaces xe-0/0/0 ether-options 802.3ad ae1
        set interfaces xe-0/0/0 description "connected_to_google_edge_device"

        set interfaces ae1 description my-interconnect2
        set interfaces ae1 flexible-vlan-tagging
        set interfaces ae1 aggregated-ether-options minimum-links 1
        set interfaces ae1 aggregated-ether-options lacp active
        set interfaces ae1 unit 1020 family inet mtu 1440
        set interfaces ae1 unit 1020 vlan-id 1020
        set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

        set routing-options autonomous-system 64500

        set policy-options prefix-list TO_GCP 192.168.12.0/24

        set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
        set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
        set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
        set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

        set protocols bgp group config_vlan_1020 type external
        set protocols bgp group config_vlan_1020 multihop ttl 4
        set protocols bgp group config_vlan_1020 local-address 169.254.20.2
        set protocols bgp group config_vlan_1020 peer-as 65200
        set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
        set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
      

Configura la topología de capa 2 o capa 3 para producción

Usa las pautas siguientes para configurar la topología de capa 2 o capa 3 en tu interruptor y en tus routers locales:

  • Las VLAN deben configurarse en el interruptor.
  • El puerto del interruptor (1/1 como se muestra en el diagrama) o los puertos orientados hacia Cloud Router deben ser parte de un canal de puerto.
    • El canal del puerto debe tener LACP habilitado, en modo activo o pasivo.
    • El canal del puerto se debe configurar en modo troncal 802.1Q y se deben permitir todos los ID de VLAN que usa la conexión de Interconnect.
    • El canal del puerto debe tener habilitado el etiquetado VLAN 802.1Q.
  • El puerto del interruptor (1/2 como se muestra en el diagrama) orientado hacia el router local puede ser un puerto troncal o un puerto de acceso. Esto incluye el caso en el que un puerto de router está dedicado a una sola VLAN.
  • Cuando se habilita el modo troncal en el lado del interruptor, el router local debe admitir subinterfaces con el encapsulamiento necesario (etiquetas dot1q).
  • Esta configuración utiliza una MTU de 1,440 bytes. Sin embargo, puedes usar una MTU de 1,500 bytes si ajustas la configuración de la interfaz del router según corresponda, y si la MTU del adjunto y la MTU de la red de VPC conectada también son de 1,500 bytes.
  • El vecino de EBGP debe tener configurado el salto múltiple. El valor recomendado para esta configuración es 4.

Configuración del dispositivo

Interruptor de VLAN 1010 (Cisco)

En la siguiente lista, se muestra una configuración de muestra de capa 2 o capa 3 para el Switch1 local (Cisco) en VLAN 1010:

          vlan 1010
          name cloud_vlan1010

          interface E1/1
            description connected_to_google_edge_device
            Channel-group 1 mode active

          interface port-channel1
            description connected_to_google_edge_device
            Switchport trunk encapsulation dot1q
            Switchport mode trunk
            Switchport trunk allowed vlan 1,1010

          interface E1/2
            description connected_to_onprem_router
            channel-group 2 mode active

          interface port-channel2
            description connected_to_onprem_router
            Switchport trunk encapsulation dot1q
            Switchport mode trunk
            Switchport trunk allowed vlan 1,1010
        

Router de VLAN 1010 (Cisco)

En la siguiente lista, se muestra una configuración de muestra de capa 2 o capa 3 para el Router1 local (Cisco) en VLAN 1010:

        interface E0/0
          description connected_to_onprem_switch
          channel-group 2 mode active
          no shut

        interface Po2
          description my-interconnect1
          no shut

        interface Po2.1010
          description attachment_vlan1010
          encapsulation dot1Q 1010
          ip address 169.254.10.2 255.255.255.248
          ip mtu 1440

        ip prefix-list TO_GCP seq 5 permit 192.168.12.0/24

        route-map TO_GCP_OUTBOUND permit 10
          match ip address prefix-list TO_GCP

        router bgp 64500
          bgp graceful-restart restart-time 1
          neighbor 169.254.10.1 description peering_to_cloud_router
          neighbor 169.254.10.1 remote-as 65200
          neighbor 169.254.10.1 ebgp-multihop 4
          neighbor 169.254.10.1 timers 20 60
          neighbor 169.254.10.1 update-source Po2.1010
          neighbor 169.254.10.1 route-map TO_GCP_OUTBOUND out
      

Interruptor de VLAN 1020 (Juniper)

En la siguiente lista, se muestra una configuración de muestra de capa 2 o capa 3 para el Switch2 local (Juniper) en VLAN 1020:

        set vlans cloud_vlan1020 vlan-id 1020

        set interfaces xe-0/1/1 description "connected_to_google_edge_device"
        set interfaces xe-0/1/1 ether-options 802.3ad ae1

        set interfaces ae1 aggregated-ether-options lacp active
        set interfaces ae1 unit 0 description "connected_to_google_edge_device"
        set interfaces ae1 unit 0 family ethernet-switching port-mode trunk
        set interfaces ae1 unit 0 family ethernet-switching vlan member cloud_vlan1020

        set interfaces xe-0/1/2 description "connected_to_onprem_router"
        set interfaces xe-0/1/2 ether-options 802.3ad ae2

        set interfaces ae2 unit 0 description "connected_to_onprem_router"
        set interfaces ae2 unit 0 family ethernet-switching port-mode trunk
        set interfaces ae2 unit 0 family ethernet-switching vlan member cloud_vlan1020
      

Router de VLAN 1020 (Juniper)

En la siguiente lista, se muestra una configuración de muestra de capa 2 o capa 3 para el Router2 local (Juniper) en VLAN 1020:


      set interfaces xe-0/0/0 ether-options 802.3ad ae1
      set interfaces xe-0/0/0 description connected_to_onprem_switch

      set interfaces ae1 description my-interconnect2
      set interfaces ae1 flexible-vlan-tagging
      set interfaces ae1 aggregated-ether-options minimum-links 1
      set interfaces ae1 aggregated-ether-options lacp active
      set interfaces ae1 unit 1020 family inet mtu 1440
      set interfaces ae1 unit 1020 vlan-id 1020
      set interfaces ae1 unit 1020 family inet address 169.254.20.2/29

      set routing-options autonomous-system 64500

      set policy-options prefix-list TO_GCP 192.168.12.0/24

      set policy-options policy-statement TO_GCP_OUTBOUND term 1 from protocol direct
      set policy-options policy-statement TO_GCP_OUTBOUND term 1 from prefix-list TO_GCP
      set policy-options policy-statement TO_GCP_OUTBOUND term 1 then accept
      set policy-options policy-statement TO_GCP_OUTBOUND term 2 then reject

      set protocols bgp group config_vlan_1020 type external
      set protocols bgp group config_vlan_1020 multihop ttl 4
      set protocols bgp group config_vlan_1020 local-address 169.254.20.2
      set protocols bgp group config_vlan_1020 peer-as 65200
      set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 export TO_GCP_OUTBOUND
      set protocols bgp group config_vlan_1020 neighbor 169.254.20.1 graceful-restart restart-time 1
      

Prácticas recomendadas

Sigue estas prácticas recomendadas para garantizar una conectividad efectiva a Google Cloud desde tus dispositivos locales cuando uses las topologías de Cloud Interconnect para la disponibilidad del 99.9% y el 99.99%.

Configura dispositivos para reenvío activo/activo

  • Asegúrate de que se intercambien los mismos valores MED en todas las sesiones BGP.
  • Habilita el enrutamiento de ruta múltiple de igual costo (ECMP) en tu configuración de BGP.
  • Habilita el reinicio ordenado en tus sesiones de BGP para minimizar el impacto de los reinicios de tareas de Cloud Router. Cuando conectas dos adjuntos a través de diferentes dominios de disponibilidad perimetral, como se describe en las topologías recomendadas, Cloud Router usa una tarea por dominio de disponibilidad perimetral. Para evitar el tiempo de inactividad, las tareas de software se programan de manera independiente.
  • Si configuras dos dispositivos locales, usa cualquier protocolo de enrutamiento para conectar ambos dispositivos entre sí. Si configuras tu dispositivo para emplear la redistribución, usa IBGP o IGP.

Configura dispositivos para reenvío activo/pasivo

  • Para evitar el enrutamiento asimétrico, asegúrate de que se apliquen valores MED más altos en el lado del Cloud Router y en el lado del dispositivo local.
  • Habilita el reinicio ordenado en tus sesiones de BGP para minimizar el impacto de los reinicios de tareas de Cloud Router. Cuando conectas dos adjuntos a través de diferentes dominios de disponibilidad perimetral, como se describe en las topologías recomendadas, Cloud Router usa una tarea por dominio de disponibilidad perimetral. Para evitar el tiempo de inactividad, las tareas de software se programan de manera independiente.
  • Si estás configurando dos dispositivos locales, asegúrate de que ambos dispositivos tengan conectividad de capa 3 entre sí. Si configuras tu dispositivo para emplear la redistribución, usa IBGP o IGP.

Verifica que tus sesiones de BGP estén en funcionamiento entre tu red local y tu red de nube privada virtual de Google (VPC). Para obtener más información, consulta Visualiza el estado y las rutas de Cloud Router en la documentación de Cloud Router.