Esta página foi traduzida pela API Cloud Translation.
Switch to English

Como migrar entre versões do Dialogflow

V2beta1 para V2

A API V2beta1 é usada para compartilhar recursos Beta com usuários do Dialogflow. Esta seção apresenta dicas para mudar para a API V2 estável.

  • Se você estiver usando REST ou RPC, atualize o endpoint de dialogflow.googleapis.com/v2beta1/... para dialogflow.googleapis.com/v2/....
  • Se você estiver usando uma biblioteca de cliente, atualize-a:
    • Linguagens dinâmicas (Python, Node.js e Ruby): faça o upgrade do pacote, e o código usará automaticamente a última versão estável.
    • Linguagens estáticas (Java, C#, PHP e Go): instale o novo pacote e atualize todas as instruções de importação para mencionar "v2" em vez de "v2beta1".
  • O campo que controla se o machine learning (ML, na sigla em inglês) está habilitado para Intent mudou. O campo mlEnabled foi removido e substituído pelo campo mlDisabled, e o ML está ativado por padrão.
    Versão REST RPC Valor padrão Comportamento padrão
    V2beta1 mlEnabled ml_enabled verdadeiro ML ativado
    V2 mlDisabled ml_disabled falso ML ativado