Résolution des problèmes liés à l'absence d'espace d'adresses IP libre

Vous consultez la documentation d'Apigee et d'Apigee hybrid.
Il n'existe pas de documentation Apigee Edge équivalente pour ce sujet.

Symptôme

Lors du provisionnement d'Apigee, si vous sélectionnez une plage CIDR réseau qui n'est pas totalement disponible, un message d'erreur peut s'afficher.

Message d'erreur

error waiting for creating
instance: error code 9: message: couldn't find a free ip space of /22 to
launch an instance. verify the peering ranges are available.

Cause possible

La plage d'adresses IP spécifiée lors du provisionnement n'est pas disponible. Chaque instance Apigee nécessite une plage CIDR /22 sans chevauchement, comme décrit dans la section Dimensionnement du réseau.

Diagnostic

  1. Dans la console Google Cloud, accédez à la page Appairage de réseaux VPC. Consultez également la section Utiliser l'appairage de réseaux VPC.

    Accéder à la page "Appairage de réseaux VPC"

  2. Sélectionnez votre connexion d'appairage de réseaux VPC. Par exemple, servicenetworking-googleapis-com. La page Informations sur la connexion d'appairage s'affiche :

  3. Identifiez la plage CIDR que vous avez spécifiée lors du processus de provisionnement et vérifiez qu'elle ne chevauche aucune des adresses IP listées sur la page Informations sur la connexion d'appairage.

Solution

Au cours du processus de provisionnement, pour l'allocation de la plage d'adresses IP, sélectionnez l'une des options suivantes :

  • Automatique (recommandé)
  • Personnalisé, puis spécifiez une plage sans chevauchement :

Vous devez collecter des informations de diagnostic

Si le problème persiste, même après avoir suivi les instructions ci-dessus, rassemblez les informations de diagnostic suivantes, puis contactez Google Cloud Customer Care :

  • Organisation Apigee