Versión 1.3. Esta versión ya no se admite como se describe en la política de asistencia de la versión de Anthos. Actualiza a una versión compatible para obtener los parches y las actualizaciones más recientes sobre vulnerabilidades de seguridad, exposiciones y problemas que afectan a los clústeres de Anthos en VMware (GKE On-Prem). Puedes encontrar la versión más reciente aquí.

Historial de versiones

En esta página, se explica el control de versiones de GKE On-Prem.

Esquema del control de versiones

La versión de GKE On-Prem tiene el formato X.Y.Z.-gke.N.

Versión principal (X)
Las versiones principales agregan cambios incompatibles con versiones anteriores.
Versiones menores (X.Y)
Por lo general, las versiones menores presentan funciones nuevas.
Versiones de parches (X.Y.Z-gke.N)
Por lo general, las versiones de parches son pequeñas e incluyen correcciones y actualizaciones de seguridad. Por lo general, no se presentan funciones nuevas. -gke.N es el número candidato de la versión de actualización.

Versiones de GKE On-Prem

Las siguientes versiones de GKE On-Prem son totalmente compatibles y ofrecen los parches y las actualizaciones más recientes de vulnerabilidades de seguridad, exposiciones y problemas que afectan a GKE On-Prem. Para obtener más detalles, consulta las notas de la versión.

VersiónFecha de lanzamientoDescargasDocumentación
1.7.0-gke.16 25 de marzo de 2021 Descargas 1.7 1.7 docs
1.6.2-gke.0 26 de febrero de 2021 Descargas 1.6 1.6 docs
1.6.1-gke.1 27 de enero de 2021 Descargas 1.6 1.6 docs
1.6.0-gke.7 10 de diciembre de 2020 . Descargas 1.6 1.6 docs
1.5.3-gke.0 21 de enero de 2021 Descargas 1.5 1.5 docs
1.5.2-gke.3 16 de noviembre de 2020 Descargas 1.5 1.5 docs
1.5.1-gke.8 23 de octubre de 2020 Descargas 1.5 1.5 docs
1.5.0-gke.27 24 de septiembre de 2020 Descargas 1.5 1.5 docs

Versiones de kernel de nodo y Kubernetes

Para cada versión de GKE On-Prem, en la siguiente tabla, se muestran la versión de Kubernetes y la versión de kernel de Linux para los nodos del clúster:

Versión de GKE On-prem Versión de Kubernetes Versión de kernel del nodo
1.7.0 1.19.7 5.4.0.1010.11 (ubuntu), 5.4.92 (cos)
1.6.2 1.18.13 5.4.0.1009.10
1.6.1 1.18.13 5.4.0.1007.8
1.6.0 1.18.6 5.4.0.1004.5
1.5.3 1.17.9 5.4.0.1007.8
1.5.2 1.17.9 5.4.0.47.51
1.5.1 1.17.9 5.4.0.47.51
1.5.0 1.17.9 5.4.0.47.51

Entidades con versiones

Cada actualización de GKE On-Prem incluye las siguientes entidades con versiones:

Entidad Descripción
gkeadm La herramienta de línea de comandos para crear y administrar estaciones de trabajo de administrador. Para verificar la versión, ejecuta gkeadm version.
Estación de trabajo de OVA

El dispositivo virtual abierto (OVA) para la estación de trabajo de administrador. Contiene la imagen de SO para la estación de trabajo del administrador, junto con el paquete del clúster y la herramienta de línea de comandos de gkectl.

El número de versión es parte del nombre de archivo, por ejemplo:


gke-on-prem-admin-appliance-vsphere-1.6.1-gke.1.ova

Para obtener más información, consulta el archivo PDF de la especificación de formato de virtualización virtual.

gkectl Es la interfaz de línea de comandos (CLI) para GKE On-Prem. Crea y administra clústeres, crea archivos de configuración y ejecuta verificaciones previas. Se incluye en el OVA de la estación de trabajo de administrador. Para verificar la versión, ejecuta gkectl version.
Paquete de clústeres

Un archivo que contiene componentes de clúster y la imagen del sistema operativo para nodos del clúster. Se incluye en el OVA de la estación de trabajo de administrador.

El número de versión es parte del nombre de archivo, por ejemplo:


gke-onprem-vsphere-1.6.1-gke.1.tgz

Actualizaciones de seguridad

Para determinar si una actualización contiene actualizaciones de seguridad, consulta las notas de la versión y los boletines de seguridad de Google Kubernetes Engine (GKE).

Compatibilidad de versiones

Capa de virtualización

1.7 1.6 1.5 1.4
Versión

vSphere 6.5U3 o superior

vSphere 6.7U3 o superior

vSphere 7.0

vSphere 6.5U3 o una versión posterior

vSphere 6.7U3 o una versión posterior

vSphere 6.5U3 o una versión posterior

vSphere 6.7U3 o una versión posterior

vSphere 6.5U3 o una versión posterior

vSphere 6.7U3 o una versión posterior

Edición vSphere Standard * o superior vSphere Standard * o superior vSphere Standard * o superior vSphere Standard * o superior

Opciones de herramientas de redes

1.7 1.6 1.5 1.4
Interruptor estándar de vSphere
Interruptor distribuido de vSphere
vSphere NSX-T † Sí ‡ Sí ‡ Sí ‡ Sí ‡

Opciones del balanceo de cargas

1.7 1.6 1.5 1.4
Big-IP de F5 #

Controlador de BIG-IP de F5 v1.14.0

Compatible con BIG-IP v12.x-v15.x

Controlador de BIG-IP de F5 v1.14.0

Compatible con BIG-IP v12.x-v15.x

Controlador de BIG-IP de F5 v1.14.0

Compatible con BIG-IP v12.x-v15.x

Controlador de BIG-IP de F5 v1.14.0

Compatible con BIG-IP v12.x-v15.x

Modo de balanceo de cargas manual
Balanceador de cargas en paquetes (proporcionado por Google)

Opciones de almacenamiento

1.7 1.6 1.5 1.4
vSAN (opcional)

vSAN 6.7U3

vSAN 7.0

vSAN 6.7U3 vSAN 6.7U3 vSAN 6.7U3
Almacenamiento compatible con vSphere (SAN/DAS/SDS)
Proveedores de almacenamiento de CSI Consulta Google announces Anthos Ready Storage partner program (Google anuncia el Programa de Partners del almacenamiento de Anthos Ready).

Notas

* Se recomienda usar vSphere Enterprise.

† No se admite NSX-V.

‡ La versión mínima admitida de NSX-T es 2.4.2. La compatibilidad incluye herramientas de redes de nodos para la comunicación entre nodos. No se admiten las herramientas de redes de Pods, la entrada ni la integración de CNI de NSX-T. No se admite NSX-V.

# Si deseas obtener una matriz de compatibilidad actualizada para F5, consulta Releases and Versioning (Versiones y control de versiones).