Laufzeitversionsliste

AI Platform verwendet auf der Laufzeitversion basierende Images, um Cloudressourcen zu konfigurieren, mit denen Trainings- und Vorhersageanfragen verarbeitet werden. Diese Seite führt die Laufzeitversionen und die zugehörigen Pakete auf. Weitere Informationen finden Sie unter Laufzeitversionen verwalten und einrichten.

Unterstützte AI Platform-Laufzeitversionen

Die folgenden Versionen werden in AI Platform unterstützt:

Version Paket Veröffentlicht am Zuletzt aktualisiert
1.13 TensorFlow 1.13.1
scikit-learn 0.20.2
XGBoost 0.81

Laufzeitversion 1.13 unterstützt TensorFlow 1.13.1 für CPU und GPU (GPUs unterstützen keine Onlinevorhersagen).

Python 3.5 ist für Training und Onlinevorhersagen mit Laufzeitversion 1.13 verfügbar. Die Ubuntu-Pakete für Python 3 (fett dargestellt) werden bei Ausführung in Python 3 installiert.

6. März 2019 25. März 2019
1.12 TensorFlow 1.12.2
scikit-learn 0.20.0
XGBoost 0.81

Laufzeitversion 1.12 unterstützt TensorFlow 1.12.0 für CPU und GPU (GPUs unterstützen keine Onlinevorhersagen).

Python 3.5 ist für Training und Onlinevorhersagen mit Laufzeitversion 1.12 verfügbar. Die Ubuntu-Pakete für Python 3 (fett dargestellt) werden bei Ausführung in Python 3 installiert.

19. Dezember 2018 3. Mai 2019
1.11 TensorFlow 1.11
scikit-learn 0.19.2
XGBoost 0.80

Laufzeitversion 1.11 unterstützt TensorFlow 1.11.0 für CPU und GPU (GPUs unterstützen keine Onlinevorhersagen).

Python 3.5 ist für Training und Onlinevorhersagen mit Laufzeitversion 1.11 verfügbar. Die Ubuntu-Pakete für Python 3 (fett dargestellt) werden bei Ausführung in Python 3 installiert.

19. Dezember 2018
1.10 TensorFlow 1.10
scikit-learn 0.19.2
XGBoost 0.72.1

Laufzeitversion 1.10 unterstützt TensorFlow 1.10.0 für CPU und GPU (GPUs unterstützen keine Onlinevorhersagen).

Python 3.5 ist für Training und Onlinevorhersagen mit Laufzeitversion 1.10 verfügbar. Die Ubuntu-Pakete für Python 3 (fett dargestellt) werden bei Ausführung in Python 3 installiert.

31. August 2018 19. Dezember 2018
1.9 TensorFlow 1.9
scikit-learn 0.19.1
XGBoost 0.72.1

Laufzeitversion 1.9 unterstützt TensorFlow 1.9.0 für CPU und GPU (GPUs unterstützen keine Onlinevorhersagen).

Python 3.5 ist für Training und Onlinevorhersagen mit Laufzeitversion 1.9 verfügbar. Die Ubuntu-Pakete für Python 3 (fett dargestellt) werden bei Ausführung in Python 3 installiert.

27. Juni 2018 19. Dezember 2018
1.8 TensorFlow 1.8
scikit-learn 0.19.1
XGBoost 0.71

Laufzeitversion 1.8 unterstützt TensorFlow 1.8.0 für CPU und GPU (GPUs unterstützen keine Onlinevorhersagen).

Python 3.5 steht für Training und Onlinevorhersagen mit Laufzeitversion 1.8 zur Verfügung. Die Ubuntu-Pakete für Python 3 (fett dargestellt) werden bei Ausführung in Python 3 installiert.

Die Pakete gcloud und google-cloud-logging wurden durch das Paket google-cloud ersetzt, das die beiden entfernten Pakete enthält.

8. Mai 2018 19. Dezember 2018
1.7 TensorFlow 1.7
scikit-learn 0.19.1
XGBoost 0.7.post3

Laufzeitversion 1.7 unterstützt TensorFlow 1.7.0 für CPU und GPU.

Python 3.5 steht für Training und Onlinevorhersagen mit Laufzeitversion 1.7 zur Verfügung. Die Ubuntu-Pakete für Python 3 (fett dargestellt) werden bei Ausführung in Python 3 installiert.

26. April 2018 19. Dezember 2018
1.6 TensorFlow 1.6
scikit-learn 0.19.1
XGBoost 0.7.post3

Laufzeitversion 1.6 unterstützt TensorFlow 1.6.0 für CPU und GPU.

Python 3.5 steht für Training und Onlinevorhersagen mit Laufzeitversion 1.6 zur Verfügung. Die Ubuntu-Pakete für Python 3 (fett dargestellt) werden bei Ausführung in Python 3 installiert.

20. März 2018 19. Dezember 2018
1.5 TensorFlow 1.5
scikit-learn 0.19.1
XGBoost 0.7.post3

Laufzeitversion 1.5 unterstützt TensorFlow 1.5.0 für CPU und GPU.

Python 3.5 steht für Training und Onlinevorhersagen mit Laufzeitversion 1.5 zur Verfügung. Die Ubuntu-Pakete für Python 3 (fett dargestellt) werden bei Ausführung in Python 3 installiert.

13. März 2018 19. Dezember 2018
1.4 TensorFlow 1.4.0 und 1.4.1
scikit-learn 0.18.1
XGBoost 0.6a2

Laufzeitversion 1.4 verwendet TensorFlow 1.4.0 für Onlinevorhersagen und 1.4.1 für Batchvorhersagen und Training.

Python 3.5 steht für Training und Onlinevorhersagen mit Laufzeitversion 1.4 zur Verfügung. Die Ubuntu-Pakete für Python 3 (fett dargestellt) werden bei Ausführung in Python 3 installiert.

Version 1.4 ist die früheste AI Platform-Laufzeitversion, die Unterstützung für scikit-learn und XGBoost bietet.

11. Dezember 2017 19. Dezember 2018
1.2 TensorFlow 1.2.0

Laufzeitversion 1.2 verwendet ein Basis-Image des Ubuntu 16.04-Betriebssystems anstelle der von 1.0 verwendeten Debian Jessie-Version.

27. Juni 2017
1.0 TensorFlow 1.0.1

Dies ist die AI Platform-Standardlaufzeitversion, die derzeit von Version 1 der AI Platform Training und Prediction API unterstützt wird.

08. März 2017

Unterstützung für ältere Laufzeitversionen

Ältere Haupt- und Nebenlaufzeitversionen werden über einen bestimmten Zeitraum nach Veröffentlichung der neuen Version unterstützt. In diesem Zeitraum können Sie damit Modelle trainieren und Vorhersagen abrufen. Außerhalb dieses Zeitfensters werden die Laufzeitversionen nicht unterstützt.

Monate nach Ablauf der Laufzeit Verfügbar für Modelltraining und Vorhersagen
0 bis 12 Ja
12+ Nein

Unterstützung für GPUs

Auf GPU-fähigen Maschinen ist das TensorFlow-Python-Paket tensorflow-gpu mit GPU-Unterstützung vorinstalliert.

Auf anderen Maschinen ist stattdessen das reguläre Paket tensorflow vorinstalliert.

Unterstützung für Cloud TPU

Die AI Platform-Laufzeitversionen 1.11 und 1.12 stehen für das Training der Modelle auf Cloud TPU zur Verfügung. Hier erfahren Sie, wie Sie ein Cloud-TPU-Kontingent anfordern und TPUs zum Trainieren des Modells verwenden.

Weitere Informationen

Hat Ihnen diese Seite weitergeholfen? Teilen Sie uns Ihr Feedback mit:

Feedback geben zu...

AI Platform für TensorFlow