Requirements

Stay organized with collections Save and categorize content based on your preferences.

This page lists Cloud Healthcare API requirements and related information.

Regions and versions

Cloud regions

Only these Google Cloud regions are available:

Regional locations

Region name Region description
North America
northamerica-northeast1 Montréal, Canada
us-central1 Iowa, USA
us-east1 South Carolina, USA
us-east4 North Virginia, USA
us-west1 Oregon, USA
us-west2 Los Angeles, USA
us-west3 Salt Lake City, USA
South America
southamerica-east1 São Paulo, Brazil
Europe
europe-west2 London, UK
europe-west3 Frankfurt, Germany
europe-west4 Netherlands
europe-west6 Zurich, Switzerland
Asia
asia-east1 Taiwan
asia-east2 Hong Kong
asia-northeast1 Tokyo, Japan
asia-northeast2 Osaka, Japan
asia-northeast3 Seoul, South Korea
asia-south1 Mumbai, India
asia-southeast1 Singapore
asia-southeast2 Jakarta, Indonesia
Australia
australia-southeast1 Sydney

Multi-regional locations

Multi-region name Multi-region description
us Data centers in the United States

Google Cloud CLI

Cloud Healthcare API requires version 236.0.0 or higher of the Google Cloud CLI.

Permitted characters and size requirements

Resources in the Cloud Healthcare API are limited to certain characters and might be limited to certain lengths.

The following table lists the permitted characters and sizes for each resource:

Resource Limitations
Datasets and FHIR, DICOM, and HL7v2 store names
  • Permitted characters: Any string consisting of unicode numbers, unicode letters, ASCII underscores, dashes, and periods
  • Minimum length: 1 character
  • Maximum length: 256 characters
  • Requirements as a regular expression: [\p{L}\p{N}_-.]{1,256}