1.1 版。如 Anthos 版本支持政策中所述,此版本已不再受支持。如需获取影响 VMware 上的 Anthos 集群 (GKE On-Prem) 的安全漏洞、威胁和问题的最新补丁程序和更新,请升级到支持的版本。您可以在此处找到最新版本。

版本历史记录

本页面介绍 GKE On-Prem 版本控制。

版本控制架构

GKE On-Prem 版本采用 X.Y.Z.-gke.N 格式。

主要版本 (X)
主要版本会引入后向不兼容的更改。
次要版本 (X.Y)
次要版本通常会引入新功能。
补丁程序版本 (X.Y.Z-gke.N)
补丁程序版本通常很小,并且包含修复程序和安全更新。 通常不会推出新功能。-gke.N 是版本的候选版本号。

GKE On-Prem 版本

以下 GKE On-Prem 版本受全面支持,提供影响 GKE On-Prem 的安全漏洞、威胁和问题的最新补丁程序和更新。如需了解详情,请参阅版本说明

版本发布日期下载文档
1.7.0-gke.16 2021 年 3 月 25 日 1.7 下载 1.7 文档
1.6.2-gke.0 2021 年 2 月 26 日 1.6 下载 1.6 文档
1.6.1-gke.1 2021 年 1 月 27 日 1.6 下载 1.6 文档
1.6.0-gke.7 2020 年 12 月 10 日 1.6 下载 1.6 文档
1.5.3-gke.0 2021 年 1 月 21 日 1.5 下载 1.5 文档
1.5.2-gke.3 2020 年 11 月 16 日 1.5 下载 1.5 文档
1.5.1-gke.8 2020 年 10 月 23 日 1.5 下载 1.5 文档
1.5.0-gke.27 2020 年 9 月 24 日 1.5 下载 1.5 文档

Kubernetes 和节点内核版本

对于每个 GKE On-Prem 版本,下表展示了集群节点的 Kubernetes 版本和 Linux 内核版本:

GKE On-Prem 版本 Kubernetes 版本 节点内核版本
1.7.0 1.19.7 5.4.0.1010.11 (ubuntu)、5.4.92 (cos)
1.6.2 1.18.13 5.4.0.1009.10
1.6.1 1.18.13 5.4.0.1007.8
1.6.0 1.18.6 5.4.0.1004.5
1.5.3 1.17.9 5.4.0.1007.8
1.5.2 1.17.9 5.4.0.47.51
1.5.1 1.17.9 5.4.0.47.51
1.5.0 1.17.9 5.4.0.47.51

有版本控制的实体

每个 GKE On-Prem 版本都包含以下有版本控制的实体:

实体 说明
gkeadm 用于创建和管理管理员工作站的命令行工具。如需查看版本,请运行 gkeadm version
管理员工作站 OVA

管理员工作站的开放虚拟设备 (OVA)。包含管理员工作站的操作系统映像以及集群软件包和 gkectl 命令行工具。

版本号是文件名的一部分,例如:


gke-on-prem-admin-appliance-vsphere-1.6.1-gke.1.ova

如需了解详情,请参阅开放虚拟化格式规范 PDF

gkectl 用于 GKE On-Prem 的命令行界面。创建和管理集群,创建配置文件并运行预检检查。包含在管理员工作站 OVA 中。 如需查看版本,请运行 gkectl version
集群软件包

包含集群节点的集群组件和操作系统映像的归档文件。包含在管理员工作站 OVA 中。

版本号是文件名的一部分,例如:


gke-onprem-vsphere-1.6.1-gke.1.tgz

安全更新

如需确定升级是否包含安全更新,请参阅版本说明和 Google Kubernetes Engine (GKE) 安全公告

版本兼容性

虚拟化层

1.7 1.6 1.5 1.4
版本

vSphere 6.5U3 或更高版本

vSphere 6.7U3 或更高版本

vSphere 7.0

vSphere 6.5U3 或更高版本

vSphere 6.7U3 或更高版本

vSphere 6.5U3 或更高版本

vSphere 6.7U3 或更高版本

vSphere 6.5U3 或更高版本

vSphere 6.7U3 或更高版本

版本 vSphere Standard * 或更高版本 vSphere Standard * 或更高版本 vSphere Standard * 或更高版本 vSphere Standard * 或更高版本

网络选项

1.7 1.6 1.5 1.4
vSphere 标准交换机
vSphere 分布式交换机
vSphere NSX-T 是 ‡ 是 ‡ 是 ‡ 是 ‡

负载平衡选项

1.7 1.6 1.5 1.4
F5 BIG-IP #

F5 Big-IP 控制器 1.14.0 版

与 BIG-IP v12.x-v15.x 兼容

F5 Big-IP 控制器 1.14.0 版

与 BIG-IP v12.x-v15.x 兼容

F5 Big-IP 控制器 1.14.0 版

与 BIG-IP v12.x-v15.x 兼容

F5 Big-IP 控制器 1.14.0 版

与 BIG-IP v12.x-v15.x 兼容

手动负载平衡模式
捆绑式负载平衡器(Google 提供)

存储选项

1.7 1.6 1.5 1.4
vSAN(可选)

vSAN 6.7U3

vSAN 7.0

vSAN 6.7U3 vSAN 6.7U3 vSAN 6.7U3
与 vSphere 兼容的存储 (SAN/DAS/SDS)
CSI 存储空间服务 请参阅 Google 宣布推出 Anthos Ready 存储合作伙伴计划

备注

* vSphere Enterprise 是推荐版本。

† 不支持 NSX-V。

‡ 支持的最低 NSX-T 版本为 2.4.2。支持包含用于节点间通信的节点网络。不支持 pod 网络、Ingress 和 NSX-T CNI 集成。不支持 NSX-V。

# 如需了解 F5 的最新兼容性矩阵,请参阅版本和版本控制