客户端库

尽管您可以通过发出直接请求来使用 Media Translation,不过我们提供了几种常用语言的客户端库。 Media Translation 客户端库基于 Google Cloud 客户端库构建。 这种通用基础架构不但提供了可实现 API 专属库的功能,而且还提供了在使用任何 Cloud API 时可以直接使用的类型和方法。

可用的客户端库

Media Translation 为以下语言提供了客户端库和指南:

Python

本页面提供了 Media Translation Python 客户端库的参考文档和相关资源。

资源 说明
库参考文档 Media Translation Python 库参考文档
语言指南 将 Python 与 GCP 搭配使用的一般指南
GitHub 代码库 此库的源代码和其他文档
Stack Overflow 带有 Media Translation 和 Python 标记的问题

安装

要安装客户端库,请运行以下命令:

pip install --upgrade google-cloud-media-translation

Java

本页面提供了 Media Translation Java 客户端库的参考文档和相关资源。

资源 说明
库参考文档 Media Translation Java 库参考文档
语言指南 将 Java 与 GCP 搭配使用的一般指南
GitHub 代码库 此库的源代码和其他文档
Stack Overflow 带有 Media Translation 和 Java 标记的问题

安装

要安装客户端库,请运行以下命令:

如果您使用的是带有 BOM 的 Maven,请将以下内容添加到您的 pod.xml 文件中:

<dependencyManagement>
  <dependencies>
    <dependency>
      <groupId>com.google.cloud</groupId>
      <artifactId>libraries-bom</artifactId>
      <version>16.4.0</version>
      <type>pom</type>
      <scope>import</scope>
    </dependency>
  </dependencies>
</dependencyManagement>
<dependencies>
  <dependency>
    <groupId>com.google.cloud</groupId>
    <artifactId>google-cloud-mediatranslation</artifactId>
  </dependency>
</dependencies>

如果您使用的是不带 BOM 的 Maven,请将此代码添加到您的依赖项中:

<dependency>
  <groupId>com.google.cloud</groupId>
  <artifactId>google-cloud-mediatranslation</artifactId>
  <version>0.2.1</version>
</dependency>

如果您使用的是 Gradle,请将以下内容添加到您的依赖项中:

compile 'com.google.cloud:google-cloud-mediatranslation:0.1.0'

如果您使用的是 SBT,请将以下内容添加到您的依赖项中:

libraryDependencies += "com.google.cloud" % "google-cloud-mediatranslation" % "0.1.0"

Node.js

本页面提供了 Media Translation Node.js 客户端库的参考文档和相关资源。

资源 说明
库参考文档 Media Translation Node.js 库参考文档
语言指南 将 Node.js 与 GCP 搭配使用的一般指南
GitHub 代码库 此库的源代码和其他文档
Stack Overflow 带有 Media Translation 和 Node.js 标记的问题

安装

要安装客户端库,请运行以下命令:

npm install @google-cloud/media-translation

身份验证和访问控制

Media Translation 快速入门指南提供了有关身份验证和访问控制的基本信息。如需了解详情,请参阅以下内容: