Module Google::Cloud::Compute (v0.2.0)

Stay organized with collections Save and categorize content based on your preferences.

Methods

.accelerator_types

def self.accelerator_types(version: :v1, &block) -> AcceleratorTypes::Rest::Client

Create a new client object for AcceleratorTypes.

By default, this returns an instance of Google::Cloud::Compute::V1::AcceleratorTypes::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the AcceleratorTypes service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About AcceleratorTypes

Services

The AcceleratorTypes API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (AcceleratorTypes::Rest::Client) — A client object for the specified version.

.addresses

def self.addresses(version: :v1, &block) -> Addresses::Rest::Client

Create a new client object for Addresses.

By default, this returns an instance of Google::Cloud::Compute::V1::Addresses::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Addresses service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Addresses

The Addresses API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Addresses::Rest::Client) — A client object for the specified version.

.autoscalers

def self.autoscalers(version: :v1, &block) -> Autoscalers::Rest::Client

Create a new client object for Autoscalers.

By default, this returns an instance of Google::Cloud::Compute::V1::Autoscalers::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Autoscalers service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Autoscalers

The Autoscalers API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Autoscalers::Rest::Client) — A client object for the specified version.

.backend_buckets

def self.backend_buckets(version: :v1, &block) -> BackendBuckets::Rest::Client

Create a new client object for BackendBuckets.

By default, this returns an instance of Google::Cloud::Compute::V1::BackendBuckets::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the BackendBuckets service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About BackendBuckets

The BackendBuckets API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (BackendBuckets::Rest::Client) — A client object for the specified version.

.backend_services

def self.backend_services(version: :v1, &block) -> BackendServices::Rest::Client

Create a new client object for BackendServices.

By default, this returns an instance of Google::Cloud::Compute::V1::BackendServices::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the BackendServices service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About BackendServices

The BackendServices API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (BackendServices::Rest::Client) — A client object for the specified version.

.configure

def self.configure() -> ::Google::Cloud::Config

Configure the google-cloud-compute library.

The following configuration parameters are supported:

  • credentials (type: String, Hash, Google::Auth::Credentials) - The path to the keyfile as a String, the contents of the keyfile as a Hash, or a Google::Auth::Credentials object.
  • lib_name (type: String) - The library name as recorded in instrumentation and logging.
  • lib_version (type: String) - The library version as recorded in instrumentation and logging.
  • timeout (type: Numeric) - Default timeout in seconds.
  • metadata (type: Hash{Symbol=>String}) - Additional REST headers to be sent with the call.
Yields
  • (::Google::Cloud.configure.compute)
Returns
  • (::Google::Cloud::Config) — The default configuration used by this library

.disk_types

def self.disk_types(version: :v1, &block) -> DiskTypes::Rest::Client

Create a new client object for DiskTypes.

By default, this returns an instance of Google::Cloud::Compute::V1::DiskTypes::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the DiskTypes service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About DiskTypes

The DiskTypes API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (DiskTypes::Rest::Client) — A client object for the specified version.

.disks

def self.disks(version: :v1, &block) -> Disks::Rest::Client

Create a new client object for Disks.

By default, this returns an instance of Google::Cloud::Compute::V1::Disks::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Disks service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Disks

The Disks API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Disks::Rest::Client) — A client object for the specified version.

.external_vpn_gateways

def self.external_vpn_gateways(version: :v1, &block) -> ExternalVpnGateways::Rest::Client

Create a new client object for ExternalVpnGateways.

By default, this returns an instance of Google::Cloud::Compute::V1::ExternalVpnGateways::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the ExternalVpnGateways service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About ExternalVpnGateways

The ExternalVpnGateways API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (ExternalVpnGateways::Rest::Client) — A client object for the specified version.

.firewall_policies

def self.firewall_policies(version: :v1, &block) -> FirewallPolicies::Rest::Client

Create a new client object for FirewallPolicies.

By default, this returns an instance of Google::Cloud::Compute::V1::FirewallPolicies::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the FirewallPolicies service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About FirewallPolicies

The FirewallPolicies API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (FirewallPolicies::Rest::Client) — A client object for the specified version.

.firewalls

def self.firewalls(version: :v1, &block) -> Firewalls::Rest::Client

Create a new client object for Firewalls.

By default, this returns an instance of Google::Cloud::Compute::V1::Firewalls::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Firewalls service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Firewalls

The Firewalls API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Firewalls::Rest::Client) — A client object for the specified version.

.forwarding_rules

def self.forwarding_rules(version: :v1, &block) -> ForwardingRules::Rest::Client

Create a new client object for ForwardingRules.

By default, this returns an instance of Google::Cloud::Compute::V1::ForwardingRules::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the ForwardingRules service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About ForwardingRules

The ForwardingRules API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (ForwardingRules::Rest::Client) — A client object for the specified version.

.global_addresses

def self.global_addresses(version: :v1, &block) -> GlobalAddresses::Rest::Client

Create a new client object for GlobalAddresses.

By default, this returns an instance of Google::Cloud::Compute::V1::GlobalAddresses::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the GlobalAddresses service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About GlobalAddresses

The GlobalAddresses API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (GlobalAddresses::Rest::Client) — A client object for the specified version.

.global_forwarding_rules

def self.global_forwarding_rules(version: :v1, &block) -> GlobalForwardingRules::Rest::Client

Create a new client object for GlobalForwardingRules.

By default, this returns an instance of Google::Cloud::Compute::V1::GlobalForwardingRules::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the GlobalForwardingRules service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About GlobalForwardingRules

The GlobalForwardingRules API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (GlobalForwardingRules::Rest::Client) — A client object for the specified version.

.global_network_endpoint_groups

def self.global_network_endpoint_groups(version: :v1, &block) -> GlobalNetworkEndpointGroups::Rest::Client

Create a new client object for GlobalNetworkEndpointGroups.

By default, this returns an instance of Google::Cloud::Compute::V1::GlobalNetworkEndpointGroups::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the GlobalNetworkEndpointGroups service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About GlobalNetworkEndpointGroups

The GlobalNetworkEndpointGroups API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (GlobalNetworkEndpointGroups::Rest::Client) — A client object for the specified version.

.global_operations

def self.global_operations(version: :v1, &block) -> GlobalOperations::Rest::Client

Create a new client object for GlobalOperations.

By default, this returns an instance of Google::Cloud::Compute::V1::GlobalOperations::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the GlobalOperations service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About GlobalOperations

The GlobalOperations API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (GlobalOperations::Rest::Client) — A client object for the specified version.

.global_organization_operations

def self.global_organization_operations(version: :v1, &block) -> GlobalOrganizationOperations::Rest::Client

Create a new client object for GlobalOrganizationOperations.

By default, this returns an instance of Google::Cloud::Compute::V1::GlobalOrganizationOperations::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the GlobalOrganizationOperations service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About GlobalOrganizationOperations

The GlobalOrganizationOperations API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (GlobalOrganizationOperations::Rest::Client) — A client object for the specified version.

.global_public_delegated_prefixes

def self.global_public_delegated_prefixes(version: :v1, &block) -> GlobalPublicDelegatedPrefixes::Rest::Client

Create a new client object for GlobalPublicDelegatedPrefixes.

By default, this returns an instance of Google::Cloud::Compute::V1::GlobalPublicDelegatedPrefixes::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the GlobalPublicDelegatedPrefixes service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About GlobalPublicDelegatedPrefixes

The GlobalPublicDelegatedPrefixes API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (GlobalPublicDelegatedPrefixes::Rest::Client) — A client object for the specified version.

.health_checks

def self.health_checks(version: :v1, &block) -> HealthChecks::Rest::Client

Create a new client object for HealthChecks.

By default, this returns an instance of Google::Cloud::Compute::V1::HealthChecks::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the HealthChecks service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About HealthChecks

The HealthChecks API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (HealthChecks::Rest::Client) — A client object for the specified version.

.image_family_views

def self.image_family_views(version: :v1, &block) -> ImageFamilyViews::Rest::Client

Create a new client object for ImageFamilyViews.

By default, this returns an instance of Google::Cloud::Compute::V1::ImageFamilyViews::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the ImageFamilyViews service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About ImageFamilyViews

The ImageFamilyViews API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (ImageFamilyViews::Rest::Client) — A client object for the specified version.

.images

def self.images(version: :v1, &block) -> Images::Rest::Client

Create a new client object for Images.

By default, this returns an instance of Google::Cloud::Compute::V1::Images::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Images service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Images

The Images API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Images::Rest::Client) — A client object for the specified version.

.instance_group_managers

def self.instance_group_managers(version: :v1, &block) -> InstanceGroupManagers::Rest::Client

Create a new client object for InstanceGroupManagers.

By default, this returns an instance of Google::Cloud::Compute::V1::InstanceGroupManagers::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the InstanceGroupManagers service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About InstanceGroupManagers

The InstanceGroupManagers API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (InstanceGroupManagers::Rest::Client) — A client object for the specified version.

.instance_groups

def self.instance_groups(version: :v1, &block) -> InstanceGroups::Rest::Client

Create a new client object for InstanceGroups.

By default, this returns an instance of Google::Cloud::Compute::V1::InstanceGroups::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the InstanceGroups service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About InstanceGroups

The InstanceGroups API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (InstanceGroups::Rest::Client) — A client object for the specified version.

.instance_templates

def self.instance_templates(version: :v1, &block) -> InstanceTemplates::Rest::Client

Create a new client object for InstanceTemplates.

By default, this returns an instance of Google::Cloud::Compute::V1::InstanceTemplates::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the InstanceTemplates service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About InstanceTemplates

The InstanceTemplates API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (InstanceTemplates::Rest::Client) — A client object for the specified version.

.instances

def self.instances(version: :v1, &block) -> Instances::Rest::Client

Create a new client object for Instances.

By default, this returns an instance of Google::Cloud::Compute::V1::Instances::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Instances service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Instances

The Instances API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Instances::Rest::Client) — A client object for the specified version.

.interconnect_attachments

def self.interconnect_attachments(version: :v1, &block) -> InterconnectAttachments::Rest::Client

Create a new client object for InterconnectAttachments.

By default, this returns an instance of Google::Cloud::Compute::V1::InterconnectAttachments::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the InterconnectAttachments service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About InterconnectAttachments

The InterconnectAttachments API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (InterconnectAttachments::Rest::Client) — A client object for the specified version.

.interconnect_locations

def self.interconnect_locations(version: :v1, &block) -> InterconnectLocations::Rest::Client

Create a new client object for InterconnectLocations.

By default, this returns an instance of Google::Cloud::Compute::V1::InterconnectLocations::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the InterconnectLocations service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About InterconnectLocations

The InterconnectLocations API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (InterconnectLocations::Rest::Client) — A client object for the specified version.

.interconnects

def self.interconnects(version: :v1, &block) -> Interconnects::Rest::Client

Create a new client object for Interconnects.

By default, this returns an instance of Google::Cloud::Compute::V1::Interconnects::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Interconnects service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Interconnects

The Interconnects API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Interconnects::Rest::Client) — A client object for the specified version.

.license_codes

def self.license_codes(version: :v1, &block) -> LicenseCodes::Rest::Client

Create a new client object for LicenseCodes.

By default, this returns an instance of Google::Cloud::Compute::V1::LicenseCodes::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the LicenseCodes service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About LicenseCodes

The LicenseCodes API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (LicenseCodes::Rest::Client) — A client object for the specified version.

.licenses

def self.licenses(version: :v1, &block) -> Licenses::Rest::Client

Create a new client object for Licenses.

By default, this returns an instance of Google::Cloud::Compute::V1::Licenses::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Licenses service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Licenses

The Licenses API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Licenses::Rest::Client) — A client object for the specified version.

.machine_images

def self.machine_images(version: :v1, &block) -> MachineImages::Rest::Client

Create a new client object for MachineImages.

By default, this returns an instance of Google::Cloud::Compute::V1::MachineImages::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the MachineImages service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About MachineImages

The MachineImages API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (MachineImages::Rest::Client) — A client object for the specified version.

.machine_types

def self.machine_types(version: :v1, &block) -> MachineTypes::Rest::Client

Create a new client object for MachineTypes.

By default, this returns an instance of Google::Cloud::Compute::V1::MachineTypes::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the MachineTypes service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About MachineTypes

The MachineTypes API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (MachineTypes::Rest::Client) — A client object for the specified version.

.network_endpoint_groups

def self.network_endpoint_groups(version: :v1, &block) -> NetworkEndpointGroups::Rest::Client

Create a new client object for NetworkEndpointGroups.

By default, this returns an instance of Google::Cloud::Compute::V1::NetworkEndpointGroups::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the NetworkEndpointGroups service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About NetworkEndpointGroups

The NetworkEndpointGroups API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (NetworkEndpointGroups::Rest::Client) — A client object for the specified version.

.networks

def self.networks(version: :v1, &block) -> Networks::Rest::Client

Create a new client object for Networks.

By default, this returns an instance of Google::Cloud::Compute::V1::Networks::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Networks service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Networks

The Networks API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Networks::Rest::Client) — A client object for the specified version.

.node_groups

def self.node_groups(version: :v1, &block) -> NodeGroups::Rest::Client

Create a new client object for NodeGroups.

By default, this returns an instance of Google::Cloud::Compute::V1::NodeGroups::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the NodeGroups service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About NodeGroups

The NodeGroups API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (NodeGroups::Rest::Client) — A client object for the specified version.

.node_templates

def self.node_templates(version: :v1, &block) -> NodeTemplates::Rest::Client

Create a new client object for NodeTemplates.

By default, this returns an instance of Google::Cloud::Compute::V1::NodeTemplates::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the NodeTemplates service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About NodeTemplates

The NodeTemplates API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (NodeTemplates::Rest::Client) — A client object for the specified version.

.node_types

def self.node_types(version: :v1, &block) -> NodeTypes::Rest::Client

Create a new client object for NodeTypes.

By default, this returns an instance of Google::Cloud::Compute::V1::NodeTypes::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the NodeTypes service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About NodeTypes

The NodeTypes API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (NodeTypes::Rest::Client) — A client object for the specified version.

.packet_mirrorings

def self.packet_mirrorings(version: :v1, &block) -> PacketMirrorings::Rest::Client

Create a new client object for PacketMirrorings.

By default, this returns an instance of Google::Cloud::Compute::V1::PacketMirrorings::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the PacketMirrorings service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About PacketMirrorings

The PacketMirrorings API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (PacketMirrorings::Rest::Client) — A client object for the specified version.

.projects

def self.projects(version: :v1, &block) -> Projects::Rest::Client

Create a new client object for Projects.

By default, this returns an instance of Google::Cloud::Compute::V1::Projects::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Projects service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Projects

The Projects API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Projects::Rest::Client) — A client object for the specified version.

.public_advertised_prefixes

def self.public_advertised_prefixes(version: :v1, &block) -> PublicAdvertisedPrefixes::Rest::Client

Create a new client object for PublicAdvertisedPrefixes.

By default, this returns an instance of Google::Cloud::Compute::V1::PublicAdvertisedPrefixes::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the PublicAdvertisedPrefixes service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About PublicAdvertisedPrefixes

The PublicAdvertisedPrefixes API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (PublicAdvertisedPrefixes::Rest::Client) — A client object for the specified version.

.public_delegated_prefixes

def self.public_delegated_prefixes(version: :v1, &block) -> PublicDelegatedPrefixes::Rest::Client

Create a new client object for PublicDelegatedPrefixes.

By default, this returns an instance of Google::Cloud::Compute::V1::PublicDelegatedPrefixes::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the PublicDelegatedPrefixes service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About PublicDelegatedPrefixes

The PublicDelegatedPrefixes API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (PublicDelegatedPrefixes::Rest::Client) — A client object for the specified version.

.region_autoscalers

def self.region_autoscalers(version: :v1, &block) -> RegionAutoscalers::Rest::Client

Create a new client object for RegionAutoscalers.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionAutoscalers::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionAutoscalers service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionAutoscalers

The RegionAutoscalers API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionAutoscalers::Rest::Client) — A client object for the specified version.

.region_backend_services

def self.region_backend_services(version: :v1, &block) -> RegionBackendServices::Rest::Client

Create a new client object for RegionBackendServices.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionBackendServices::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionBackendServices service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionBackendServices

The RegionBackendServices API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionBackendServices::Rest::Client) — A client object for the specified version.

.region_commitments

def self.region_commitments(version: :v1, &block) -> RegionCommitments::Rest::Client

Create a new client object for RegionCommitments.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionCommitments::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionCommitments service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionCommitments

The RegionCommitments API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionCommitments::Rest::Client) — A client object for the specified version.

.region_disk_types

def self.region_disk_types(version: :v1, &block) -> RegionDiskTypes::Rest::Client

Create a new client object for RegionDiskTypes.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionDiskTypes::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionDiskTypes service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionDiskTypes

The RegionDiskTypes API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionDiskTypes::Rest::Client) — A client object for the specified version.

.region_disks

def self.region_disks(version: :v1, &block) -> RegionDisks::Rest::Client

Create a new client object for RegionDisks.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionDisks::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionDisks service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionDisks

The RegionDisks API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionDisks::Rest::Client) — A client object for the specified version.

.region_health_check_services

def self.region_health_check_services(version: :v1, &block) -> RegionHealthCheckServices::Rest::Client

Create a new client object for RegionHealthCheckServices.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionHealthCheckServices::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionHealthCheckServices service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionHealthCheckServices

The RegionHealthCheckServices API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionHealthCheckServices::Rest::Client) — A client object for the specified version.

.region_health_checks

def self.region_health_checks(version: :v1, &block) -> RegionHealthChecks::Rest::Client

Create a new client object for RegionHealthChecks.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionHealthChecks::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionHealthChecks service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionHealthChecks

The RegionHealthChecks API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionHealthChecks::Rest::Client) — A client object for the specified version.

.region_instance_group_managers

def self.region_instance_group_managers(version: :v1, &block) -> RegionInstanceGroupManagers::Rest::Client

Create a new client object for RegionInstanceGroupManagers.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionInstanceGroupManagers::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionInstanceGroupManagers service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionInstanceGroupManagers

The RegionInstanceGroupManagers API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionInstanceGroupManagers::Rest::Client) — A client object for the specified version.

.region_instance_groups

def self.region_instance_groups(version: :v1, &block) -> RegionInstanceGroups::Rest::Client

Create a new client object for RegionInstanceGroups.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionInstanceGroups::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionInstanceGroups service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionInstanceGroups

The RegionInstanceGroups API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionInstanceGroups::Rest::Client) — A client object for the specified version.

.region_instances

def self.region_instances(version: :v1, &block) -> RegionInstances::Rest::Client

Create a new client object for RegionInstances.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionInstances::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionInstances service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionInstances

The RegionInstances API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionInstances::Rest::Client) — A client object for the specified version.

.region_network_endpoint_groups

def self.region_network_endpoint_groups(version: :v1, &block) -> RegionNetworkEndpointGroups::Rest::Client

Create a new client object for RegionNetworkEndpointGroups.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionNetworkEndpointGroups::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionNetworkEndpointGroups service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionNetworkEndpointGroups

The RegionNetworkEndpointGroups API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionNetworkEndpointGroups::Rest::Client) — A client object for the specified version.

.region_notification_endpoints

def self.region_notification_endpoints(version: :v1, &block) -> RegionNotificationEndpoints::Rest::Client

Create a new client object for RegionNotificationEndpoints.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionNotificationEndpoints::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionNotificationEndpoints service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionNotificationEndpoints

The RegionNotificationEndpoints API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionNotificationEndpoints::Rest::Client) — A client object for the specified version.

.region_operations

def self.region_operations(version: :v1, &block) -> RegionOperations::Rest::Client

Create a new client object for RegionOperations.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionOperations::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionOperations service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionOperations

The RegionOperations API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionOperations::Rest::Client) — A client object for the specified version.

.region_ssl_certificates

def self.region_ssl_certificates(version: :v1, &block) -> RegionSslCertificates::Rest::Client

Create a new client object for RegionSslCertificates.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionSslCertificates::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionSslCertificates service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionSslCertificates

The RegionSslCertificates API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionSslCertificates::Rest::Client) — A client object for the specified version.

.region_target_http_proxies

def self.region_target_http_proxies(version: :v1, &block) -> RegionTargetHttpProxies::Rest::Client

Create a new client object for RegionTargetHttpProxies.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionTargetHttpProxies::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionTargetHttpProxies service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionTargetHttpProxies

The RegionTargetHttpProxies API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionTargetHttpProxies::Rest::Client) — A client object for the specified version.

.region_target_https_proxies

def self.region_target_https_proxies(version: :v1, &block) -> RegionTargetHttpsProxies::Rest::Client

Create a new client object for RegionTargetHttpsProxies.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionTargetHttpsProxies::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionTargetHttpsProxies service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionTargetHttpsProxies

The RegionTargetHttpsProxies API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionTargetHttpsProxies::Rest::Client) — A client object for the specified version.

.region_url_maps

def self.region_url_maps(version: :v1, &block) -> RegionUrlMaps::Rest::Client

Create a new client object for RegionUrlMaps.

By default, this returns an instance of Google::Cloud::Compute::V1::RegionUrlMaps::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the RegionUrlMaps service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About RegionUrlMaps

The RegionUrlMaps API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (RegionUrlMaps::Rest::Client) — A client object for the specified version.

.regions

def self.regions(version: :v1, &block) -> Regions::Rest::Client

Create a new client object for Regions.

By default, this returns an instance of Google::Cloud::Compute::V1::Regions::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Regions service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Regions

The Regions API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Regions::Rest::Client) — A client object for the specified version.

.reservations

def self.reservations(version: :v1, &block) -> Reservations::Rest::Client

Create a new client object for Reservations.

By default, this returns an instance of Google::Cloud::Compute::V1::Reservations::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Reservations service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Reservations

The Reservations API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Reservations::Rest::Client) — A client object for the specified version.

.resource_policies

def self.resource_policies(version: :v1, &block) -> ResourcePolicies::Rest::Client

Create a new client object for ResourcePolicies.

By default, this returns an instance of Google::Cloud::Compute::V1::ResourcePolicies::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the ResourcePolicies service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About ResourcePolicies

The ResourcePolicies API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (ResourcePolicies::Rest::Client) — A client object for the specified version.

.routers

def self.routers(version: :v1, &block) -> Routers::Rest::Client

Create a new client object for Routers.

By default, this returns an instance of Google::Cloud::Compute::V1::Routers::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Routers service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Routers

The Routers API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Routers::Rest::Client) — A client object for the specified version.

.routes

def self.routes(version: :v1, &block) -> Routes::Rest::Client

Create a new client object for Routes.

By default, this returns an instance of Google::Cloud::Compute::V1::Routes::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Routes service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Routes

The Routes API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Routes::Rest::Client) — A client object for the specified version.

.security_policies

def self.security_policies(version: :v1, &block) -> SecurityPolicies::Rest::Client

Create a new client object for SecurityPolicies.

By default, this returns an instance of Google::Cloud::Compute::V1::SecurityPolicies::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the SecurityPolicies service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About SecurityPolicies

The SecurityPolicies API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (SecurityPolicies::Rest::Client) — A client object for the specified version.

.service_attachments

def self.service_attachments(version: :v1, &block) -> ServiceAttachments::Rest::Client

Create a new client object for ServiceAttachments.

By default, this returns an instance of Google::Cloud::Compute::V1::ServiceAttachments::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the ServiceAttachments service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About ServiceAttachments

The ServiceAttachments API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (ServiceAttachments::Rest::Client) — A client object for the specified version.

.snapshots

def self.snapshots(version: :v1, &block) -> Snapshots::Rest::Client

Create a new client object for Snapshots.

By default, this returns an instance of Google::Cloud::Compute::V1::Snapshots::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Snapshots service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Snapshots

The Snapshots API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Snapshots::Rest::Client) — A client object for the specified version.

.ssl_certificates

def self.ssl_certificates(version: :v1, &block) -> SslCertificates::Rest::Client

Create a new client object for SslCertificates.

By default, this returns an instance of Google::Cloud::Compute::V1::SslCertificates::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the SslCertificates service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About SslCertificates

The SslCertificates API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (SslCertificates::Rest::Client) — A client object for the specified version.

.ssl_policies

def self.ssl_policies(version: :v1, &block) -> SslPolicies::Rest::Client

Create a new client object for SslPolicies.

By default, this returns an instance of Google::Cloud::Compute::V1::SslPolicies::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the SslPolicies service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About SslPolicies

The SslPolicies API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (SslPolicies::Rest::Client) — A client object for the specified version.

.subnetworks

def self.subnetworks(version: :v1, &block) -> Subnetworks::Rest::Client

Create a new client object for Subnetworks.

By default, this returns an instance of Google::Cloud::Compute::V1::Subnetworks::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Subnetworks service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Subnetworks

The Subnetworks API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Subnetworks::Rest::Client) — A client object for the specified version.

.target_grpc_proxies

def self.target_grpc_proxies(version: :v1, &block) -> TargetGrpcProxies::Rest::Client

Create a new client object for TargetGrpcProxies.

By default, this returns an instance of Google::Cloud::Compute::V1::TargetGrpcProxies::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the TargetGrpcProxies service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About TargetGrpcProxies

The TargetGrpcProxies API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (TargetGrpcProxies::Rest::Client) — A client object for the specified version.

.target_http_proxies

def self.target_http_proxies(version: :v1, &block) -> TargetHttpProxies::Rest::Client

Create a new client object for TargetHttpProxies.

By default, this returns an instance of Google::Cloud::Compute::V1::TargetHttpProxies::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the TargetHttpProxies service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About TargetHttpProxies

The TargetHttpProxies API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (TargetHttpProxies::Rest::Client) — A client object for the specified version.

.target_https_proxies

def self.target_https_proxies(version: :v1, &block) -> TargetHttpsProxies::Rest::Client

Create a new client object for TargetHttpsProxies.

By default, this returns an instance of Google::Cloud::Compute::V1::TargetHttpsProxies::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the TargetHttpsProxies service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About TargetHttpsProxies

The TargetHttpsProxies API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (TargetHttpsProxies::Rest::Client) — A client object for the specified version.

.target_instances

def self.target_instances(version: :v1, &block) -> TargetInstances::Rest::Client

Create a new client object for TargetInstances.

By default, this returns an instance of Google::Cloud::Compute::V1::TargetInstances::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the TargetInstances service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About TargetInstances

The TargetInstances API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (TargetInstances::Rest::Client) — A client object for the specified version.

.target_pools

def self.target_pools(version: :v1, &block) -> TargetPools::Rest::Client

Create a new client object for TargetPools.

By default, this returns an instance of Google::Cloud::Compute::V1::TargetPools::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the TargetPools service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About TargetPools

The TargetPools API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (TargetPools::Rest::Client) — A client object for the specified version.

.target_ssl_proxies

def self.target_ssl_proxies(version: :v1, &block) -> TargetSslProxies::Rest::Client

Create a new client object for TargetSslProxies.

By default, this returns an instance of Google::Cloud::Compute::V1::TargetSslProxies::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the TargetSslProxies service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About TargetSslProxies

The TargetSslProxies API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (TargetSslProxies::Rest::Client) — A client object for the specified version.

.target_tcp_proxies

def self.target_tcp_proxies(version: :v1, &block) -> TargetTcpProxies::Rest::Client

Create a new client object for TargetTcpProxies.

By default, this returns an instance of Google::Cloud::Compute::V1::TargetTcpProxies::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the TargetTcpProxies service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About TargetTcpProxies

The TargetTcpProxies API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (TargetTcpProxies::Rest::Client) — A client object for the specified version.

.target_vpn_gateways

def self.target_vpn_gateways(version: :v1, &block) -> TargetVpnGateways::Rest::Client

Create a new client object for TargetVpnGateways.

By default, this returns an instance of Google::Cloud::Compute::V1::TargetVpnGateways::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the TargetVpnGateways service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About TargetVpnGateways

The TargetVpnGateways API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (TargetVpnGateways::Rest::Client) — A client object for the specified version.

.url_maps

def self.url_maps(version: :v1, &block) -> UrlMaps::Rest::Client

Create a new client object for UrlMaps.

By default, this returns an instance of Google::Cloud::Compute::V1::UrlMaps::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the UrlMaps service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About UrlMaps

The UrlMaps API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (UrlMaps::Rest::Client) — A client object for the specified version.

.vpn_gateways

def self.vpn_gateways(version: :v1, &block) -> VpnGateways::Rest::Client

Create a new client object for VpnGateways.

By default, this returns an instance of Google::Cloud::Compute::V1::VpnGateways::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the VpnGateways service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About VpnGateways

The VpnGateways API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (VpnGateways::Rest::Client) — A client object for the specified version.

.vpn_tunnels

def self.vpn_tunnels(version: :v1, &block) -> VpnTunnels::Rest::Client

Create a new client object for VpnTunnels.

By default, this returns an instance of Google::Cloud::Compute::V1::VpnTunnels::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the VpnTunnels service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About VpnTunnels

The VpnTunnels API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (VpnTunnels::Rest::Client) — A client object for the specified version.

.zone_operations

def self.zone_operations(version: :v1, &block) -> ZoneOperations::Rest::Client

Create a new client object for ZoneOperations.

By default, this returns an instance of Google::Cloud::Compute::V1::ZoneOperations::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the ZoneOperations service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About ZoneOperations

The ZoneOperations API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (ZoneOperations::Rest::Client) — A client object for the specified version.

.zones

def self.zones(version: :v1, &block) -> Zones::Rest::Client

Create a new client object for Zones.

By default, this returns an instance of Google::Cloud::Compute::V1::Zones::Rest::Client for version V1 of the API. However, you can specify specify a different API version by passing it in the version parameter. If the Zones service is supported by that API version, and the corresponding gem is available, the appropriate versioned client will be returned.

About Zones

The Zones API.

Parameter
  • version (::String, ::Symbol) (defaults to: :v1) — The API version to connect to. Optional. Defaults to :v1.
Returns
  • (Zones::Rest::Client) — A client object for the specified version.

Constants

VERSION

value: "0.2.0"