Estado de asistencia de la versión del SDK

Esta página enumera el estado de compatibilidad para las versiones del SDK de Apache Beam y Cloud Dataflow:

SDK 2.x de Apache Beam

Apache Beam es un proyecto de código abierto dirigido por la comunidad. Google es parte de la comunidad, pero no somos dueños del proyecto ni controlamos el proceso de actualización. Podemos informar errores o enviar parches a la base de código de Apache Beam en nombre de los clientes de Cloud Dataflow, pero no podemos crear revisiones o actualizaciones oficiales de Apache Beam según demanda.

Sin embargo, la comunidad de Apache Beam designa actualizaciones específicas como las de soporte a largo plazo (LTS). Las actualizaciones de LTS reciben parches para corregir problemas más graves durante un período designado. Consulta la página de las políticas de Apache Beam para obtener más información sobre las políticas de actualizaciones.

Nota: No se admiten las versiones de SDK de desarrollo (marcadas como -SNAPSHOT para Java y .dev para Python).

Las siguientes tablas contienen el estado de compatibilidad de los SDK 2.x de Apache Beam:

Java

Cloud Dataflow admite los componentes de SDK de Apache Beam para las actualizaciones de SDK que se enumeran a continuación. Estos componentes se probaron exhaustivamente con Cloud Dataflow. No se admiten las funciones experimentales.

Consulta las notas de actualización de Apache Beam para obtener información sobre los cambios.

Versiones del SDK Estado Componentes compatibles Detalles
2.9.0 Compatible org.apache.beam:beam-sdks-java-core
org.apache.beam:beam-sdks-java-io-google-cloud-platform
org.apache.beam:beam-sdks-java-extensions-google-cloud-platform-core
org.apache.beam:beam-sdks-java-extensions-protobuf
org.apache.beam:beam-runners-direct-java
org.apache.beam:beam-runners-google-cloud-dataflow-java
org.apache.beam:beam-model-pipeline
org.apache.beam:beam-runners-core-construction-java
org.apache.beam:beam-model-job-management
org.apache.beam:beam-sdks-java-io-kafka
Problema conocido: Los usuarios que habilitan la versión experimental de Streaming Engine (Beta) no deberían actualizar a SDK 2.9.0 debido a un problema conocido. Si eliges usar SDK 2.9.0, también debes configurar la función experimental enable_conscrypt_security_provider para habilitar Conscrypt, que tiene problemas de estabilidad conocidos.

Esta versión dejará de estar disponible el 13 de diciembre de 2019.

2.8.0 Compatible org.apache.beam:beam-sdks-java-core
org.apache.beam:beam-sdks-java-io-google-cloud-platform
org.apache.beam:beam-sdks-java-extensions-google-cloud-platform-core
org.apache.beam:beam-sdks-java-extensions-protobuf
org.apache.beam:beam-runners-direct-java
org.apache.beam:beam-runners-google-cloud-dataflow-java
org.apache.beam:beam-model-pipeline
org.apache.beam:beam-runners-core-construction-java
org.apache.beam:beam-model-job-management
org.apache.beam:beam-sdks-java-io-kafka
Problema conocido: Las canalizaciones podrían atascarse debido a un problema con la biblioteca de Conscrypt. Si observas errores en Stackdriver Logging con seguimientos de pila que incluyen llamadas relacionadas, es posible que tengas este problema. Para resolver el problema, actualiza a SDK 2.9.0 o regresa a SDK 2.4.0.

Esta versión dejará de estar disponible el 25 de octubre de 2019.

2.7.0 LTS Compatible org.apache.beam:beam-sdks-java-core
org.apache.beam:beam-sdks-java-io-google-cloud-platform
org.apache.beam:beam-sdks-java-extensions-google-cloud-platform-core
org.apache.beam:beam-sdks-java-extensions-protobuf
org.apache.beam:beam-runners-direct-java
org.apache.beam:beam-runners-google-cloud-dataflow-java
org.apache.beam:beam-model-pipeline
org.apache.beam:beam-runners-core-construction-java
org.apache.beam:beam-model-job-management
org.apache.beam:beam-sdks-java-io-kafka

2.7.0 es una versión de soporte a largo plazo (LTS) y recibirá parches hasta el 16 de mayo de 2019.

Problema conocido: Las canalizaciones podrían atascarse debido a un problema con la biblioteca de Conscrypt. Si observas errores en Stackdriver Logging con seguimientos de pila que incluyen llamadas relacionadas, es posible que tengas este problema. Para resolver el problema, actualiza a SDK 2.9.0 o regresa a SDK 2.4.0.

Esta versión dejará de estar disponible el 3 de octubre de 2019.

2.6.0 Compatible org.apache.beam:beam-sdks-java-core
org.apache.beam:beam-sdks-java-io-google-cloud-platform
org.apache.beam:beam-sdks-java-extensions-google-cloud-platform-core
org.apache.beam:beam-sdks-java-extensions-protobuf
org.apache.beam:beam-runners-direct-java
org.apache.beam:beam-runners-google-cloud-dataflow-java
org.apache.beam:beam-model-pipeline
org.apache.beam:beam-runners-core-construction-java
org.apache.beam:beam-model-job-management
org.apache.beam:beam-sdks-java-io-kafka
Problema conocido: Las canalizaciones podrían atascarse debido a un problema con la biblioteca de Conscrypt. Si observas errores en Stackdriver Logging con seguimientos de pila que incluyen llamadas relacionadas, es posible que tengas este problema. Para resolver el problema, actualiza a SDK 2.9.0 o regresa a SDK 2.4.0.

Esta versión dejará de estar disponible el 8 de agosto de 2019.

2.5.0 Compatible org.apache.beam:beam-sdks-java-core
org.apache.beam:beam-sdks-java-io-google-cloud-platform
org.apache.beam:beam-sdks-java-extensions-google-cloud-platform-core
org.apache.beam:beam-sdks-java-extensions-protobuf
org.apache.beam:beam-runners-direct-java
org.apache.beam:beam-runners-google-cloud-dataflow-java
org.apache.beam:beam-model-pipeline
org.apache.beam:beam-runners-core-construction-java
org.apache.beam:beam-model-job-management
org.apache.beam:beam-sdks-java-io-kafka
Problema conocido: Las canalizaciones podrían atascarse debido a un problema con la biblioteca de Conscrypt. Si observas errores en Stackdriver Logging con seguimientos de pila que incluyen llamadas relacionadas, es posible que tengas este problema. Para resolver el problema, actualiza a SDK 2.9.0 o regresa a SDK 2.4.0.

Esta versión dejará de estar disponible el 6 de junio de 2019.

2.4.0 Compatible org.apache.beam:beam-sdks-java-core
org.apache.beam:beam-sdks-java-io-google-cloud-platform
org.apache.beam:beam-sdks-java-extensions-google-cloud-platform-core
org.apache.beam:beam-sdks-java-extensions-protobuf
org.apache.beam:beam-runners-direct-java
org.apache.beam:beam-runners-google-cloud-dataflow-java
org.apache.beam:beam-model-pipeline
org.apache.beam:beam-runners-core-construction-java
org.apache.beam:beam-model-job-management
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.3.0 Compatible org.apache.beam:beam-sdks-java-core
org.apache.beam:beam-sdks-java-io-google-cloud-platform
org.apache.beam:beam-sdks-java-extensions-google-cloud-platform-core
org.apache.beam:beam-sdks-java-extensions-protobuf
org.apache.beam:beam-runners-direct-java
org.apache.beam:beam-runners-google-cloud-dataflow-java
org.apache.beam:beam-model-pipeline
org.apache.beam:beam-runners-core-construction-java
org.apache.beam:beam-model-job-management
Esta versión dejará de estar disponible el 30 de enero de 2019.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.2.0 Obsoleta org.apache.beam:beam-sdks-java-core
org.apache.beam:beam-sdks-java-io-google-cloud-platform
org.apache.beam:beam-sdks-java-extensions-google-cloud-platform-core
org.apache.beam:beam-sdks-java-extensions-protobuf
org.apache.beam:beam-runners-direct-java
org.apache.beam:beam-runners-google-cloud-dataflow-java
org.apache.beam:beam-model-pipeline
org.apache.beam:beam-runners-core-construction-java
org.apache.beam:beam-model-job-management
Fuera de servicio a partir del 2 de diciembre de 2018.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.1.0 Obsoleta org.apache.beam:beam-sdks-java-core
org.apache.beam:beam-sdks-java-io-google-cloud-platform
org.apache.beam:beam-sdks-java-extensions-google-cloud-platform-core
org.apache.beam:beam-sdks-java-extensions-protobuf
org.apache.beam:beam-runners-direct-java
org.apache.beam:beam-runners-google-cloud-dataflow-java
org.apache.beam:beam-model-pipeline
org.apache.beam:beam-runners-core-construction-java
org.apache.beam:beam-model-job-management
Fuera de servicio a partir del 23 de agosto de 2018.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.0.0 Obsoleta org.apache.beam:beam-sdks-java-core
org.apache.beam:beam-sdks-java-io-google-cloud-platform
org.apache.beam:beam-sdks-java-extensions-google-cloud-platform-core
org.apache.beam:beam-sdks-java-extensions-protobuf
org.apache.beam:beam-runners-direct-java
org.apache.beam:beam-runners-google-cloud-dataflow-java
org.apache.beam:beam-model-pipeline
org.apache.beam:beam-runners-core-construction-java
org.apache.beam:beam-model-job-management
Fuera de servicio a partir del 17 de mayo de 2018.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.

Python

Versiones del SDK Estado Detalles
2.9.0 Compatible Esta versión dejará de estar disponible el 13 de diciembre de 2019.
2.8.0 Compatible Esta versión dejará de estar disponible el 25 de octubre de 2019.
2.7.0 LTS Compatible

2.7.0 es una versión de soporte a largo plazo (LTS) y recibirá parches hasta el 16 de mayo de 2019.

Esta versión dejará de estar disponible el 3 de octubre de 2019.

2.6.0 Compatible Esta versión dejará de estar disponible el 8 de agosto de 2019.
2.5.0 Compatible Esta versión dejará de estar disponible el 6 de junio de 2019.
2.4.0 Compatible Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.3.0 Compatible Esta versión dejará de estar disponible el 30 de enero de 2019.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.2.0 Obsoleta Fuera de servicio a partir del 2 de diciembre de 2018.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.1.1
2.1.0
Obsoleta Fuera de servicio a partir del 23 de agosto de 2018.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.0.0 Obsoleta Fuera de servicio a partir del 17 de mayo de 2018.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.

SDK 2.x de Cloud Dataflow

Nota: No se admiten las versiones de SDK de desarrollo (marcadas como -SNAPSHOT para Java y .dev para Python).

Las siguientes tablas contienen el estado de compatibilidad de los SDK 2.x de Cloud Dataflow:

Java

Consulta las notas de la versión del SDK 2.x de Cloud Dataflow para Java si deseas obtener información sobre los cambios.

Versiones del SDK Estado Detalles
2.5.0 Compatible Esta versión dejará de estar disponible el 6 de junio de 2019.
2.4.0 Compatible Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.3.0 Compatible Esta versión dejará de estar disponible el 30 de enero de 2019.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.2.0 Obsoleta Fuera de servicio a partir del 2 de diciembre de 2018.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.1.0 Obsoleta Fuera de servicio a partir del 23 de agosto de 2018.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.0.0 Obsoleta Fuera de servicio a partir del 17 de mayo de 2018.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.0.0-Beta3
2.0.0-Beta2
2.0.0-Beta1
Fuera de servicio Fuera de servicio a partir del 28 de febrero de 2018.

Python

Consulta las notas de la actualización del SDK 2.x de Cloud Dataflow para Python si deseas obtener información sobre los cambios.

Versiones del SDK Estado Detalles
2.5.0 Compatible Esta versión dejará de estar disponible el 6 de junio de 2019.
2.4.0 Compatible Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.3.0 Compatible Esta versión dejará de estar disponible el 30 de enero de 2019.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.2.0 Obsoleta Fuera de servicio a partir del 2 de diciembre de 2018.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
2.1.1 Obsoleta Fuera de servicio a partir del 23 de agosto de 2018.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
Corrige un problema de compatibilidad con el paquete six de Python.
Consulta las notas de la versión para obtener más información.
2.1.0 Obsoleta Fuera de servicio a partir del 23 de agosto de 2018.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
Esta versión tiene un problema de compatibilidad con el paquete six 1.11.0 de Python.
Consulta las notas de la versión para obtener más información.
2.0.0 Obsoleta Fuera de servicio a partir del 17 de mayo de 2018.
Esta versión se retirará de servicio el 25 de marzo de 2019, debido a la suspensión de la compatibilidad con JSON-RPC y los extremos globales del lote HTTP.
Esta versión tiene un problema de compatibilidad con el paquete six 1.11.0 de Python.
Consulta las notas de la versión para obtener más información.
0.6.0
0.5.5
0.5.1
0.4.4
0.4.3
0.4.2
0.4.1
0.4.0
Fuera de servicio Fuera de servicio a partir del 29 de enero de 2018.
0.2.7 y versiones anteriores Fuera de servicio Fuera de servicio a partir del 23 de marzo de 2017.

SDK 1.x de Cloud Dataflow

La siguiente tabla contiene el estado de compatibilidad de los SDK 1.x de Cloud Dataflow para Java: Consulta las notas de la versión del SDK 1.x de Cloud Dataflow para Java si deseas obtener información sobre los cambios.

Versiones del SDK Estado Detalles
1.9.1
1.9.0
No compatible No es compatible desde el 16 de octubre de 2018.
1.8.1
1.8.0
No compatible No es compatible desde el 9 de abril de 2018.
1.7.0
No compatible No es compatible desde el 12 de marzo de 2018.
1.6.1
1.6.0
No compatible No es compatible desde el 22 de enero de 2018.
1.5.1
1.5.0
1.4.0
1.3.0
No compatible No es compatible desde el 1 de octubre de 2017.
1.2.1
1.2.0
1.1.0
1.0.0
No compatible No es compatible desde el 26 de febrero de 2017.
Anteriores a la versión 1.0.0 (incluida la 0.4.* y 0.3.*) No compatible
¿Te sirvió esta página? Envíanos tu opinión:

Enviar comentarios sobre…

¿Necesitas ayuda? Visita nuestra página de asistencia.