Ajude a moldar o futuro da entrega de software e manifeste-se respondendo à pesquisa sobre o estado de DevOps 2202.

Guia de início rápido: como executar um aplicativo do Kubernetes com o Cloud Code

Veja nesta página como começar a usar o Cloud Code.

Neste guia de início rápido, você configurará um novo aplicativo do Kubernetes usando um modelo inicial do Hello World, criará um cluster, executará o aplicativo nesse cluster, iniciará a recriação contínua para desenvolver o aplicativo iterativamente, depurar o {101 }executando código, além de ver os registros do aplicativo em execução.

Se você estiver executando este guia de início rápido no Apple Series Series da série, o aplicativo será criado usando o Cloud Build, o que pode gerar cobranças. Para mais informações, consulte Suporte do Cloud Code para silício da série Apple M.

Como criar um novo aplicativo "Olá mundo" com o Cloud Code

Antes de começar

Se quiser usar o Google Cloud, você precisará criar ou selecionar um projeto do Google Cloud e ativar o faturamento no seu projeto.

Como alternativa, use um cluster hospedado em qualquer outra plataforma de nuvem ou em um cluster local do Kubernetes com ferramentas como minikube e Docker Desktop (links em inglês).

Como instalar o plug-in

Para instalar o plug-in do Cloud Code, faça o seguinte:

  1. Instale a versão 2020.2 (em inglês) do ambiente de desenvolvimento integrado JetBrains, como IntelliJ Ultimate/Community, PyCharm Professional/Community, WebStorm, GoLand), caso ainda não tenha feito isso.

  2. Para todas as plataformas de nuvem, verifique se o cliente do Docker (autenticado com o registro do Docker) está instalado no PATH da sua máquina. A pasta ficará visível em um diretório no PATH). Para verificar se você já tem o Docker instalado, execute o comando docker -v.

    O Cloud Code instala e gerencia automaticamente as seguintes dependências no ambiente de desenvolvimento integrado: kubectl, Skaffold e Cloud SDK.

  3. Abra o IntelliJ IDEA ou qualquer ambiente de desenvolvimento integrado compatível do JetBrains.

  4. No mercado de plug-ins, procure e instale o plug-in do Cloud Code.

    O mercado de plug-ins pode ser acessado pelos seguintes menus:

    • Windows ou Linux: Arquivo > Configurações > Plug-ins
    • macOS: IntelliJ IDEA > Preferências > Plug-ins

    Se você estiver executando o Cloud Code no silício da série Apple M, será solicitado que você instale o Rosetta 2. Isso permite que o Cloud Code instale o kubectl como uma dependência gerenciada. Se você preferir não instalar o Rosetta 2, desative as dependências gerenciadas (IntelliJ IDEA > Preferências > Ferramentas > Cloud Code > Dependências) e instale sua própria versão ARM do kubectl conforme descrito em Versões personalizadas de dependências.

    Se necessário, você precisará reiniciar o ambiente de desenvolvimento integrado para ativar o plug-in.

Como criar um aplicativo

Para criar um novo aplicativo usando uma amostra existente:

  1. No seu IDE, abra Arquivo e Novo projeto e selecione Cloud Code: Kubernetes.
  2. Selecione um modelo Hello World na lista de aplicativos iniciais. Lista de modelos disponíveis: Python, Go, NodeJS, Java hello world e aplicativos de livro de visitas
  3. Se estiver usando o IntelliJ IDEA, você será solicitado a especificar onde sua imagem do contêiner está armazenada.

    Especifique o repositório de imagem padrão no campo usando o formato gcr.io/{gcp-project-name} ou docker.io/{account}

    Dependendo da sua escolha de registro de contêiner, escolha um formato apropriado:

    • Se você estiver usando o GKE, poderá armazenar suas imagens no Container Registry.

      O campo vem com preenchimento automático para você encontrar facilmente a imagem associada ao projeto do Google Cloud preferido e ao cluster ativo, se houver. Se você não tiver um cluster ou quiser um novo para este guia de início rápido, crie um na seção a seguir.

      Use o seguinte formato:

      gcr.io/{project-name}, em que {project-name} é o nome do projeto do Google Cloud (que contém ou onde você pretende criar o cluster).

    • Se você optar por armazenar suas imagens no Docker Hub (verifique se está autenticado corretamente se estiver usando um repositório particular do Docker Hub), use o seguinte formato:

      docker.io/{account}, em que {account} é o nome da sua conta do Docker Hub.

    • Se você estiver executando um cluster local, como o Minikube ou o Docker Desktop, pule esta etapa e clique em Próxima.

  4. Escolha um nome para seu projeto.

    Depois que você clicar em Concluir, o Cloud Code clonará o modelo escolhido e abrirá o projeto recém-criado para uso.

    • Para modelos Java, você precisa importar os projetos necessários do Maven para sincronizar o pom.xml. Clique em Adicionar como projeto Maven e, em seguida, clique em Importar alterações.

      Notificação pom.xml não gerenciada

      Importar notificação de mudanças no Maven

Como criar um cluster

Se você já tem um cluster configurado para trabalhar com ferramentas do Kubernetes, como o kubectl, que pode ser usado neste guia de início rápido, avance para como desenvolver seu aplicativo.

Para desenvolver seu aplicativo, você precisará de um cluster do Kubernetes associado (hospedado localmente com o minikube ou usando uma plataforma de nuvem, como um cluster do Google Kubernetes Engine (GKE)). para começar. Se você ainda não tem um cluster para usar neste guia de início rápido, crie um usando suas instruções específicas da plataforma do Cloud.

Se você optar por usar o Google Cloud, será possível criar um cluster do GKE usando o terminal do Cloud Code ou o Console do Google Cloud:

Como usar o terminal do Cloud Code

  1. Com a janela do projeto aberta no ambiente de desenvolvimento integrado, abra o terminal do Cloud Code usando a barra lateral na parte inferior do ambiente de desenvolvimento integrado ou o menu Ferramentas Ferramentas > Cloud Code > Tools > Cloud Code Terminal.

  2. Defina seu projeto padrão, caso ainda não tenha feito:

    gcloud config set project PROJECT_ID
    
  3. Para criar um cluster, execute o seguinte comando:

    gcloud container clusters create CLUSTER_NAME --zone=COMPUTE_ZONE
    

    Por exemplo, para criar um cluster chamado test-cluster, localizado na zona us-central1-a, execute gcloud container clusters create test-cluster --zone=us-central1-a.

    Para detalhes sobre mais personalização de cluster, consulte a documentação de referência do comando.

  4. Depois de criar um cluster, adicione-o ao arquivo kubeconfig local executando o seguinte comando:

    gcloud container clusters get-credentials CLUSTER_NAME --zone=COMPUTE_ZONE
    

    Isso também define o cluster especificado para o contexto ativo.

Usando o Console do Cloud

  1. Abra o menu do Google Kubernetes Engine.

    Abra o menu do Google Kubernetes Engine

  2. Clique em Criar.

  3. Selecione o tipo de cluster de sua preferência (padrão ou automático) e clique em Configurar.

  4. Escolha o nome e o local do cluster de sua preferência.

  5. Clique em Criar para concluir a criação do cluster.

    Para mais detalhes sobre a personalização de campos, consulte Como criar um cluster zonal.

  6. Depois de criar um cluster, adicione-o ao arquivo kubeconfig local e defina o cluster no contexto ativo executando o seguinte comando:

    gcloud container clusters get-credentials CLUSTER_NAME --zone=COMPUTE_ZONE
    

Desenvolver um aplicativo

Para iniciar o desenvolvimento do aplicativo no Kubernetes:

  1. Se você estiver executando em um cluster hospedado em uma plataforma de nuvem, verifique se definiu onde as imagens de contêiner estão armazenadas para Desenvolver no Kubernetes.
  2. Escolha o destino de execução Desenvolver no Kubernetes a partir do seletor de configuração Executar/Depurar na barra de navegação.

    Isso garante que todas as alterações de código sejam criadas, enviadas e implantadas automaticamente em uma nova versão do aplicativo.

    Configurações de execução de implantação do Kubernetes

  3. Para iniciar o ciclo de desenvolvimento no cluster do Kubernetes, clique na ação de execução para Desenvolver no Kubernetes Ícone do botão de execução.

  4. Na janela de saída, veja os registros de aplicativos recebidos.

    Depois que a implantação for iniciada, você verá a lista de portas encaminhadas para o aplicativo implantado.

    Como visualizar registros de stream do aplicativo Kubernetes

  5. Depois que a implantação for bem-sucedida, você receberá uma notificação informando que seu serviço pode ser acessado usando URLs locais. Clique em Visualizar para abrir o log de eventos e, em seguida, clique no link para abrir o navegador com o aplicativo em execução.

    Notificação informando que o URL para acessar o aplicativo ativo agora está disponível no Log de eventos

    Como usar o log de eventos para encontrar serviços encaminhados por porta

Depuração do aplicativo

Para depurar seu aplicativo, faça o seguinte:

  1. Se você estiver executando em um cluster hospedado em uma plataforma de nuvem, verifique se definiu onde as imagens de contêiner estão armazenadas para Desenvolver no Kubernetes.
  2. Clique na ação de depuração Ícone do botão de execução para Desenvolver no Kubernetes para iniciar o ciclo de desenvolvimento no modo de depuração no cluster do Kubernetes.

    Como iniciar o ciclo de desenvolvimento do cluster do Kubernetes no modo de depuração

  3. O Cloud Code anexará uma sessão de depuração. Quando a janela é concluída, a janela da ferramenta de depuração é aberta, confirmando a conexão (na guia "Console").

    Agora é possível depurar no cluster ativo do Kubernetes.

  4. Clique na divisão na linha executável do código em que você quer adicionar um ponto de interrupção.

    Os círculos preenchidos em vermelho indicam pontos de interrupção ativos, enquanto os círculos vazios destacados em vermelho indicam pontos de interrupção desativados.

  5. Quando você envia uma nova solicitação ao aplicativo, ela é interrompida nessa linha escolhida.

    Sessão do depurador do Kubernetes

  6. Para encerrar a sessão de depuração, clique no ícone de parada na configuração de execução do Develop on Kubernetes.

Como executar o aplicativo

Para executar um aplicativo no Kubernetes:

  1. Verifique se você definiu onde as imagens de contêiner são armazenadas para Executar no Kubernetes.
  2. Verifique se você está pronto para implantar o aplicativo no contexto do Kubernetes de sua preferência.

    Selecione Edit Configurations... no seletor de configurações da execução/depuração na barra de navegação. Na guia "Run" da configuração do Run on Kubernetes, é possível especificar a preferência de implantação.

  3. Agora que seu aplicativo está pronto para implantação, escolha Executar no Kubernetes no seletor de configuração "Executar/Depurar" na barra de navegação para implantar o aplicativo.

    Configurações de execução de implantação do Kubernetes

  4. Clique em Run on Kubernetes Ícone do botão de execução.

  5. Como no desenvolvimento no Kubernetes, é possível ver os registros de aplicativos recebidos na janela de saída.

  6. Após a implantação bem-sucedida, você será notificado de que o serviço pode ser acessado usando URLs locais. Clique em Visualizar para abrir o log de eventos.

    Em Log de eventos, encontre a porta em que o aplicativo está sendo exibido. Para abrir o navegador com o aplicativo em execução, clique no link.

  7. Visite http://localhost:{port-number} para acessar seu aplicativo recém-implantado.

    Aplicativo em http://localhost:{port-number} exibindo "Olá mundo!"

Como ver registros

Além de ver uma transmissão ao vivo dos registros de pods em execução na saída do terminal enquanto você desenvolve e executa seu aplicativo, é possível ver os registros de um pod específico navegando até o Kubernetes Explorer.

Para ver os registros de um pod específico, siga estas etapas:

  1. Navegue até o Kubernetes Explorer. Ele pode ser acessado no painel lateral à direita ou usando Ferramentas > Cloud Code > Kubernetes > Visualizar o Cluster Explorer.

    Painel do Kubernetes Explorer aberto usando a guia na barra de tarefas do lado direito

  2. Selecione o pod do qual você quer ver os registros.

  3. Clique com o botão direito do mouse no pod e selecione Registros de stream. Outra opção é fazer streaming de registros para contêineres individuais em execução em pods.

    Isso gera registros para o Console do Kubernetes Explorer.

    Streaming de registros de um pod usando o menu do botão direito do mouse para gerar registros no Console do Kubernetes Explorer

Como limpar

Para evitar cobranças na sua conta pelos recursos usados neste guia de início rápido, exclua o cluster e o projeto que você criou.

Se você estiver usando o Google Cloud e quiser excluir seu projeto (e os recursos associados, incluindo os clusters do GKE):

  1. Acesse a página Projetos no Console do Cloud:

    Acessar a página "Projetos"

  2. Selecione o projeto criado para este guia de início rápido e clique no ícone de lixeira ao lado dele para excluí-lo.

    Isso encerrará o projeto e programará a remoção dele.

A seguir

Como receber suporte

Para enviar feedback, relate um problema no GitHub ou faça uma pergunta no Stack Overflow.