Como criar um aplicativo para o ambiente padrão do App Engine

O App Engine é uma plataforma sem servidor totalmente gerenciada para desenvolver e hospedar aplicativos da Web em grande escala.

Neste documento, descrevemos como criar um aplicativo (ou importar um projeto existente) para o ambiente padrão do App Engine com o Cloud Code.

Antes de começar

  • Instale e configure a versão 2019.3 ou posterior do ambiente de desenvolvimento integrado JetBrains (como IntelliJ Ultimate/Community, PyCharm Professional/Community, WebStorm e GoLand) no PATH da sua máquina.
  • Para instalar o plug-in do Cloud Code, siga estas instruções:

    • Abra o IntelliJ IDEA ou qualquer ambiente de desenvolvimento integrado compatível do JetBrains.
    • Acesse o mercado de plug-ins em Arquivo > Configurações > Plug-ins. Como opção, no Mac OS X acesse IntelliJ IDEA > Preferences > Plugins e procure o plug-in do Cloud Code para instalá-lo.

    Talvez seja necessário reiniciar o ambiente de desenvolvimento integrado para ativar o plug-in.

Como criar um novo aplicativo

É possível criar um novo aplicativo com o novo assistente de projeto ou importando um projeto existente no Cloud Source Repositories.

Como usar o novo assistente de projeto

Para criar um novo projeto, você pode usar o assistente de novo projeto do IntelliJ para gerar um aplicativo de modelo como ponto de partida para seu próprio aplicativo.

Crie um projeto novo da seguinte maneira:

  1. Selecione Arquivo > Novo > Projeto para exibir a caixa de diálogo Novo projeto.

  2. Escolha Java no painel à esquerda.

  3. Na seção Bibliotecas e frameworks adicionais, marque a caixa Google App Engine para seu ambiente.

    Novo projeto Java com o ambiente padrão do Google App Engine selecionado em bibliotecas e estruturas adicionais.

  4. Selecione as outras bibliotecas que você quer adicionar ao classpath do seu aplicativo. A API Servlet é selecionada por padrão.

  5. Clique em Avançar.

  6. Digite o Nome do projeto.

  7. Insira um Local do projeto se você não quiser manter o padrão.

  8. Atualize os campos na seção Mais configurações se você não quiser manter os padrões.

  9. Clique em Concluir.

Como fazer o check-out de um projeto existente

Faça o check-out do seu projeto existente no Cloud Source Repositories da maneira a seguir:

  1. Escolha VCS > Check-out do controle de versões > Conseguir o controle de versões…

  2. Selecione "Google Cloud" na lista suspensa "Controle de versões" e clique em "Clonar".
  3. Na caixa de diálogo Clonar usando o Google Cloud, selecione o projeto do Cloud associado ao seu projeto em Projeto do Cloud.
  4. Selecione seu Cloud Repository.
  5. Selecione o diretório pai em Parent Directory.
  6. Digite o nome do diretório em Directory Name.
  7. Clique em Clone.

Como adicionar suporte de biblioteca

Se você nunca adicionou um suporte de biblioteca ao aplicativo, o IntelliJ IDEA solicitará a configuração da biblioteca depois de detectar que você abriu um aplicativo do App Engine.

  1. Clique com o botão direito do mouse no projeto.

  2. Escolha Adicionar suporte de biblioteca.

  3. Selecione a caixa ambiente padrão do App Engine.

    Outra opção é adicionar suporte ao framework do App Engine por meio do menu Cloud Code:

    1. Selecione Ferramentas > Cloud Code > Adicionar suporte do App Engine > Ambiente padrão do Google App Engine.

    2. Selecione o módulo a que quer adicionar o suporte do framework.

    3. Clique em OK.

    4. Selecione as bibliotecas que você quer adicionar ao seu projeto.

    5. Clique em OK.

    A seguir

    Agora que você criou um aplicativo, basta executar e depurar na estação de trabalho.

    Além disso, também é possível implantá-lo no ambiente padrão do App Engine.

    Como conseguir suporte

    Acesse o GitHub para enviar feedback e informar problemas ou o Stack Overflow (ambos em inglês) para fazer perguntas.