Cloud TPU Supported Versions

Cloud TPU currently supports an n and n+1 version policy, where a TensorFlow version n is supported for 2 months after support for version n+1 is announced. After 2 months, the TensorFlow version expires. You can no longer create a Cloud TPU with an expired TensorFlow version, and existing Cloud TPU instances are disabled.

When Cloud TPU reaches general availability (GA), stable TensorFlow releases will be supported for a longer period of time.

Supported TensorFlow versions

TensorFlow version Cloud TPU support start Cloud TPU support end
1.9 July 2, 2018 (End date not yet set)
1.8 April 20, 2018 (End date not yet set)
1.7 April 2, 2018 (End date not yet set)
Was this page helpful? Let us know how we did:

Send feedback about...