Afficher des rapports d'erreurs dans Error Reporting

Ce document explique comment accéder aux rapports d'erreurs de la suite Google Cloud Operations et comment les afficher dans l'onglet "Error Reporting" (Rapports d'erreurs) de Cloud Tools for Visual Studio.

Avant de commencer

Configurez votre application pour qu'elle enregistre les exceptions dans Cloud Logging.

Accéder à l'onglet Error Reporting

Pour accéder aux rapports d'erreurs dans Visual Studio et les afficher, sélectionnez Tools -> Google Cloud Tools -> Show Stackdriver Error Reporting (Outils -> Outils Google Cloud -> Afficher Stackdriver Error Reporting).

Image montrant l'onglet Stackdriver Error Reporting

Informations concernant les rapports d'erreurs

Les rapports affichent les éléments suivants :

ColonneDescription
Occurrences Nombre d'occurrences de l'erreur pendant la période sélectionnée.
Users (utilisateurs) Nombre d'utilisateurs affectés par l'erreur pendant la période sélectionnée.
Error (erreur) Affiche les informations d'erreur extraites de sa trace de pile, y compris le message d'erreur et son emplacement de code.
Seen in (emplacement) Répertorie le service et la version pour lesquels l'erreur se produit.
First seen (première occurrence) Heure à laquelle l'erreur s'est produite pour la première fois. Un tri sur cette colonne permet d'identifier les erreurs les plus récentes.
Last seen (dernière occurrence) Heure à laquelle l'erreur s'est produite pour la dernière fois. Un tri sur cette colonne permet d'identifier les erreurs qui se produisent encore. Vous pouvez également inverser le tri pour identifier les erreurs qui ne se produisent plus.
Status (état) Le cas échéant, le code d'état HTTP affiché avec cette erreur.

Error Reporting analyse les traces de la pile pour supprimer les erreurs en double et regrouper les erreurs en fonction des frameworks courants utilisés par le langage de programmation de votre application.

Vous pouvez sélectionner un bouton de période pour n'afficher que les erreurs qui se produisent pendant la période spécifiée. Par exemple, lorsque vous cliquez sur 1 hour (1 heure), les erreurs survenues au cours de la dernière heure s'affichent.

Vous pouvez cliquer sur Auto reload (Actualisation automatique) pour actualiser la liste toutes les 10 secondes.

Afficher les détails d'une erreur

Pour afficher les détails d'une erreur spécifique, cliquez sur la ligne correspondante dans la liste des erreurs. L'onglet Detail View (Vue détaillée) de l'erreur s'affiche.

Image montrant l'onglet Detail View (Vue détaillée) pour l'erreur sélectionnée

Vous pouvez consulter l'historique de l'erreur sélectionnée et accéder aux informations de diagnostic contenues dans une série d'exemples d'erreurs. Les applications C# génèrent des exemples qui incluent des traces de pile analysées.

Error Reporting regroupe des erreurs similaires. Ainsi, il ne conserve que 1 000 exemples d'erreurs et extrapole les informations restantes. Pour chaque exemple, l'interface utilisateur affiche les données fournies à Error Reporting.

Afficher le code source pour une erreur

Les erreurs de l'application C# et de la version de débogage contiennent des informations sur l'emplacement du code source au niveau des cadres de pile. Pour accéder au code source, cliquez sur le lien source. Tout d'abord, vous devez charger le projet contenant le fichier dans votre solution Visual Studio actuelle.

Image montrant le code source associé à l'erreur