Consulter les journaux dans la visionneuse de journaux Cloud Logging

Ce document fournit des informations sur l'utilisation de la visionneuse de journaux Cloud Logging pour consulter les journaux.

Avant de commencer

  • Configurez votre application pour qu'elle utilise l'API Cloud Logging.

  • Connectez-vous à votre compte pour accéder aux ressources Google Cloud.

    • Sélectionnez Tools -> Google Cloud Tools -> Manage Accounts... (Outils -> Outils Google Cloud -> Gérer les comptes), puis sélectionnez votre compte.

Accéder à la visionneuse de journaux

Pour accéder à la visionneuse de journaux Cloud Logging, sélectionnez Tools -> Google Cloud Tools -> Show Stackdrive Logs Viewer (Outils -> Outils Google Cloud -> Afficher la visionneuse de journaux Stackdriver).

L'onglet Google Stackdriver Logging s'ouvre.

Vous pouvez également ouvrir la visionneuse de journaux pour un projet spécifique à partir de Google Cloud Explorer en sélectionnant Tools -> Google Cloud Tools -> Google Cloud Explorer (Outils -> Outils Google Cloud -> Google Cloud Explorer). Effectuez un clic droit sur le projet et sélectionnez Browse Stackdriver Logs (Parcourir les journaux Stackdriver).

Image montrant la vue d'ensemble de l'onglet de la visionneuse de journaux

Se déplacer dans l'interface

L'interface de la visionneuse de journaux comprend les principaux composants suivants :

  • Une barre de recherche pour filtrer les entrées de journal par libellé ou texte recherché.

  • Des menus déroulants permettant de filtrer la liste par ressources, journaux et niveaux de gravité.

  • Un menu déroulant Jump to time (Avancer dans le temps) pour afficher une date et une heure spécifiques dans les journaux.

  • Un bouton Refresh (Actualiser) pour récupérer les derniers journaux dans l'ordre décroissant.

  • Auto load log stream (flux de journaux à chargement automatique) pour déterminer si les nouvelles entrées de journal doivent être affichées au fur et à mesure de leur arrivée.

    • Cliquez sur Play (Lecture) pour lancer le flux des journaux les plus récents. Le flux s'arrête si vous faites défiler la page d'affichage des journaux.

    • Cliquez sur Pause pour arrêter le flux de journaux.

  • Le tableau des résumés de journaux sur lequel vous pouvez cliquer pour afficher les détails complets de chaque entrée de journal.

  • Une flèche Expand all (Tout développer) située dans l'angle supérieur droit du panneau des entrées de journal pour afficher les détails de toutes les entrées de journal. Cette action peut prendre un certain temps si le panneau contient de nombreuses entrées de journal.

  • Le cas échéant, un lien source pour localiser le code source qui génère l'entrée de journal.

La visionneuse de journaux vous permet d'accéder au code source qui génère une entrée de journal. Pour activer cette fonctionnalité, vous devez créer votre projet à partir d'un dépôt Git local et ajouter des informations sur l'emplacement source aux entrées de journal.

Ajouter l'emplacement source à votre journal

Configurez votre application pour fournir des informations sur l'emplacement du code source dans les journaux :

  1. Écrivez les informations d'emplacement pour les entrées de journal en utilisant l'exemple suivant de GitHub.

  2. Déployez un fichier source_context.json à la racine de l'application.

    Si vous publiez la solution via Cloud Tools for Visual Studio, l'extension génère et déploie le fichier automatiquement. Vous pouvez également générer le fichier vous-même en suivant les instructions de génération du fichier de contexte source.

Une fois ces étapes terminées, les entrées de journal contiennent un champ sourceLocation (emplacement source) contenant les informations File (Fichier) et Line (Ligne). La ligne facultative Function (Fonction) peut contenir le nom ou la version de l'assembly, ou encore le nom de la fonction.

Image montrant une entrée de journal développée et un lien permettant d'accéder au code source

En cliquant sur le lien source, vous accédez au code source si le fichier source est accessible.

Image montrant le code source accessible à partir d'un lien dans une entrée de journal

Afficher les journaux

Dans l'interface de la visionneuse de journaux, vous pouvez filtrer les entrées de journal ou rechercher des journaux spécifiques à afficher.

Filtrer les journaux

Vous pouvez filtrer les entrées de journal pour n'afficher que les journaux qui vous intéressent.

  • Dans le menu déroulant Type de ressource et instance, vous pouvez sélectionner toutes les instances d'un type de ressource particulier que vous souhaitez afficher, ou afficher une instance spécifique. Pour obtenir la liste des types de ressources, consultez la page Ressources surveillées et services.

  • Dans le menu déroulant Type de journal, sélectionnez les journaux nommés que vous souhaitez afficher ou sélectionnez All logs (Tous les journaux). Le menu n'affiche que les journaux générés par la ressource sélectionnée.

  • Dans le menu déroulant Gravité du journal, sélectionnez le niveau de gravité à afficher. Si vous sélectionnez All log levels (Tous les niveaux de journal), les entrées de journal qui n'ont pas de niveau de gravité sont incluses.

  • Dans le menu déroulant Jump to time (Avancer dans le temps), sélectionnez une date et une heure. Choisissez si vous voulez afficher les journaux before (avant) ou after (après) l'horodatage sélectionné.

Vous pouvez également cliquer sur To Advanced Filter (Accéder au filtre avancé) pour accéder à la barre de filtre avancé dans laquelle vous pouvez filtrer les entrées de journal via des requêtes. Cliquez sur le lien Advanced filter help (Aide sur le filtre avancé) pour plus d'informations.

Image montrant la barre de filtre avancé

Rechercher dans les journaux

Dans la barre de recherche, recherchez les mots clés qui apparaissent dans les entrées de journal.

Image montrant des résultats de recherche

Afficher des journaux similaires

Vous pouvez cliquer sur la valeur d'un champ individuel dans la vue développée des entrées de journal, puis afficher ou masquer toutes les entrées de journal ayant la même valeur :

Image illustrant comment cliquer pour trouver des entrées de journal similaires

Lorsque vous affichez des entrées de journal similaires, la barre de filtre avancé s'affiche. Elle vous permet de modifier le filtre et de cliquer sur Submit Filters (Envoyer les filtres). Cliquez sur le lien Advanced filter help (Aide sur le filtre avancé) pour plus d'informations.