Deploying to the App Engine Standard Environment

This document describes how to deploy an App Engine standard application to the App Engine standard environment from within IntelliJ IDEA, Ultimate Edition.

Before you begin

  • Follow the Quickstart to install and set up IntelliJ IDEA, Ultimate Edition.

  • Make sure you have the latest version of Java installed on your system.

  • To deploy to the App Engine standard environment from IntelliJ Ultimate Edition, you must install the Google Cloud SDK Java Extensions:

    gcloud components install app-engine-java
    

Selecting an App Engine standard app to deploy

You can create a new project or import an existing project to deploy to the App Engine Standard environment.

Creating a new project

To create a new project, you can use the IntelliJ New Project wizard to generate a template application that you can use as the start for your own application.

Create a new project as follows:

  1. Choose File > New > Project to display the New Project dialog.

  2. Choose Java in the left panel.

  3. In the Additional Libraries and Frameworks section, check the box for Google App Engine Standard.

  4. Verify that the Cloud SDK directory field displays the correct path to where you installed the Cloud SDK.

    1. If the path is incorrect, click the ellipsis (...) to navigate to the correct location.
  5. Choose additional libraries you want to add to the classpath of your application. The Servlet API is selected by default.

  6. When finished, click Next.

  7. Enter a Project name.

  8. Enter a Project location if you do not want to keep the default.

  9. Click Finish.

Checking out an existing project

You can check out your existing project in Cloud Source Repositories as follows:

  1. Choose VCS > Checkout from Version Control > Google Cloud.

  2. Screenshot showing the navigation to the
Source Code checkout menu option.
  3. In the Clone from Google Cloud dialog, select the Cloud Project associated with your project.
  4. Screenshot showing the dialog to checkout
source code.
  5. Select your Cloud Repository.
  6. Select the Parent Directory.
  7. Enter the Directory Name.
  8. Click Clone.

Downloading the Hello World app

If you do not have a project, you can download a sample Hello World app to complete the rest of these deployment procedures.

  1. Clone the Hello World sample app to your local machine:

    git clone https://github.com/GoogleCloudPlatform/java-docs-samples
    
  2. In IntelliJ IDEA, choose File > Open to open the file selector.

  3. Navigate to /java-docs-samples/appengine/.

  4. Select the /helloworld/ directory.

  5. Click OK.

Deploying to the standard environment

Deploy an App Engine app to the standard environment as follows:

  1. Configure the App Engine framework if you haven't done so already.

    IntelliJ IDEA should detect that you opened an App Engine application and prompt you to configure the framework.

    1. If it doesn't, right click the project.

    2. Select Add Framework Support.

    3. Enable Google App Engine.

    Now, your project is an App Engine standard project.

  2. Choose Tools > Google Cloud Tools > Deploy to App Engine....

    Screenshot showing the fields on the Create Deployment
Configuration dialog.

  3. Configure the server:

    1. Click the ellipsis (...) next to the Server field.

    2. Click Add (+) to add Google App Engine.

    3. Verify that the Cloud SDK directory field displays the correct path to where you installed the Cloud SDK.

      Screenshot
showing how to configure the Cloud SDK.

    4. Click OK.

  4. Select a project in the Project field.

    The first time you configure the deployment, you will be prompted to sign in to the account associated with the Cloud Platform Console project that you want to deploy.

    Screenshot showing the project selection field now visible that
     previously was hidden until the Server field was populated.

  5. Notice the Environment label is App Engine standard environment. The plugin detected that this project is deployable to the standard environment.

  6. Click Run to build and deploy your app.

  7. In the Application Servers window, click the name of your project to monitor its deployment progress. If the window is not displaying, click View > Tool Windows > Application Servers.

    After deployment completes, you can view your app's URL in the console output.

Deleting the server

To delete the server you configured for your project, do the following:

  1. Choose File > Settings > Build, Execution, Deployment.

    On Mac OS X, this is IntelliJ IDEA > Preferences > Build, Execution, Deployment > Clouds.

  2. Select your server (Google App Engine) and click the minus sign (-) at the top of the window to remove it.

  3. Click OK.

What's next

Monitor your resources on the go

Get the Google Cloud Console app to help you manage your projects.

Send feedback about...

Cloud Tools for IntelliJ