安装 Google Cloud SDK

本页面包含有关选择和维护 Cloud SDK 安装的说明。

系统要求

Cloud SDK 可在 Linux、macOS 和 Windows 上运行。Cloud SDK 要求安装 Python。 受支持的版本有 3.5 到 3.7 版本,以及 2.7.9 或更高版本。 运行 gcloud topic startup,详细了解如何配置 Python 解析器。一些与 Cloud SDK 捆绑在一起的工具还有其他要求。例如,用于 Google App Engine 开发的 Java 工具必须为 Java 1.7 或更高版本。

准备工作

  1. 登录您的 Google 帐号。

    如果您还没有 Google 帐号,请注册一个新帐号

  2. 在 Cloud Console 的项目选择器页面上,选择或创建 Cloud 项目。

    转到项目选择器页面

  3. 确保您的 Google Cloud 项目已启用结算功能。 了解如何确认您的项目已启用结算功能

安装选项

根据您的需要,使用以下任一方法安装 Cloud SDK:

  • 如需将 Cloud SDK 与脚本或持续集成/部署结合使用, 请下载 版本归档,以非交互方式安装特定版本的 Cloud SDK。
  • 如需运行 Debian/Ubuntu,请使用 apt-get 获取软件包格式的最新版本。
  • 如需运行 Red Hat Enterprise Linux 7/CentOS 7,请使用 yum 获取软件包格式的最新版本。
  • 如需作为 Docker 映像运行 Cloud SDK,请使用 Cloud SDK Docker 映像 获取最新版本(或特定版本)的 Cloud SDK。
  • 对于 Windows 和 macOS 交互式安装以及所有其他用例,请运行交互式安装程序以安装最新版本的 Cloud SDK。

随附组件

上述所有安装方法都会安装默认的 Cloud SDK 组件,其中包括 gcloudgsutilbq 命令行工具。

如需安装其他组件,您可以使用 gcloud components install 命令,或安装相应的 debRPM 软件包。

管理安装

在使用上述一种方法安装 Cloud SDK 后,您可以使用 gcloud components 命令组中的命令来 管理安装。这包括查看已安装的组件、添加和移除组件,以及升级到新的 Cloud SDK 版本(或降级到特定版本)。

旧版 Cloud SDK

如果您需要还原到较旧版本的 Cloud SDK,可以从此归档文件中找到所有可供下载的旧版 Cloud SDK。