Installing Google Cloud SDK

This page contains instructions for choosing and maintaining a Cloud SDK installation.

System requirements

Cloud SDK runs on Linux, macOS, and Windows. It requires Python 2.7.9 or higher. Some tools bundled with Cloud SDK have additional requirements. For example, Java tools for Google App Engine development require Java 1.7 or later.

Before you begin

  1. Sign in to your Google Account.

    If you don't already have one, sign up for a new account.

  2. In the Cloud Console, on the project selector page, select or create a Google Cloud project.

    Go to the project selector page

  3. Make sure that billing is enabled for your Google Cloud project. Learn how to confirm billing is enabled for your project.

Installation options

Depending on your needs, use one of the following methods to install Cloud SDK:

  • Using Cloud SDK with scripts or Continuous Integration/Deployment? Download a versioned archive for a non-interactive installation of a specific version of Cloud SDK.
  • Running Debian/Ubuntu? Use apt-get for the latest release in package format.
  • Running Red Hat Enterprise Linux 7/CentOS 7? Use yum for the latest release in package format.
  • Need to run Cloud SDK as a Docker image? Use the Cloud SDK Docker image for the latest release (or specific version) of Cloud SDK.
  • For Windows and macOS interactive installations, and all other use cases, run the interactive installer to install the latest release of Cloud SDK.

What's in the box?

All of the installation methods above install the default Cloud SDK components, which include gcloud, gsutil and bq command-line tools.

You can install additional components using the gcloud components install command, or by installing the appropriate deb or RPM packages.

Managing an installation

After you have installed Cloud SDK using one of the methods above, you can use commands in the gcloud components command group to manage your installation. This includes viewing installed components, adding and removing components, and upgrading to a new version (or downgrading to a specific version) of Cloud SDK.

Older versions of Cloud SDK

If you'd need an older version of Cloud SDK to revert to, you can find all previous releases available to download from this archive.

Oliko tästä sivusta apua? Kerro mielipiteesi

Palautteen aihe:

Tämä sivu
Cloud SDK Documentation